r8210 - in trunk/BOOK: . gnome/add introduction/welcome

wblaszcz at linuxfromscratch.org wblaszcz at linuxfromscratch.org
Tue Jan 12 02:47:02 PST 2010


Author: wblaszcz
Date: 2010-01-12 03:47:02 -0700 (Tue, 12 Jan 2010)
New Revision: 8210

Modified:
   trunk/BOOK/general.ent
   trunk/BOOK/gnome/add/evolution-data-server.xml
   trunk/BOOK/introduction/welcome/changelog.xml
Log:
Updated to Evolution Data Server-2.28.2.

Modified: trunk/BOOK/general.ent
===================================================================
--- trunk/BOOK/general.ent	2010-01-12 10:27:47 UTC (rev 8209)
+++ trunk/BOOK/general.ent	2010-01-12 10:47:02 UTC (rev 8210)
@@ -580,7 +580,7 @@
 <!-- Chapter 32 -->
 
 <!-- Libraries -->
-<!ENTITY evolution-data-server-version "1.10.3">
+<!ENTITY evolution-data-server-version "2.28.2">
 <!ENTITY gnome-audio-version          "2.0.0">
 <!ENTITY gtkhtml-version              "3.14.3">
 <!ENTITY gtksourceview-version        "2.8.1">

Modified: trunk/BOOK/gnome/add/evolution-data-server.xml
===================================================================
--- trunk/BOOK/gnome/add/evolution-data-server.xml	2010-01-12 10:27:47 UTC (rev 8209)
+++ trunk/BOOK/gnome/add/evolution-data-server.xml	2010-01-12 10:47:02 UTC (rev 8210)
@@ -4,12 +4,12 @@
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
 
-  <!ENTITY evolution-data-server-download-http "&gnome-download-http;/evolution-data-server/1.10/evolution-data-server-&evolution-data-server-version;.tar.bz2">
-  <!ENTITY evolution-data-server-download-ftp  "&gnome-download-ftp;/evolution-data-server/1.10/evolution-data-server-&evolution-data-server-version;.tar.bz2">
-  <!ENTITY evolution-data-server-md5sum        "44438eca3ca3cab861109605611fe778">
-  <!ENTITY evolution-data-server-size          "7.1 MB">
-  <!ENTITY evolution-data-server-buildsize     "185 MB">
-  <!ENTITY evolution-data-server-time          "3.3 SBU (additional 0.5 SBU to run the test suite)">
+  <!ENTITY evolution-data-server-download-http "&gnome-download-http;/evolution-data-server/&gnome-version;/evolution-data-server-&evolution-data-server-version;.tar.bz2">
+  <!ENTITY evolution-data-server-download-ftp  "&gnome-download-ftp;/evolution-data-server/&gnome-version;/evolution-data-server-&evolution-data-server-version;.tar.bz2">
+  <!ENTITY evolution-data-server-md5sum        "416248e60b1bec3f913a6857576cbcb0">
+  <!ENTITY evolution-data-server-size          "21.3 MB">
+  <!ENTITY evolution-data-server-buildsize     "176 MB">
+  <!ENTITY evolution-data-server-time          "2.5 SBU">
 ]>
 
 <sect1 id="evolution-data-server"
@@ -61,32 +61,33 @@
     <bridgehead renderas="sect3">Evolution Data Server Dependencies</bridgehead>
 
     <bridgehead renderas="sect4">Required</bridgehead>
-    <para role="required"><xref linkend="libgnomeui"/> and
-    <xref linkend="libsoup"/></para>
+    <para role="required"><xref linkend="GConf"/>,
+    <xref linkend="intltool"/>,
+    <xref linkend="libbonobo"/>,
+    <xref linkend="libglade"/>,
+    <xref linkend="libical"/>,
+    <xref linkend="libsoup"/>, and
+    <xref linkend="sqlite"/></para>
 
-    <bridgehead renderas="sect4">Recommended
-    (For SSL and S/MIME support)</bridgehead>
-    <para role="recommended"><xref linkend="nss"/></para>
+    <bridgehead renderas="sect4">Recommended</bridgehead>
+    <para role="recommended"><xref linkend="gnome-keyring"/>,
+    <xref linkend="libgweather"/>,
+    <xref linkend="nss"/>, and
+    <xref linkend="openssl"/> (the latter two for S/MIME and SSL support)</para>
 
-    <para>The <application>NSS</application> package is not required if you
-    have <xref linkend="firefox"/>, <xref linkend="thunderbird"/>,
-    <xref linkend="seamonkey"/> or
-    <ulink url="http://www.mozilla.org/products/mozilla1.x/">Mozilla</ulink>
-    installed. These packages contain internal copies of
-    <application>NSS</application> (or they used a system-installed copy).
-    If any of the four packages are installed, one way or another you will
-    already have NSS/NSPR libraries on your system.</para>
+    <para>The <application>NSS</application> package is not required if you have
+    <xref linkend="firefox"/>, <xref linkend="thunderbird"/>, or <xref
+    linkend="seamonkey"/> installed. These packages contain internal copies of
+    <application>NSS</application> (or they used a system-installed copy).  If
+    any of the three packages are installed, one way or another you will already
+    have NSS/NSPR libraries on your system.</para>
 
-
     <bridgehead renderas="sect4">Optional</bridgehead>
-    <para role="optional"><xref linkend="openldap"/>,
-    an <xref linkend="server-mail"/> (that provides a
-    <command>sendmail</command> command),
+    <para role="optional"><xref linkend="gtk-doc"/>,
     <xref linkend="heimdal"/> or <xref linkend="mitkrb"/>,
-    <ulink url="http://www.pdc.kth.se/kth-krb/">krb4</ulink>,
-    <xref linkend="gtk-doc"/>,
-    <xref linkend="intltool"/>, and
-    <xref linkend="docbook-utils"/></para>
+    a <xref linkend="server-mail"/> (that provides a <command>sendmail</command> command),
+    <xref linkend="openldap"/>, and
+    <xref linkend="tcl"/></para>
 
     <para condition="html" role="usernotes">User Notes:
     <ulink url="&blfs-wiki;/evolution-data-server"/></para>
@@ -167,6 +168,13 @@
     in the Mozilla Network Security Services libraries for S/MIME
     support.</para>
 
+    <para><option>--without-weather</option>: Use this option to disable the
+    weather calendar backend and is required if
+    <application>libgweather</application> is not installed.</para>
+
+    <xi:include xmlns:xi="http://www.w3.org/2003/XInclude"
+    href="../../xincludes/gtk-doc-rebuild.xml"/>
+
     <!--
     <para><parameter>-with-{nspr,nss}-includes</parameter>: This parameter is
     used to identify where the Mozilla Network Security Services interface
@@ -195,18 +203,16 @@
 
       <seglistitem>
         <seg>None</seg>
-        <seg>libcamel-1.2.so, libcamel-provider-1.2.so, libebook-1.2.so,
-        libecal-1.2.so, libedata-book-1.2.so, libedata-cal-1.2.so,
-        libedataserver-1.2.so, libedataserverui-1.2.so, libegroupwise-1.2.so,
-        libexchange-storage-1.2.so and numerous provider and extension
-        modules.</seg>
-        <seg>The following subdirectories of <envar>$GNOME_PREFIX</envar>/:
-        include/evolution-data-server-1.10,
-        lib/evolution-data-server-1.2,
-        share/{evolution-data-server-1.10,
-        gtk-doc/html/libe{book,cal,data{,server}},
-        idl/evolution-data-server-1.10,
-        pixmaps/evolution-data-server-1.10}</seg>
+        <seg>libcamel-1.2.so, libcamel-provider-1.2.so, libebackend-1.2.so,
+        libebook-1.2.so, libecal-1.2.so, libedata-book-1.2.so,
+        libedata-cal-1.2.so, libedataserver-1.2.so, libedataserverui-1.2.so,
+        libegroupwise-1.2.so, libexchange-storage-1.2.so, libgdata-1.2.so,
+        libgdata-google and numerous provider and extension modules.</seg>
+        <seg><envar>$GNOME_PREFIX</envar>/{include/evolution-data-server-&gnome-version;/*,
+        lib/evolution-data-server-1.2/{camel-providers,extensions},
+        share/{evolution-data-server-&gnome-version;/{glade,weather},
+        gtk-doc/html/*,idl/evolution-data-server-1.2,
+        pixmaps/evolution-data-server}}</seg>
       </seglistitem>
     </segmentedlist>
 

Modified: trunk/BOOK/introduction/welcome/changelog.xml
===================================================================
--- trunk/BOOK/introduction/welcome/changelog.xml	2010-01-12 10:27:47 UTC (rev 8209)
+++ trunk/BOOK/introduction/welcome/changelog.xml	2010-01-12 10:47:02 UTC (rev 8210)
@@ -45,6 +45,9 @@
       <para>January 12th, 2010</para>
       <itemizedlist>
         <listitem>
+          <para>[wblaszcz] - Updated to Evolution Data Server-2.28.2.</para>
+        </listitem>
+        <listitem>
           <para>[wblaszcz] - Added new package, libical-0.43 and minor
           ammendments to webkitgtk and enchant.</para>
         </listitem>




More information about the blfs-book mailing list