r8583 - in trunk/BOOK: . book general/genutils gnome gnome/add/obsolete gnome/core introduction/welcome

wblaszcz at linuxfromscratch.org wblaszcz at linuxfromscratch.org
Sat Aug 28 23:37:27 PDT 2010


Author: wblaszcz
Date: 2010-08-29 00:37:22 -0600 (Sun, 29 Aug 2010)
New Revision: 8583

Modified:
   trunk/BOOK/book/organization.xml
   trunk/BOOK/general.ent
   trunk/BOOK/general/genutils/scrollkeeper.xml
   trunk/BOOK/gnome/add/obsolete/ggv.xml
   trunk/BOOK/gnome/add/obsolete/gpdf.xml
   trunk/BOOK/gnome/core/pre-install-config.xml
   trunk/BOOK/gnome/gnome-intro.xml
   trunk/BOOK/introduction/welcome/changelog.xml
Log:
Removed gnome-old-version.

Modified: trunk/BOOK/book/organization.xml
===================================================================
--- trunk/BOOK/book/organization.xml	2010-08-29 06:24:44 UTC (rev 8582)
+++ trunk/BOOK/book/organization.xml	2010-08-29 06:37:22 UTC (rev 8583)
@@ -62,7 +62,7 @@
 
   <para><application>GNOME</application> is the main alternative to
   <application>KDE</application> in the Desktop Environment arena and
-  we cover <application>GNOME</application>-&gnome-old-version; here.</para>
+  we cover <application>GNOME</application>-&gnome-version; here.</para>
 
   <bridgehead renderas="sect2">Part IX - X Software</bridgehead>
 

Modified: trunk/BOOK/general/genutils/scrollkeeper.xml
===================================================================
--- trunk/BOOK/general/genutils/scrollkeeper.xml	2010-08-29 06:24:44 UTC (rev 8582)
+++ trunk/BOOK/general/genutils/scrollkeeper.xml	2010-08-29 06:37:22 UTC (rev 8583)
@@ -83,7 +83,7 @@
             --disable-static \
             --with-omfdirs=/usr/share/omf:\
 /opt/kde-&kde-version;/share/omf:\
-/opt/gnome-&gnome-old-version;&gnome-minor-version;/share/omf &&
+/opt/gnome-&gnome-version;&gnome-minor-version;/share/omf &&
 
 make</userinput></screen>
 

Modified: trunk/BOOK/general.ent
===================================================================
--- trunk/BOOK/general.ent	2010-08-29 06:24:44 UTC (rev 8582)
+++ trunk/BOOK/general.ent	2010-08-29 06:37:22 UTC (rev 8583)
@@ -566,7 +566,6 @@
 
 <!-- Part IX -->
 <!ENTITY gnome-version                "2.30">
-<!ENTITY gnome-old-version            "2.28">
 <!ENTITY gnome-minor-version          ".2">
 <!ENTITY gnome-etc-dir                "/etc/gnome/&gnome-version;&gnome-minor-version;">
 <!ENTITY gnome-download-http          "http://ftp.gnome.org/pub/gnome/sources">

Modified: trunk/BOOK/gnome/add/obsolete/ggv.xml
===================================================================
--- trunk/BOOK/gnome/add/obsolete/ggv.xml	2010-08-29 06:24:44 UTC (rev 8582)
+++ trunk/BOOK/gnome/add/obsolete/ggv.xml	2010-08-29 06:37:22 UTC (rev 8583)
@@ -4,8 +4,8 @@
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
 
-  <!ENTITY ggv-download-http "http://ftp.gnome.org/pub/GNOME/sources/ggv/&gnome-old-version;/ggv-&ggv-version;.tar.bz2">
-  <!ENTITY ggv-download-ftp  "ftp://ftp.gnome.org/pub/GNOME/sources/ggv/&gnome-old-version;/ggv-&ggv-version;.tar.bz2">
+  <!ENTITY ggv-download-http "http://ftp.gnome.org/pub/GNOME/sources/ggv/&gnome-version;/ggv-&ggv-version;.tar.bz2">
+  <!ENTITY ggv-download-ftp  "ftp://ftp.gnome.org/pub/GNOME/sources/ggv/&gnome-version;/ggv-&ggv-version;.tar.bz2">
   <!ENTITY ggv-md5sum        "418f0ef3f8b82bb0c423a2a1cf6769f7">
   <!ENTITY ggv-size          "1.0 MB">
   <!ENTITY ggv-buildsize     "17.8 MB">

Modified: trunk/BOOK/gnome/add/obsolete/gpdf.xml
===================================================================
--- trunk/BOOK/gnome/add/obsolete/gpdf.xml	2010-08-29 06:24:44 UTC (rev 8582)
+++ trunk/BOOK/gnome/add/obsolete/gpdf.xml	2010-08-29 06:37:22 UTC (rev 8583)
@@ -4,8 +4,8 @@
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
 
-  <!ENTITY gpdf-download-http "http://ftp.gnome.org/pub/GNOME/sources/gpdf/&gnome-old-version;/gpdf-&gpdf-version;.tar.bz2">
-  <!ENTITY gpdf-download-ftp "ftp://ftp.gnome.org/pub/GNOME/sources/gpdf/&gnome-old-version;/gpdf-&gpdf-version;.tar.bz2">
+  <!ENTITY gpdf-download-http "http://ftp.gnome.org/pub/GNOME/sources/gpdf/&gnome-version;/gpdf-&gpdf-version;.tar.bz2">
+  <!ENTITY gpdf-download-ftp "ftp://ftp.gnome.org/pub/GNOME/sources/gpdf/&gnome-version;/gpdf-&gpdf-version;.tar.bz2">
   <!ENTITY gpdf-md5sum "9278cd3b9d06e3b1d364452f0e512fa9">
   <!ENTITY gpdf-size "1.0 MB">
   <!ENTITY gpdf-buildsize "36 MB">

Modified: trunk/BOOK/gnome/core/pre-install-config.xml
===================================================================
--- trunk/BOOK/gnome/core/pre-install-config.xml	2010-08-29 06:24:44 UTC (rev 8582)
+++ trunk/BOOK/gnome/core/pre-install-config.xml	2010-08-29 06:37:22 UTC (rev 8583)
@@ -33,33 +33,33 @@
     issue the following commands as the
     <systemitem class='username'>root</systemitem> user:</para>
 
-<screen role='root'><userinput>install -v -m755 -d /opt/gnome-&gnome-old-version;&gnome-minor-version; &&
-ln -v -s gnome-&gnome-old-version;&gnome-minor-version; /opt/gnome</userinput></screen>
+<screen role='root'><userinput>install -v -m755 -d /opt/gnome-&gnome-version;&gnome-minor-version; &&
+ln -v -s gnome-&gnome-version;&gnome-minor-version; /opt/gnome</userinput></screen>
   </note>
 
   <para>If you created the symbolic link, change all instances of <filename
-  class='directory'>/opt/gnome-&gnome-old-version;&gnome-minor-version;</filename>
+  class='directory'>/opt/gnome-&gnome-version;&gnome-minor-version;</filename>
   to <filename class='directory'>/opt/gnome</filename> in the instructions
   below.</para>
 
-<screen><userinput>export GNOME_PREFIX=/opt/gnome-&gnome-old-version;&gnome-minor-version;</userinput></screen>
+<screen><userinput>export GNOME_PREFIX=/opt/gnome-&gnome-version;&gnome-minor-version;</userinput></screen>
 
   <para>The try-out group will also need to make all the following
   configuration changes:</para>
 
   <para>Add to your system or personal profile:</para>
 
-<screen><literal>export PATH=$PATH:/opt/gnome-&gnome-old-version;&gnome-minor-version;/bin
-export PKG_CONFIG_PATH=$PKG_CONFIG_PATH:/opt/gnome-&gnome-old-version;&gnome-minor-version;/lib/pkgconfig
-export PKG_CONFIG_PATH=$PKG_CONFIG_PATH:/opt/gnome-&gnome-old-version;&gnome-minor-version;/share/pkgconfig
-export GNOME_LIBCONFIG_PATH=/usr/lib:/opt/gnome-&gnome-old-version;&gnome-minor-version;/lib</literal></screen>
+<screen><literal>export PATH=$PATH:/opt/gnome-&gnome-version;&gnome-minor-version;/bin
+export PKG_CONFIG_PATH=$PKG_CONFIG_PATH:/opt/gnome-&gnome-version;&gnome-minor-version;/lib/pkgconfig
+export PKG_CONFIG_PATH=$PKG_CONFIG_PATH:/opt/gnome-&gnome-version;&gnome-minor-version;/share/pkgconfig
+export GNOME_LIBCONFIG_PATH=/usr/lib:/opt/gnome-&gnome-version;&gnome-minor-version;/lib</literal></screen>
 
   <para>Add to your <filename>/etc/ld.so.conf</filename>:</para>
 
 <screen role='root'><userinput>cat >> /etc/ld.so.conf << "EOF"
 <literal># Begin gnome addition to /etc/ld.so.conf
 
-/opt/gnome-&gnome-old-version;&gnome-minor-version;/lib
+/opt/gnome-&gnome-version;&gnome-minor-version;/lib
 
 # End gnome addition</literal>
 EOF</userinput></screen>
@@ -69,7 +69,7 @@
 <screen role='root'><userinput>cat >> /etc/man_db.conf << "EOF"
 <literal># Begin gnome addition to man_db.conf
 
-MANDATORY_MANPATH /opt/gnome-&gnome-old-version;&gnome-minor-version;/share/man
+MANDATORY_MANPATH /opt/gnome-&gnome-version;&gnome-minor-version;/share/man
 
 # End gnome addition to man_db.conf</literal>
 EOF</userinput></screen>

Modified: trunk/BOOK/gnome/gnome-intro.xml
===================================================================
--- trunk/BOOK/gnome/gnome-intro.xml	2010-08-29 06:24:44 UTC (rev 8582)
+++ trunk/BOOK/gnome/gnome-intro.xml	2010-08-29 06:37:22 UTC (rev 8583)
@@ -25,23 +25,23 @@
   </warning> -->
 
   <!-- <para>This chapter presents the instructions to install a complete
-  GNOME-&gnome-old-version;&gnome-minor-version; desktop environment; and a limited
+  GNOME-&gnome-version;&gnome-minor-version; desktop environment; and a limited
   GNOME 1.4 library environment that is sufficient to run GNOME 1.4
   applications included in this book. The order of the pages follows the build
   order defined by the GNOME development team and documented in the <ulink
-  url="http://www.gnome.org/start/&gnome-old-version;/notes/en/rninstallation.html">
+  url="http://www.gnome.org/start/&gnome-version;/notes/en/rninstallation.html">
   Release Notes</ulink>.</para> -->
 
   <para>This chapter presents the instructions to install a complete
-  GNOME-&gnome-old-version;&gnome-minor-version; desktop environment. The order of
+  GNOME-&gnome-version;&gnome-minor-version; desktop environment. The order of
   the installed packages follows the build order defined by the GNOME
   development team and has been thoroughly tested by the BLFS team.</para>
 
-  <para>The installation of GNOME-&gnome-old-version;&gnome-minor-version; is a
+  <para>The installation of GNOME-&gnome-version;&gnome-minor-version; is a
   large undertaking and one we would like to see you complete with the least
   amount of stress. One of the first goals in this installation is to protect
   your previously installed software, especially if you are testing GNOME on
-  your machine. GNOME-&gnome-old-version; packages utilize the
+  your machine. GNOME-&gnome-version; packages utilize the
   <option>--prefix=option</option> passed to <command>configure</command>,
   so you will use that and an environment variable (<envar>GNOME_PREFIX</envar>)
   to add flexibility to the installation.</para>
@@ -50,26 +50,26 @@
   install using <option>--prefix=/usr</option>. If you are not sure that you
   are going to keep the GNOME installation, or you think you will update to the
   newest releases as they become available, you should install with
-  <option>--prefix=/opt/gnome-&gnome-old-version;&gnome-minor-version;</option>.
+  <option>--prefix=/opt/gnome-&gnome-version;&gnome-minor-version;</option>.
   Setting the environment variable and the additional edits required by the
   second option are covered in the Pre-Installation Configuration
   section.</para>
 
   <para>If you choose the second option, removal of
-  GNOME-&gnome-old-version;&gnome-minor-version; is as easy as removing the edits
+  GNOME-&gnome-version;&gnome-minor-version; is as easy as removing the edits
   from the pre-installation page and issuing the following command (you may
   need to become the <systemitem class='username'>root</systemitem>
   user):</para>
 
-<screen role="root"><userinput>rm -rf /opt/gnome-&gnome-old-version;&gnome-minor-version;</userinput></screen>
+<screen role="root"><userinput>rm -rf /opt/gnome-&gnome-version;&gnome-minor-version;</userinput></screen>
 
   <para>If your system was completely built per LFS and BLFS instructions,
   you have a very good chance of using
-  GNOME-&gnome-old-version;&gnome-minor-version; after your first installation. If
+  GNOME-&gnome-version;&gnome-minor-version; after your first installation. If
   you are a typical LFS user, you have made modifications to the instructions
   along the way knowing that you have to take those modifications into account
   on future installations. You should have no problems integrating
-  GNOME-&gnome-old-version;&gnome-minor-version; into your unique setup, but you
+  GNOME-&gnome-version;&gnome-minor-version; into your unique setup, but you
   will have to install well over 50 packages before you can run GNOME through
   any testing (assuming your windowing system is preinstalled and tested). You
   should anticipate that you will be rebuilding GNOME at least once to make
@@ -97,16 +97,16 @@
   <filename class='directory'>/opt/gnome/var</filename> to
   <filename class='directory'>/var</filename>. You should consider using
   the GNOME 1.4 hint located at <ulink url="&hints-root;"/> if you have no
-  interest in GNOME-&gnome-old-version;&gnome-minor-version;.</para> -->
+  interest in GNOME-&gnome-version;&gnome-minor-version;.</para> -->
 
   <bridgehead renderas="sect3">Alternate Installation Methods</bridgehead>
   <para>As was previously mentioned, building a GNOME desktop from sources is a
   significant project. Some may find it too tedious or time-consuming to perform
   a full installation following the BLFS book. You may wish to review the
-  automated methods mentioned in the GNOME-&gnome-old-version; <ulink
-  url="http://www.gnome.org/start/&gnome-old-version;/notes/en/rninstallation.html">Release
+  automated methods mentioned in the GNOME-&gnome-version; <ulink
+  url="http://www.gnome.org/start/&gnome-version;/notes/en/rninstallation.html">Release
   Notes</ulink>. Note that using any other method to install
-  GNOME-&gnome-old-version;&gnome-minor-version; other than using the BLFS
+  GNOME-&gnome-version;&gnome-minor-version; other than using the BLFS
   instructions cannot be supported by the BLFS team. Alternate methods are only
   mentioned as a courtesy to builders who would like to build GNOME from sources
   but do not have the time/desire/patience/whatever to follow the BLFS

Modified: trunk/BOOK/introduction/welcome/changelog.xml
===================================================================
--- trunk/BOOK/introduction/welcome/changelog.xml	2010-08-29 06:24:44 UTC (rev 8582)
+++ trunk/BOOK/introduction/welcome/changelog.xml	2010-08-29 06:37:22 UTC (rev 8583)
@@ -44,6 +44,9 @@
       <para>August 29th, 2010</para>
       <itemizedlist>
         <listitem>
+          <para>[wblaszcz] - Removed gnome-old-version.</para>
+        </listitem>
+        <listitem>
           <para>[wblaszcz] - Added new package, gtk-vnc-0.3.10.</para>
         </listitem>
         <listitem>




More information about the blfs-book mailing list