r8476 - in trunk/BOOK: . gnome/add gnome/add/obsolete introduction/welcome x/lib

ken at linuxfromscratch.org ken at linuxfromscratch.org
Thu Aug 12 05:58:40 PDT 2010


Author: ken
Date: 2010-08-12 06:58:36 -0600 (Thu, 12 Aug 2010)
New Revision: 8476

Added:
   trunk/BOOK/gnome/add/obsolete/gail.xml
Removed:
   trunk/BOOK/gnome/add/gail.xml
Modified:
   trunk/BOOK/general.ent
   trunk/BOOK/gnome/add/add.xml
   trunk/BOOK/introduction/welcome/changelog.xml
   trunk/BOOK/x/lib/webkitgtk.xml
Log:
Revert reinstatement of gail, I obviously didn't get the memo that it is now in gtk+.  Thanks to William Immendorf for pointing this out.

Modified: trunk/BOOK/general.ent
===================================================================
--- trunk/BOOK/general.ent	2010-08-12 12:18:41 UTC (rev 8475)
+++ trunk/BOOK/general.ent	2010-08-12 12:58:36 UTC (rev 8476)
@@ -643,7 +643,6 @@
 
 <!-- Accessibility -->
 <!ENTITY at-spi-version               "1.30.1">
-<!ENTITY gail-version                 "1.22.3">
 <!ENTITY gnome-mag-version            "0.15.9">
 <!ENTITY gnome-speech-version         "0.4.25">
 <!ENTITY gok-version                  "2.28.1">
@@ -664,6 +663,7 @@
 <!ENTITY gnome-volume-manager-version "2.17.0">
 <!ENTITY nautilus-cd-burner-version   "2.18.2">
 <!ENTITY eel-version                  "2.18.3">
+<!ENTITY gail-version                 "1.22.3">
 <!ENTITY gnome-keyring-manager-version "2.18.0">
 -->
 

Modified: trunk/BOOK/gnome/add/add.xml
===================================================================
--- trunk/BOOK/gnome/add/add.xml	2010-08-12 12:18:41 UTC (rev 8475)
+++ trunk/BOOK/gnome/add/add.xml	2010-08-12 12:58:36 UTC (rev 8476)
@@ -63,7 +63,6 @@
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="dummy-accessibility.xml"/>
 
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="at-spi.xml"/>
-  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="gail.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="gnome-mag.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="gnome-speech.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="gok.xml"/>
@@ -82,6 +81,7 @@
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="gnome-volume-manager.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="nautilus-cd-burner.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="eel.xml"/>
+  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="gail.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="gnome-keyring-manager.xml"/>
   -->
 

Deleted: trunk/BOOK/gnome/add/gail.xml
===================================================================
--- trunk/BOOK/gnome/add/gail.xml	2010-08-12 12:18:41 UTC (rev 8475)
+++ trunk/BOOK/gnome/add/gail.xml	2010-08-12 12:58:36 UTC (rev 8476)
@@ -1,164 +0,0 @@
-<?xml version="1.0" encoding="ISO-8859-1"?>
-<!DOCTYPE sect1 PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
-   "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
-  <!ENTITY % general-entities SYSTEM "../../general.ent">
-  %general-entities;
-
-  <!ENTITY gail-download-http "&gnome-download-http;/gail/1.22/gail-&gail-version;.tar.bz2">
-  <!ENTITY gail-download-ftp  "&gnome-download-ftp;/gail/1.22/gail-&gail-version;.tar.bz2">
-  <!ENTITY gail-md5sum        "d58ad8cc79d3cb6778bc015ef69fb499">
-  <!ENTITY gail-size          "659 KB">
-  <!ENTITY gail-buildsize     "26 MB">
-  <!ENTITY gail-time          "0.5 SBU">
-]>
-
-<sect1 id="gail" xreflabel="GAIL-&gail-version;">
-  <?dbhtml filename="gail.html"?>
-
-  <sect1info>
-    <othername>$LastChangedBy$</othername>
-    <date>$Date$</date>
-  </sect1info>
-
-  <title>GAIL-&gail-version;</title>
-
-  <indexterm zone="gail">
-    <primary sortas="a-GAIL">GAIL</primary>
-  </indexterm>
-
-  <sect2 role="package">
-    <title>Introduction to GAIL</title>
-
-    <para>The <application>GAIL</application> package provides accessibility
-    support for <application>GTK+</application> and
-    <application>libgnomecanvas</application> by implementing AtkObjects for
-    widgets in <application>GTK+</application> and
-    <application>libgnomecanvas</application>. The
-    <application>GAIL</application> library is a
-    <application>GTK+</application> module. This module is normally used with
-    the atk-bridge <application>GTK+</application> module from
-    <application>AT-SPI</application> to allow an assistive technology, e.g., a
-    screenreader, to query or drive the program.</para>
-
-    <para>&lfssvn_built;20100803&lfssvn_built2;</para>
-
-    <bridgehead renderas="sect3">Package Information</bridgehead>
-    <itemizedlist spacing="compact">
-      <listitem>
-        <para>Download (HTTP): <ulink url="&gail-download-http;"/></para>
-      </listitem>
-      <listitem>
-        <para>Download (FTP): <ulink url="&gail-download-ftp;"/></para>
-      </listitem>
-      <listitem>
-        <para>Download MD5 sum: &gail-md5sum;</para>
-      </listitem>
-      <listitem>
-        <para>Download size: &gail-size;</para>
-      </listitem>
-      <listitem>
-        <para>Estimated disk space required: &gail-buildsize;</para>
-      </listitem>
-      <listitem>
-        <para>Estimated build time: &gail-time;</para>
-      </listitem>
-    </itemizedlist>
-
-    <bridgehead renderas="sect3">GAIL Dependencies</bridgehead>
-
-    <bridgehead renderas="sect4">Required</bridgehead>
-    <para role="required"><xref linkend="gtk2"/></para>
-
-    <bridgehead renderas="sect4">Optional</bridgehead>
-    <para role="optional"><xref linkend="gtk-doc"/></para>
-
-    <para condition="html" role="usernotes">User Notes:
-    <ulink url="&blfs-wiki;/gail"/></para>
-
-  </sect2>
-
-  <sect2 role="installation">
-    <title>Installation of GAIL</title>
-
-    <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
-    href="../../xincludes/without-gnome.xml"/>
-
-    <para>Install <application>GAIL</application> by running
-    the following commands:</para>
-
-<screen><userinput>./configure --prefix=$(pkg-config --variable=prefix ORBit-2.0) &&
-make</userinput></screen>
-
-    <para>This package does not come with a test suite.</para>
-
-    <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
-
-<screen role="root"><userinput>make install &&
-
-if [ $(pkg-config --variable=prefix ORBit-2.0) != "/usr" ]; then
-    ln -v -s $(pkg-config --variable=prefix \
-             ORBit-2.0)/lib/gtk-2.0/modules \
-         /usr/lib/gtk-2.0
-fi</userinput></screen>
-
-  </sect2>
-
-  <sect2 role="commands">
-    <title>Command Explanations</title>
-
-    <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
-    href="../../xincludes/gnome-prefix.xml"/>
-
-    <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
-    href="../../xincludes/gtk-doc-rebuild.xml"/>
-
-    <para><command>if [ ... != "/usr" ]; then ...; fi</command>:
-    <application>GTK+</application> will look for the
-    <application>GAIL</application> modules in
-    <filename class='directory'>/usr/lib</filename> even if
-    <envar>$GNOME_PREFIX</envar> is NOT
-    <filename class='directory'>/usr</filename>. This command creates a
-    symbolic link to satisfy this requirement.</para>
-
-  </sect2>
-
-  <sect2 role="content">
-    <title>Contents</title>
-
-    <segmentedlist>
-      <segtitle>Installed Programs</segtitle>
-      <segtitle>Installed Libraries</segtitle>
-      <segtitle>Installed Directories</segtitle>
-
-      <seglistitem>
-        <seg>None</seg>
-        <seg>libgailutil.so and <application>GAIL</application>
-        <application>GTK+</application> modules</seg>
-        <seg>The following subdirectories of <envar>$GNOME_PREFIX</envar>/:
-        include/gail-1.0,
-        lib/gtk-2.0/modules and
-        share/gtk-doc/html/gail-libgail-util</seg>
-      </seglistitem>
-    </segmentedlist>
-
-    <variablelist>
-      <bridgehead renderas="sect3">Short Descriptions</bridgehead>
-      <?dbfo list-presentation="list"?>
-      <?dbhtml list-presentation="table"?>
-
-      <varlistentry id="libgailutil">
-        <term><filename class='libraryfile'>libgailutil.so</filename></term>
-        <listitem>
-          <para>provides the functions that solve accessibility problems
-          in a consistent manner across <application>GNOME</application>.</para>
-          <indexterm zone="gail libgailutil">
-            <primary sortas="c-libgailutil">libgailutil.so</primary>
-          </indexterm>
-        </listitem>
-      </varlistentry>
-
-    </variablelist>
-
-  </sect2>
-
-</sect1>

Copied: trunk/BOOK/gnome/add/obsolete/gail.xml (from rev 8475, trunk/BOOK/gnome/add/gail.xml)
===================================================================
--- trunk/BOOK/gnome/add/obsolete/gail.xml	                        (rev 0)
+++ trunk/BOOK/gnome/add/obsolete/gail.xml	2010-08-12 12:58:36 UTC (rev 8476)
@@ -0,0 +1,164 @@
+<?xml version="1.0" encoding="ISO-8859-1"?>
+<!DOCTYPE sect1 PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
+   "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
+  <!ENTITY % general-entities SYSTEM "../../general.ent">
+  %general-entities;
+
+  <!ENTITY gail-download-http "&gnome-download-http;/gail/1.22/gail-&gail-version;.tar.bz2">
+  <!ENTITY gail-download-ftp  "&gnome-download-ftp;/gail/1.22/gail-&gail-version;.tar.bz2">
+  <!ENTITY gail-md5sum        "d58ad8cc79d3cb6778bc015ef69fb499">
+  <!ENTITY gail-size          "659 KB">
+  <!ENTITY gail-buildsize     "26 MB">
+  <!ENTITY gail-time          "0.5 SBU">
+]>
+
+<sect1 id="gail" xreflabel="GAIL-&gail-version;">
+  <?dbhtml filename="gail.html"?>
+
+  <sect1info>
+    <othername>$LastChangedBy$</othername>
+    <date>$Date$</date>
+  </sect1info>
+
+  <title>GAIL-&gail-version;</title>
+
+  <indexterm zone="gail">
+    <primary sortas="a-GAIL">GAIL</primary>
+  </indexterm>
+
+  <sect2 role="package">
+    <title>Introduction to GAIL</title>
+
+    <para>The <application>GAIL</application> package provides accessibility
+    support for <application>GTK+</application> and
+    <application>libgnomecanvas</application> by implementing AtkObjects for
+    widgets in <application>GTK+</application> and
+    <application>libgnomecanvas</application>. The
+    <application>GAIL</application> library is a
+    <application>GTK+</application> module. This module is normally used with
+    the atk-bridge <application>GTK+</application> module from
+    <application>AT-SPI</application> to allow an assistive technology, e.g., a
+    screenreader, to query or drive the program.</para>
+
+    <para>&lfssvn_built;20100803&lfssvn_built2;</para>
+
+    <bridgehead renderas="sect3">Package Information</bridgehead>
+    <itemizedlist spacing="compact">
+      <listitem>
+        <para>Download (HTTP): <ulink url="&gail-download-http;"/></para>
+      </listitem>
+      <listitem>
+        <para>Download (FTP): <ulink url="&gail-download-ftp;"/></para>
+      </listitem>
+      <listitem>
+        <para>Download MD5 sum: &gail-md5sum;</para>
+      </listitem>
+      <listitem>
+        <para>Download size: &gail-size;</para>
+      </listitem>
+      <listitem>
+        <para>Estimated disk space required: &gail-buildsize;</para>
+      </listitem>
+      <listitem>
+        <para>Estimated build time: &gail-time;</para>
+      </listitem>
+    </itemizedlist>
+
+    <bridgehead renderas="sect3">GAIL Dependencies</bridgehead>
+
+    <bridgehead renderas="sect4">Required</bridgehead>
+    <para role="required"><xref linkend="gtk2"/></para>
+
+    <bridgehead renderas="sect4">Optional</bridgehead>
+    <para role="optional"><xref linkend="gtk-doc"/></para>
+
+    <para condition="html" role="usernotes">User Notes:
+    <ulink url="&blfs-wiki;/gail"/></para>
+
+  </sect2>
+
+  <sect2 role="installation">
+    <title>Installation of GAIL</title>
+
+    <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
+    href="../../xincludes/without-gnome.xml"/>
+
+    <para>Install <application>GAIL</application> by running
+    the following commands:</para>
+
+<screen><userinput>./configure --prefix=$(pkg-config --variable=prefix ORBit-2.0) &&
+make</userinput></screen>
+
+    <para>This package does not come with a test suite.</para>
+
+    <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
+
+<screen role="root"><userinput>make install &&
+
+if [ $(pkg-config --variable=prefix ORBit-2.0) != "/usr" ]; then
+    ln -v -s $(pkg-config --variable=prefix \
+             ORBit-2.0)/lib/gtk-2.0/modules \
+         /usr/lib/gtk-2.0
+fi</userinput></screen>
+
+  </sect2>
+
+  <sect2 role="commands">
+    <title>Command Explanations</title>
+
+    <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
+    href="../../xincludes/gnome-prefix.xml"/>
+
+    <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
+    href="../../xincludes/gtk-doc-rebuild.xml"/>
+
+    <para><command>if [ ... != "/usr" ]; then ...; fi</command>:
+    <application>GTK+</application> will look for the
+    <application>GAIL</application> modules in
+    <filename class='directory'>/usr/lib</filename> even if
+    <envar>$GNOME_PREFIX</envar> is NOT
+    <filename class='directory'>/usr</filename>. This command creates a
+    symbolic link to satisfy this requirement.</para>
+
+  </sect2>
+
+  <sect2 role="content">
+    <title>Contents</title>
+
+    <segmentedlist>
+      <segtitle>Installed Programs</segtitle>
+      <segtitle>Installed Libraries</segtitle>
+      <segtitle>Installed Directories</segtitle>
+
+      <seglistitem>
+        <seg>None</seg>
+        <seg>libgailutil.so and <application>GAIL</application>
+        <application>GTK+</application> modules</seg>
+        <seg>The following subdirectories of <envar>$GNOME_PREFIX</envar>/:
+        include/gail-1.0,
+        lib/gtk-2.0/modules and
+        share/gtk-doc/html/gail-libgail-util</seg>
+      </seglistitem>
+    </segmentedlist>
+
+    <variablelist>
+      <bridgehead renderas="sect3">Short Descriptions</bridgehead>
+      <?dbfo list-presentation="list"?>
+      <?dbhtml list-presentation="table"?>
+
+      <varlistentry id="libgailutil">
+        <term><filename class='libraryfile'>libgailutil.so</filename></term>
+        <listitem>
+          <para>provides the functions that solve accessibility problems
+          in a consistent manner across <application>GNOME</application>.</para>
+          <indexterm zone="gail libgailutil">
+            <primary sortas="c-libgailutil">libgailutil.so</primary>
+          </indexterm>
+        </listitem>
+      </varlistentry>
+
+    </variablelist>
+
+  </sect2>
+
+</sect1>

Modified: trunk/BOOK/introduction/welcome/changelog.xml
===================================================================
--- trunk/BOOK/introduction/welcome/changelog.xml	2010-08-12 12:18:41 UTC (rev 8475)
+++ trunk/BOOK/introduction/welcome/changelog.xml	2010-08-12 12:58:36 UTC (rev 8476)
@@ -72,6 +72,9 @@
         <listitem>
           <para>[wblaszcz] - Updated to ORBit2-2.14.18.</para>
         </listitem>
+        <listitem>
+          <para>[ken] - Revert reinstatement of gail, it is now in Gtk+.</para>
+        </listitem>
       </itemizedlist>
     </listitem>
 

Modified: trunk/BOOK/x/lib/webkitgtk.xml
===================================================================
--- trunk/BOOK/x/lib/webkitgtk.xml	2010-08-12 12:18:41 UTC (rev 8475)
+++ trunk/BOOK/x/lib/webkitgtk.xml	2010-08-12 12:58:36 UTC (rev 8476)
@@ -64,7 +64,6 @@
 
     <bridgehead renderas="sect4">Required</bridgehead>
     <para role="required"><xref linkend="enchant"/>,
-    <xref linkend="gail"/>,
     <xref linkend="gperf"/>,
     <xref linkend="gst-plugins-base"/>,
     <xref linkend="gtk2"/>,




More information about the blfs-book mailing list