r7895 - in trunk/BOOK: . general/genlib general/genutils general/sysutils introduction/welcome

gdalziel at linuxfromscratch.org gdalziel at linuxfromscratch.org
Tue Jul 28 07:31:06 PDT 2009


Author: gdalziel
Date: 2009-07-28 08:31:06 -0600 (Tue, 28 Jul 2009)
New Revision: 7895

Modified:
   trunk/BOOK/general.ent
   trunk/BOOK/general/genlib/aspell.xml
   trunk/BOOK/general/genlib/glib2.xml
   trunk/BOOK/general/genlib/libxml.xml
   trunk/BOOK/general/genlib/libxslt.xml
   trunk/BOOK/general/genutils/desktop-file-utils.xml
   trunk/BOOK/general/sysutils/pciutils.xml
   trunk/BOOK/introduction/welcome/changelog.xml
Log:
Updated to pciutils-3.1.3. Includes several LFS-6.5 checks.

Modified: trunk/BOOK/general/genlib/aspell.xml
===================================================================
--- trunk/BOOK/general/genlib/aspell.xml	2009-07-28 13:49:51 UTC (rev 7894)
+++ trunk/BOOK/general/genlib/aspell.xml	2009-07-28 14:31:06 UTC (rev 7895)
@@ -34,6 +34,8 @@
     <application>Aspell</application> can either be used as a library or as an
     independent spell checker.</para>
 
+    &lfs65_checked;
+
     <bridgehead renderas="sect3">Package Information</bridgehead>
     <itemizedlist spacing="compact">
       <listitem>

Modified: trunk/BOOK/general/genlib/glib2.xml
===================================================================
--- trunk/BOOK/general/genlib/glib2.xml	2009-07-28 13:49:51 UTC (rev 7894)
+++ trunk/BOOK/general/genlib/glib2.xml	2009-07-28 14:31:06 UTC (rev 7895)
@@ -93,10 +93,11 @@
             --with-pcre=system &&
 make</userinput></screen>
 
-    <para>The GLib test suite requires <application>desktop-file-utils</application> 
-    in order to run. However, <application>desktop-file-utils</application> 
-    requires <application>GLib</application> in order to compile; therefore,
-    you must first install <application>GLib</application> and then run the test 
+    <para>The <application>GLib</application> test suite requires
+    <application>desktop-file-utils</application> in order to run. However,
+    <application>desktop-file-utils</application> requires
+    <application>GLib</application> in order to compile; therefore, you must
+    first install <application>GLib</application> and then run the test
     suite.</para>
 
     <para>Now, as the <systemitem class="username">root</systemitem> user:</para>

Modified: trunk/BOOK/general/genlib/libxml.xml
===================================================================
--- trunk/BOOK/general/genlib/libxml.xml	2009-07-28 13:49:51 UTC (rev 7894)
+++ trunk/BOOK/general/genlib/libxml.xml	2009-07-28 14:31:06 UTC (rev 7895)
@@ -33,6 +33,8 @@
     <application>libxml</application> libraries. These are useful for parsing
     XML files.</para>
 
+    &lfs65_checked;
+
     <bridgehead renderas="sect3">Package Information</bridgehead>
     <itemizedlist spacing="compact">
       <listitem>

Modified: trunk/BOOK/general/genlib/libxslt.xml
===================================================================
--- trunk/BOOK/general/genlib/libxslt.xml	2009-07-28 13:49:51 UTC (rev 7894)
+++ trunk/BOOK/general/genlib/libxslt.xml	2009-07-28 14:31:06 UTC (rev 7895)
@@ -34,6 +34,8 @@
     class="libraryfile">libxml2</filename> libraries to support
     XSLT files.</para>
 
+    &lfs65_checked;
+
     <bridgehead renderas="sect3">Package Information</bridgehead>
     <itemizedlist spacing="compact">
       <listitem>

Modified: trunk/BOOK/general/genutils/desktop-file-utils.xml
===================================================================
--- trunk/BOOK/general/genutils/desktop-file-utils.xml	2009-07-28 13:49:51 UTC (rev 7894)
+++ trunk/BOOK/general/genutils/desktop-file-utils.xml	2009-07-28 14:31:06 UTC (rev 7895)
@@ -115,7 +115,7 @@
       extended with the environment variables <envar>XDG_CONFIG_DIRS</envar>
       and <envar>XDG_DATA_DIRS</envar>, respectively. The
       <application>GNOME</application>, <application>KDE</application> and
-      <application>XFCE</application> environments respect respect these
+      <application>XFCE</application> environments respect these
       settings. Update the <envar>XDG_DATA_DIRS</envar> (if necessary) and
       <envar>XDG_CONFIG_DIRS</envar> environment variables so that the
       additional MIME-types application databases and desktop menu files are

Modified: trunk/BOOK/general/sysutils/pciutils.xml
===================================================================
--- trunk/BOOK/general/sysutils/pciutils.xml	2009-07-28 13:49:51 UTC (rev 7894)
+++ trunk/BOOK/general/sysutils/pciutils.xml	2009-07-28 14:31:06 UTC (rev 7895)
@@ -6,9 +6,9 @@
 
   <!ENTITY pciutils-download-http "http://www.kernel.org/pub/software/utils/pciutils/pciutils-&pciutils-version;.tar.bz2">
   <!ENTITY pciutils-download-ftp  "ftp://ftp.kernel.org/pub/software/utils/pciutils/pciutils-&pciutils-version;.tar.bz2">
-  <!ENTITY pciutils-md5sum        "7c891d039c8e7a7ec73ff2fc8317e21c">
-  <!ENTITY pciutils-size          "256 KB">
-  <!ENTITY pciutils-buildsize     "3.3 MB">
+  <!ENTITY pciutils-md5sum        "ca1f40e03bea12ac3646e47cefa47f01">
+  <!ENTITY pciutils-size          "266 KB">
+  <!ENTITY pciutils-buildsize     "3 MB">
   <!ENTITY pciutils-time          "less than 0.1 SBU">
 ]>
 
@@ -33,6 +33,8 @@
     is a set of programs for listing PCI devices, inspecting
     their status and setting their configuration registers.</para>
 
+    &lfs65_checked;
+
     <bridgehead renderas="sect3">Package Information</bridgehead>
     <itemizedlist spacing="compact">
       <listitem>
@@ -75,12 +77,14 @@
 <screen role="root"><userinput>make PREFIX=/usr install</userinput></screen>
 
     <para>Some packages require the PCI static library. To install the library
-    and headers, issue the following commands as the
+    and headers, issue the following command as the
     <systemitem class="username">root</systemitem> user:</para>
 
-<screen role="root"><userinput>install -v -m 755 -d /usr/include/pci &&
+<screen role="root"><userinput>make PREFIX=/usr install-lib</userinput></screen>
+
+<!-- <screen role="root"><userinput>install -v -m 755 -d /usr/include/pci &&
 install -v -m 644 lib/libpci.a /usr/lib &&
-install -v -m 644 lib/*.h /usr/include/pci</userinput></screen>
+install -v -m 644 lib/*.h /usr/include/pci</userinput></screen> -->
 
   </sect2>
 

Modified: trunk/BOOK/general.ent
===================================================================
--- trunk/BOOK/general.ent	2009-07-28 13:49:51 UTC (rev 7894)
+++ trunk/BOOK/general.ent	2009-07-28 14:31:06 UTC (rev 7895)
@@ -213,7 +213,7 @@
 <!ENTITY which-version                "2.20">
 <!ENTITY unzip-version                "5.52">
 <!ENTITY zip-version                  "3.0">
-<!ENTITY pciutils-version             "3.0.3">
+<!ENTITY pciutils-version             "3.1.3">
 <!ENTITY usbutils-version             "0.73">
 <!ENTITY cpio-version                 "2.9">
 <!ENTITY mc-version                   "4.6.1">

Modified: trunk/BOOK/introduction/welcome/changelog.xml
===================================================================
--- trunk/BOOK/introduction/welcome/changelog.xml	2009-07-28 13:49:51 UTC (rev 7894)
+++ trunk/BOOK/introduction/welcome/changelog.xml	2009-07-28 14:31:06 UTC (rev 7895)
@@ -44,6 +44,10 @@
       <para>July 28th, 2009</para>
       <itemizedlist>
         <listitem>
+          <para>[gdalziel] - Updated to pciutils-3.1.3. Thanks to Matthew for 
+          the hint about install-lib.</para>
+        </listitem>
+        <listitem>
           <para>[gdalziel] - Updated to desktop-file-utils-0.15.</para>
         </listitem>
         <listitem>




More information about the blfs-book mailing list