[BLFS Trac] #2482: GNOME-2.24.2

BLFS Trac trac at linuxfromscratch.org
Sat Nov 29 01:19:45 PST 2008


#2482: GNOME-2.24.2
----------------------------------------+-----------------------------------
 Reporter:  randy at linuxfromscratch.org  |        Owner:  blfs-book at linuxfromscratch.org
     Type:  task                        |       Status:  new                           
 Priority:  normal                      |    Milestone:  6.4                           
Component:  BOOK                        |      Version:  SVN                           
 Severity:  normal                      |   Resolution:                                
 Keywords:                              |  
----------------------------------------+-----------------------------------
Comment (by dj at linuxfromscratch.org):

 Correction...libffi.a and libffi.la would be overwritten.

 BTW..citing recent discussions concerning nss, EDS does _not_ require a
 rebuild if system nss is replaced.

 pygtk still will not use numpy...will look into updating it with the numpy
 script at a later time.

 gnome-panel _requires_ libgweather...and will use polkit_gnome and network
 manager (both left out for now).

 vte no longer supports pcre (didn't in 2.18.x gnome either, did in 2.20
 and 2.22) but the configure summary output is still there with an always
 empty variable.

 libgtop will optionall use AFS.

 dep libxklavier (3.8) requires iso-codes.

 eel has optional dependency for startup notification (though Desktop
 recommends it, it is not a hard dep and should be listed).

 Nautilus will optionally use Exempi.  Exempi is an XMP implementation
 based on Adobe's XMP.  Looks like a pretty cool addition.
 http://libopenraw.freedesktop.org/wiki/Exempi  and more info about what
 XMP is from adobe's site http://www.adobe.com/products/xmp/overview.html

 gstreamer fails to install if gtkdoc is not installed, Debian has a
 patch...but Ken already submitted one...which I found after I had already
 rediffed the thing...however, debian one puts the which an the command in
 a subshell and goes true on exit.  Either way works...maybe a dash thing?

 same thing for gst-plugins-base, and same difference in patches, but I
 used Ken's patch! :-)

 new package and dep for control-center, gnome setting daemon.  Configure
 is broken if $XORG_PREFIX != /usr.  AFAICT the autofoo requires major
 surgery on this one, or put the old /usr/include/X11 symlink back.  Filing
 a bug upstream as it's broken either way.

-- 
Ticket URL: <http://wiki.linuxfromscratch.org/blfs/ticket/2482#comment:7>
BLFS Trac <http://wiki.linuxfromscratch.org/blfs>
Beyond Linux From Scratch



More information about the blfs-book mailing list