[BLFS Trac] #2696: PCI Utilities-3.0.3 and HAL-0.5.9.1

BLFS Trac trac at linuxfromscratch.org
Tue Dec 23 22:46:19 PST 2008


#2696: PCI Utilities-3.0.3 and HAL-0.5.9.1
--------------------+-------------------------------------------------------
 Reporter:  Spinal  |       Owner:  blfs-book@…                   
     Type:  defect  |      Status:  new                           
 Priority:  normal  |   Milestone:  6.4                           
Component:  BOOK    |     Version:  SVN                           
 Severity:  normal  |    Keywords:                                
--------------------+-------------------------------------------------------
 HAL depends on PCI Utils installation and needs uncompressed PCI ID list.
 It won't even compile with the current installation provided by
 instructions in BLFS book.

 To fix the issue alter PCI Utils instructions to be like this:

 {{{
 make PREFIX=/usr ZLIB=no
 }}}
 or like this (my installation):
 {{{
 make PREFIX=/usr ZLIB=no SHARED=yes
 }}}

 And by the way all this stuff after 'make install' in the book is not
 needed:
 {{{
 make PREFIX=/usr ZLIB=no [ SHARED=yes ] install install-lib
 }}}

-- 
Ticket URL: <http://wiki.linuxfromscratch.org/blfs/ticket/2696>
BLFS Trac <http://wiki.linuxfromscratch.org/blfs>
Beyond Linux From Scratch



More information about the blfs-book mailing list