[BLFS Trac] #2690: udftools-1.0.0b3 no longer builds

BLFS Trac trac at linuxfromscratch.org
Sun Dec 21 14:11:05 PST 2008


#2690: udftools-1.0.0b3 no longer builds
--------------------------------------+-------------------------------------
 Reporter:  ken@…                     |       Owner:  blfs-book@…                   
     Type:  task                      |      Status:  new                           
 Priority:  normal                    |   Milestone:  6.4                           
Component:  BOOK                      |     Version:  SVN                           
 Severity:  normal                    |    Keywords:                                
--------------------------------------+-------------------------------------
 Some of this is gcc-4.3, some of it might even be the kernel header
 changes in 2.6.23.

 Fedora has a metric shed load of changes to this.  I tried cherry picking
 their changes to cdrwtool.c, and then pktsetup.c, but that just let it die
 in wrudf.c with
 {{{
 wrudf.c: In function ‘initialise’:
 wrudf.c:248: error: lvalue required as left operand of assignment
 make[1]: *** [wrudf.o] Error 1
 }}}

 I tried using parts of their warningfixes2.patch which makes some changes
 to wrudf.c, but the first hunk in that file doesn't apply (probably
 depends on another of their patches), and with that hunk dropped the rest
 of the patch makes no change to that error.

 Upstream appears to be defunct.  I don't have any interest in this
 package, so unless someone cares to fix it I think we should drop it.

-- 
Ticket URL: <http://wiki.linuxfromscratch.org/blfs/ticket/2690>
BLFS Trac <http://wiki.linuxfromscratch.org/blfs>
Beyond Linux From Scratch



More information about the blfs-book mailing list