[BLFS Trac] #2684: libmad-0.15.1b fails to build with gcc-4.3.2

BLFS Trac trac at linuxfromscratch.org
Sun Dec 14 10:15:48 PST 2008


#2684: libmad-0.15.1b fails to build with gcc-4.3.2
--------------------------------------+-------------------------------------
 Reporter:  ken@…                     |       Owner:  blfs-book@…                   
     Type:  task                      |      Status:  new                           
 Priority:  normal                    |   Milestone:  6.4                           
Component:  BOOK                      |     Version:  SVN                           
 Severity:  normal                    |    Keywords:                                
--------------------------------------+-------------------------------------
 For my own builds, I've dropped libmad.  But, I was testing cdrdao in
 greater depth and figured I might as well isntall this again.  cc1 now
 barfs on -fforce-mem which had been deprecated for a long time, and was
 dropped for gcc-4.3.

 The build fix is a simple
 {{{
 sed -i '/-fforce-mem/d' configure
 }}}
 but this does highlight that the package is no longer maintained.  Perhaps
 it's a bit too early to drop it, in which case the fix needs to go in.

-- 
Ticket URL: <http://wiki.linuxfromscratch.org/blfs/ticket/2684>
BLFS Trac <http://wiki.linuxfromscratch.org/blfs>
Beyond Linux From Scratch



More information about the blfs-book mailing list