r6797 - in trunk/BOOK: introduction/welcome x/installing

dnicholson at linuxfromscratch.org dnicholson at linuxfromscratch.org
Thu May 31 00:26:12 PDT 2007


Author: dnicholson
Date: 2007-05-31 01:26:12 -0600 (Thu, 31 May 2007)
New Revision: 6797

Modified:
   trunk/BOOK/introduction/welcome/changelog.xml
   trunk/BOOK/x/installing/x7app.xml
   trunk/BOOK/x/installing/x7driver.xml
   trunk/BOOK/x/installing/x7lib.xml
Log:
Streamlined the commands in the Xorg sections


Modified: trunk/BOOK/introduction/welcome/changelog.xml
===================================================================
--- trunk/BOOK/introduction/welcome/changelog.xml	2007-05-31 07:13:24 UTC (rev 6796)
+++ trunk/BOOK/introduction/welcome/changelog.xml	2007-05-31 07:26:12 UTC (rev 6797)
@@ -49,6 +49,10 @@
           Xorg-Server to match that from XKeyboardConfig. Reported by
           DJ Lucas.</para>
         </listitem>
+        <listitem>
+          <para>[dnicholson] - Streamlined the commands for each Xorg
+          section.</para>
+        </listitem>
       </itemizedlist>
     </listitem>
 

Modified: trunk/BOOK/x/installing/x7app.xml
===================================================================
--- trunk/BOOK/x/installing/x7app.xml	2007-05-31 07:13:24 UTC (rev 6796)
+++ trunk/BOOK/x/installing/x7app.xml	2007-05-31 07:26:12 UTC (rev 6797)
@@ -11,6 +11,9 @@
   <!ENTITY x7apps-buildsize     "30.7 MB">
   <!ENTITY x7apps-time          "2.9 SBU">
 
+  <!-- Versions for patches -->
+  <!ENTITY xload-version        "1.0.1">
+
 ]>
 
 <sect1 id="xorg7-app" xreflabel="Xorg Applications">
@@ -62,7 +65,7 @@
     <itemizedlist spacing="compact">
       <listitem>
         <para>Required patch: <ulink
-        url="&patch-root;/xload-1.0.1-setuid-1.patch"/></para>
+        url="&patch-root;/xload-&xload-version;-setuid-1.patch"/></para>
       </listitem>
     </itemizedlist>
 
@@ -104,18 +107,15 @@
     <warning><para>The <application>mkcfm</application> package is
     deprecated and should not be installed.</para></warning>
 
-    <para>A <ulink url='http://wiki.x.org/wiki/Development/Security'>security
-    vulnerability</ulink> has been identified in the xload package.
-    Before building this package with the commands
-    shown below, be sure to apply the supplied patches. The patch can be
-    applied with with the following command:</para>
-
-<screen><userinput>patch -Np1 -i ../xload-1.0.1-setuid-1.patch</userinput></screen>
-
     <para>Install the applications by running the following commands for each
-    chosen package:</para>
+    package:</para>
 
-<screen><userinput>./configure $XORG_CONFIG &&
+<screen><userinput>case $(basename "$PWD") in
+xload-&xload-version; )
+    patch -Np1 -i ../xload-&xload-version;-setuid-1.patch
+    ;;
+esac &&
+./configure $XORG_CONFIG &&
 make</userinput></screen>
 
     <para>These packages do not provide test suites.</para>
@@ -127,6 +127,16 @@
 
   </sect2>
 
+  <sect2 role="commands">
+    <title>Command Explanations</title>
+
+    <para><command>patch -Np1 -i
+    ../xload-&xload-version;-setuid-1.patch</command>: This patch fixes a
+    <ulink url='http://wiki.x.org/wiki/Development/Security'>security
+    vulnerability</ulink> that has been identified in the xload package.</para>
+
+  </sect2>
+
   <sect2 role="content">
     <title>Contents</title>
 

Modified: trunk/BOOK/x/installing/x7driver.xml
===================================================================
--- trunk/BOOK/x/installing/x7driver.xml	2007-05-31 07:13:24 UTC (rev 6796)
+++ trunk/BOOK/x/installing/x7driver.xml	2007-05-31 07:26:12 UTC (rev 6797)
@@ -85,21 +85,6 @@
   <sect2 role="installation">
     <title>Installation of Xorg Drivers</title>
 
-    <para>The <application>xf86-input-evdev</application>,
-    <application>xf86-video-ati</application>,
-    <application>xf86-video-fbdev</application>,
-    <application>xf86-video-glint</application>, and
-    <application>xf86-video-newport</application> packages install
-    man pages in UTF-8 encoding, and they will not display correctly
-    using <application>Man-DB</application>. Issue the following
-    command before building these packages to replace the offending
-    characters with ones that <command>man</command> can properly
-    display.</para>
-
-<screen><userinput>sed -i -e "s/\xc3\xb8/\\\\[\/o]/" \
-       -e "s/\xc3\xa4/\\\\[:a]/" \
-       -e "s/\xc3\x9c/\\\\[:U]/" man/*.man</userinput></screen>
-
     <warning><para>It is very important not to build display drivers that
     cannot be used with your hardware.  For instance, do not build Sun drivers
     for an x86 PC as the Sun drivers will expect to see SPARC symbols
@@ -110,7 +95,16 @@
     <para>Install the drivers by running the following commands for each
     package:</para>
 
-<screen><userinput>./configure $XORG_CONFIG \
+<screen><userinput>case $(basename "$PWD") in
+xf86-input-evdev-[0-9]* | xf86-video-ati-[0-9]* | \
+xf86-video-fbdev-[0-9]* | xf86-video-glint-[0-9]* | \
+xf86-video-newport-[0-9]* )
+    sed -i -e "s/\xc3\xb8/\\\\[\/o]/" \
+           -e "s/\xc3\xa4/\\\\[:a]/" \
+           -e "s/\xc3\x9c/\\\\[:U]/" man/*.man
+    ;;
+esac &&
+./configure $XORG_CONFIG \
     --with-xorg-module-dir=$XORG_PREFIX/lib/X11/modules &&
 make</userinput></screen>
 
@@ -126,6 +120,12 @@
   <sect2 role="commands">
     <title>Command Explanations</title>
 
+    <para><command>sed -i ... man/*.man</command>: A few packages install
+    man pages in UTF-8 encoding, and they will not display correctly
+    using <application>Man-DB</application>. This command converts the
+    offending characters to ones that <command>man</command> can properly
+    display.</para>
+
     <para><parameter>--with-xorg-module-dir=...</parameter>: This switch
     ensures that the drivers are installed into the correct directory.</para>
 

Modified: trunk/BOOK/x/installing/x7lib.xml
===================================================================
--- trunk/BOOK/x/installing/x7lib.xml	2007-05-31 07:13:24 UTC (rev 6796)
+++ trunk/BOOK/x/installing/x7lib.xml	2007-05-31 07:26:12 UTC (rev 6797)
@@ -11,6 +11,10 @@
   <!ENTITY x7libs-buildsize     "186 MB">
   <!ENTITY x7libs-time          "6.6 SBU">
 
+  <!-- Versions for patches -->
+  <!ENTITY libX11-version       "1.1.1">
+  <!ENTITY libXfont-version     "1.2.7">
+
 ]>
 
 <sect1 id="xorg7-lib" xreflabel="Xorg Libraries">
@@ -61,11 +65,11 @@
     <itemizedlist spacing="compact">
       <listitem>
         <para>Required patch: <ulink
-        url="&patch-root;/libX11-1.1.1-xinitimage-1.patch"/></para>
+        url="&patch-root;/libX11-&libX11-version;-xinitimage-1.patch"/></para>
       </listitem>
       <listitem>
         <para>Required patch: <ulink
-        url="&patch-root;/libXfont-1.2.7-bdf_fontsdir-1.patch"/></para>
+        url="&patch-root;/libXfont-&libXfont-version;-bdf_fontsdir-1.patch"/></para>
       </listitem>
     </itemizedlist>
 
@@ -103,24 +107,18 @@
   <sect2 role="installation">
     <title>Installation of Xorg Libraries</title>
 
-    <para><ulink url='http://wiki.x.org/wiki/Development/Security'>Security
-    vulnerabilities</ulink> have been identified in the
-    <application>libX11</application> and <application>libXfont</application>
-    packages. Before building these packages with the commands shown below,
-    be sure to apply the supplied patches. For <application>libX11</application>,
-    this can be done by issuing the following command:</para>
-
-<screen><userinput>patch -Np1 -i ../libX11-1.1.1-xinitimage-1.patch</userinput></screen>
-
-    <para>For <application>libXfont</application>, the patch can be applied
-    with the following command:</para>
-
-<screen><userinput>patch -Np1 -i ../libXfont-1.2.7-bdf_fontsdir-1.patch</userinput></screen>
-
     <para>Install the libraries by running the following commands for each
-    of the chosen packages:</para>
+    package:</para>
 
-<screen><userinput>./configure $XORG_CONFIG --without-xcb &&
+<screen><userinput>case $(basename "$PWD") in
+libX11-&libX11-version; )
+    patch -Np1 -i ../libX11-&libX11-version;-xinitimage-1.patch
+    ;;
+libXfont-&libXfont-version; )
+    patch -Np1 -i ../libXfont-&libXfont-version;-bdf_fontsdir-1.patch
+    ;;
+esac &&
+./configure $XORG_CONFIG &&
 make</userinput></screen>
 
     <para>These packages do not provide test suites.</para>
@@ -141,6 +139,12 @@
     for it's transport layer unless this parameter is supplied. This parameter
     will be ignored for other packages.</para>
 
+    <para><command>patch -Np1 -i ...</command>: These commands apply patches
+    to fix <ulink url='http://wiki.x.org/wiki/Development/Security'>security
+    vulnerabilities</ulink> identified in the
+    <application>libX11</application> and <application>libXfont</application>
+    packages.</para>
+
   </sect2>
 
   <sect2 role="configuration">




More information about the blfs-book mailing list