r6680 - in trunk/BOOK: . introduction/welcome postlfs/security server/databases

randy at linuxfromscratch.org randy at linuxfromscratch.org
Tue Mar 20 08:55:46 PDT 2007


Author: randy
Date: 2007-03-20 09:55:46 -0600 (Tue, 20 Mar 2007)
New Revision: 6680

Modified:
   trunk/BOOK/general.ent
   trunk/BOOK/introduction/welcome/changelog.xml
   trunk/BOOK/postlfs/security/heimdal.xml
   trunk/BOOK/server/databases/db.xml
Log:
Updated to Berkeley DB-4.5.20 to match the version used in LFS

Modified: trunk/BOOK/general.ent
===================================================================
--- trunk/BOOK/general.ent	2007-03-20 04:29:48 UTC (rev 6679)
+++ trunk/BOOK/general.ent	2007-03-20 15:55:46 UTC (rev 6680)
@@ -36,11 +36,11 @@
      BDB package updates cause the library names to change,
      ensure you update the Heimdal package to the current
      BDB library names. -->
-<!ENTITY lfs-bdb-version              "4.4.20">
-<!ENTITY lfs-coreutils-version        "5.96">
+<!ENTITY lfs-bdb-version              "4.5.20">
+<!ENTITY lfs-coreutils-version        "6.7">
 <!ENTITY lfs-flex-version             "2.5.33">
 <!ENTITY lfs-perl-version             "5.8.8">
-<!ENTITY lfs-shadow-version           "4.0.17">
+<!ENTITY lfs-shadow-version           "4.0.18.1">
 <!ENTITY lfs-vim-version              "7.0">
 <!ENTITY lfs-gcc-version              "4.1.2">
 <!-- End LFS versions -->
@@ -349,7 +349,7 @@
 
 <!-- Ensure you check the library version number and update the
      Heimdal instructions (postlfs/security/heimdal.xml) if necessary -->
-<!ENTITY db-version                   "4.4.20">
+<!ENTITY db-version                   "4.5.20">
 <!-- End special note about Heimdal -->
 
 <!ENTITY mysql-version                "5.0.21">

Modified: trunk/BOOK/introduction/welcome/changelog.xml
===================================================================
--- trunk/BOOK/introduction/welcome/changelog.xml	2007-03-20 04:29:48 UTC (rev 6679)
+++ trunk/BOOK/introduction/welcome/changelog.xml	2007-03-20 15:55:46 UTC (rev 6680)
@@ -45,6 +45,10 @@
       <para>March 20th, 2007</para>
       <itemizedlist>
         <listitem>
+          <para>[randy] - Updated to Berkeley DB-4.5.20 to match the version
+          used in LFS.</para>
+        </listitem>
+        <listitem>
           <para>[randy] - Updated to JDK-1.5.0.11 (source and binary).</para>
         </listitem>
       </itemizedlist>

Modified: trunk/BOOK/postlfs/security/heimdal.xml
===================================================================
--- trunk/BOOK/postlfs/security/heimdal.xml	2007-03-20 04:29:48 UTC (rev 6679)
+++ trunk/BOOK/postlfs/security/heimdal.xml	2007-03-20 15:55:46 UTC (rev 6680)
@@ -194,9 +194,9 @@
 mv -v /usr/bin/{login,su} /bin &&
 ln -v -sf ../../bin/login /usr/bin &&
 mv -v /usr/lib/lib{otp,kafs,krb5,asn1,roken,crypto}.so.* \
-      /usr/lib/libdb-4.4.so /lib &&
-ln -v -sf ../../lib/libdb-4.4.so /usr/lib/libdb.so &&
-ln -v -sf ../../lib/libdb-4.4.so /usr/lib/libdb-4.so &&
+      /usr/lib/libdb-4.5.so /lib &&
+ln -v -sf ../../lib/libdb-4.5.so /usr/lib/libdb.so &&
+ln -v -sf ../../lib/libdb-4.5.so /usr/lib/libdb-4.so &&
 for SYMLINK in otp.so.0.1.3  kafs.so.0.4.1   krb5.so.17.4.0 \
                asn1.so.6.1.0 roken.so.16.1.0 crypto.so.0.9.8
 do

Modified: trunk/BOOK/server/databases/db.xml
===================================================================
--- trunk/BOOK/server/databases/db.xml	2007-03-20 04:29:48 UTC (rev 6679)
+++ trunk/BOOK/server/databases/db.xml	2007-03-20 15:55:46 UTC (rev 6680)
@@ -4,12 +4,12 @@
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
 
-  <!ENTITY db-download-http "http://downloads.sleepycat.com/db-&db-version;.tar.gz">
-  <!ENTITY db-download-ftp  "ftp://ftp.sleepycat.com/releases/db-&db-version;.tar.gz">
-  <!ENTITY db-md5sum        "d84dff288a19186b136b0daf7067ade3">
-  <!ENTITY db-size          "7.9 MB">
-  <!ENTITY db-buildsize     "66.7 MB (additional 100 MB to run parallel standard test suite)">
-  <!ENTITY db-time          "1.4 SBU (builds all bindings, add an additional 145 SBU to run parallel standard test suite)">
+  <!ENTITY db-download-http "http://download-east.oracle.com/berkeley-db/db-&db-version;.tar.gz">
+  <!ENTITY db-download-ftp  "ftp://ftp.fu-berlin.de/unix/linux/mirrors/gentoo/distfiles/db-&db-version;.tar.gz">
+  <!ENTITY db-md5sum        "b0f1c777708cb8e9d37fb47e7ed3312d">
+  <!ENTITY db-size          "9.2 MB">
+  <!ENTITY db-buildsize     "94 MB (additional 100 MB to run parallel standard test suite)">
+  <!ENTITY db-time          "1.7 SBU (builds all bindings, add an additional 145 SBU to run parallel standard test suite)">
 ]>
 
 <sect1 id="db" xreflabel="Berkeley DB-&db-version;">
@@ -63,20 +63,12 @@
     <itemizedlist spacing="compact">
       <listitem>
         <para>Required patch: <ulink
-        url="http://www.sleepycat.com/update/4.4.20/patch.4.4.20.1"/></para>
+        url="http://www.oracle.com/technology/products/berkeley-db/db/update/&db-version;/patch.&db-version;.1"/></para>
       </listitem>
       <listitem>
         <para>Required patch: <ulink
-        url="http://www.sleepycat.com/update/4.4.20/patch.4.4.20.2"/></para>
+        url="http://www.oracle.com/technology/products/berkeley-db/db/update/&db-version;/patch.&db-version;.2"/></para>
       </listitem>
-      <listitem>
-        <para>Required patch: <ulink
-        url="http://www.sleepycat.com/update/4.4.20/patch.4.4.20.3"/></para>
-      </listitem>
-      <listitem>
-        <para>Required patch: <ulink
-        url="http://www.sleepycat.com/update/4.4.20/patch.4.4.20.4"/></para>
-      </listitem>
     </itemizedlist>
 
     <bridgehead renderas="sect3">Berkeley DB Dependencies</bridgehead>
@@ -106,7 +98,8 @@
     <para>Build for the <application>Berkeley DB</application> test by running
     the following commands:</para>
 
-<screen><userinput>for PATCH in ../patch.4.4.20.{1..4}; do patch -Np0 -i $PATCH; done &&
+<screen><userinput>patch -Np0 -i ../patch.&db-version;.1 &&
+patch -Np0 -i ../patch.&db-version;.2 &&
 cd build_unix &&
 ../dist/configure --prefix=/usr \
                   --enable-test \
@@ -143,7 +136,8 @@
     below. Install <application>Berkeley DB</application> by running the
     following commands:</para>
 
-<screen><userinput>for PATCH in ../patch.4.4.20.{1..4}; do patch -Np0 -i $PATCH; done &&
+<screen><userinput>patch -Np0 -i ../patch.&db-version;.1 &&
+patch -Np0 -i ../patch.&db-version;.2 &&
 cd build_unix &&
 ../dist/configure --prefix=/usr \
                   --enable-compat185 \




More information about the blfs-book mailing list