r6676 - in trunk/BOOK: gnome gnome/core introduction/welcome

randy at linuxfromscratch.org randy at linuxfromscratch.org
Sun Mar 18 13:51:46 PDT 2007


Author: randy
Date: 2007-03-18 14:51:46 -0600 (Sun, 18 Mar 2007)
New Revision: 6676

Modified:
   trunk/BOOK/gnome/core/libgnomecanvas.xml
   trunk/BOOK/gnome/core/orbit2.xml
   trunk/BOOK/gnome/gnome-intro.xml
   trunk/BOOK/introduction/welcome/changelog.xml
Log:
Added a warning to the GNOME introduction section, and links to this warning in various GNOME package instructions telling to use the stable version of BLFS to build current GNOME

Modified: trunk/BOOK/gnome/core/libgnomecanvas.xml
===================================================================
--- trunk/BOOK/gnome/core/libgnomecanvas.xml	2007-03-18 19:43:07 UTC (rev 6675)
+++ trunk/BOOK/gnome/core/libgnomecanvas.xml	2007-03-18 20:51:46 UTC (rev 6676)
@@ -59,7 +59,9 @@
     <bridgehead renderas="sect3">libgnomecanvas Dependencies</bridgehead>
 
     <bridgehead renderas="sect4">Required</bridgehead>
-    <para role="required"><xref linkend="libglade"/> and
+    <para role="required"><xref linkend="libglade"/> (ensure you read the
+    <quote><xref linkend="gnome_broken"/></quote> warning before installing
+    the dependencies) and
     <xref linkend="libart_lgpl"/></para>
 
     <bridgehead renderas="sect4">Optional</bridgehead>

Modified: trunk/BOOK/gnome/core/orbit2.xml
===================================================================
--- trunk/BOOK/gnome/core/orbit2.xml	2007-03-18 19:43:07 UTC (rev 6675)
+++ trunk/BOOK/gnome/core/orbit2.xml	2007-03-18 20:51:46 UTC (rev 6676)
@@ -58,7 +58,9 @@
     <bridgehead renderas="sect3">ORBit2 Dependencies</bridgehead>
 
     <bridgehead renderas="sect4">Required</bridgehead>
-    <para role="required"><xref linkend="libidl"/></para>
+    <para role="required"><xref linkend="libidl"/> (ensure you read the
+    <quote><xref linkend="gnome_broken"/></quote> warning before installing
+    the dependencies)</para>
 
     <bridgehead renderas="sect4">Optional</bridgehead>
     <para role="optional"><xref linkend="gtk-doc"/> and

Modified: trunk/BOOK/gnome/gnome-intro.xml
===================================================================
--- trunk/BOOK/gnome/gnome-intro.xml	2007-03-18 19:43:07 UTC (rev 6675)
+++ trunk/BOOK/gnome/gnome-intro.xml	2007-03-18 20:51:46 UTC (rev 6676)
@@ -14,6 +14,16 @@
 
   <title>Introduction to GNOME</title>
 
+  <warning id="gnome_broken" xreflabel="SVN GNOME is Broken">
+    <para>The <application>GLib</application>/<application>GTK+</application>
+    tool stack in the current SVN book is not compatible with this version
+    of GNOME. If you want to build GNOME using these instructions, you should
+    follow the stable BLFS 6.2.0 book (<ulink url="../stable/gnome/gnome.html"/>),
+    including
+    using the versions of the packages listed there. The BLFS development team
+    is working as hard as possible to bring the book up to GNOME-2.18.x.</para>
+  </warning>
+
   <para>This chapter presents the instructions to install a complete
   GNOME-&gnome-version;&gnome-minor-version; desktop environment; and a limited
   GNOME 1.4 library environment that is sufficient to run GNOME 1.4

Modified: trunk/BOOK/introduction/welcome/changelog.xml
===================================================================
--- trunk/BOOK/introduction/welcome/changelog.xml	2007-03-18 19:43:07 UTC (rev 6675)
+++ trunk/BOOK/introduction/welcome/changelog.xml	2007-03-18 20:51:46 UTC (rev 6676)
@@ -45,6 +45,12 @@
       <para>March 18th, 2007</para>
       <itemizedlist>
         <listitem>
+          <para>[randy] - Added a warning to the GNOME introduction section,
+          and links to this warning in various GNOME package instructions
+          telling to use the stable version of BLFS to build current
+          GNOME.</para>
+        </listitem>
+        <listitem>
           <para>[randy] - Updated to GTK+-2.10.11.</para>
         </listitem>
         <listitem>




More information about the blfs-book mailing list