r6968 - in trunk/BOOK: . gnome gnome/core introduction/welcome

randy at linuxfromscratch.org randy at linuxfromscratch.org
Wed Jul 25 07:48:31 PDT 2007


Author: randy
Date: 2007-07-25 08:48:30 -0600 (Wed, 25 Jul 2007)
New Revision: 6968

Modified:
   trunk/BOOK/general.ent
   trunk/BOOK/gnome/core/config.xml
   trunk/BOOK/gnome/core/control-center.xml
   trunk/BOOK/gnome/core/core.xml
   trunk/BOOK/gnome/core/eel.xml
   trunk/BOOK/gnome/core/gail.xml
   trunk/BOOK/gnome/core/gconf.xml
   trunk/BOOK/gnome/core/gnome-applets.xml
   trunk/BOOK/gnome/core/gnome-backgrounds.xml
   trunk/BOOK/gnome/core/gnome-desktop-file-utils.xml
   trunk/BOOK/gnome/core/gnome-desktop.xml
   trunk/BOOK/gnome/core/gnome-doc-utils.xml
   trunk/BOOK/gnome/core/gnome-icon-theme.xml
   trunk/BOOK/gnome/core/gnome-keyring.xml
   trunk/BOOK/gnome/core/gnome-menus.xml
   trunk/BOOK/gnome/core/gnome-mime-data.xml
   trunk/BOOK/gnome/core/gnome-panel.xml
   trunk/BOOK/gnome/core/gnome-session.xml
   trunk/BOOK/gnome/core/gnome-shared-mime-info.xml
   trunk/BOOK/gnome/core/gnome-terminal.xml
   trunk/BOOK/gnome/core/gnome-themes.xml
   trunk/BOOK/gnome/core/gnome-user-docs.xml
   trunk/BOOK/gnome/core/gnome-vfs.xml
   trunk/BOOK/gnome/core/gtk-engines.xml
   trunk/BOOK/gnome/core/libbonobo.xml
   trunk/BOOK/gnome/core/libbonoboui.xml
   trunk/BOOK/gnome/core/libgnome.xml
   trunk/BOOK/gnome/core/libgnomecanvas.xml
   trunk/BOOK/gnome/core/libgnomeui.xml
   trunk/BOOK/gnome/core/libgtop.xml
   trunk/BOOK/gnome/core/nautilus.xml
   trunk/BOOK/gnome/core/orbit2.xml
   trunk/BOOK/gnome/core/pre-install-config.xml
   trunk/BOOK/gnome/core/vte.xml
   trunk/BOOK/gnome/core/yelp.xml
   trunk/BOOK/gnome/gnome-intro.xml
   trunk/BOOK/introduction/welcome/changelog.xml
Log:
Updated core GNOME-2 to version 2.18.3. Separated the core packages into 'Platform' and 'Desktop' sections

Modified: trunk/BOOK/general.ent
===================================================================
--- trunk/BOOK/general.ent	2007-07-25 04:06:14 UTC (rev 6967)
+++ trunk/BOOK/general.ent	2007-07-25 14:48:30 UTC (rev 6968)
@@ -443,7 +443,7 @@
 <!ENTITY kdevelop-version             "3.3.6">
 
 <!-- Part IX -->
-<!ENTITY gnome-version                "2.14">
+<!ENTITY gnome-version                "2.18">
 <!ENTITY gnome-minor-version          ".3">
 <!ENTITY gnome-etc-dir                "/etc/gnome/&gnome-version;&gnome-minor-version;">
 <!ENTITY gnome-download-http          "http://ftp.gnome.org/pub/gnome/sources">
@@ -452,86 +452,86 @@
 <!-- Chapter 31 -->
 
 <!-- Platform -->
-<!ENTITY GConf-version                "2.14.0">
-<!ENTITY gnome-icon-theme-version     "2.14.2">
-<!ENTITY gnome-keyring-version        "0.4.9">
-<!ENTITY gnome-mime-data-version      "2.4.2">
-<!ENTITY gnome-vfs-version            "2.14.2">
+<!ENTITY GConf-version                "2.18.0.1">
+<!ENTITY gnome-icon-theme-version     "2.18.0">
+<!ENTITY gnome-keyring-version        "0.8.1">
+<!ENTITY gnome-mime-data-version      "2.4.3">
+<!ENTITY gnome-vfs-version            "2.18.1">
 <!ENTITY gnome-vfs-monikers-version   "2.15.3">
-<!ENTITY libbonobo-version            "2.14.0">
-<!ENTITY libbonoboui-version          "2.14.0">
-<!ENTITY libgnome-version             "2.14.1">
+<!ENTITY libbonobo-version            "2.18.0">
+<!ENTITY libbonoboui-version          "2.18.0">
+<!ENTITY libgnome-version             "2.18.0">
 <!ENTITY libgnomecanvas-version       "2.14.0">
-<!ENTITY libgnomeui-version           "2.14.1">
-<!ENTITY ORBit2-version               "2.14.2">
+<!ENTITY libgnomeui-version           "2.18.1">
+<!ENTITY ORBit2-version               "2.14.7">
 
 <!-- Desktop -->
-<!ENTITY control-center-version       "2.14.2">
-<!ENTITY eel-version                  "2.14.3">
-<!ENTITY gail-version                 "1.8.11">
-<!ENTITY gnome-applets-version        "2.14.3">
-<!ENTITY gnome-backgrounds-version    "2.14.2.1">
-<!ENTITY gnome-desktop-version        "2.14.3">
-<!ENTITY gnome-doc-utils-version      "0.6.1">
-<!ENTITY gnome-menus-version          "2.14.3">
-<!ENTITY gnome-panel-version          "2.14.3">
-<!ENTITY gnome-session-version        "2.14.3">
-<!ENTITY gnome-terminal-version       "2.14.2">
-<!ENTITY gnome-themes-version         "2.14.3">
-<!ENTITY gnome-user-docs-version      "2.14.2">
-<!ENTITY gtk-engines-version          "2.6.10">
-<!ENTITY libgtop-version              "2.14.2">
-<!ENTITY nautilus-version             "2.14.3">
-<!ENTITY vte-version                  "0.16.0">
-<!ENTITY yelp-version                 "2.14.3">
+<!ENTITY control-center-version       "2.18.1">
+<!ENTITY eel-version                  "2.18.3">
+<!ENTITY gail-version                 "1.18.0">
+<!ENTITY gnome-applets-version        "2.18.0">
+<!ENTITY gnome-backgrounds-version    "2.18.3">
+<!ENTITY gnome-desktop-version        "2.18.3">
+<!ENTITY gnome-doc-utils-version      "0.10.3">
+<!ENTITY gnome-menus-version          "2.18.3">
+<!ENTITY gnome-panel-version          "2.18.3">
+<!ENTITY gnome-session-version        "2.18.3">
+<!ENTITY gnome-terminal-version       "2.18.1">
+<!ENTITY gnome-themes-version         "2.18.1">
+<!ENTITY gnome-user-docs-version      "2.18.2">
+<!ENTITY gtk-engines-version          "2.10.2">
+<!ENTITY libgtop-version              "2.14.9">
+<!ENTITY nautilus-version             "2.18.3">
+<!ENTITY vte-version                  "0.16.6">
+<!ENTITY yelp-version                 "2.18.1">
 
 <!-- Chapter 32 -->
 
 <!-- Libraries -->
-<!ENTITY evolution-data-server-version "1.6.3">
+<!ENTITY evolution-data-server-version "1.10.3">
 <!ENTITY gnome-audio-version          "2.0.0">
-<!ENTITY gtkhtml-version              "3.10.3">
-<!ENTITY gtksourceview-version        "1.6.2">
+<!ENTITY gtkhtml-version              "3.14.3">
+<!ENTITY gtksourceview-version        "1.8.5">
 <!ENTITY libgnomecups-version         "0.2.2">
 <!ENTITY libgnomekbd-version          "2.18.2">
-<!ENTITY libgnomeprint-version        "2.12.1">
-<!ENTITY libgnomeprintui-version      "2.12.1">
+<!ENTITY libgnomeprint-version        "2.18.0">
+<!ENTITY libgnomeprintui-version      "2.18.0">
 <!ENTITY system-tools-backends-version "1.4.2">
 
 <!-- Utilities -->
-<!ENTITY bug-buddy-version            "2.14.0">
-<!ENTITY ekiga-version                "2.0.2">
-<!ENTITY eog-version                  "2.14.3">
-<!ENTITY epiphany-version             "2.14.2.1">
-<!ENTITY evince-version               "0.5.3">
-<!ENTITY file-roller-version          "2.14.4">
-<!ENTITY gcalctool-version            "5.8.19">
-<!ENTITY gconf-editor-version         "2.14.0">
-<!ENTITY gdm-version                  "2.14.10">
-<!ENTITY gedit-version                "2.14.4">
-<!ENTITY gnome-games-version          "2.14.3">
-<!ENTITY gnome-keyring-manager-version "2.14.0">
-<!ENTITY gnome-media-version          "2.14.2">
-<!ENTITY gnome-mount-version          "0.4">
-<!ENTITY gnome-netstatus-version      "2.12.0">
-<!ENTITY gnome-screensaver-version    "2.14.3">
-<!ENTITY gnome-system-monitor-version "2.14.5">
-<!ENTITY gnome-utils-version          "2.14.0">
-<!ENTITY gnome-volume-manager-version "1.5.15">
-<!ENTITY gucharmap-version            "1.6.0">
-<!ENTITY nautilus-cd-burner-version   "2.14.3">
-<!ENTITY sound-juicer-version         "2.14.5">
-<!ENTITY totem-version                "1.4.3">
-<!ENTITY zenity-version               "2.14.3">
+<!ENTITY bug-buddy-version            "2.18.1">
+<!ENTITY ekiga-version                "2.0.9">
+<!ENTITY eog-version                  "2.18.2">
+<!ENTITY epiphany-version             "2.18.3">
+<!ENTITY evince-version               "0.8.3">
+<!ENTITY file-roller-version          "2.18.4">
+<!ENTITY gcalctool-version            "5.9.14">
+<!ENTITY gconf-editor-version         "2.18.0">
+<!ENTITY gdm-version                  "2.18.2">
+<!ENTITY gedit-version                "2.18.1">
+<!ENTITY gnome-games-version          "2.18.2.1">
+<!ENTITY gnome-keyring-manager-version "2.18.0">
+<!ENTITY gnome-media-version          "2.18.0">
+<!ENTITY gnome-mount-version          "0.6">
+<!ENTITY gnome-netstatus-version      "2.12.1">
+<!ENTITY gnome-screensaver-version    "2.18.2">
+<!ENTITY gnome-system-monitor-version "2.18.2">
+<!ENTITY gnome-utils-version          "2.18.1">
+<!ENTITY gnome-volume-manager-version "2.17.0">
+<!ENTITY gucharmap-version            "1.10.0">
+<!ENTITY nautilus-cd-burner-version   "2.18.2">
+<!ENTITY sound-juicer-version         "2.16.4">
+<!ENTITY totem-version                "2.18.2">
+<!ENTITY zenity-version               "2.18.2">
 
 <!-- Accessibility -->
-<!ENTITY at-spi-version               "1.7.7">
-<!ENTITY gnome-mag-version            "0.12.6">
-<!ENTITY gnome-speech-version         "0.4.2">
-<!ENTITY gnopernicus-version          "1.1.1">
-<!ENTITY gok-version                  "1.0.10">
-<!ENTITY java-access-bridge-version   "1.5.0">
-<!ENTITY libgail-gnome-version        "1.1.3">
+<!ENTITY at-spi-version               "1.18.1">
+<!ENTITY gnome-mag-version            "0.14.6">
+<!ENTITY gnome-speech-version         "0.4.14">
+<!ENTITY gok-version                  "1.2.5">
+<!ENTITY java-access-bridge-version   "1.18.0">
+<!ENTITY libgail-gnome-version        "1.18.0">
+<!ENTITY orca-version                 "2.18.1">
 
 <!-- Obsolete -->
 <!ENTITY gal-version                  "2.4.3">
@@ -540,6 +540,7 @@
 <!ENTITY ggv-version                  "2.12.0">
 <!ENTITY gnomemeeting-version         "1.2.2">
 <!ENTITY gnome2-user-docs-version     "2.8.1">
+<!ENTITY gnopernicus-version          "1.1.1">
 
 <!-- Chapter 33 -->
 <!ENTITY ORBit-version                "0.5.17">

Modified: trunk/BOOK/gnome/core/config.xml
===================================================================
--- trunk/BOOK/gnome/core/config.xml	2007-07-25 04:06:14 UTC (rev 6967)
+++ trunk/BOOK/gnome/core/config.xml	2007-07-25 14:48:30 UTC (rev 6968)
@@ -34,7 +34,7 @@
     mentioned before <application>GNOME</application>.</para>
   </note>
 
-  <para>Ensure all libraries can be found with (as
+  <para>Ensure all libraries can be found by udating the linker's cache (as
   <systemitem class="username">root</systemitem>):</para>
 
 <screen role='root'><userinput>ldconfig</userinput></screen>

Modified: trunk/BOOK/gnome/core/control-center.xml
===================================================================
--- trunk/BOOK/gnome/core/control-center.xml	2007-07-25 04:06:14 UTC (rev 6967)
+++ trunk/BOOK/gnome/core/control-center.xml	2007-07-25 14:48:30 UTC (rev 6968)
@@ -6,10 +6,10 @@
 
   <!ENTITY control-center-download-http "&gnome-download-http;/control-center/&gnome-version;/control-center-&control-center-version;.tar.bz2">
   <!ENTITY control-center-download-ftp  "&gnome-download-ftp;/control-center/&gnome-version;/control-center-&control-center-version;.tar.bz2">
-  <!ENTITY control-center-md5sum        "08711b0f14584e7eaa9f4c275085ab36">
-  <!ENTITY control-center-size          "1.8 MB">
-  <!ENTITY control-center-buildsize     "60.2 MB">
-  <!ENTITY control-center-time          "1.5 SBU">
+  <!ENTITY control-center-md5sum        "bae0fd0f9e32f374bd7236d98788b13f">
+  <!ENTITY control-center-size          "2.1 MB">
+  <!ENTITY control-center-buildsize     "71 MB">
+  <!ENTITY control-center-time          "2 SBU">
 ]>
 
 <sect1 id="control-center" xreflabel="Control Center-&control-center-version;">
@@ -57,24 +57,24 @@
     <bridgehead renderas="sect3">Control Center Dependencies</bridgehead>
 
     <bridgehead renderas="sect4">Required</bridgehead>
-    <para role="required"><xref linkend="libxklavier"/>,
-    <xref linkend="metacity"/>,
-    <xref linkend="gnome-icon-theme"/>, and
+    <para role="required"><xref linkend="gst-plugins-base"/>,
+    <xref linkend="libgnomekbd"/>,
+    <xref linkend="metacity"/>, and
     <xref linkend="nautilus"/></para>
 
     <bridgehead renderas="sect4">Optional</bridgehead>
-    <para role="optional"><xref linkend="evolution-data-server"/>,
-    <xref linkend="alsa"/>, and
-    <xref linkend="gst-plugins-base"/></para>
+    <para role="optional"><xref linkend="hal"/>,
+    <xref linkend="shared-mime-info"/>,
+    <xref linkend="evolution-data-server"/>, and
+    <xref linkend="alsa"/></para>
 
     <para>Though they are only run-time dependencies and
     <application>Control Center</application> will compile just fine without
     them installed, there are two screen saver packages that can be installed
     which will provide a robust collection of screen savers and screen
-    locking capability. <ulink
-    url="&gnome-download-http;/gnome-screensaver/2.14/">GNOME
-    ScreenSaver</ulink> (BLFS page is forthcoming) is looked for first, with a
-    fallback to <xref linkend="xscreensaver"/> if necessary.</para>
+    locking capability. <xref linkend="gnome-screensaver"/> is looked for
+    first, with a fallback to <xref linkend="xscreensaver"/> if
+    necessary.</para>
 
     <para condition="html" role="usernotes">User Notes:
     <ulink url="&blfs-wiki;/control-center"/></para>
@@ -127,6 +127,29 @@
 
   </sect2>
 
+  <sect2 role="configuration">
+    <title>Configuring Control Center</title>
+
+    <sect3 id="control-center-config">
+      <title>Configuration Information</title>
+
+      <para>If <application>HAL</application> was linked into the build and
+      GNOME is being installed in any location other than
+      <filename class='directory'>/usr</filename>, you should create a local
+      <application>D-Bus</application> session configuration file so that the
+      installed <filename>org.gnome.SettingsDaemon.service</filename>
+      file can be discovered by <application>D-Bus</application>. You should
+      reference the information on the <application>D-Bus</application> page
+      for instructions on how to create a
+      <xref linkend="dbus-session-config"/>. You may disregard this if you
+      already created the local <application>D-Bus</application> session
+      configuration file during the <application>GNOME VFS</application>
+      installation.</para>
+
+    </sect3>
+
+  </sect2>
+
   <sect2 role="content">
     <title>Contents</title>
 

Modified: trunk/BOOK/gnome/core/core.xml
===================================================================
--- trunk/BOOK/gnome/core/core.xml	2007-07-25 04:06:14 UTC (rev 6967)
+++ trunk/BOOK/gnome/core/core.xml	2007-07-25 14:48:30 UTC (rev 6968)
@@ -17,7 +17,9 @@
 
   <para>This section contains required elements of the
   <application>GNOME</application> environment to display a functional
-  desktop.</para>
+  desktop. The packages are separated into <quote>Platform</quote> and
+  <quote>Desktop</quote> sections in the same manner as the sources are
+  distributed on the GNOME download mirrors.</para>
 
   <caution>
     <para>The BLFS team recommends that you carefully
@@ -27,20 +29,31 @@
     package that lists the dependency, even if you later install it.</para>
   </caution>
 
+  <!-- This is used as a TOC separator -->
   <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="pre-install-config.xml"/>
+
+  <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="dummy-platform.xml"/>
+
   <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="orbit2.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="libbonobo.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="gconf.xml"/>
+  <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="gnome-shared-mime-info.xml"/>
+  <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="gnome-mime-data.xml"/>
+  <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="gnome-hicolor-icon-theme.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="gnome-desktop-file-utils.xml"/>
-  <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="gnome-mime-data.xml"/>
-  <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="gnome-shared-mime-info.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="gnome-vfs.xml"/>
+  <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="gnome-vfs-monikers.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="libgnome.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="libgnomecanvas.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="libbonoboui.xml"/>
+  <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="gnome-keyring.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="gnome-icon-theme.xml"/>
-  <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="gnome-keyring.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="libgnomeui.xml"/>
+  <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="gail.xml"/>
+
+  <!-- This is used as a TOC separator -->
+  <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="dummy-desktop.xml"/>
+
   <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="gtk-engines.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="gnome-themes.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="gnome-doc-utils.xml"/>
@@ -48,17 +61,18 @@
   <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="gnome-backgrounds.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="gnome-menus.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="gnome-panel.xml"/>
-  <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="gnome-session.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="vte.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="gnome-terminal.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="libgtop.xml"/>
-  <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="gail.xml"/>
-  <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="gnome-applets.xml"/>
+  <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="libgnomekbd.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="eel.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="nautilus.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="control-center.xml"/>
+  <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="gnome-applets.xml"/>
+  <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="gnome-session.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="yelp.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="gnome-user-docs.xml"/>
+
   <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="config.xml"/>
 
 </chapter>

Modified: trunk/BOOK/gnome/core/eel.xml
===================================================================
--- trunk/BOOK/gnome/core/eel.xml	2007-07-25 04:06:14 UTC (rev 6967)
+++ trunk/BOOK/gnome/core/eel.xml	2007-07-25 14:48:30 UTC (rev 6968)
@@ -6,9 +6,9 @@
 
   <!ENTITY eel-download-http "&gnome-download-http;/eel/&gnome-version;/eel-&eel-version;.tar.bz2">
   <!ENTITY eel-download-ftp  "&gnome-download-ftp;/eel/&gnome-version;/eel-&eel-version;.tar.bz2">
-  <!ENTITY eel-md5sum        "cdff898f9a054b35f5e3b7c0142cc2a5">
-  <!ENTITY eel-size          "640 KB">
-  <!ENTITY eel-buildsize     "14.4 MB">
+  <!ENTITY eel-md5sum        "c51fea61eb99eaa7995754b8acf787ff">
+  <!ENTITY eel-size          "643 KB">
+  <!ENTITY eel-buildsize     "14 MB">
   <!ENTITY eel-time          "0.5 SBU">
 ]>
 
@@ -79,9 +79,7 @@
 <screen><userinput>./configure --prefix=$(pkg-config --variable=prefix ORBit-2.0) &&
 make</userinput></screen>
 
-    <para>To test the results, first modify the permissions of the test script
-    by issuing <command>chmod 755 eel/check-eel</command>, then issue:
-    <command>make check</command>.</para>
+    <para>To test the results, issue: <command>make check</command>.</para>
 
     <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
 

Modified: trunk/BOOK/gnome/core/gail.xml
===================================================================
--- trunk/BOOK/gnome/core/gail.xml	2007-07-25 04:06:14 UTC (rev 6967)
+++ trunk/BOOK/gnome/core/gail.xml	2007-07-25 14:48:30 UTC (rev 6968)
@@ -6,9 +6,9 @@
 
   <!ENTITY gail-download-http "&gnome-download-http;/gail/1.8/gail-&gail-version;.tar.bz2">
   <!ENTITY gail-download-ftp  "&gnome-download-ftp;/gail/1.8/gail-&gail-version;.tar.bz2">
-  <!ENTITY gail-md5sum        "ff79df7dd0cf7a5109c089b9b5fbe17f">
-  <!ENTITY gail-size          "584 KB">
-  <!ENTITY gail-buildsize     "19.5 MB">
+  <!ENTITY gail-md5sum        "d58ad8cc79d3cb6778bc015ef69fb499">
+  <!ENTITY gail-size          "610 KB">
+  <!ENTITY gail-buildsize     "21 MB">
   <!ENTITY gail-time          "0.6 SBU">
 ]>
 
@@ -29,9 +29,16 @@
   <sect2 role="package">
     <title>Introduction to GAIL</title>
 
-    <para>The <application>GAIL</application> package contains the
-    <application>GNOME</application> Accessibility Implementation
-    Libraries.</para>
+    <para>The <application>GAIL</application> package provides accessibility
+    support for <application>GTK+</application> and
+    <application>libgnomecanvas</application> by implementing AtkObjects for
+    widgets in <application>GTK+</application> and
+    <application>libgnomecanvas</application>. The
+    <application>GAIL</application> library is a
+    <application>GTK+</application> module. This module is normally used with
+    the atk-bridge <application>GTK+</application> module from
+    <application>AT-SPI</application> to allow an assistive technology, e.g., a
+    screenreader, to query or drive the program.</para>
 
     <bridgehead renderas="sect3">Package Information</bridgehead>
     <itemizedlist spacing="compact">
@@ -89,7 +96,7 @@
     <para><application>GTK+</application> will look for the
     <application>GAIL</application> modules in
     <filename class='directory'>/usr/lib</filename> even if
-    <envar>$GNOME_PREFIX</envar> is <emphasis role='strong'>NOT</emphasis>
+    <envar>$GNOME_PREFIX</envar> is <emphasis>NOT</emphasis>
     <filename class='directory'>/usr</filename>. If <envar>$GNOME_PREFIX</envar>
     is anything other than <filename class='directory'>/usr</filename>, create
     a symlink to <envar>$GNOME_PREFIX</envar> to satisfy this requirement:</para>

Modified: trunk/BOOK/gnome/core/gconf.xml
===================================================================
--- trunk/BOOK/gnome/core/gconf.xml	2007-07-25 04:06:14 UTC (rev 6967)
+++ trunk/BOOK/gnome/core/gconf.xml	2007-07-25 14:48:30 UTC (rev 6968)
@@ -6,9 +6,9 @@
 
   <!ENTITY GConf-download-http "&gnome-download-http;/GConf/&gnome-version;/GConf-&GConf-version;.tar.bz2">
   <!ENTITY GConf-download-ftp  "&gnome-download-http;/GConf/&gnome-version;/GConf-&GConf-version;.tar.bz2">
-  <!ENTITY GConf-md5sum        "d07c2efcaf477cf34225c604a04b6271">
-  <!ENTITY GConf-size          "1.8 MB">
-  <!ENTITY GConf-buildsize     "29.7 MB">
+  <!ENTITY GConf-md5sum        "aa0e0a0729fb021bab72b4166fd392f9">
+  <!ENTITY GConf-size          "1.3 MB">
+  <!ENTITY GConf-buildsize     "32 MB">
   <!ENTITY GConf-time          "0.4 SBU">
 ]>
 
@@ -63,8 +63,8 @@
     <bridgehead renderas="sect4">Optional</bridgehead>
     <para role="optional"><xref linkend="gtk2"/>,
     <xref linkend="openldap"/>,
-    <xref linkend="gtk-doc"/>, and
-    <xref linkend="docbook-utils"/></para>
+    <xref linkend="intltool"/>, and
+    <xref linkend="gtk-doc"/></para>
 
     <para condition="html" role="usernotes">User Notes:
     <ulink url="&blfs-wiki;/gconf"/></para>

Modified: trunk/BOOK/gnome/core/gnome-applets.xml
===================================================================
--- trunk/BOOK/gnome/core/gnome-applets.xml	2007-07-25 04:06:14 UTC (rev 6967)
+++ trunk/BOOK/gnome/core/gnome-applets.xml	2007-07-25 14:48:30 UTC (rev 6968)
@@ -6,10 +6,10 @@
 
   <!ENTITY gnome-applets-download-http "&gnome-download-http;/gnome-applets/&gnome-version;/gnome-applets-&gnome-applets-version;.tar.bz2">
   <!ENTITY gnome-applets-download-ftp  "&gnome-download-ftp;/gnome-applets/&gnome-version;/gnome-applets-&gnome-applets-version;.tar.bz2">
-  <!ENTITY gnome-applets-md5sum        "ab96f071db993461533cb740281a7373">
-  <!ENTITY gnome-applets-size          "6.5 MB">
-  <!ENTITY gnome-applets-buildsize     "111 MB">
-  <!ENTITY gnome-applets-time          "1.3 SBU">
+  <!ENTITY gnome-applets-md5sum        "db3ef99c00335798f30fc0a9162c0257">
+  <!ENTITY gnome-applets-size          "7.1 MB">
+  <!ENTITY gnome-applets-buildsize     "118 MB">
+  <!ENTITY gnome-applets-time          "1.1 SBU">
 ]>
 
 <sect1 id="gnome-applets" xreflabel="GNOME Applets-&gnome-applets-version;">
@@ -58,16 +58,24 @@
     <bridgehead renderas="sect3">GNOME Applets Dependencies</bridgehead>
 
     <bridgehead renderas="sect4">Required</bridgehead>
-    <para role="required"><xref linkend="gail"/>,
-    <xref linkend="gnome-panel"/>, and
-    <xref linkend="libxklavier"/></para>
+    <para role="required"><xref linkend="scrollkeeper"/>,
+    <xref linkend="gail"/>,
+    <xref linkend="gnome-icon-theme"/>,
+    <xref linkend="gnome-panel"/></para>
 
     <bridgehead renderas="sect4">Optional</bridgehead>
     <para role="optional"><xref linkend="libgtop"/>,
+    <xref linkend="control-center"/>,
     <xref linkend="gst-plugins-base"/>,
     <xref linkend="hal"/>,
+    <xref linkend="libgnomekbd"/>,
     <xref linkend="gucharmap"/>,
     <xref linkend="system-tools-backends"/>,
+    <ulink url="&gnome-download-http;/gnome-python-desktop/">gnome-python-desktop</ulink>,
+    <ulink url="&gnome-download-http;/gnome-python/">GNOME-Python</ulink>
+    (requires <ulink url="http://www.pygtk.org/">PyGTK</ulink> and can use
+    <ulink url="&gnome-download-http;/pyorbit/">PyORBit</ulink>,
+    see <xref linkend="hal-runtime-dependencies"/>),
     <xref linkend="docbook-utils"/>,
     <ulink url="http://club.pep.ne.jp/~ishioka/Software/Linux/libapm-e.html">libapm</ulink>, and
     <ulink url="http://www.galago-project.org/news/index.php">libnotify</ulink></para>
@@ -133,15 +141,15 @@
     <title>Contents</title>
 
     <segmentedlist>
-      <segtitle>Installed Programs</segtitle>
+      <segtitle>Installed Program</segtitle>
       <segtitle>Installed Libraries</segtitle>
       <segtitle>Installed Directories</segtitle>
 
       <seglistitem>
-        <seg>cpufreq-selector and gswitchit-plugins-capplet</seg>
+        <seg>cpufreq-selector</seg>
         <seg>None</seg>
         <seg>The following subdirectories of <envar>$GNOME_PREFIX</envar>/:
-        include/libg{switchit,weather},
+        include/libgweather,
         lib/gnome-applets,
         share/{gnome-applets, {gnome/help,omf}/{too many to list},
         pixmaps/{accessx-status-applet, cpufreq-applet, stickynotes},

Modified: trunk/BOOK/gnome/core/gnome-backgrounds.xml
===================================================================
--- trunk/BOOK/gnome/core/gnome-backgrounds.xml	2007-07-25 04:06:14 UTC (rev 6967)
+++ trunk/BOOK/gnome/core/gnome-backgrounds.xml	2007-07-25 14:48:30 UTC (rev 6968)
@@ -6,9 +6,9 @@
 
   <!ENTITY gnome-backgrounds-download-http "&gnome-download-http;/gnome-backgrounds/&gnome-version;/gnome-backgrounds-&gnome-backgrounds-version;.tar.bz2">
   <!ENTITY gnome-backgrounds-download-ftp  "&gnome-download-ftp;/gnome-backgrounds/&gnome-version;/gnome-backgrounds-&gnome-backgrounds-version;.tar.bz2">
-  <!ENTITY gnome-backgrounds-md5sum        "10480df7c2e5a08c920c5b0a2ff4f161">
-  <!ENTITY gnome-backgrounds-size          "1.1 MB">
-  <!ENTITY gnome-backgrounds-buildsize     "4.3 MB">
+  <!ENTITY gnome-backgrounds-md5sum        "d91b925d358d2cbc705b4a033e7d5c2e">
+  <!ENTITY gnome-backgrounds-size          "1.2 MB">
+  <!ENTITY gnome-backgrounds-buildsize     "5 MB">
   <!ENTITY gnome-backgrounds-time          "less than 0.1 SBU">
 ]>
 

Modified: trunk/BOOK/gnome/core/gnome-desktop-file-utils.xml
===================================================================
--- trunk/BOOK/gnome/core/gnome-desktop-file-utils.xml	2007-07-25 04:06:14 UTC (rev 6967)
+++ trunk/BOOK/gnome/core/gnome-desktop-file-utils.xml	2007-07-25 14:48:30 UTC (rev 6968)
@@ -18,7 +18,7 @@
   <para>The <xref linkend="desktop-file-utils"/> package is located in
   Chapter 10 — General Utilities and is required by GNOME-2 but is not
   a direct dependency of any GNOME-2 package, therefore the package is
-  mentioned within the GNOME-2 Core Packages chapter to ensure it is
-  installed.</para>
+  mentioned within the GNOME-2 Core Packages (Platform section) chapter to
+  ensure it is installed.</para>
 
 </sect1>

Modified: trunk/BOOK/gnome/core/gnome-desktop.xml
===================================================================
--- trunk/BOOK/gnome/core/gnome-desktop.xml	2007-07-25 04:06:14 UTC (rev 6967)
+++ trunk/BOOK/gnome/core/gnome-desktop.xml	2007-07-25 14:48:30 UTC (rev 6968)
@@ -6,9 +6,9 @@
 
   <!ENTITY gnome-desktop-download-http "&gnome-download-http;/gnome-desktop/&gnome-version;/gnome-desktop-&gnome-desktop-version;.tar.bz2">
   <!ENTITY gnome-desktop-download-ftp  "&gnome-download-ftp;/gnome-desktop/&gnome-version;/gnome-desktop-&gnome-desktop-version;.tar.bz2">
-  <!ENTITY gnome-desktop-md5sum        "2a8547ab0dcb10a1ad297874ae95b06b">
-  <!ENTITY gnome-desktop-size          "1.1 MB">
-  <!ENTITY gnome-desktop-buildsize     "13.6 MB">
+  <!ENTITY gnome-desktop-md5sum        "98de3b7d0da690da8b94cddc74f3914b">
+  <!ENTITY gnome-desktop-size          "1.3 MB">
+  <!ENTITY gnome-desktop-buildsize     "15 MB">
   <!ENTITY gnome-desktop-time          "0.3 SBU">
 ]>
 
@@ -65,6 +65,9 @@
     <bridgehead renderas="sect4">Recommended</bridgehead>
     <para role="recommended"><xref linkend="startup-notification"/></para>
 
+    <bridgehead renderas="sect4">Optional</bridgehead>
+    <para role="optional"><xref linkend="intltool"/></para>
+
     <para condition="html" role="usernotes">User Notes:
     <ulink url="&blfs-wiki;/gnome-desktop"/></para>
 
@@ -78,9 +81,7 @@
 
 <screen><userinput>./configure --prefix=$(pkg-config --variable=prefix ORBit-2.0) \
             --sysconfdir=&gnome-etc-dir; \
-            --localstatedir=/var/lib \
-            --mandir=$(pkg-config \
-                --variable=prefix ORBit-2.0)/share/man &&
+            --localstatedir=/var/lib &&
 make</userinput></screen>
 
     <para>This package does not come with a test suite.</para>
@@ -112,9 +113,6 @@
     other than <filename class='directory'>/usr</filename>.</para>
 
     <xi:include xmlns:xi="http://www.w3.org/2003/XInclude"
-    href="../../xincludes/gnome-mandir.xml"/>
-
-    <xi:include xmlns:xi="http://www.w3.org/2003/XInclude"
     href="../../xincludes/gtk-doc-rebuild.xml"/>
 
   </sect2>

Modified: trunk/BOOK/gnome/core/gnome-doc-utils.xml
===================================================================
--- trunk/BOOK/gnome/core/gnome-doc-utils.xml	2007-07-25 04:06:14 UTC (rev 6967)
+++ trunk/BOOK/gnome/core/gnome-doc-utils.xml	2007-07-25 14:48:30 UTC (rev 6968)
@@ -4,11 +4,11 @@
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
 
-  <!ENTITY gnome-doc-utils-download-http "&gnome-download-http;/gnome-doc-utils/0.6/gnome-doc-utils-&gnome-doc-utils-version;.tar.bz2">
-  <!ENTITY gnome-doc-utils-download-ftp  "&gnome-download-ftp;/gnome-doc-utils/0.6/gnome-doc-utils-&gnome-doc-utils-version;.tar.bz2">
-  <!ENTITY gnome-doc-utils-md5sum        "c706b807b15e07e58561f903c0f20c26">
-  <!ENTITY gnome-doc-utils-size          "384 KB">
-  <!ENTITY gnome-doc-utils-buildsize     "9.0 MB">
+  <!ENTITY gnome-doc-utils-download-http "&gnome-download-http;/gnome-doc-utils/0.10/gnome-doc-utils-&gnome-doc-utils-version;.tar.bz2">
+  <!ENTITY gnome-doc-utils-download-ftp  "&gnome-download-ftp;/gnome-doc-utils/0.10/gnome-doc-utils-&gnome-doc-utils-version;.tar.bz2">
+  <!ENTITY gnome-doc-utils-md5sum        "43f3a4086ec1254cbe20b85948192d18">
+  <!ENTITY gnome-doc-utils-size          "451 KB">
+  <!ENTITY gnome-doc-utils-buildsize     "12 MB">
   <!ENTITY gnome-doc-utils-time          "less than 0.1 SBU">
 ]>
 
@@ -65,7 +65,8 @@
     <bridgehead renderas="sect3">GNOME Doc Utils Dependencies</bridgehead>
 
     <bridgehead renderas="sect4">Required</bridgehead>
-    <para role="required"><xref linkend="libxslt"/></para>
+    <para role="required"><xref linkend="libxslt"/> and
+    <xref linkend="perl-xml-parser"/></para>
 
     <bridgehead renderas="sect4">Recommended</bridgehead>
     <para role="required"><xref linkend="python"/> and
@@ -79,7 +80,8 @@
     other GNOME packages.</para>
 
     <bridgehead renderas="sect4">Optional</bridgehead>
-    <para role="optional"><xref linkend="pkgconfig"/></para>
+    <para role="optional"><xref linkend="pkgconfig"/> and
+    <xref linkend="intltool"/></para>
 
     <para condition="html" role="usernotes">User Notes:
     <ulink url="&blfs-wiki;/gnome-doc-utils"/></para>

Modified: trunk/BOOK/gnome/core/gnome-icon-theme.xml
===================================================================
--- trunk/BOOK/gnome/core/gnome-icon-theme.xml	2007-07-25 04:06:14 UTC (rev 6967)
+++ trunk/BOOK/gnome/core/gnome-icon-theme.xml	2007-07-25 14:48:30 UTC (rev 6968)
@@ -6,10 +6,10 @@
 
   <!ENTITY gnome-icon-theme-download-http "&gnome-download-http;/gnome-icon-theme/&gnome-version;/gnome-icon-theme-&gnome-icon-theme-version;.tar.bz2">
   <!ENTITY gnome-icon-theme-download-ftp  "&gnome-download-ftp;/gnome-icon-theme/&gnome-version;/gnome-icon-theme-&gnome-icon-theme-version;.tar.bz2">
-  <!ENTITY gnome-icon-theme-md5sum        "6f1d33a297bd27e0e9f4c1a5fa956166">
-  <!ENTITY gnome-icon-theme-size          "2.9 MB">
-  <!ENTITY gnome-icon-theme-buildsize     "29.6 MB">
-  <!ENTITY gnome-icon-theme-time          "0.2 SBU">
+  <!ENTITY gnome-icon-theme-md5sum        "0b9aa12c473e0be61dc324b059c106e3">
+  <!ENTITY gnome-icon-theme-size          "2.7 MB">
+  <!ENTITY gnome-icon-theme-buildsize     "19 MB">
+  <!ENTITY gnome-icon-theme-time          "0.3 SBU">
 ]>
 
 <sect1 id="gnome-icon-theme" xreflabel="GNOME Icon Theme-&gnome-icon-theme-version;">
@@ -58,10 +58,11 @@
     <bridgehead renderas="sect3">GNOME Icon Theme Dependencies</bridgehead>
 
     <bridgehead renderas="sect4">Required</bridgehead>
-    <para role="required"><xref linkend="perl-xml-parser"/></para>
+    <para role="required"><xref linkend="icon-naming-utils"/> and
+    <xref linkend="perl-xml-parser"/></para>
 
     <bridgehead renderas="sect4">Optional</bridgehead>
-    <para role="optional"><xref linkend="hicolor-icon-theme"/> and
+    <para role="optional"><xref linkend="intltool"/> and
     <xref linkend="pkgconfig"/></para>
 
     <para condition="html" role="usernotes">User Notes:
@@ -93,14 +94,11 @@
       <segtitle>Installed Programs</segtitle>
       <segtitle>Installed Libraries</segtitle>
       <segtitle>Installed Directory</segtitle>
-      <segtitle>Installed Icons</segtitle>
 
       <seglistitem>
         <seg>None</seg>
         <seg>None</seg>
         <seg>/usr/share/icons/gnome</seg>
-        <seg>Several icons under the /usr/share/icons/gnome and
-        /usr/share/icons/hicolor hierarchies.</seg>
       </seglistitem>
     </segmentedlist>
 

Modified: trunk/BOOK/gnome/core/gnome-keyring.xml
===================================================================
--- trunk/BOOK/gnome/core/gnome-keyring.xml	2007-07-25 04:06:14 UTC (rev 6967)
+++ trunk/BOOK/gnome/core/gnome-keyring.xml	2007-07-25 14:48:30 UTC (rev 6968)
@@ -4,11 +4,11 @@
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
 
-  <!ENTITY gnome-keyring-download-http "&gnome-download-http;/gnome-keyring/0.4/gnome-keyring-&gnome-keyring-version;.tar.bz2">
-  <!ENTITY gnome-keyring-download-ftp  "&gnome-download-ftp;/gnome-keyring/0.4/gnome-keyring-&gnome-keyring-version;.tar.bz2">
-  <!ENTITY gnome-keyring-md5sum        "9a90820acf11a66e4c3dd9e163231071">
-  <!ENTITY gnome-keyring-size          "396 KB">
-  <!ENTITY gnome-keyring-buildsize     "5.6 MB">
+  <!ENTITY gnome-keyring-download-http "&gnome-download-http;/gnome-keyring/0.8/gnome-keyring-&gnome-keyring-version;.tar.bz2">
+  <!ENTITY gnome-keyring-download-ftp  "&gnome-download-ftp;/gnome-keyring/0.8/gnome-keyring-&gnome-keyring-version;.tar.bz2">
+  <!ENTITY gnome-keyring-md5sum        "24b15dedcf40c1c60d0fb989370d80ff">
+  <!ENTITY gnome-keyring-size          "448 KB">
+  <!ENTITY gnome-keyring-buildsize     "8 MB">
   <!ENTITY gnome-keyring-time          "0.1 SBU">
 ]>
 
@@ -57,8 +57,13 @@
     <bridgehead renderas="sect3">gnome-keyring Dependencies</bridgehead>
 
     <bridgehead renderas="sect4">Required</bridgehead>
-    <para role="required"><xref linkend="gtk2"/></para>
+    <para role="required"><xref linkend="gtk2"/> and
+    <xref linkend="perl-xml-parser"/></para>
 
+    <bridgehead renderas="sect4">Optional</bridgehead>
+    <para role="optional"><xref linkend="dbus"/> and
+    <xref linkend="intltool"/></para>
+
     <para condition="html" role="usernotes">User Notes:
     <ulink url="&blfs-wiki;/gnome-keyring"/></para>
 

Modified: trunk/BOOK/gnome/core/gnome-menus.xml
===================================================================
--- trunk/BOOK/gnome/core/gnome-menus.xml	2007-07-25 04:06:14 UTC (rev 6967)
+++ trunk/BOOK/gnome/core/gnome-menus.xml	2007-07-25 14:48:30 UTC (rev 6968)
@@ -6,9 +6,9 @@
 
   <!ENTITY gnome-menus-download-http "&gnome-download-http;/gnome-menus/&gnome-version;/gnome-menus-&gnome-menus-version;.tar.bz2">
   <!ENTITY gnome-menus-download-ftp  "&gnome-download-ftp;/gnome-menus/&gnome-version;/gnome-menus-&gnome-menus-version;.tar.bz2">
-  <!ENTITY gnome-menus-md5sum        "9926e7ad14255d1a08c7e774052f8a3a">
-  <!ENTITY gnome-menus-size          "406 KB">
-  <!ENTITY gnome-menus-buildsize     "7.4 MB">
+  <!ENTITY gnome-menus-md5sum        "e2b97b01b33b9744baf26982a8ad588a">
+  <!ENTITY gnome-menus-size          "437 KB">
+  <!ENTITY gnome-menus-buildsize     "8 MB">
   <!ENTITY gnome-menus-time          "0.2 SBU">
 ]>
 
@@ -85,7 +85,8 @@
     following commands:</para>
 
 <screen><userinput>./configure --prefix=$(pkg-config --variable=prefix ORBit-2.0) \
-            --sysconfdir=&gnome-etc-dir; &&
+            --sysconfdir=&gnome-etc-dir; \
+            --enable-inotify &&
 make</userinput></screen>
 
     <para>This package does not come with a test suite.</para>
@@ -105,6 +106,11 @@
     <xi:include xmlns:xi="http://www.w3.org/2003/XInclude"
     href="../../xincludes/gnome-sysconfdir.xml"/>
 
+    <para><parameter>--enable-inotify</parameter>: This parameter is used so
+    that file polling is accomplished using the kernel inotify calls, instead
+    of using other polling methods. Remove this parameter if you wish to fall
+    back to <application>Gamin</application> as the file polling method.</para>
+
   </sect2>
 
   <sect2 role="configuration">
@@ -151,9 +157,9 @@
         profile, or in individual user's profiles as shown below:</para>
 
 <screen><literal>export PYTHONPATH=$PYTHONPATH:$(pkg-config --variable=prefix \
-       ORBit-2.0)/lib/python2.4/site-packages:$(pkg-config \
+       ORBit-2.0)/lib/python2.5/site-packages:$(pkg-config \
        --variable=prefix \
-       ORBit-2.0)/lib/python2.4/site-packages/GMenuSimpleEditor</literal></screen>
+       ORBit-2.0)/lib/python2.5/site-packages/GMenuSimpleEditor</literal></screen>
 
       </sect4>
 

Modified: trunk/BOOK/gnome/core/gnome-mime-data.xml
===================================================================
--- trunk/BOOK/gnome/core/gnome-mime-data.xml	2007-07-25 04:06:14 UTC (rev 6967)
+++ trunk/BOOK/gnome/core/gnome-mime-data.xml	2007-07-25 14:48:30 UTC (rev 6968)
@@ -6,8 +6,8 @@
 
   <!ENTITY gnome-mime-data-download-http "&gnome-download-http;/gnome-mime-data/2.4/gnome-mime-data-&gnome-mime-data-version;.tar.bz2">
   <!ENTITY gnome-mime-data-download-ftp  "&gnome-download-ftp;/gnome-mime-data/2.4/gnome-mime-data-&gnome-mime-data-version;.tar.bz2">
-  <!ENTITY gnome-mime-data-md5sum        "37242776b08625fa10c73c18b790e552">
-  <!ENTITY gnome-mime-data-size          "849 KB">
+  <!ENTITY gnome-mime-data-md5sum        "2abe573a6e84b71c58a661d4bafa9bd6">
+  <!ENTITY gnome-mime-data-size          "563 KB">
   <!ENTITY gnome-mime-data-buildsize     "12 MB">
   <!ENTITY gnome-mime-data-time          "less than 0.1 SBU">
 ]>

Modified: trunk/BOOK/gnome/core/gnome-panel.xml
===================================================================
--- trunk/BOOK/gnome/core/gnome-panel.xml	2007-07-25 04:06:14 UTC (rev 6967)
+++ trunk/BOOK/gnome/core/gnome-panel.xml	2007-07-25 14:48:30 UTC (rev 6968)
@@ -6,10 +6,10 @@
 
   <!ENTITY gnome-panel-download-http "&gnome-download-http;/gnome-panel/&gnome-version;/gnome-panel-&gnome-panel-version;.tar.bz2">
   <!ENTITY gnome-panel-download-ftp  "&gnome-download-ftp;/gnome-panel/&gnome-version;/gnome-panel-&gnome-panel-version;.tar.bz2">
-  <!ENTITY gnome-panel-md5sum        "14ab4c3d3ff3d0c1be397b6799a8626c">
-  <!ENTITY gnome-panel-size          "2.5 MB">
-  <!ENTITY gnome-panel-buildsize     "58.7 MB">
-  <!ENTITY gnome-panel-time          "1.0 SBU">
+  <!ENTITY gnome-panel-md5sum        "545348de234fa8222e328fa7f3a5ba71">
+  <!ENTITY gnome-panel-size          "2.7 MB">
+  <!ENTITY gnome-panel-buildsize     "67 MB">
+  <!ENTITY gnome-panel-time          "0.8 SBU">
 ]>
 
 <sect1 id="gnome-panel" xreflabel="GNOME Panel-&gnome-panel-version;">

Modified: trunk/BOOK/gnome/core/gnome-session.xml
===================================================================
--- trunk/BOOK/gnome/core/gnome-session.xml	2007-07-25 04:06:14 UTC (rev 6967)
+++ trunk/BOOK/gnome/core/gnome-session.xml	2007-07-25 14:48:30 UTC (rev 6968)
@@ -6,9 +6,9 @@
 
   <!ENTITY gnome-session-download-http "&gnome-download-http;/gnome-session/&gnome-version;/gnome-session-&gnome-session-version;.tar.bz2">
   <!ENTITY gnome-session-download-ftp  "&gnome-download-ftp;/gnome-session/&gnome-version;/gnome-session-&gnome-session-version;.tar.bz2">
-  <!ENTITY gnome-session-md5sum        "34eb4641e2791ae51acf6f1edfcf3d64">
-  <!ENTITY gnome-session-size          "662 KB">
-  <!ENTITY gnome-session-buildsize     "11.8 MB">
+  <!ENTITY gnome-session-md5sum        "59b6809ed1d8e39c1550217e665c75df">
+  <!ENTITY gnome-session-size          "716 KB">
+  <!ENTITY gnome-session-buildsize     "14 MB">
   <!ENTITY gnome-session-time          "0.3 SBU">
 ]>
 
@@ -57,8 +57,9 @@
     <bridgehead renderas="sect3">GNOME Session Dependencies</bridgehead>
 
     <bridgehead renderas="sect4">Required</bridgehead>
-    <para role="required"><xref linkend="gnome-desktop"/> and
-    <xref linkend="esound"/></para>
+    <para role="required"><xref linkend="gnome-desktop"/>,
+    <xref linkend="control-center"/>, and
+    <xref linkend="dbus-glib"/></para>
 
     <bridgehead renderas="sect4">Optional</bridgehead>
     <para role="optional"><xref linkend="tcpwrappers"/> and

Modified: trunk/BOOK/gnome/core/gnome-shared-mime-info.xml
===================================================================
--- trunk/BOOK/gnome/core/gnome-shared-mime-info.xml	2007-07-25 04:06:14 UTC (rev 6967)
+++ trunk/BOOK/gnome/core/gnome-shared-mime-info.xml	2007-07-25 14:48:30 UTC (rev 6968)
@@ -18,7 +18,7 @@
   <para>The <xref linkend="shared-mime-info"/> package is located in
   Chapter 26 — X Libraries and is required by GNOME-2 but is not a
   direct dependency of any GNOME-2 package, therefore the package is
-  mentioned within the GNOME-2 Core Packages chapter to ensure it is
-  installed.</para>
+  mentioned within the GNOME-2 Core Packages (Platform section) chapter to
+  ensure it is installed.</para>
 
 </sect1>

Modified: trunk/BOOK/gnome/core/gnome-terminal.xml
===================================================================
--- trunk/BOOK/gnome/core/gnome-terminal.xml	2007-07-25 04:06:14 UTC (rev 6967)
+++ trunk/BOOK/gnome/core/gnome-terminal.xml	2007-07-25 14:48:30 UTC (rev 6968)
@@ -6,9 +6,9 @@
 
   <!ENTITY gnome-terminal-download-http "&gnome-download-http;/gnome-terminal/&gnome-version;/gnome-terminal-&gnome-terminal-version;.tar.bz2">
   <!ENTITY gnome-terminal-download-ftp  "&gnome-download-ftp;/gnome-terminal/&gnome-version;/gnome-terminal-&gnome-terminal-version;.tar.bz2">
-  <!ENTITY gnome-terminal-md5sum        "da80071cd707e89cedcfb476cab8b39a">
-  <!ENTITY gnome-terminal-size          "1.7 MB">
-  <!ENTITY gnome-terminal-buildsize     "39.0 MB">
+  <!ENTITY gnome-terminal-md5sum        "c1902cf4727f4cd976d6cc0beb1c03fe">
+  <!ENTITY gnome-terminal-size          "1.9 MB">
+  <!ENTITY gnome-terminal-buildsize     "43 MB">
   <!ENTITY gnome-terminal-time          "0.3 SBU">
 ]>
 
@@ -58,7 +58,7 @@
 
     <bridgehead renderas="sect4">Required</bridgehead>
     <para role="required"><xref linkend="libgnomeui"/>,
-    <xref linkend="scrollkeeper"/>,
+    <xref linkend="gnome-doc-utils"/>,
     <xref linkend="vte"/>, and
     <xref linkend="startup-notification"/></para>
 

Modified: trunk/BOOK/gnome/core/gnome-themes.xml
===================================================================
--- trunk/BOOK/gnome/core/gnome-themes.xml	2007-07-25 04:06:14 UTC (rev 6967)
+++ trunk/BOOK/gnome/core/gnome-themes.xml	2007-07-25 14:48:30 UTC (rev 6968)
@@ -6,10 +6,10 @@
 
   <!ENTITY gnome-themes-download-http "&gnome-download-http;/gnome-themes/&gnome-version;/gnome-themes-&gnome-themes-version;.tar.bz2">
   <!ENTITY gnome-themes-download-ftp  "&gnome-download-ftp;/gnome-themes/&gnome-version;/gnome-themes-&gnome-themes-version;.tar.bz2">
-  <!ENTITY gnome-themes-md5sum        "7c07c4c01404b447f2624e8e400ee787">
-  <!ENTITY gnome-themes-size          "2.5 MB">
-  <!ENTITY gnome-themes-buildsize     "19.7 MB">
-  <!ENTITY gnome-themes-time          "0.2 SBU">
+  <!ENTITY gnome-themes-md5sum        "caa1683da286eeeb0f4f7ec8b0cc34bb">
+  <!ENTITY gnome-themes-size          "2.4 MB">
+  <!ENTITY gnome-themes-buildsize     "25 MB">
+  <!ENTITY gnome-themes-time          "0.3 SBU">
 ]>
 
 <sect1 id="gnome-themes" xreflabel="GNOME Themes-&gnome-themes-version;">
@@ -57,7 +57,7 @@
     <bridgehead renderas="sect3">GNOME Themes Dependencies</bridgehead>
 
     <bridgehead renderas="sect4">Required</bridgehead>
-    <para role="required"><xref linkend="perl-xml-parser"/> and
+    <para role="required"><xref linkend="icon-naming-utils"/> and
     <xref linkend="gtk-engines"/></para>
 
     <bridgehead renderas="sect4">Optional</bridgehead>

Modified: trunk/BOOK/gnome/core/gnome-user-docs.xml
===================================================================
--- trunk/BOOK/gnome/core/gnome-user-docs.xml	2007-07-25 04:06:14 UTC (rev 6967)
+++ trunk/BOOK/gnome/core/gnome-user-docs.xml	2007-07-25 14:48:30 UTC (rev 6968)
@@ -6,10 +6,10 @@
 
   <!ENTITY gnome-user-docs-download-http "&gnome-download-http;/gnome-user-docs/&gnome-version;/gnome-user-docs-&gnome-user-docs-version;.tar.bz2">
   <!ENTITY gnome-user-docs-download-ftp  "&gnome-download-ftp;/gnome-user-docs/&gnome-version;/gnome-user-docs-&gnome-user-docs-version;.tar.bz2">
-  <!ENTITY gnome-user-docs-md5sum        "4f5a7114ccf9e4e31137da50b7333570">
-  <!ENTITY gnome-user-docs-size          "2.0 MB">
-  <!ENTITY gnome-user-docs-buildsize     "13.4 MB">
-  <!ENTITY gnome-user-docs-time          "1.3 SBU">
+  <!ENTITY gnome-user-docs-md5sum        "4d3b5c8bd3cc8008f2a44d98efaa2502">
+  <!ENTITY gnome-user-docs-size          "6.5 MB">
+  <!ENTITY gnome-user-docs-buildsize     "52 MB">
+  <!ENTITY gnome-user-docs-time          "0.1 SBU">
 ]>
 
 <sect1 id="gnome-user-docs"

Modified: trunk/BOOK/gnome/core/gnome-vfs.xml
===================================================================
--- trunk/BOOK/gnome/core/gnome-vfs.xml	2007-07-25 04:06:14 UTC (rev 6967)
+++ trunk/BOOK/gnome/core/gnome-vfs.xml	2007-07-25 14:48:30 UTC (rev 6968)
@@ -6,10 +6,10 @@
 
   <!ENTITY gnome-vfs-download-http "&gnome-download-http;/gnome-vfs/&gnome-version;/gnome-vfs-&gnome-vfs-version;.tar.bz2">
   <!ENTITY gnome-vfs-download-ftp  "&gnome-download-ftp;/gnome-vfs/&gnome-version;/gnome-vfs-&gnome-vfs-version;.tar.bz2">
-  <!ENTITY gnome-vfs-md5sum        "b657e31974d6981adf9b2c4db981f62c">
-  <!ENTITY gnome-vfs-size          "1.8 MB">
-  <!ENTITY gnome-vfs-buildsize     "54.1 MB">
-  <!ENTITY gnome-vfs-time          "1.4 SBU">
+  <!ENTITY gnome-vfs-md5sum        "bf4a6d95180d05981893e5d021c6695c">
+  <!ENTITY gnome-vfs-size          "1.9 MB">
+  <!ENTITY gnome-vfs-buildsize     "56 MB">
+  <!ENTITY gnome-vfs-time          "1.3 SBU">
 ]>
 
 <sect1 id="gnome-vfs" xreflabel="GNOME Virtual File System-&gnome-vfs-version;">
@@ -58,13 +58,11 @@
     <bridgehead renderas="sect3">GNOME Virtual File System Dependencies</bridgehead>
 
     <bridgehead renderas="sect4">Required</bridgehead>
-    <para role="required"><xref linkend="GConf"/>,
-    <xref linkend="libbonobo"/>, and
+    <para role="required"><xref linkend="GConf"/> and
     <xref linkend="gnome-mime-data"/></para>
 
     <bridgehead renderas="sect4">Optional</bridgehead>
     <para role="optional"><xref linkend="samba3"/>,
-    <xref linkend="cdparanoia"/>,
     <xref linkend="gamin"/>,
     <xref linkend="hal"/>,
     <xref linkend="gtk-doc"/>,
@@ -77,8 +75,9 @@
     then <ulink
     url="http://www.gnupg.org/download/index.html#libgcrypt">libgcrypt</ulink>),
     <xref linkend="heimdal"/> or <xref linkend="mitkrb"/>,
+    <ulink url="http://www.avahi.org">Avahi</ulink>,
     <ulink url="http://www.openafs.org/">OpenAFS</ulink>, and
-    <ulink url="http://www.avahi.org">Avahi</ulink></para>
+    <xref linkend="cdparanoia"/> (not recommended)</para>
 
     <para>If you run <command>./configure --help</command> for the complete
     list of dependency requirements and available parameters, you may notice a
@@ -130,6 +129,15 @@
     instead of
     <filename class="directory">$GNOME_PREFIX/libexec</filename>.</para>
 
+    <para><option>--with-dbus-service-dir=/usr/share/dbus-1/services</option>:
+    Use this parameter if you linked <application>HAL</application> into the
+    build and you want the <filename>gnome-vfs-daemon.service</filename> file
+    installed in the default <application>D-Bus</application> location instead
+    of in <filename
+    class='directory'><envar>GNOME_PREFIX</envar>/share/dbus-1/services</filename>.
+    See the information in the configuration section below if you don't use this
+    parameter.</para>
+
     <para><option>--with-hal-eject=PROGRAM</option>: This parameter does not
     need to be passed if you have <ulink
     url="http://ca.geocities.com/jefftranter@rogers.com/eject.html">Eject</ulink>
@@ -142,6 +150,26 @@
 
   </sect2>
 
+  <sect2 role="configuration">
+    <title>Configuring Gnome Virtual File System</title>
+
+    <sect3 id="gnome-vfs-config">
+      <title>Configuration Information</title>
+
+      <para>If <application>HAL</application> was linked into the build and
+      GNOME is being installed in any location other than
+      <filename class='directory'>/usr</filename>, you should create a local
+      <application>D-Bus</application> session configuration file so that the
+      installed <filename>gnome-vfs-daemon.service</filename> file can be
+      discovered by <application>D-Bus</application>. You should reference
+      the information on the <application>D-Bus</application> page for
+      instructions on how to create a
+      <xref linkend="dbus-session-config"/>.</para>
+
+    </sect3>
+
+  </sect2>
+
   <sect2 role="content">
     <title>Contents</title>
 

Modified: trunk/BOOK/gnome/core/gtk-engines.xml
===================================================================
--- trunk/BOOK/gnome/core/gtk-engines.xml	2007-07-25 04:06:14 UTC (rev 6967)
+++ trunk/BOOK/gnome/core/gtk-engines.xml	2007-07-25 14:48:30 UTC (rev 6968)
@@ -4,12 +4,12 @@
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
 
-  <!ENTITY gtk-engines-download-http "&gnome-download-http;/gtk-engines/2.6/gtk-engines-&gtk-engines-version;.tar.bz2">
-  <!ENTITY gtk-engines-download-ftp  "&gnome-download-http;/gtk-engines/2.6/gtk-engines-&gtk-engines-version;.tar.bz2">
-  <!ENTITY gtk-engines-md5sum        "f3e2b14b0cff0988277ccba42e69813d">
-  <!ENTITY gtk-engines-size          "472 KB">
-  <!ENTITY gtk-engines-buildsize     "12.9 MB">
-  <!ENTITY gtk-engines-time          "0.4 SBU">
+  <!ENTITY gtk-engines-download-http "&gnome-download-http;/gtk-engines/2.10/gtk-engines-&gtk-engines-version;.tar.bz2">
+  <!ENTITY gtk-engines-download-ftp  "&gnome-download-http;/gtk-engines/2.10/gtk-engines-&gtk-engines-version;.tar.bz2">
+  <!ENTITY gtk-engines-md5sum        "01de081b24d7b5d92093cad5c5e4b8c7">
+  <!ENTITY gtk-engines-size          "654 KB">
+  <!ENTITY gtk-engines-buildsize     "19 MB">
+  <!ENTITY gtk-engines-time          "0.5 SBU (additional ~9 SBU to run the test suite)">
 ]>
 
 <sect1 id="gtk-engines" xreflabel="GTK Engines-&gtk-engines-version;">
@@ -58,8 +58,12 @@
     <bridgehead renderas="sect3">GTK Engines Dependencies</bridgehead>
 
     <bridgehead renderas="sect4">Required</bridgehead>
-    <para role="required"><xref linkend="gtk2"/></para>
+    <para role="required"><xref linkend="gtk2"/> and
+    <xref linkend="perl-xml-parser"/></para>
 
+    <bridgehead renderas="sect4">Optional</bridgehead>
+    <para role="optional"><xref linkend="intltool"/></para>
+
     <para condition="html" role="usernotes">User Notes:
     <ulink url="&blfs-wiki;/gtk-engines"/></para>
 
@@ -74,7 +78,8 @@
 <screen><userinput>./configure --prefix=/usr &&
 make</userinput></screen>
 
-    <para>This package does not come with a test suite.</para>
+    <para>To test the results, issue: <command>make check</command>. This
+    takes quite a while.</para>
 
     <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
 

Modified: trunk/BOOK/gnome/core/libbonobo.xml
===================================================================
--- trunk/BOOK/gnome/core/libbonobo.xml	2007-07-25 04:06:14 UTC (rev 6967)
+++ trunk/BOOK/gnome/core/libbonobo.xml	2007-07-25 14:48:30 UTC (rev 6968)
@@ -6,9 +6,9 @@
 
   <!ENTITY libbonobo-download-http "&gnome-download-http;/libbonobo/&gnome-version;/libbonobo-&libbonobo-version;.tar.bz2">
   <!ENTITY libbonobo-download-ftp  "&gnome-download-ftp;/libbonobo/&gnome-version;/libbonobo-&libbonobo-version;.tar.bz2">
-  <!ENTITY libbonobo-md5sum        "f1f0255f94e3354250d142b688013fad">
-  <!ENTITY libbonobo-size          "1.3 MB">
-  <!ENTITY libbonobo-buildsize     "35.8 MB">
+  <!ENTITY libbonobo-md5sum        "8f0676e63420abf622f799cdd24ed9cc">
+  <!ENTITY libbonobo-size          "1.4 MB">
+  <!ENTITY libbonobo-buildsize     "38 MB">
   <!ENTITY libbonobo-time          "0.7 SBU">
 ]>
 
@@ -65,7 +65,8 @@
     <xref linkend="perl-xml-parser"/></para>
 
     <bridgehead renderas="sect4">Optional</bridgehead>
-    <para role="optional"><xref linkend="x-window-system"/> and
+    <para role="optional"><xref linkend="x-window-system"/>,
+    <xref linkend="intltool"/>, and
     <xref linkend="gtk-doc"/></para>
 
     <para condition="html" role="usernotes">User Notes:

Modified: trunk/BOOK/gnome/core/libbonoboui.xml
===================================================================
--- trunk/BOOK/gnome/core/libbonoboui.xml	2007-07-25 04:06:14 UTC (rev 6967)
+++ trunk/BOOK/gnome/core/libbonoboui.xml	2007-07-25 14:48:30 UTC (rev 6968)
@@ -6,9 +6,9 @@
 
   <!ENTITY libbonoboui-download-http "&gnome-download-http;/libbonoboui/&gnome-version;/libbonoboui-&libbonoboui-version;.tar.bz2">
   <!ENTITY libbonoboui-download-ftp  "&gnome-download-ftp;/libbonoboui/&gnome-version;/libbonoboui-&libbonoboui-version;.tar.bz2">
-  <!ENTITY libbonoboui-md5sum        "dc26dc17cddc625cac37ecfab263a51a">
-  <!ENTITY libbonoboui-size          "893 KB">
-  <!ENTITY libbonoboui-buildsize     "29.1 MB">
+  <!ENTITY libbonoboui-md5sum        "22bd67a0a8b7f156c02c5fc08fb1fa24">
+  <!ENTITY libbonoboui-size          "981 KB">
+  <!ENTITY libbonoboui-buildsize     "31 MB">
   <!ENTITY libbonoboui-time          "1.0 SBU">
 ]>
 
@@ -61,7 +61,8 @@
     <xref linkend="libgnomecanvas"/></para>
 
     <bridgehead renderas="sect4">Optional</bridgehead>
-    <para role="optional"><xref linkend="gtk-doc"/></para>
+    <para role="optional"><xref linkend="gtk-doc"/> and
+    <xref linkend="intltool"/></para>
 
     <para condition="html" role="usernotes">User Notes:
     <ulink url="&blfs-wiki;/libbonoboui"/></para>

Modified: trunk/BOOK/gnome/core/libgnome.xml
===================================================================
--- trunk/BOOK/gnome/core/libgnome.xml	2007-07-25 04:06:14 UTC (rev 6967)
+++ trunk/BOOK/gnome/core/libgnome.xml	2007-07-25 14:48:30 UTC (rev 6968)
@@ -6,10 +6,10 @@
 
   <!ENTITY libgnome-download-http "&gnome-download-http;/libgnome/&gnome-version;/libgnome-&libgnome-version;.tar.bz2">
   <!ENTITY libgnome-download-ftp  "&gnome-download-ftp;/libgnome/&gnome-version;/libgnome-&libgnome-version;.tar.bz2">
-  <!ENTITY libgnome-md5sum        "bf53815df10db62bbf00defd4100b8d8">
-  <!ENTITY libgnome-size          "995 KB">
-  <!ENTITY libgnome-buildsize     "17.0 MB">
-  <!ENTITY libgnome-time          "0.2 SBU">
+  <!ENTITY libgnome-md5sum        "73426589d7c6fa3266fe4e8f3be2f5b5">
+  <!ENTITY libgnome-size          "1.0 MB">
+  <!ENTITY libgnome-buildsize     "24 MB">
+  <!ENTITY libgnome-time          "0.3 SBU">
 ]>
 
 <sect1 id="libgnome" xreflabel="libgnome-&libgnome-version;">
@@ -57,7 +57,8 @@
     <bridgehead renderas="sect3">libgnome Dependencies</bridgehead>
 
     <bridgehead renderas="sect4">Required</bridgehead>
-    <para role="required"><xref linkend="gnome-vfs"/></para>
+    <para role="required"><xref linkend="libbonobo"/> and
+    <xref linkend="gnome-vfs"/></para>
 
     <bridgehead renderas="sect4">Optional</bridgehead>
     <para role="optional"><xref linkend="esound"/>,

Modified: trunk/BOOK/gnome/core/libgnomecanvas.xml
===================================================================
--- trunk/BOOK/gnome/core/libgnomecanvas.xml	2007-07-25 04:06:14 UTC (rev 6967)
+++ trunk/BOOK/gnome/core/libgnomecanvas.xml	2007-07-25 14:48:30 UTC (rev 6968)
@@ -59,9 +59,7 @@
     <bridgehead renderas="sect3">libgnomecanvas Dependencies</bridgehead>
 
     <bridgehead renderas="sect4">Required</bridgehead>
-    <para role="required"><xref linkend="libglade"/> (ensure you read the
-    <quote><xref linkend="gnome_broken"/></quote> warning before installing
-    the dependencies) and
+    <para role="required"><xref linkend="libglade"/> and
     <xref linkend="libart_lgpl"/></para>
 
     <bridgehead renderas="sect4">Optional</bridgehead>

Modified: trunk/BOOK/gnome/core/libgnomeui.xml
===================================================================
--- trunk/BOOK/gnome/core/libgnomeui.xml	2007-07-25 04:06:14 UTC (rev 6967)
+++ trunk/BOOK/gnome/core/libgnomeui.xml	2007-07-25 14:48:30 UTC (rev 6968)
@@ -6,10 +6,10 @@
 
   <!ENTITY libgnomeui-download-http "&gnome-download-http;/libgnomeui/&gnome-version;/libgnomeui-&libgnomeui-version;.tar.bz2">
   <!ENTITY libgnomeui-download-ftp  "&gnome-download-ftp;/libgnomeui/&gnome-version;/libgnomeui-&libgnomeui-version;.tar.bz2">
-  <!ENTITY libgnomeui-md5sum        "ff6b6c25de0e7e39c79998621cdec048">
-  <!ENTITY libgnomeui-size          "1.8 MB">
-  <!ENTITY libgnomeui-buildsize     "40.0 MB">
-  <!ENTITY libgnomeui-time          "0.7 SBU">
+  <!ENTITY libgnomeui-md5sum        "dbdb274517ad643d9397dd6868788631">
+  <!ENTITY libgnomeui-size          "1.4 MB">
+  <!ENTITY libgnomeui-buildsize     "42 MB">
+  <!ENTITY libgnomeui-time          "0.8 SBU">
 ]>
 
 <sect1 id="libgnomeui" xreflabel="libgnomeui-&libgnomeui-version;">
@@ -62,7 +62,8 @@
 
     <bridgehead renderas="sect4">Optional</bridgehead>
     <para role="optional"><xref linkend="libjpeg"/>,
-    <xref linkend="esound"/>, and
+    <xref linkend="esound"/>,
+    <xref linkend="intltool"/>, and
     <xref linkend="gtk-doc"/></para>
 
     <para condition="html" role="usernotes">User Notes:
@@ -93,8 +94,8 @@
     <systemitem class="username">root</systemitem> user:</para>
 
 <screen role="root"><userinput>ln -v -s $(pkg-config \
-      --variable=prefix ORBit-2.0)/lib/gtk-2.0/2.4.0/filesystems \
-      /usr/lib/gtk-2.0/2.4.0</userinput></screen>
+      --variable=prefix ORBit-2.0)/lib/gtk-2.0/2.10.0/filesystems \
+      /usr/lib/gtk-2.0/2.10.0</userinput></screen>
 
   </sect2>
 

Modified: trunk/BOOK/gnome/core/libgtop.xml
===================================================================
--- trunk/BOOK/gnome/core/libgtop.xml	2007-07-25 04:06:14 UTC (rev 6967)
+++ trunk/BOOK/gnome/core/libgtop.xml	2007-07-25 14:48:30 UTC (rev 6968)
@@ -6,9 +6,9 @@
 
   <!ENTITY libgtop-download-http "&gnome-download-http;/libgtop/&gnome-version;/libgtop-&libgtop-version;.tar.bz2">
   <!ENTITY libgtop-download-ftp  "&gnome-download-ftp;/libgtop/&gnome-version;/libgtop-&libgtop-version;.tar.bz2">
-  <!ENTITY libgtop-md5sum        "adcc07c6d1c115c6d275a3c9bb1f3b68">
-  <!ENTITY libgtop-size          "664 KB">
-  <!ENTITY libgtop-buildsize     "13.2 MB">
+  <!ENTITY libgtop-md5sum        "a228ccab58216f7fef97de9c2b6e328e">
+  <!ENTITY libgtop-size          "772 KB">
+  <!ENTITY libgtop-buildsize     "16 MB">
   <!ENTITY libgtop-time          "0.3 SBU">
 ]>
 
@@ -57,11 +57,12 @@
     <bridgehead renderas="sect3">LibGTop Dependencies</bridgehead>
 
     <bridgehead renderas="sect4">Required</bridgehead>
-    <para role="required"><xref linkend="glib2"/></para>
+    <para role="required"><xref linkend="glib2"/> and
+    <xref linkend="popt"/></para>
 
     <bridgehead renderas="sect4">Optional</bridgehead>
-    <para role="optional"><xref linkend="popt"/>,
-    <xref linkend="gdbm"/>, and
+    <para role="optional"><xref linkend="gdbm"/>,
+    <xref linkend="gtk-doc"/>, and
     <xref linkend="x-window-system"/></para>
 
     <para condition="html" role="usernotes">User Notes:
@@ -125,6 +126,9 @@
     <application>GDBM</application> installed and wish to build the inodedb
     programs.</para>
 
+    <xi:include xmlns:xi="http://www.w3.org/2003/XInclude"
+    href="../../xincludes/gtk-doc-rebuild.xml"/>
+
   </sect2>
 
   <sect2 role="configuration">

Modified: trunk/BOOK/gnome/core/nautilus.xml
===================================================================
--- trunk/BOOK/gnome/core/nautilus.xml	2007-07-25 04:06:14 UTC (rev 6967)
+++ trunk/BOOK/gnome/core/nautilus.xml	2007-07-25 14:48:30 UTC (rev 6968)
@@ -6,10 +6,10 @@
 
   <!ENTITY nautilus-download-http "&gnome-download-http;/nautilus/&gnome-version;/nautilus-&nautilus-version;.tar.bz2">
   <!ENTITY nautilus-download-ftp  "&gnome-download-ftp;/nautilus/&gnome-version;/nautilus-&nautilus-version;.tar.bz2">
-  <!ENTITY nautilus-md5sum        "e82df2a1cb11719d054959539b74b3c7">
-  <!ENTITY nautilus-size          "4.0 MB">
-  <!ENTITY nautilus-buildsize     "91.4 MB">
-  <!ENTITY nautilus-time          "1.2 SBU">
+  <!ENTITY nautilus-md5sum        "e027b4e1a925122ef3e7f54323cc3c44">
+  <!ENTITY nautilus-size          "4.3 MB">
+  <!ENTITY nautilus-buildsize     "103 MB">
+  <!ENTITY nautilus-time          "1.1 SBU">
 ]>
 
 <sect1 id="nautilus" xreflabel="Nautilus-&nautilus-version;">
@@ -64,14 +64,13 @@
 
     <bridgehead renderas="sect4">Optional</bridgehead>
     <para role="optional"><xref linkend="startup-notification"/>,
-    <ulink url="http://www.gnome.org/~jamiemcc/tracker/">Tracker</ulink>
-    (requires <xref linkend="mysql"/> and
-    <xref linkend="dbus"/>, and can use
-    <xref linkend="gamin"/> and
-    <filename class='headerfile'>inotify.h</filename> capability),
-    <ulink url="http://beaglewiki.org/Main_Page">Beagle</ulink>
-    (uses <filename class='headerfile'>inotify.h</filename> capability), and
-    <xref linkend="docbook-utils"/></para>
+    <ulink url="http://www.tracker-project.org/">Tracker</ulink>
+    (see the Tracker README file for the extensive dependencies),
+    <ulink url="http://beagle-project.org/Main_Page">Beagle</ulink>
+    (needs <ulink url="http://ftp.acc.umu.se/pub/gnome/sources/gnome-sharp/">
+    Gnome-Sharp</ulink> which requires <ulink
+    url="http://www.mono-project.com/Main_Page">Mono</ulink>),
+    and <xref linkend="docbook-utils"/></para>
 
     <para condition="html" role="usernotes">User Notes:
     <ulink url="&blfs-wiki;/nautilus"/></para>

Modified: trunk/BOOK/gnome/core/orbit2.xml
===================================================================
--- trunk/BOOK/gnome/core/orbit2.xml	2007-07-25 04:06:14 UTC (rev 6967)
+++ trunk/BOOK/gnome/core/orbit2.xml	2007-07-25 14:48:30 UTC (rev 6968)
@@ -4,11 +4,11 @@
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
 
-  <!ENTITY ORBit2-download-http "&gnome-download-http;/ORBit2/&gnome-version;/ORBit2-&ORBit2-version;.tar.bz2">
-  <!ENTITY ORBit2-download-ftp  "&gnome-download-ftp;/ORBit2/&gnome-version;/ORBit2-&ORBit2-version;.tar.bz2">
-  <!ENTITY ORBit2-md5sum        "88ea9b8e686ab0dd27b4199e0f41ac84">
-  <!ENTITY ORBit2-size          "706 KB">
-  <!ENTITY ORBit2-buildsize     "34.5 MB">
+  <!ENTITY ORBit2-download-http "&gnome-download-http;/ORBit2/2.14/ORBit2-&ORBit2-version;.tar.bz2">
+  <!ENTITY ORBit2-download-ftp  "&gnome-download-ftp;/ORBit2/2.14/ORBit2-&ORBit2-version;.tar.bz2">
+  <!ENTITY ORBit2-md5sum        "3440c44aaef14dd96e4ccd7ce22a7e6e">
+  <!ENTITY ORBit2-size          "729 KB">
+  <!ENTITY ORBit2-buildsize     "34 MB">
   <!ENTITY ORBit2-time          "0.6 SBU">
 ]>
 
@@ -58,9 +58,7 @@
     <bridgehead renderas="sect3">ORBit2 Dependencies</bridgehead>
 
     <bridgehead renderas="sect4">Required</bridgehead>
-    <para role="required"><xref linkend="libidl"/> (ensure you read the
-    <quote><xref linkend="gnome_broken"/></quote> warning before installing
-    the dependencies)</para>
+    <para role="required"><xref linkend="libidl"/></para>
 
     <bridgehead renderas="sect4">Optional</bridgehead>
     <para role="optional"><xref linkend="gtk-doc"/> and

Modified: trunk/BOOK/gnome/core/pre-install-config.xml
===================================================================
--- trunk/BOOK/gnome/core/pre-install-config.xml	2007-07-25 04:06:14 UTC (rev 6967)
+++ trunk/BOOK/gnome/core/pre-install-config.xml	2007-07-25 14:48:30 UTC (rev 6968)
@@ -51,6 +51,7 @@
 
 <screen><literal>export PATH=$PATH:/opt/gnome-&gnome-version;&gnome-minor-version;/bin
 export PKG_CONFIG_PATH=$PKG_CONFIG_PATH:/opt/gnome-&gnome-version;&gnome-minor-version;/lib/pkgconfig
+export PKG_CONFIG_PATH=$PKG_CONFIG_PATH:/opt/gnome-&gnome-version;&gnome-minor-version;/share/pkgconfig
 export GNOME_LIBCONFIG_PATH=/usr/lib:/opt/gnome-&gnome-version;&gnome-minor-version;/lib</literal></screen>
 
   <para>Add to your <filename>/etc/ld.so.conf</filename>:</para>

Modified: trunk/BOOK/gnome/core/vte.xml
===================================================================
--- trunk/BOOK/gnome/core/vte.xml	2007-07-25 04:06:14 UTC (rev 6967)
+++ trunk/BOOK/gnome/core/vte.xml	2007-07-25 14:48:30 UTC (rev 6968)
@@ -6,10 +6,10 @@
 
   <!ENTITY vte-download-http "&gnome-download-http;/vte/0.16/vte-&vte-version;.tar.bz2">
   <!ENTITY vte-download-ftp  "&gnome-download-ftp;/vte/0.16/vte-&vte-version;.tar.bz2">
-  <!ENTITY vte-md5sum        "6b85967ba75ed574d0e5782697fbc79f">
-  <!ENTITY vte-size          "1 MB">
-  <!ENTITY vte-buildsize     "21.8 MB">
-  <!ENTITY vte-time          "0.5 SBU">
+  <!ENTITY vte-md5sum        "131174986ab519b91dfcd6cf22541cbb">
+  <!ENTITY vte-size          "1.1 MB">
+  <!ENTITY vte-buildsize     "26 MB">
+  <!ENTITY vte-time          "0.6 SBU">
 ]>
 
 <sect1 id="vte" xreflabel="VTE-&vte-version;">

Modified: trunk/BOOK/gnome/core/yelp.xml
===================================================================
--- trunk/BOOK/gnome/core/yelp.xml	2007-07-25 04:06:14 UTC (rev 6967)
+++ trunk/BOOK/gnome/core/yelp.xml	2007-07-25 14:48:30 UTC (rev 6968)
@@ -6,9 +6,9 @@
 
   <!ENTITY yelp-download-http "&gnome-download-http;/yelp/&gnome-version;/yelp-&yelp-version;.tar.bz2">
   <!ENTITY yelp-download-ftp  "&gnome-download-ftp;/yelp/&gnome-version;/yelp-&yelp-version;.tar.bz2">
-  <!ENTITY yelp-md5sum        "d3c4300c9a7d38ff2179b934ca5e2d1a">
-  <!ENTITY yelp-size          "779 KB">
-  <!ENTITY yelp-buildsize     "15.6 MB">
+  <!ENTITY yelp-md5sum        "84abbfe7e042706cbf21752957e29bf3">
+  <!ENTITY yelp-size          "900 KB">
+  <!ENTITY yelp-buildsize     "18 MB">
   <!ENTITY yelp-time          "0.3 SBU">
 ]>
 
@@ -58,7 +58,7 @@
 
     <bridgehead renderas="sect4">Required</bridgehead>
     <para role="required"><xref linkend="libgnomeui"/>,
-    <xref linkend="libgnomeprintui"/>,
+    <xref linkend="dbus-glib"/>,
     <xref linkend="startup-notification"/>,
     <xref linkend="gnome-doc-utils"/>, and
     a mozilla.org Gecko layout engine
@@ -95,7 +95,8 @@
 
 <screen><userinput>./configure --prefix=$(pkg-config --variable=prefix ORBit-2.0) \
             --sysconfdir=&gnome-etc-dir; \
-            --localstatedir=/var/lib &&
+            --localstatedir=/var/lib \
+            --enable-cpp-rtti &&
 make</userinput></screen>
 
     <para>This package does not come with a test suite.</para>

Modified: trunk/BOOK/gnome/gnome-intro.xml
===================================================================
--- trunk/BOOK/gnome/gnome-intro.xml	2007-07-25 04:06:14 UTC (rev 6967)
+++ trunk/BOOK/gnome/gnome-intro.xml	2007-07-25 14:48:30 UTC (rev 6968)
@@ -14,7 +14,7 @@
 
   <title>Introduction to GNOME</title>
 
-  <warning id="gnome_broken" xreflabel="SVN GNOME is Broken">
+  <!-- <warning id="gnome_broken" xreflabel="SVN GNOME is Broken">
     <para>The <application>GLib</application>/<application>GTK+</application>
     tool stack in the current SVN book is not compatible with this version
     of GNOME. If you want to build GNOME using these instructions, you should
@@ -22,7 +22,7 @@
     including
     using the versions of the packages listed there. The BLFS development team
     is working as hard as possible to bring the book up to GNOME-2.18.x.</para>
-  </warning>
+  </warning> -->
 
   <para>This chapter presents the instructions to install a complete
   GNOME-&gnome-version;&gnome-minor-version; desktop environment; and a limited
@@ -101,8 +101,8 @@
   the automated methods mentioned in the
   GNOME-&gnome-version; <ulink
   url="http://www.gnome.org/start/2.14/notes/en/rninstallation.html">Release
-  Notes</ulink>. Note that using any other method to install
-  GNOME-&gnome-version;&gnome-minor-version; other than using the BLFS
+  Notes</ulink> (they are a bit dated). Note that using any other method to
+  install GNOME-&gnome-version;&gnome-minor-version; other than using the BLFS
   instructions cannot be supported by the BLFS team. Alternate methods are only
   mentioned as a courtesy to builders who would like to build GNOME from
   sources but do not have the time/desire/patience/whatever to follow the

Modified: trunk/BOOK/introduction/welcome/changelog.xml
===================================================================
--- trunk/BOOK/introduction/welcome/changelog.xml	2007-07-25 04:06:14 UTC (rev 6967)
+++ trunk/BOOK/introduction/welcome/changelog.xml	2007-07-25 14:48:30 UTC (rev 6968)
@@ -45,6 +45,10 @@
       <para>July 25th, 2007</para>
       <itemizedlist>
         <listitem>
+          <para>[randy] - Updated core GNOME-2 to version 2.18.3. Separated
+          the core packages into 'Platform' and 'Desktop' sections. </para>
+        </listitem>
+        <listitem>
           <para>[randy] - Updated to ImageMagick-6.3.5-3.</para>
         </listitem>
         <listitem>




More information about the blfs-book mailing list