r6862 - in trunk/BOOK: . introduction/welcome pst/printing

randy at linuxfromscratch.org randy at linuxfromscratch.org
Sun Jul 8 14:10:09 PDT 2007


Author: randy
Date: 2007-07-08 15:10:09 -0600 (Sun, 08 Jul 2007)
New Revision: 6862

Modified:
   trunk/BOOK/general.ent
   trunk/BOOK/introduction/welcome/changelog.xml
   trunk/BOOK/pst/printing/cups.xml
Log:
Updated to CUPS-1.2.11

Modified: trunk/BOOK/general.ent
===================================================================
--- trunk/BOOK/general.ent	2007-07-08 20:28:43 UTC (rev 6861)
+++ trunk/BOOK/general.ent	2007-07-08 21:10:09 UTC (rev 6862)
@@ -45,7 +45,7 @@
 <!ENTITY lfs-gcc-version              "4.1.2">
 <!-- End LFS versions -->
 
-<!ENTITY blfs-bootscripts-version     "20070620">
+<!ENTITY blfs-bootscripts-version     "20070708">
 <!ENTITY blfs-bootscripts-download    "&downloads-root;/blfs-bootscripts-&blfs-bootscripts-version;.tar.bz2">
 
 <!ENTITY blfs-wiki                    "http://wiki.&lfs-domainname;/blfs/wiki">
@@ -640,7 +640,7 @@
 
 <!-- Part XII -->
 <!-- Chapter 42 -->
-<!ENTITY cups-version                 "1.2.7">
+<!ENTITY cups-version                 "1.2.11">
 <!ENTITY LPRng-version                "3.8.28">
 <!ENTITY gs-version                   "8.53">
 <!ENTITY espgs-version                "8.15.4">

Modified: trunk/BOOK/introduction/welcome/changelog.xml
===================================================================
--- trunk/BOOK/introduction/welcome/changelog.xml	2007-07-08 20:28:43 UTC (rev 6861)
+++ trunk/BOOK/introduction/welcome/changelog.xml	2007-07-08 21:10:09 UTC (rev 6862)
@@ -45,6 +45,9 @@
       <para>July 8th, 2007</para>
       <itemizedlist>
         <listitem>
+          <para>[randy] - Updated to CUPS-1.2.11.</para>
+        </listitem>
+        <listitem>
           <para>[randy] - Updated to PHP-5.2.3.</para>
         </listitem>
         <listitem>

Modified: trunk/BOOK/pst/printing/cups.xml
===================================================================
--- trunk/BOOK/pst/printing/cups.xml	2007-07-08 20:28:43 UTC (rev 6861)
+++ trunk/BOOK/pst/printing/cups.xml	2007-07-08 21:10:09 UTC (rev 6862)
@@ -6,9 +6,9 @@
 
   <!ENTITY cups-download-http "http://ftp2.easysw.com/pub/cups/&cups-version;/cups-&cups-version;-source.tar.bz2">
   <!ENTITY cups-download-ftp  "ftp://ftp3.easysw.com/pub/cups/&cups-version;/cups-&cups-version;-source.tar.bz2">
-  <!ENTITY cups-md5sum        "bf44783d9b46130bee9f2995e6055470">
-  <!ENTITY cups-size          "3.5 MB">
-  <!ENTITY cups-buildsize     "55 MB">
+  <!ENTITY cups-md5sum        "2742f1eec38abb04472b86627da8e493">
+  <!ENTITY cups-size          "3.7 MB">
+  <!ENTITY cups-buildsize     "67 MB">
   <!ENTITY cups-time          "0.6 SBU">
 ]>
 
@@ -79,11 +79,8 @@
     <xref linkend="openldap"/>,
     <xref linkend="openssl"/> or
     <ulink url="http://www.gnu.org/software/gnutls/">GnuTLS</ulink> (which needs
-    <ulink url="ftp://ftp.gnupg.org/gcrypt/alpha/libgpg-error/">
-    libgpg-error</ulink>,
-    <ulink url="ftp://ftp.gnupg.org/gcrypt/libgcrypt/">libgcrypt</ulink> and
-    <ulink url="ftp://ftp.gnupg.org/gcrypt/alpha/gnutls/opencdk/">opencdk</ulink>,
-    in that order),
+    <ulink url="ftp://ftp.gnupg.org/gcrypt/alpha/libgpg-error/">libgpg-error</ulink>
+    then <ulink url="ftp://ftp.gnupg.org/gcrypt/libgcrypt/">libgcrypt</ulink>)
     <xref linkend="linux-pam"/>,
     <xref linkend="php"/>,
     <xref linkend="python"/>,
@@ -114,24 +111,6 @@
 
 <screen role="root"><userinput>useradd -c "Print Service User" -d /dev/null -g lp -s /bin/false -u 9 lp</userinput></screen>
 
-    <!--
-    <para>If you utilize <application>Linux-PAM</application>, you need to
-    modify some files so <application>CUPS</application> can find needed headers.
-    Make the appropriate modifications using the following command:</para>
-
-<screen><userinput>sed -i -e "s at pam/pam at security/pam at g" \
-{config-scripts/cups-pam.m4,scheduler/auth.c,configure}</userinput></screen>
-    -->
-
-    <!--
-    <para>If you plan on running the test suite, you should apply the patch
-    listed above to fix several issues in the test suite script. Note that if
-    you have the non-free <command>htmldoc</command> program installed, the
-    patch disables its use.</para>
-
-<screen><userinput>patch -Np1 -i ../cups-&cups-version;-testsuite_fix-1.patch</userinput></screen>
-    -->
-
     <para>Install <application>CUPS</application> by running the
     following commands:</para>
 
@@ -230,13 +209,14 @@
       <segtitle>Installed Directories</segtitle>
 
       <seglistitem>
-        <seg>accept, cancel, cups-config, cupsaddsmb, cupsd, cupstestppd, disable,
-        enable, lp, lpadmin, lpc, lpinfo, lpmove, lpoptions, lppasswd, lpq, lpr,
-        lprm, lpstat, and reject</seg>
-        <seg>libcups.{so,a}, libcupsimage.{so,a}, and various filters and backend
-        drivers</seg>
-        <seg>/etc/cups, /usr/include/cups, /usr/lib/cups, /usr/share/doc/cups,
-        /usr/share/cups, /var/log/cups, and /var/spool/cups</seg>
+        <seg>accept, cancel, cups-config, cupsaddsmb, cupsd, cupstestppd,
+        disable, enable, lp, lpadmin, lpc, lpinfo, lpmove, lpoptions, lppasswd,
+        lpq, lpr, lprm, lpstat, and reject</seg>
+        <seg>libcups.{so,a}, libcupsimage.{so,a}, and various filters and
+        backend drivers</seg>
+        <seg>/etc/cups, /usr/include/cups, /usr/lib/cups, /usr/share/cups,
+        /usr/share/doc/cups-&cups-version;, /var/cache/cups, /var/log/cups, and
+        /var/spool/cups</seg>
       </seglistitem>
     </segmentedlist>
 




More information about the blfs-book mailing list