r7069 - in trunk/BOOK: . basicnet/mailnews basicnet/netlibs basicnet/netutils basicnet/textweb general/genlib gnome/core introduction/welcome kde/add pst/printing xsoft/other

randy at linuxfromscratch.org randy at linuxfromscratch.org
Wed Aug 15 22:09:28 PDT 2007


Author: randy
Date: 2007-08-15 23:09:28 -0600 (Wed, 15 Aug 2007)
New Revision: 7069

Added:
   trunk/BOOK/general/genlib/libgpg-error.xml
Modified:
   trunk/BOOK/basicnet/mailnews/mutt.xml
   trunk/BOOK/basicnet/netlibs/libsoup.xml
   trunk/BOOK/basicnet/netutils/wireshark.xml
   trunk/BOOK/basicnet/textweb/lynx.xml
   trunk/BOOK/general.ent
   trunk/BOOK/general/genlib/genlib.xml
   trunk/BOOK/general/genlib/libxslt.xml
   trunk/BOOK/gnome/core/gnome-vfs.xml
   trunk/BOOK/introduction/welcome/changelog.xml
   trunk/BOOK/introduction/welcome/credits.xml
   trunk/BOOK/kde/add/kdepim.xml
   trunk/BOOK/pst/printing/cups.xml
   trunk/BOOK/xsoft/other/pidgin.xml
Log:
Added new package Libgpg-error-1.5

Modified: trunk/BOOK/basicnet/mailnews/mutt.xml
===================================================================
--- trunk/BOOK/basicnet/mailnews/mutt.xml	2007-08-16 03:42:37 UTC (rev 7068)
+++ trunk/BOOK/basicnet/mailnews/mutt.xml	2007-08-16 05:09:28 UTC (rev 7069)
@@ -56,10 +56,9 @@
     <bridgehead renderas="sect4">Optional</bridgehead>
     <para role="optional"><xref linkend="gnupg"/>,
       <xref linkend="openssl"/> or
-      <ulink url="http://www.gnu.org/software/gnutls/">GnuTLS</ulink> (which
-      needs <ulink
-      url="ftp://ftp.gnupg.org/gcrypt/alpha/libgpg-error/">libgpg-error</ulink>
-      then <ulink url="ftp://ftp.gnupg.org/gcrypt/libgcrypt/">libgcrypt</ulink>),
+      <ulink url="http://www.gnu.org/software/gnutls/">GnuTLS</ulink> (which needs
+      <xref linkend="libgpg-error"/> then
+      <ulink url="http://www.gnupg.org/download/index.html#libgcrypt">Libgcrypt</ulink>),
       an <xref linkend="server-mail"/>
       (that provides a <command>sendmail</command> command),
       <!-- Ispell removed. Aspell provides an ispell wrapper script

Modified: trunk/BOOK/basicnet/netlibs/libsoup.xml
===================================================================
--- trunk/BOOK/basicnet/netlibs/libsoup.xml	2007-08-16 03:42:37 UTC (rev 7068)
+++ trunk/BOOK/basicnet/netlibs/libsoup.xml	2007-08-16 05:09:28 UTC (rev 7069)
@@ -67,12 +67,9 @@
     <xref linkend="php"/> compiled with
     <ulink url="http://xmlrpc-epi.sourceforge.net/main.php?t=php_about">XMLRPC-EPI</ulink>
     support (only used for the XMLRPC regression tests), and
-    <ulink url="http://www.gnu.org/software/gnutls/">GnuTLS</ulink>
-    (which needs <ulink
-    url="http://www.gnupg.org/download/index.html#libgpg-error">libgpg-error</ulink>
-    then <ulink
-    url="http://www.gnupg.org/download/index.html#libgcrypt">libgcrypt</ulink>)
-    </para>
+    <ulink url="http://www.gnu.org/software/gnutls/">GnuTLS</ulink> (which needs
+    <xref linkend="libgpg-error"/> then
+    <ulink url="http://www.gnupg.org/download/index.html#libgcrypt">Libgcrypt</ulink>)</para>
 
     <para condition="html" role="usernotes">User Notes:
     <ulink url="&blfs-wiki;/libsoup"/></para>

Modified: trunk/BOOK/basicnet/netutils/wireshark.xml
===================================================================
--- trunk/BOOK/basicnet/netutils/wireshark.xml	2007-08-16 03:42:37 UTC (rev 7068)
+++ trunk/BOOK/basicnet/netutils/wireshark.xml	2007-08-16 05:09:28 UTC (rev 7069)
@@ -93,11 +93,9 @@
     <xref linkend="heimdal"/> or <xref linkend="mitkrb"/>,
     <xref linkend="python"/>,
     <xref linkend="pcre"/>,
-    <ulink url="http://www.gnu.org/software/gnutls/">GnuTLS</ulink>
-    (which needs <ulink
-    url="http://www.gnupg.org/download/index.html#libgpg-error">libgpg-error</ulink>
-    then <ulink
-    url="http://www.gnupg.org/download/index.html#libgcrypt">libgcrypt</ulink>),
+    <ulink url="http://www.gnu.org/software/gnutls/">GnuTLS</ulink> (which needs
+    <xref linkend="libgpg-error"/> then <ulink
+    url="http://www.gnupg.org/download/index.html#libgcrypt">Libgcrypt</ulink>),
     <ulink url="http://www.net-snmp.org/">Net-SNMP</ulink>,
     <ulink url="http://www.gnu.org/software/adns/adns.html">adns</ulink>, and
     <ulink url="http://www.lua.org/">Lua</ulink></para>

Modified: trunk/BOOK/basicnet/textweb/lynx.xml
===================================================================
--- trunk/BOOK/basicnet/textweb/lynx.xml	2007-08-16 03:42:37 UTC (rev 7068)
+++ trunk/BOOK/basicnet/textweb/lynx.xml	2007-08-16 05:09:28 UTC (rev 7069)
@@ -57,10 +57,9 @@
 
     <bridgehead renderas="sect4">Optional</bridgehead>
     <para role="optional"><xref linkend="openssl"/> or experimentaly,
-    <ulink url="http://www.gnu.org/software/gnutls/">GnuTLS</ulink> (which
-    needs <ulink
-    url="ftp://ftp.gnupg.org/gcrypt/alpha/libgpg-error/">libgpg-error</ulink>
-    then <ulink url="ftp://ftp.gnupg.org/gcrypt/libgcrypt/">libgcrypt</ulink>),
+    <ulink url="http://www.gnu.org/software/gnutls/">GnuTLS</ulink> (which needs
+    <xref linkend="libgpg-error"/> then
+    <ulink url="http://www.gnupg.org/download/index.html#libgcrypt">Libgcrypt</ulink>),
     <xref linkend="zip"/>,
     <xref linkend="unzip"/>,
     an <xref linkend="server-mail"/> (that provides a

Modified: trunk/BOOK/general/genlib/genlib.xml
===================================================================
--- trunk/BOOK/general/genlib/genlib.xml	2007-08-16 03:42:37 UTC (rev 7068)
+++ trunk/BOOK/general/genlib/genlib.xml	2007-08-16 05:09:28 UTC (rev 7069)
@@ -74,6 +74,7 @@
   <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="libpthread-stubs.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="pth.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="libassuan.xml"/>
+  <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="libgpg-error.xml"/>
 
   <!-- <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="ispell.xml"/> -->
   <!-- <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="fam.xml"/> -->

Added: trunk/BOOK/general/genlib/libgpg-error.xml
===================================================================
--- trunk/BOOK/general/genlib/libgpg-error.xml	                        (rev 0)
+++ trunk/BOOK/general/genlib/libgpg-error.xml	2007-08-16 05:09:28 UTC (rev 7069)
@@ -0,0 +1,143 @@
+<?xml version="1.0" encoding="ISO-8859-1"?>
+<!DOCTYPE sect1 PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
+   "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
+  <!ENTITY % general-entities SYSTEM "../../general.ent">
+  %general-entities;
+
+  <!ENTITY libgpg-error-download-http "http://ftp.gnupg.org/gcrypt/libgpg-error/libgpg-error-&libgpg-error-version;.tar.bz2">
+  <!ENTITY libgpg-error-download-ftp  "ftp://ftp.gnupg.org/gcrypt/libgpg-error/libgpg-error-&libgpg-error-version;.tar.bz2">
+  <!ENTITY libgpg-error-md5sum        "8599b96c911b1df1be24a6ff4ec3c364">
+  <!ENTITY libgpg-error-size          "372 KB">
+  <!ENTITY libgpg-error-buildsize     "5 MB">
+  <!ENTITY libgpg-error-time          "0.1 SBU">
+]>
+
+<sect1 id="libgpg-error" xreflabel="Libgpg-error-&libgpg-error-version;">
+  <?dbhtml filename="libgpg-error.html"?>
+
+  <sect1info>
+    <othername>$LastChangedBy$</othername>
+    <date>$Date$</date>
+  </sect1info>
+
+  <title>Libgpg-error-&libgpg-error-version;</title>
+
+  <indexterm zone="libgpg-error">
+    <primary sortas="a-Libgpg-error">Libgpg-error</primary>
+  </indexterm>
+
+  <sect2 role="package">
+    <title>Introduction to Libgpg-error</title>
+
+    <para>The <application>Libgpg-error</application> package contains a
+    library that defines common error values for all
+    <application>GnuPG</application> components. Among these are GPG, GPGSM,
+    GPGME, GPG-Agent, libgcrypt, Libksba, DirMngr, Pinentry, SmartCard Daemon
+    and more.</para>
+
+    <bridgehead renderas="sect3">Package Information</bridgehead>
+    <itemizedlist spacing="compact">
+      <listitem>
+        <para>Download (HTTP): <ulink url="&libgpg-error-download-http;"/></para>
+      </listitem>
+      <listitem>
+        <para>Download (FTP): <ulink url="&libgpg-error-download-ftp;"/></para>
+      </listitem>
+      <listitem>
+        <para>Download MD5 sum: &libgpg-error-md5sum;</para>
+      </listitem>
+      <listitem>
+        <para>Download size: &libgpg-error-size;</para>
+      </listitem>
+      <listitem>
+        <para>Estimated disk space required: &libgpg-error-buildsize;</para>
+      </listitem>
+      <listitem>
+        <para>Estimated build time: &libgpg-error-time;</para>
+      </listitem>
+    </itemizedlist>
+
+    <para condition="html" role="usernotes">User Notes:
+    <ulink url="&blfs-wiki;/libgpg-error"/></para>
+
+  </sect2>
+
+  <sect2 role="installation">
+    <title>Installation of Libgpg-error</title>
+
+    <para>Install <application>Libgpg-error</application> by running the
+    following commands:</para>
+
+<screen><userinput>./configure --prefix=/usr &&
+make</userinput></screen>
+
+    <para>To test the results, issue: <command>make check</command>.</para>
+
+    <para>Now, as the <systemitem class="username">root</systemitem>
+    user:</para>
+
+<screen role="root"><userinput>make install &&
+install -v -m644 -D README /usr/share/doc/libgpg-error-&libgpg-error-version;/README</userinput></screen>
+
+  </sect2>
+
+  <sect2 role="content">
+    <title>Contents</title>
+
+    <segmentedlist>
+      <segtitle>Installed Program</segtitle>
+      <segtitle>Installed Library</segtitle>
+      <segtitle>Installed Directory</segtitle>
+
+      <seglistitem>
+        <seg>libgpg-error and libgpg-error-config</seg>
+        <seg>liblibgpg-error.{so,a}</seg>
+        <seg>/usr/share/common-lisp</seg>
+      </seglistitem>
+    </segmentedlist>
+
+    <variablelist>
+      <bridgehead renderas="sect3">Short Descriptions</bridgehead>
+      <?dbfo list-presentation="list"?>
+      <?dbhtml list-presentation="table"?>
+
+      <varlistentry id="gpg-error">
+        <term><command>gpg-error</command></term>
+        <listitem>
+          <para>is used to determine <application>Libgpg-error</application>
+          error codes.</para>
+          <indexterm zone="libgpg-error gpg-error">
+            <primary sortas="b-gpg-error">gpg-error</primary>
+          </indexterm>
+        </listitem>
+      </varlistentry>
+
+      <varlistentry id="gpg-error-config">
+        <term><command>gpg-error-config</command></term>
+        <listitem>
+          <para>is a utility used to configure and build applications based on
+          the Libgpg-error library. It can be used to query the C compiler and
+          linker flags which are required to correctly compile and link the
+          application against the Libgpg-error library.</para>
+          <indexterm zone="libgpg-error gpg-error-config">
+            <primary sortas="b-gpg-error-config">gpg-error-config</primary>
+          </indexterm>
+        </listitem>
+      </varlistentry>
+
+      <varlistentry id="liblibgpg-error">
+        <term><filename class='libraryfile'>liblibgpg-error.{so,a}</filename></term>
+        <listitem>
+          <para>contains the <application>Libgpg-error</application> API
+          functions.</para>
+          <indexterm zone="libgpg-error liblibgpg-error">
+            <primary sortas="c-liblibgpg-error">liblibgpg-error.{so,a}</primary>
+          </indexterm>
+        </listitem>
+      </varlistentry>
+
+    </variablelist>
+
+  </sect2>
+
+</sect1>


Property changes on: trunk/BOOK/general/genlib/libgpg-error.xml
___________________________________________________________________
Name: svn:keywords
   + LastChangedBy Date

Modified: trunk/BOOK/general/genlib/libxslt.xml
===================================================================
--- trunk/BOOK/general/genlib/libxslt.xml	2007-08-16 03:42:37 UTC (rev 7068)
+++ trunk/BOOK/general/genlib/libxslt.xml	2007-08-16 05:09:28 UTC (rev 7069)
@@ -63,10 +63,8 @@
 
     <bridgehead renderas="sect4">Optional</bridgehead>
     <para role="optional"><xref linkend="python"/> and
-    <ulink url="http://www.gnupg.org/download/index.html#libgcrypt">
-    Libgcrypt</ulink> (requires
-    <ulink url="http://www.gnupg.org/download/index.html#libgpg-error">
-    Libgpg-error</ulink>)</para>
+    <ulink url="http://www.gnupg.org/download/index.html#libgcrypt">Libgcrypt</ulink> (requires
+    <xref linkend="libgpg-error"/>)</para>
 
     <para condition="html" role="usernotes">User Notes:
     <ulink url="&blfs-wiki;/libxslt"/></para>

Modified: trunk/BOOK/general.ent
===================================================================
--- trunk/BOOK/general.ent	2007-08-16 03:42:37 UTC (rev 7068)
+++ trunk/BOOK/general.ent	2007-08-16 05:09:28 UTC (rev 7069)
@@ -132,6 +132,7 @@
 <!ENTITY libpthread-stubs-version     "0.1">
 <!ENTITY pth-version                  "2.0.7">
 <!ENTITY libassuan-version            "1.0.2">
+<!ENTITY libgpg-error-version         "1.5">
 
 <!-- Obsolete
 <!ENTITY fam-version                  "2.7.0">

Modified: trunk/BOOK/gnome/core/gnome-vfs.xml
===================================================================
--- trunk/BOOK/gnome/core/gnome-vfs.xml	2007-08-16 03:42:37 UTC (rev 7068)
+++ trunk/BOOK/gnome/core/gnome-vfs.xml	2007-08-16 05:09:28 UTC (rev 7069)
@@ -70,11 +70,9 @@
     <xref linkend="intltool"/>,
     <xref linkend="openssh"/>,
     <xref linkend="openssl"/> or
-    <ulink url="http://www.gnu.org/software/gnutls/">GnuTLS</ulink>
-    (which needs <ulink
-    url="http://www.gnupg.org/download/index.html#libgpg-error">libgpg-error</ulink>
-    then <ulink
-    url="http://www.gnupg.org/download/index.html#libgcrypt">libgcrypt</ulink>),
+    <ulink url="http://www.gnu.org/software/gnutls/">GnuTLS</ulink> (which needs
+    <xref linkend="libgpg-error"/> then
+    <ulink url="http://www.gnupg.org/download/index.html#libgcrypt">Libgcrypt</ulink>),
     <xref linkend="heimdal"/> or <xref linkend="mitkrb"/>,
     <ulink url="http://www.avahi.org">Avahi</ulink>,
     <ulink url="http://www.openafs.org/">OpenAFS</ulink>, and

Modified: trunk/BOOK/introduction/welcome/changelog.xml
===================================================================
--- trunk/BOOK/introduction/welcome/changelog.xml	2007-08-16 03:42:37 UTC (rev 7068)
+++ trunk/BOOK/introduction/welcome/changelog.xml	2007-08-16 05:09:28 UTC (rev 7069)
@@ -45,6 +45,9 @@
       <para>August 16th, 2007</para>
       <itemizedlist>
         <listitem>
+          <para>[randy] - Added new package Libgpg-error-1.5.</para>
+        </listitem>
+        <listitem>
           <para>[randy] - Added new package Libassuan-1.0.2.</para>
         </listitem>
         <listitem>

Modified: trunk/BOOK/introduction/welcome/credits.xml
===================================================================
--- trunk/BOOK/introduction/welcome/credits.xml	2007-08-16 03:42:37 UTC (rev 7068)
+++ trunk/BOOK/introduction/welcome/credits.xml	2007-08-16 05:09:28 UTC (rev 7069)
@@ -277,8 +277,8 @@
         GStreamer Base Plug-ins, GStreamer Good Plug-ins, GStreamer Ugly
         Plug-ins, HAL, Heimdal, HTML Tidy, icon-naming-utils, ISO Codes,
         JadeTeX, Java Access Bridge, JUnit, K3b, Libassuan, LessTif (rewrite),
-        libexif, libgail-gnome, libgnomecups, libgnomekbd, Libidn, libmpeg2,
-        libmusicbrainz, libquicktime, mcs,
+        libexif, libgail-gnome, libgnomecups, libgnomekbd, libgpg-error,
+        Libidn, libmpeg2, libmusicbrainz, libquicktime, mcs,
         MIT Kerberos V5 (many updates and enhancements), MPlayer
         (extensive overhaul), NSS, Orca, Other Programming Tools, PDL,
         Perl Modules,

Modified: trunk/BOOK/kde/add/kdepim.xml
===================================================================
--- trunk/BOOK/kde/add/kdepim.xml	2007-08-16 03:42:37 UTC (rev 7068)
+++ trunk/BOOK/kde/add/kdepim.xml	2007-08-16 05:09:28 UTC (rev 7069)
@@ -70,8 +70,8 @@
 
     <bridgehead renderas="sect4">Optional</bridgehead>
     <para role="optional"><xref linkend="pilot-link"/>,
-    <ulink url="&gnu-org;#gpgme">GPGME</ulink>
-      (requires <ulink url="&gnu-org;#libgpg-error">Libgpg-error</ulink> then
+    <ulink url="&gnu-org;#gpgme">GPGME</ulink> (requires
+    <xref linkend="libgpg-error"/> then
     <ulink url="&gnu-org;#libgcrypt">Libgcrypt</ulink> then
     <xref linkend="libassuan"/> then
     <ulink url="&gnu-org;#libksba">Libksba</ulink>,

Modified: trunk/BOOK/pst/printing/cups.xml
===================================================================
--- trunk/BOOK/pst/printing/cups.xml	2007-08-16 03:42:37 UTC (rev 7068)
+++ trunk/BOOK/pst/printing/cups.xml	2007-08-16 05:09:28 UTC (rev 7069)
@@ -79,8 +79,8 @@
     <xref linkend="openldap"/>,
     <xref linkend="openssl"/> or
     <ulink url="http://www.gnu.org/software/gnutls/">GnuTLS</ulink> (which needs
-    <ulink url="ftp://ftp.gnupg.org/gcrypt/alpha/libgpg-error/">libgpg-error</ulink>
-    then <ulink url="ftp://ftp.gnupg.org/gcrypt/libgcrypt/">libgcrypt</ulink>)
+    <xref linkend="libgpg-error"/> then
+    <ulink url="http://www.gnupg.org/download/index.html#libgcrypt">Libgcrypt</ulink>),
     <xref linkend="linux-pam"/>,
     <xref linkend="php"/>,
     <xref linkend="python"/>,

Modified: trunk/BOOK/xsoft/other/pidgin.xml
===================================================================
--- trunk/BOOK/xsoft/other/pidgin.xml	2007-08-16 03:42:37 UTC (rev 7068)
+++ trunk/BOOK/xsoft/other/pidgin.xml	2007-08-16 05:09:28 UTC (rev 7069)
@@ -64,8 +64,8 @@
 
     <bridgehead renderas="sect4">Optional for SSL Support</bridgehead>
     <para role="optional"><ulink url="http://ftp.gnupg.org/gcrypt/gnutls/">GnuTLS</ulink> (requires
-    <ulink url="http://ftp.gnupg.org/gcrypt/libgpg-error/">libgpg-error</ulink> then
-    <ulink url="http://ftp.gnupg.org/gcrypt/libgcrypt/">libgcrypt</ulink>) or
+    <xref linkend="libgpg-error"/> then
+    <ulink url="http://www.gnupg.org/download/index.html#libgcrypt">Libgcrypt</ulink>) or
     <xref linkend="nss"/></para>
 
     <para>SSL support is required for MSN and Google Talk support and




More information about the blfs-book mailing list