r7064 - in trunk/BOOK: . introduction/welcome xsoft/other

randy at linuxfromscratch.org randy at linuxfromscratch.org
Wed Aug 15 11:40:35 PDT 2007


Author: randy
Date: 2007-08-15 12:40:35 -0600 (Wed, 15 Aug 2007)
New Revision: 7064

Added:
   trunk/BOOK/xsoft/other/pidgin.xml
Removed:
   trunk/BOOK/xsoft/other/gaim.xml
Modified:
   trunk/BOOK/general.ent
   trunk/BOOK/introduction/welcome/changelog.xml
   trunk/BOOK/xsoft/other/other.xml
Log:
Updated Gaim to Pidgin-2.1.0

Modified: trunk/BOOK/general.ent
===================================================================
--- trunk/BOOK/general.ent	2007-08-14 23:38:51 UTC (rev 7063)
+++ trunk/BOOK/general.ent	2007-08-15 18:40:35 UTC (rev 7064)
@@ -601,7 +601,7 @@
 <!ENTITY thunderbird-version          "2.0.0.6">
 <!ENTITY pan-version                  "0.14.2">
 <!ENTITY balsa-version                "2.3.13">
-<!ENTITY gaim-version                 "1.5.0">
+<!ENTITY pidgin-version               "2.1.0">
 <!ENTITY xchat-version                "2.8.4">
 
 <!-- Part XI -->

Modified: trunk/BOOK/introduction/welcome/changelog.xml
===================================================================
--- trunk/BOOK/introduction/welcome/changelog.xml	2007-08-14 23:38:51 UTC (rev 7063)
+++ trunk/BOOK/introduction/welcome/changelog.xml	2007-08-15 18:40:35 UTC (rev 7064)
@@ -45,6 +45,9 @@
       <para>August 15th, 2007</para>
       <itemizedlist>
         <listitem>
+          <para>[randy] - Updated Gaim to Pidgin-2.1.0.</para>
+        </listitem>
+        <listitem>
           <para>[randy] - Removed an unneeded sed command from the RP-PPPoE
           instructions.</para>
         </listitem>

Deleted: trunk/BOOK/xsoft/other/gaim.xml
===================================================================
--- trunk/BOOK/xsoft/other/gaim.xml	2007-08-14 23:38:51 UTC (rev 7063)
+++ trunk/BOOK/xsoft/other/gaim.xml	2007-08-15 18:40:35 UTC (rev 7064)
@@ -1,188 +0,0 @@
-<?xml version="1.0" encoding="ISO-8859-1"?>
-<!DOCTYPE sect1 PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
-   "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
-  <!ENTITY % general-entities SYSTEM "../../general.ent">
-  %general-entities;
-
-  <!-- <!ENTITY gaim-download-http "http://downloads.sourceforge.net/gaim/gaim-1.5.0.tar.bz2"> -->
-  <!ENTITY gaim-download-http "http://anduin.linuxfromscratch.org/sources/BLFS/svn/g/gaim-1.5.0.tar.bz2">
-  <!ENTITY gaim-download-ftp  " ">
-  <!ENTITY gaim-md5sum        "9205321ac11fad271c90f2f0d7c5e7ce">
-  <!ENTITY gaim-size          "6.0 MB">
-  <!ENTITY gaim-buildsize     "179 MB">
-  <!ENTITY gaim-time          "1.2 SBU">
-]>
-
-<sect1 id="gaim" xreflabel="Gaim-&gaim-version;">
-  <?dbhtml filename="gaim.html"?>
-
-  <sect1info>
-    <othername>$LastChangedBy$</othername>
-    <date>$Date$</date>
-  </sect1info>
-
-  <title>Gaim-&gaim-version;</title>
-
-  <indexterm zone="gaim">
-    <primary sortas="a-Gaim">Gaim</primary>
-  </indexterm>
-
-  <sect2 role="package">
-    <title>Introduction to Gaim</title>
-
-    <para><application>Gaim</application> is an instant messaging client that
-    can connect with a wide range of networks including AIM, ICQ, MSN, Jabber,
-    IRC, Napster, Gadu-Gadu, Zephyr and Yahoo!. Note that the package has been
-    renamed to <application>Pidgin</application>, and can be found at
-    <ulink url="http://sourceforge.net/projects/pidgin"/>.</para>
-
-    <bridgehead renderas="sect3">Package Information</bridgehead>
-    <itemizedlist spacing="compact">
-      <listitem>
-        <para>Download (HTTP): <ulink url="&gaim-download-http;"/></para>
-      </listitem>
-      <listitem>
-        <para>Download (FTP): <ulink url="&gaim-download-ftp;"/></para>
-      </listitem>
-      <listitem>
-        <para>Download MD5 sum: &gaim-md5sum;</para>
-      </listitem>
-      <listitem>
-        <para>Download size: &gaim-size;</para>
-      </listitem>
-      <listitem>
-        <para>Estimated disk space required: &gaim-buildsize;</para>
-      </listitem>
-      <listitem>
-        <para>Estimated build time: &gaim-time;</para>
-      </listitem>
-    </itemizedlist>
-
-    <bridgehead renderas="sect3">Gaim Dependencies</bridgehead>
-
-    <bridgehead renderas="sect4">Required</bridgehead>
-    <para role="required"><xref linkend="gtk2"/></para>
-
-    <bridgehead renderas="sect4">Optional</bridgehead>
-    <para role="optional"><xref linkend="libao"/>,
-    <ulink url="http://ftp.gnupg.org/gcrypt/gnutls/">GnuTLS</ulink> (requires
-    <ulink url="http://ftp.gnupg.org/gcrypt/libgpg-error/">libgpg-error</ulink>
-    then <ulink url="http://ftp.gnupg.org/gcrypt/libgcrypt/">libgcrypt</ulink>),
-    <ulink url="http://gtkspell.sourceforge.net/">Gtkspell</ulink>,
-    <xref linkend="tcl"/>,
-    <xref linkend="tk"/>,
-    <xref linkend="startup-notification"/>,
-    <xref linkend="audiofile"/>,
-    <xref linkend="mitkrb"/>,
-    <xref linkend="nas"/>,
-    <xref linkend="doxygen"/>, and
-    <ulink url="http://www.avahi.org">Avahi</ulink>
-
-</para>
-
-    <para condition="html" role="usernotes">User Notes:
-    <ulink url="&blfs-wiki;/gaim"/></para>
-
-  </sect2>
-
-  <sect2 role="installation">
-    <title>Installation of Gaim</title>
-
-    <para>To connect with MSN you will need to compile
-    <application>Gaim</application> with SSL support. For this you will need to
-    have already installed <application>libgpg-error</application>,
-    <application>libgcrypt</application>
-    and <application>GnuTLS</application> compiled in that order. Use of the
-    <application>Mozilla</application> SSL library is deprecated.</para>
-
-    <para>To compile <application>Gaim</application> with audio support, first
-    install <xref linkend="libao"/>.</para>
-
-    <para>Compile <application>Gaim</application> by running the following
-    commands:</para>
-
-<screen><userinput>./configure --prefix=/usr &&
-make</userinput></screen>
-
-    <!-- <para>If you want to compile <application>Gaim</application> with support
-    for <xref linkend="nas"/>, configure it like this:</para>
-
-<screen><userinput>CPPFLAGS="-I/usr/X11R6/include" ./configure -prefix=/usr \
-    -enable-nas &&
-make</userinput></screen> -->
-
-    <para>To test the results, issue: <command>make check</command>.</para>
-
-    <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
-
-<screen role="root"><userinput>make install</userinput></screen>
-
-  </sect2>
-
-  <!-- <sect2 role="commands">
-    <title>Command Explanations</title>
-
-    <para><command>CPPFLAGS=...-enable-nas</command>: To avoid a compilation
-    error the <filename>configure</filename> script needs to be told to look
-    for the <application>NAS</application> header files in /usr/X11R6/include.
-    </para>
-
-  </sect2> -->
-
-  <sect2 role="content">
-    <title>Contents</title>
-
-    <segmentedlist>
-      <segtitle>Installed Programs</segtitle>
-      <segtitle>Installed Library</segtitle>
-      <segtitle>Installed Directories</segtitle>
-
-      <seglistitem>
-        <seg>gaim and gaim-remote</seg>
-        <seg>libgaim-remote.so</seg>
-        <seg>/usr/include/gaim, /usr/lib/gaim, /usr/share/pixmaps/gaim, and
-        /usr/share/sounds/gaim</seg>
-      </seglistitem>
-    </segmentedlist>
-
-    <variablelist>
-      <bridgehead renderas="sect3">Short Descriptions</bridgehead>
-      <?dbfo list-presentation="list"?>
-      <?dbhtml list-presentation="table"?>
-
-      <varlistentry id="gaim-prog">
-        <term><command>gaim</command></term>
-        <listitem>
-          <para> is an instant messaging client</para>
-          <indexterm zone="gaim gaim-prog">
-            <primary sortas="b-gaim">gaim</primary>
-          </indexterm>
-        </listitem>
-      </varlistentry>
-
-      <varlistentry id="gaim-remote">
-        <term><command>gaim-remote</command></term>
-        <listitem>
-          <para> is a command-line interface for controlling an already running
-          instance of <command>gaim</command></para>
-          <indexterm zone="gaim gaim-remote">
-            <primary sortas="b-gaim-remote">gaim-remote</primary>
-          </indexterm>
-        </listitem>
-      </varlistentry>
-
-      <varlistentry id="libgaim-remote">
-        <term><filename class='libraryfile'>libgaim-remote.so</filename></term>
-        <listitem>
-          <para> contains functions that are used by gaim-remote</para>
-          <indexterm zone="gaim libgaim-remote">
-            <primary sortas="c-libgaim-remote">libgaim-remote.so</primary>
-          </indexterm>
-        </listitem>
-      </varlistentry>
-
-    </variablelist>
-
-  </sect2>
-
-</sect1>

Modified: trunk/BOOK/xsoft/other/other.xml
===================================================================
--- trunk/BOOK/xsoft/other/other.xml	2007-08-14 23:38:51 UTC (rev 7063)
+++ trunk/BOOK/xsoft/other/other.xml	2007-08-15 18:40:35 UTC (rev 7064)
@@ -21,7 +21,7 @@
   <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="thunderbird.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="pan.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="balsa.xml"/>
-  <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="gaim.xml"/>
+  <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="pidgin.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="xchat.xml"/>
 
 </chapter>

Copied: trunk/BOOK/xsoft/other/pidgin.xml (from rev 7054, trunk/BOOK/xsoft/other/gaim.xml)
===================================================================
--- trunk/BOOK/xsoft/other/pidgin.xml	                        (rev 0)
+++ trunk/BOOK/xsoft/other/pidgin.xml	2007-08-15 18:40:35 UTC (rev 7064)
@@ -0,0 +1,292 @@
+<?xml version="1.0" encoding="ISO-8859-1"?>
+<!DOCTYPE sect1 PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
+   "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
+  <!ENTITY % general-entities SYSTEM "../../general.ent">
+  %general-entities;
+
+  <!ENTITY pidgin-download-http "http://downloads.sourceforge.net/pidgin/pidgin-&pidgin-version;.tar.bz2">
+  <!ENTITY pidgin-download-ftp  " ">
+  <!ENTITY pidgin-md5sum        "83f44bf9c076595967f7374c50250176">
+  <!ENTITY pidgin-size          "7.7 MB">
+  <!ENTITY pidgin-buildsize     "172 MB (additinoal 106 MB for API documentation)">
+  <!ENTITY pidgin-time          "2.5 SBU">
+]>
+
+<sect1 id="pidgin" xreflabel="Pidgin-&pidgin-version;">
+  <?dbhtml filename="pidgin.html"?>
+
+  <sect1info>
+    <othername>$LastChangedBy$</othername>
+    <date>$Date$</date>
+  </sect1info>
+
+  <title>Pidgin-&pidgin-version;</title>
+
+  <indexterm zone="pidgin">
+    <primary sortas="a-Pidgin">Pidgin</primary>
+  </indexterm>
+
+  <sect2 role="package">
+    <title>Introduction to Pidgin</title>
+
+    <para><application>Pidgin</application> is an instant messaging client that
+    can connect with a wide range of networks including AIM, ICQ, GroupWise,
+    MSN, Jabber, IRC, Napster, Gadu-Gadu, SILC, Zephyr and Yahoo!.</para>
+
+    <bridgehead renderas="sect3">Package Information</bridgehead>
+    <itemizedlist spacing="compact">
+      <listitem>
+        <para>Download (HTTP): <ulink url="&pidgin-download-http;"/></para>
+      </listitem>
+      <listitem>
+        <para>Download (FTP): <ulink url="&pidgin-download-ftp;"/></para>
+      </listitem>
+      <listitem>
+        <para>Download MD5 sum: &pidgin-md5sum;</para>
+      </listitem>
+      <listitem>
+        <para>Download size: &pidgin-size;</para>
+      </listitem>
+      <listitem>
+        <para>Estimated disk space required: &pidgin-buildsize;</para>
+      </listitem>
+      <listitem>
+        <para>Estimated build time: &pidgin-time;</para>
+      </listitem>
+    </itemizedlist>
+
+    <bridgehead renderas="sect3">Pidgin Dependencies</bridgehead>
+
+    <bridgehead renderas="sect4">Required</bridgehead>
+    <para role="required"><xref linkend="glib2"/>,
+    <xref linkend="libxml2"/>, and
+    <xref linkend="perl-xml-parser"/></para>
+
+    <bridgehead renderas="sect4">Optional for SSL Support</bridgehead>
+    <para role="optional"><ulink url="http://ftp.gnupg.org/gcrypt/gnutls/">GnuTLS</ulink> (requires
+    <ulink url="http://ftp.gnupg.org/gcrypt/libgpg-error/">libgpg-error</ulink> then
+    <ulink url="http://ftp.gnupg.org/gcrypt/libgcrypt/">libgcrypt</ulink>) or
+    <xref linkend="nss"/></para>
+
+    <para>SSL support is required for MSN and Google Talk support and
+      <application>GnuTLS</application> is the preferred method. Note that one of
+    <xref linkend="firefox"/>,
+    <xref linkend="thunderbird"/>,
+    <xref linkend="seamonkey"/>,or
+    <ulink url="http://www.mozilla.org/products/mozilla1.x/">Mozilla</ulink> can be used instead
+      of NSS.</para>
+
+    <bridgehead renderas="sect4">Optional GUI Tools</bridgehead>
+    <para role="optional">
+    <xref linkend="gtk2"/>
+      (required to build the GUI interface),
+    <ulink url="http://gtkspell.sourceforge.net/">Gtkspell</ulink>
+      (for spell-check support and only used if <application>Gtk+</application> is installed),
+    <xref linkend="xscreensaver"/>
+      (to check for idleness and only used if <application>Gtk+</application> is installed),
+    <xref linkend="startup-notification"/>
+      (only used if <application>Gtk+</application> is installed), and
+    <xref linkend="x-window-system"/>
+      (used for session management support)</para>
+
+    <bridgehead renderas="sect4">Optional</bridgehead>
+    <para role="optional">
+    <xref linkend="intltool"/>,
+    <xref linkend="GConf"/>,
+    <xref linkend="dbus-glib"/> (requires
+    <xref linkend="python"/> also),
+    <ulink url="http://silcnet.org/software/">SILC Client</ulink>,
+    <ulink url="http://silcnet.org/software/">SILC Toolkit</ulink>,
+    <ulink url="http://packages.debian.org/stable/source/zephyr">zephyr</ulink>,
+    <xref linkend="gstreamer"/>
+      (required for audio support),
+    <xref linkend="evolution-data-server"/>
+      (required for Evolution integration),
+    <ulink url="http://www.sqlite.org/">SQLite</ulink>
+      (required for the Contact Availability Prediction plugin),
+    <xref linkend="cyrus-sasl"/>
+      (required for Jabber support),
+    <xref linkend="mitkrb"/>
+      (required for Kerberos support in the Zephyr module),
+    <ulink url="http://www.avahi.org">Avahi</ulink>
+      (required for the Bonjour plugin),
+    <ulink url="http://meanwhile.sourceforge.net/">Meanwhile</ulink>
+      (required for Sametime protocol support),
+    <ulink url="http://www.gnome.org/projects/NetworkManager/">NetworkManager</ulink>
+    (<ulink url="&gnome-download-http;/NetworkManager/">download</ulink> and
+      requires that <application>D-Bus</application> is installed),
+    <ulink url="http://sourceforge.net/projects/check">check</ulink>
+      (only used during the test suite), and
+    Gadu-Gadu external libraries (cannot find a URL)</para>
+
+    <bridgehead renderas="sect4">Optional for Programming Language Support</bridgehead>
+    <para role="optional"><ulink url="http://www.mono-project.com/Main_Page">Mono</ulink>
+      (experimental),
+    <xref linkend="tcl"/>, and
+    <xref linkend="tk"/></para>
+
+    <para condition="html" role="usernotes">User Notes:
+    <ulink url="&blfs-wiki;/pidgin"/></para>
+
+  </sect2>
+
+  <sect2 role="installation">
+    <title>Installation of Pidgin</title>
+
+    <para>Compile <application>Pidgin</application> by running the following
+    commands:</para>
+
+<screen><userinput>./configure --prefix=/usr \
+            --with-gconf-schema-file-dir=&gnome-etc-dir;/gconf/schemas \
+            --disable-gtkui &&
+make</userinput></screen>
+
+    <para> If you have <xref linkend="doxygen"/> installed
+    (<xref linkend="graphviz"/> can be used also) and you wish to create the
+    API documentation, issue: <command>make docs</command></para>
+
+    <para>To test the results, issue: <command>make check</command>. Note
+    that the end result of the suite indicates an error. This error is only
+    due to some locale translation issues and not the actual tests. The
+    actual result of the tests are displayed about half way through the
+    tests and should indicate that they passed.</para>
+
+    <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
+
+<screen role="root"><userinput>make install &&
+install -v -m755 -d /usr/share/doc/pidgin-&pidgin-version; &&
+install -v -m644    README* doc/*.txt doc/gtkrc-2.0 \
+                    /usr/share/doc/pidgin-&pidgin-version;</userinput></screen>
+
+    <para>If you created the API documentation, install it using the following
+    commands as the <systemitem class="username">root</systemitem> user:</para>
+
+<screen role="root"><userinput>install -v -m755 -d /usr/share/doc/pidgin-&pidgin-version;/api &&
+install -v -m644    doc/html/* \
+                    /usr/share/doc/pidgin-&pidgin-version;/api</userinput></screen>
+
+  </sect2>
+
+  <sect2 role="commands">
+    <title>Command Explanations</title>
+
+    <para><parameter>--with-gconf-schema-file-dir=&gnome-etc-dir;/gconf/schemas</parameter>:
+    This parameter is used so that the <application>GConf</application> schema
+    files are installed into the existing database. If
+    <application>GConf</application> is not installed, the parameter does not
+    affect the build or installation of the package.</para>
+
+    <para><parameter>--disable-gtkui</parameter>: This parameter is used if
+    <application>GTK+</application> is not installed. The build will only
+    produce the <command>finch</command> program, which is a text-based
+    (<application>Ncurses</application>) only version. Remove this parameter
+    if you have <application>GTK+</application> installed to build the GUI
+    <command>pidgin</command> program.</para>
+
+  </sect2>
+
+  <sect2 role="configuration">
+    <title>Configuring Pidgin</title>
+
+    <sect3 id="pidgin-config">
+      <title>Config Files</title>
+      <para><filename>~/.purple/*</filename> and
+      <filename>~/.gtkrc-02</filename></para>
+
+      <indexterm zone="pidgin pidgin-config">
+        <primary sortas="e-AA-purple-star">~/.purple/*</primary>
+      </indexterm>
+
+      <indexterm zone="pidgin pidgin-config">
+        <primary sortas="e-AA-gtkrc-02">~/.gtkrc-02</primary>
+      </indexterm>
+    </sect3>
+
+    <sect3><title>Configuration Information</title>
+
+      <para>Most configuration can be accomplished by using the various
+      preference settings inside the programs. Additionally, you can create
+      a <filename>~/.gtkrc-02</filename> file which can store settings that
+      affect the <application>Pidgin</application> application. Note that an
+      example <filename>gtkrc-02</filename> file was installed during the
+      package installation and can be used as a starting point or
+      reference.</para>
+
+    </sect3>
+
+  </sect2>
+
+  <sect2 role="content">
+    <title>Contents</title>
+
+    <segmentedlist>
+      <segtitle>Installed Programs</segtitle>
+      <segtitle>Installed Library</segtitle>
+      <segtitle>Installed Directories</segtitle>
+
+      <seglistitem>
+        <seg>finch, pidgin, purple-client-example, purple-remote, purple-send,
+        purple-send-async, and purple-url-handler</seg>
+        <seg>libgnt.so, libpurple.so, and libpurple-client.so along with
+        numerous plugin and support modules located in various subdirectories
+        of /usr/lib.</seg>
+        <seg>/usr/include/{finch,gnt,libpurple,pidgin},
+        /usr/lib/{finch,gnt,pidgin,purple-2},
+        /usr/share/doc/pidgin-&pidgin-version;, /usr/share/pixmaps/pidgin, and
+        /usr/share/sounds/pidgin</seg>
+      </seglistitem>
+    </segmentedlist>
+
+    <variablelist>
+      <bridgehead renderas="sect3">Short Descriptions</bridgehead>
+      <?dbfo list-presentation="list"?>
+      <?dbhtml list-presentation="table"?>
+
+      <varlistentry id="finch">
+        <term><command>finch</command></term>
+        <listitem>
+          <para>is a text-based (<application>Ncurses</application>) instant
+          messaging client.</para>
+          <indexterm zone="pidgin finch">
+            <primary sortas="b-finch">finch</primary>
+          </indexterm>
+        </listitem>
+      </varlistentry>
+
+      <varlistentry id="pidgin-prog">
+        <term><command>pidgin</command></term>
+        <listitem>
+          <para>is an instant messaging client based on the
+          <application>Gtk+</application> GUI toolkit.</para>
+          <indexterm zone="pidgin pidgin-prog">
+            <primary sortas="b-pidgin">pidgin</primary>
+          </indexterm>
+        </listitem>
+      </varlistentry>
+
+      <varlistentry id="purple-remote">
+        <term><command>purple-remote</command></term>
+        <listitem>
+          <para> is a command-line interface for controlling an already running
+          instance of <command>pidgin</command></para>
+          <indexterm zone="pidgin purple-remote">
+            <primary sortas="b-purple-remote">purple-remote</primary>
+          </indexterm>
+        </listitem>
+      </varlistentry>
+
+      <!-- <varlistentry id="libpidgin-remote">
+        <term><filename class='libraryfile'>libpidgin-remote.so</filename></term>
+        <listitem>
+          <para> contains functions that are used by pidgin-remote</para>
+          <indexterm zone="pidgin libpidgin-remote">
+            <primary sortas="c-libpidgin-remote">libpidgin-remote.so</primary>
+          </indexterm>
+        </listitem>
+      </varlistentry> -->
+
+    </variablelist>
+
+  </sect2>
+
+</sect1>




More information about the blfs-book mailing list