r7047 - in trunk/BOOK: . general/genlib general/prog general/sysutils gnome/add gnome/core introduction/welcome xsoft/office

dnicholson at linuxfromscratch.org dnicholson at linuxfromscratch.org
Sun Aug 12 09:35:36 PDT 2007


Author: dnicholson
Date: 2007-08-12 10:35:36 -0600 (Sun, 12 Aug 2007)
New Revision: 7047

Added:
   trunk/BOOK/general/prog/python-modules.xml
Removed:
   trunk/BOOK/general/prog/pyxml.xml
Modified:
   trunk/BOOK/general.ent
   trunk/BOOK/general/genlib/libgsf.xml
   trunk/BOOK/general/prog/prog.xml
   trunk/BOOK/general/sysutils/hal.xml
   trunk/BOOK/gnome/add/epiphany.xml
   trunk/BOOK/gnome/add/gedit.xml
   trunk/BOOK/gnome/add/gnome-mag.xml
   trunk/BOOK/gnome/add/orca.xml
   trunk/BOOK/gnome/core/gnome-applets.xml
   trunk/BOOK/gnome/core/vte.xml
   trunk/BOOK/introduction/welcome/changelog.xml
   trunk/BOOK/xsoft/office/gimp.xml
   trunk/BOOK/xsoft/office/gnumeric.xml
Log:
Added python-modules page and the gnome-python stack


Modified: trunk/BOOK/general/genlib/libgsf.xml
===================================================================
--- trunk/BOOK/general/genlib/libgsf.xml	2007-08-12 14:34:20 UTC (rev 7046)
+++ trunk/BOOK/general/genlib/libgsf.xml	2007-08-12 16:35:36 UTC (rev 7047)
@@ -64,8 +64,7 @@
     <xref linkend="perl-xml-parser"/></para>
 
     <bridgehead renderas="sect4">Optional</bridgehead>
-    <para role="optional"><ulink url="http://www.pygtk.org/">PyGTK</ulink>
-    (requires <xref linkend="python"/>),
+    <para role="optional"><xref linkend="pygtk"/>,
     <xref linkend="GConf"/> (required to build the
     <command>gsf-office-thumbnailer</command> program),
     <xref linkend="gnome-vfs"/> and <xref linkend="libbonobo"/> (required to

Modified: trunk/BOOK/general/prog/prog.xml
===================================================================
--- trunk/BOOK/general/prog/prog.xml	2007-08-12 14:34:20 UTC (rev 7046)
+++ trunk/BOOK/general/prog/prog.xml	2007-08-12 16:35:36 UTC (rev 7047)
@@ -37,7 +37,7 @@
   <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="perl-modules.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="php.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="python.xml"/>
-  <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="pyxml.xml"/>
+  <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="python-modules.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="ruby.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="tcl.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="tk.xml"/>

Added: trunk/BOOK/general/prog/python-modules.xml
===================================================================
--- trunk/BOOK/general/prog/python-modules.xml	                        (rev 0)
+++ trunk/BOOK/general/prog/python-modules.xml	2007-08-12 16:35:36 UTC (rev 7047)
@@ -0,0 +1,870 @@
+<?xml version="1.0" encoding="ISO-8859-1"?>
+<!DOCTYPE sect1 PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
+   "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
+  <!ENTITY % general-entities SYSTEM "../../general.ent">
+  %general-entities;
+
+  <!ENTITY pyxml-download-http "http://downloads.sourceforge.net/pyxml/PyXML-&pyxml-version;.tar.gz">
+  <!ENTITY pyxml-download-ftp  "&gentoo-ftp-repo;/PyXML-&pyxml-version;.tar.gz">
+  <!ENTITY pyxml-md5sum        "1f7655050cebbb664db976405fdba209">
+  <!ENTITY pyxml-size          "734 KB">
+  <!ENTITY pyxml-buildsize     "14.6 MB">
+  <!ENTITY pyxml-time          "less than 0.1 SBU">
+
+  <!ENTITY pycairo-download-http "http://cairographics.org/releases/pycairo-&pycairo-version;.tar.gz">
+  <!ENTITY pycairo-download-ftp  " ">
+  <!ENTITY pycairo-md5sum        "e26e77919b606113f565d70036c1f504">
+  <!ENTITY pycairo-size          "468 KB">
+  <!ENTITY pycairo-buildsize     "5.2 MB">
+  <!ENTITY pycairo-time          "0.1 SBU">
+
+  <!ENTITY pygobject-download-http "&gnome-download-http;/pygobject/2.12/pygobject-&pygobject-version;.tar.bz2">
+  <!ENTITY pygobject-download-ftp  "&gnome-download-ftp;/pygobject/2.12/pygobject-&pygobject-version;.tar.bz2">
+  <!ENTITY pygobject-md5sum        "009986021225b7ea6e0ba848707785af">
+  <!ENTITY pygobject-size          "331 KB">
+  <!ENTITY pygobject-buildsize     "5.2">
+  <!ENTITY pygobject-time          "0.1 SBU">
+
+  <!ENTITY pygtk-download-http "&gnome-download-http;/pygtk/2.10/pygtk-&pygtk-version;.tar.bz2">
+  <!ENTITY pygtk-download-ftp  "&gnome-download-ftp;/pygtk/2.10/pygtk-&pygtk-version;.tar.bz2">
+  <!ENTITY pygtk-md5sum        "f051e25adcbdc1ddcf736fadad3d66f2">
+  <!ENTITY pygtk-size          "1.9 MB">
+  <!ENTITY pygtk-buildsize     "5.2 MB">
+  <!ENTITY pygtk-time          "0.7 SBU">
+
+  <!ENTITY pyorbit-download-http "&gnome-download-http;/pyorbit/2.14/pyorbit-&pyorbit-version;.tar.bz2">
+  <!ENTITY pyorbit-download-ftp  "&gnome-download-ftp;/pyorbit/2.14/pyorbit-&pyorbit-version;.tar.bz2">
+  <!ENTITY pyorbit-md5sum        "3c4d42ae1a7303fd85071a842617043f">
+  <!ENTITY pyorbit-size          "0.3 MB">
+  <!ENTITY pyorbit-buildsize     "5.3 MB">
+  <!ENTITY pyorbit-time          "0.1 SBU">
+
+  <!ENTITY gnome-python-download-http "&gnome-download-http;/gnome-python/2.18/gnome-python-&gnome-python-version;.tar.bz2">
+  <!ENTITY gnome-python-download-ftp  "&gnome-download-ftp;/gnome-python/2.18/gnome-python-&gnome-python-version;.tar.bz2">
+  <!ENTITY gnome-python-md5sum        "3df58e4354526d4e0be8524c0bf6ddb8">
+  <!ENTITY gnome-python-size          "0.4 MB">
+  <!ENTITY gnome-python-buildsize     "5.4 MB">
+  <!ENTITY gnome-python-time          "0.3 SBU">
+
+  <!ENTITY gnome-python-desktop-download-http "&gnome-download-http;/gnome-python-desktop/2.18/gnome-python-desktop-&gnome-python-desktop-version;.tar.bz2">
+  <!ENTITY gnome-python-desktop-download-ftp  "&gnome-download-ftp;/gnome-python-desktop/2.18/gnome-python-desktop-&gnome-python-desktop-version;.tar.bz2">
+  <!ENTITY gnome-python-desktop-md5sum        "ce1b1c095a69c2656177570a2939fabb">
+  <!ENTITY gnome-python-desktop-size          "0.4 MB">
+  <!ENTITY gnome-python-desktop-buildsize     "5.5 MB">
+  <!ENTITY gnome-python-desktop-time          "0.2 SBU">
+]>
+
+<sect1 id="python-modules" xreflabel="Python modules">
+  <?dbhtml filename="python-modules.html" ?>
+
+  <sect1info>
+    <othername>$LastChangedBy$</othername>
+    <date>$Date$</date>
+  </sect1info>
+
+  <title>Python Modules</title>
+
+  <indexterm zone="python-modules">
+    <primary sortas="a-Python-modules">Python modules</primary>
+  </indexterm>
+
+  <sect2 role="package">
+    <title>Introduction to Python Modules</title>
+
+    <para>The <application>Python</application> module packages add useful
+    objects to the <application>Python</application> language. Modules utilized
+    by packages throughout BLFS are listed here, along with their dependencies.
+    Installation of the modules shown on this page is meant to follow from top
+    to bottom to handle optional dependencies in each module.</para>
+
+    <itemizedlist spacing="compact">
+      <listitem>
+        <para><xref linkend="pyxml"/></para>
+      </listitem>
+      <listitem>
+        <para><xref linkend="pycairo"/></para>
+      </listitem>
+      <listitem>
+        <para><xref linkend="pygobject"/></para>
+      </listitem>
+      <listitem>
+        <para><xref linkend="pygtk"/></para>
+      </listitem>
+      <listitem>
+        <para><xref linkend="pyorbit"/></para>
+      </listitem>
+      <listitem>
+        <para><xref linkend="gnome-python"/></para>
+      </listitem>
+      <listitem>
+        <para><xref linkend="gnome-python-desktop"/></para>
+      </listitem>
+    </itemizedlist>
+
+  </sect2>
+
+  <!-- Begin PyXML -->
+  <sect2 id="pyxml" xreflabel="PyXML-&pyxml-version;">
+
+    <title>PyXML-&pyxml-version;</title>
+
+    <indexterm zone="pyxml">
+      <primary sortas="a-PyXML">PyXML</primary>
+    </indexterm>
+
+    <para>The <application>PyXML</application> package contains a validating
+    XML parser, an implementation of the SAX and DOM programming interfaces,
+    an interface to the Expat parser, and a C helper module that can speed up
+    <filename>xmllib.py</filename> by a factor of five. This is useful for
+    validating, parsing and manipulating XML files using Python
+    programs.</para>
+
+    <bridgehead renderas="sect3">Package Information</bridgehead>
+    <itemizedlist spacing="compact">
+      <listitem>
+        <para>Download (HTTP): <ulink url="&pyxml-download-http;"/></para>
+      </listitem>
+      <listitem>
+        <para>Download (FTP): <ulink url="&pyxml-download-ftp;"/></para>
+      </listitem>
+      <listitem>
+        <para>Download MD5 sum: &pyxml-md5sum;</para>
+      </listitem>
+      <listitem>
+        <para>Download size: &pyxml-size;</para>
+      </listitem>
+      <listitem>
+        <para>Estimated disk space required: &pyxml-buildsize;</para>
+      </listitem>
+      <listitem>
+        <para>Estimated build time: &pyxml-time;</para>
+      </listitem>
+    </itemizedlist>
+
+    <bridgehead renderas="sect3">PyXML Dependencies</bridgehead>
+
+    <bridgehead renderas="sect4">Required</bridgehead>
+    <para role="required"><xref linkend="python"/></para>
+
+    <para condition="html" role="usernotes">User Notes:
+    <ulink url="&blfs-wiki;/pyxml"/></para>
+
+  </sect2>
+
+  <sect2 role="installation">
+    <title>Installation of PyXML</title>
+
+    <para>Install <application>PyXML</application> by running the following
+    commands:</para>
+
+<screen><userinput>python setup.py build</userinput></screen>
+
+    <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
+
+<screen role="root"><userinput>python setup.py install &&
+install -v -m644 doc/man/xmlproc_*.1 /usr/share/man/man1 &&
+install -v -m755 -d /usr/share/doc/PyXML-&pyxml-version; &&
+cp -v -R doc demo test /usr/share/doc/PyXML-&pyxml-version; &&
+install -v -m644 README* /usr/share/doc/PyXML-&pyxml-version;</userinput></screen>
+
+    <para>To run the regression tests, the package must first be installed.
+    Then, as an unprivileged user, issue the following commands:</para>
+
+<screen><userinput>cd test &&
+python regrtest.py &&
+cd ..</userinput></screen>
+
+  </sect2>
+
+  <sect2 role="commands">
+    <title>Command Explanations</title>
+
+    <para><command>python setup.py build</command>: This command copies the
+    <filename>*.py</filename> files to a staging area and compiles the C
+    extensions.</para>
+
+    <para><command>python setup.py install</command>: This command installs
+    the package.</para>
+
+  </sect2>
+
+  <sect2 role="content">
+    <title>Contents</title>
+
+    <segmentedlist>
+      <segtitle>Installed Programs</segtitle>
+      <segtitle>Installed Libraries</segtitle>
+      <segtitle>Installed Directories</segtitle>
+
+      <seglistitem>
+        <seg>xmlproc_parse and xmlproc_val</seg>
+        <seg>PyXML Python library modules</seg>
+        <seg>/usr/lib/python&python-libdir;/site-packages/_xmlplus and
+        /usr/share/doc/PyXML-&pyxml-version;</seg>
+      </seglistitem>
+    </segmentedlist>
+
+    <variablelist>
+      <bridgehead renderas="sect3">Short Descriptions</bridgehead>
+      <?dbfo list-presentation="list"?>
+      <?dbhtml list-presentation="table"?>
+
+      <varlistentry id="xmlproc_parse">
+        <term><command>xmlproc_parse</command></term>
+        <listitem>
+          <para>is a simple XML file parser using the xmlproc parser.</para>
+          <indexterm zone="pyxml xmlproc_parse">
+            <primary sortas="b-xmlproc_parse">xmlproc_parse</primary>
+          </indexterm>
+        </listitem>
+      </varlistentry>
+
+      <varlistentry id="xmlproc_val">
+        <term><command>xmlproc_val</command></term>
+        <listitem>
+          <para>is a validating XML file parser using the xmlproc parser.</para>
+          <indexterm zone="pyxml xmlproc_val">
+            <primary sortas="b-xmlproc_val">xmlproc_val</primary>
+          </indexterm>
+        </listitem>
+      </varlistentry>
+    </variablelist>
+
+  </sect2>
+  <!-- End PyXML -->
+
+  <!-- Begin Pycairo -->
+  <sect2 id="pycairo" xreflabel="Pycairo-&pycairo-version;">
+
+    <title>Pycairo-&pycairo-version;</title>
+
+    <indexterm zone="pycairo">
+      <primary sortas="a-Pycairo">Pycairo</primary>
+    </indexterm>
+
+    <para>Pycairo provides <application>Python</application> bindings to
+    <application>Cairo</application>.</para>
+
+    <bridgehead renderas="sect3">Package Information</bridgehead>
+    <itemizedlist spacing="compact">
+      <listitem>
+        <para>Download (HTTP): <ulink url="&pycairo-download-http;"/></para>
+      </listitem>
+      <listitem>
+        <para>Download (FTP): <ulink url="&pycairo-download-ftp;"/></para>
+      </listitem>
+      <listitem>
+        <para>Download MD5 sum: &pycairo-md5sum;</para>
+      </listitem>
+      <listitem>
+        <para>Download size: &pycairo-size;</para>
+      </listitem>
+      <listitem>
+        <para>Estimated disk space required: &pycairo-buildsize;</para>
+      </listitem>
+      <listitem>
+        <para>Estimated build time: &pycairo-time;</para>
+      </listitem>
+    </itemizedlist>
+
+    <bridgehead renderas="sect3">Pycairo Dependencies</bridgehead>
+
+    <bridgehead renderas="sect4">Required</bridgehead>
+    <para role="required"><xref linkend="python"/> and
+    <xref linkend="cairo"/></para>
+
+    <para condition="html" role="usernotes">User Notes:
+    <ulink url="&blfs-wiki;/pycairo"/></para>
+
+  </sect2>
+
+  <sect2 role="installation">
+    <title>Installation of Pycairo</title>
+
+    <para>Install <application>Pycairo</application> by running the following
+    commands:</para>
+
+<screen><userinput>./configure --prefix=/usr &&
+make</userinput></screen>
+
+    <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
+
+<screen role="root"><userinput>make install</userinput></screen>
+
+    <para>To run the regression tests, the package must first be installed.
+    Then, as an unprivileged user, issue the following commands:</para>
+
+<screen><userinput>(cd test && python test.py)</userinput></screen>
+
+  </sect2>
+
+  <sect2 role="content">
+    <title>Contents</title>
+
+    <segmentedlist>
+      <segtitle>Installed Programs</segtitle>
+      <segtitle>Installed Libraries</segtitle>
+      <segtitle>Installed Directories</segtitle>
+
+      <seglistitem>
+        <seg>None</seg>
+        <seg>Pycairo Python library module</seg>
+        <seg>/usr/include/pycairo and
+        /usr/lib/python&python-libdir;/site-packages/cairo</seg>
+      </seglistitem>
+    </segmentedlist>
+
+  </sect2>
+  <!-- End Pycairo -->
+
+  <!-- Begin PyGObject -->
+  <sect2 id="pygobject" xreflabel="PyGObject-&pygobject-version;">
+
+    <title>PyGObject-&pygobject-version;</title>
+
+    <indexterm zone="pygobject">
+      <primary sortas="a-PyGObject">PyGObject</primary>
+    </indexterm>
+
+    <para>PyGObject provides <application>Python</application> bindings to the
+    GObject class from <application>GLib</application>.</para>
+
+    <bridgehead renderas="sect3">Package Information</bridgehead>
+    <itemizedlist spacing="compact">
+      <listitem>
+        <para>Download (HTTP): <ulink url="&pygobject-download-http;"/></para>
+      </listitem>
+      <listitem>
+        <para>Download (FTP): <ulink url="&pygobject-download-ftp;"/></para>
+      </listitem>
+      <listitem>
+        <para>Download MD5 sum: &pygobject-md5sum;</para>
+      </listitem>
+      <listitem>
+        <para>Download size: &pygobject-size;</para>
+      </listitem>
+      <listitem>
+        <para>Estimated disk space required: &pygobject-buildsize;</para>
+      </listitem>
+      <listitem>
+        <para>Estimated build time: &pygobject-time;</para>
+      </listitem>
+    </itemizedlist>
+
+    <bridgehead renderas="sect3">PyGObject Dependencies</bridgehead>
+
+    <bridgehead renderas="sect4">Required</bridgehead>
+    <para role="required"><xref linkend="python"/> and
+    <xref linkend="glib2"/></para>
+
+    <bridgehead renderas="sect4">Optional (to Build Documentation)</bridgehead>
+    <para role="optional"><xref linkend="libxslt"/></para>
+
+    <para condition="html" role="usernotes">User Notes:
+    <ulink url="&blfs-wiki;/pygobject"/></para>
+
+  </sect2>
+
+  <sect2 role="installation">
+    <title>Installation of PyGObject</title>
+
+    <para>Install <application>PyGObject</application> by running the following
+    commands:</para>
+
+<screen><userinput>./configure --prefix=/usr &&
+make</userinput></screen>
+
+    <para>To test the results, issue: <command>make check</command>.</para>
+
+    <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
+
+<screen role="root"><userinput>make install</userinput></screen>
+
+  </sect2>
+
+  <sect2 role="commands">
+    <title>Command Explanations</title>
+
+    <para><parameter>--disable-docs</parameter>: This option disables the
+    rebuilding of the html documentation if <xref linkend="libxslt"/> is
+    installed.</para>
+
+  </sect2>
+
+  <sect2 role="content">
+    <title>Contents</title>
+
+    <segmentedlist>
+      <segtitle>Installed Programs</segtitle>
+      <segtitle>Installed Libraries</segtitle>
+      <segtitle>Installed Directories</segtitle>
+
+      <seglistitem>
+        <seg>None</seg>
+        <seg>PyGObject Python library module</seg>
+        <seg>/usr/include/pygtk-2.0, /usr/share/pygobject and
+        /usr/lib/python&python-libdir;/site-packages/gtk-2.0</seg>
+      </seglistitem>
+    </segmentedlist>
+
+  </sect2>
+  <!-- End PyGObject -->
+
+  <!-- Begin PyGTK -->
+  <sect2 id="pygtk" xreflabel="PyGTK-&pygtk-version;">
+
+    <title>PyGTK-&pygtk-version;</title>
+
+    <indexterm zone="pygtk">
+      <primary sortas="a-PyGTK">PyGTK</primary>
+    </indexterm>
+
+    <para>PyGTK lets you to easily create programs with a graphical user
+    interface using the <application>Python</application> programming
+    language.</para>
+
+    <bridgehead renderas="sect3">Package Information</bridgehead>
+    <itemizedlist spacing="compact">
+      <listitem>
+        <para>Download (HTTP): <ulink url="&pygtk-download-http;"/></para>
+      </listitem>
+      <listitem>
+        <para>Download (FTP): <ulink url="&pygtk-download-ftp;"/></para>
+      </listitem>
+      <listitem>
+        <para>Download MD5 sum: &pygtk-md5sum;</para>
+      </listitem>
+      <listitem>
+        <para>Download size: &pygtk-size;</para>
+      </listitem>
+      <listitem>
+        <para>Estimated disk space required: &pygtk-buildsize;</para>
+      </listitem>
+      <listitem>
+        <para>Estimated build time: &pygtk-time;</para>
+      </listitem>
+    </itemizedlist>
+
+    <bridgehead renderas="sect3">PyGTK Dependencies</bridgehead>
+
+    <bridgehead renderas="sect4">Required</bridgehead>
+    <para role="required"><xref linkend="pygobject"/></para>
+
+    <bridgehead renderas="sect4">Required (atk module)</bridgehead>
+    <para role="required"><xref linkend="atk"/></para>
+
+    <bridgehead renderas="sect4">Required (pango module)</bridgehead>
+    <para role="required"><xref linkend="pango"/></para>
+
+    <bridgehead renderas="sect4">Required (pangocairo module)</bridgehead>
+    <para role="required"><xref linkend="pycairo"/> and
+    <xref linkend="pango"/></para>
+
+    <bridgehead renderas="sect4">Required (gtk and gtk.unixprint
+    modules)</bridgehead>
+    <para role="required"><xref linkend="pycairo"/> and
+    <xref linkend="gtk2"/></para>
+
+    <bridgehead renderas="sect4">Required (gtk.libglade module)</bridgehead>
+    <para role="required"><xref linkend="pycairo"/> and
+    <xref linkend="libglade"/></para>
+
+    <bridgehead renderas="sect4">Optional</bridgehead>
+    <para role="optional"><ulink url="http://numpy.scipy.org/">Numeric
+    (version 24.2)</ulink></para>
+
+    <bridgehead renderas="sect4">Optional (to Build Documentation)</bridgehead>
+    <para role="optional"><xref linkend="libxslt"/></para>
+
+    <para condition="html" role="usernotes">User Notes:
+    <ulink url="&blfs-wiki;/pygtk"/></para>
+
+  </sect2>
+
+  <sect2 role="installation">
+    <title>Installation of PyGTK</title>
+
+    <para>Install <application>PyGTK</application> by running the following
+    commands:</para>
+
+<screen><userinput>./configure --prefix=/usr &&
+make</userinput></screen>
+
+    <para>The tests must be run from an active X display. If this is so,
+    issue: <command>make check</command>.</para>
+
+    <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
+
+<screen role="root"><userinput>make install</userinput></screen>
+
+  </sect2>
+
+  <sect2 role="commands">
+    <title>Command Explanations</title>
+
+    <para><parameter>--enable-docs</parameter>: This option enables
+    rebuilding the html documentation if <xref linkend="libxslt"/> is
+    installed.</para>
+
+  </sect2>
+
+  <sect2 role="content">
+    <title>Contents</title>
+
+    <segmentedlist>
+      <segtitle>Installed Programs</segtitle>
+      <segtitle>Installed Libraries</segtitle>
+      <segtitle>Installed Directories</segtitle>
+
+      <seglistitem>
+        <seg>pygtk-codegen-2.0 and pygtk-demo</seg>
+        <seg>PyGTK Python library modules</seg>
+        <seg>/usr/lib/pygtk, /usr/share/pygtk and
+        /usr/lib/python&python-libdir;/site-packages/gtk-2.0</seg>
+      </seglistitem>
+    </segmentedlist>
+
+    <variablelist>
+      <bridgehead renderas="sect3">Short Descriptions</bridgehead>
+      <?dbfo list-presentation="list"?>
+      <?dbhtml list-presentation="table"?>
+
+      <varlistentry id="pygtk-codegen-2.0">
+        <term><command>pygtk-codegen-2.0</command></term>
+        <listitem>
+          <para>is a wrapper script to run the <application>PyGTK</application>
+          codegen module.</para>
+          <indexterm zone="pygtk pygtk-codegen-2.0">
+            <primary sortas="b-pygtk-codegen-2.0">pygtk-codegen-2.0</primary>
+          </indexterm>
+        </listitem>
+      </varlistentry>
+
+      <varlistentry id="pygtk-demo">
+        <term><command>pygtk-demo</command></term>
+        <listitem>
+          <para>is a Python wrapper to run the <application>PyGTK</application>
+          demo program.</para>
+          <indexterm zone="pygtk pygtk-demo">
+            <primary sortas="b-pygtk-demo">pygtk-demo</primary>
+          </indexterm>
+        </listitem>
+      </varlistentry>
+    </variablelist>
+
+  </sect2>
+  <!-- End PyGTK -->
+
+  <!-- Begin PyORBit -->
+  <sect2 id="pyorbit" xreflabel="PyORBit-&pyorbit-version;">
+
+    <title>PyORBit-&pyorbit-version;</title>
+
+    <indexterm zone="pyorbit">
+      <primary sortas="a-PyORBit">PyORBit</primary>
+    </indexterm>
+
+    <para>This is a <application>Python</application> language binding for
+    the <application>ORBit2</application> CORBA implementation.</para>
+
+    <bridgehead renderas="sect3">Package Information</bridgehead>
+    <itemizedlist spacing="compact">
+      <listitem>
+        <para>Download (HTTP): <ulink url="&pyorbit-download-http;"/></para>
+      </listitem>
+      <listitem>
+        <para>Download (FTP): <ulink url="&pyorbit-download-ftp;"/></para>
+      </listitem>
+      <listitem>
+        <para>Download MD5 sum: &pyorbit-md5sum;</para>
+      </listitem>
+      <listitem>
+        <para>Download size: &pyorbit-size;</para>
+      </listitem>
+      <listitem>
+        <para>Estimated disk space required: &pyorbit-buildsize;</para>
+      </listitem>
+      <listitem>
+        <para>Estimated build time: &pyorbit-time;</para>
+      </listitem>
+    </itemizedlist>
+
+    <bridgehead renderas="sect3">PyORBit Dependencies</bridgehead>
+
+    <bridgehead renderas="sect4">Required</bridgehead>
+    <para role="required"><xref linkend="python"/> and
+    <xref linkend="ORBit2"/></para>
+
+    <para condition="html" role="usernotes">User Notes:
+    <ulink url="&blfs-wiki;/pyorbit"/></para>
+
+  </sect2>
+
+  <sect2 role="installation">
+    <title>Installation of PyORBit</title>
+
+    <para>Install <application>PyORBit</application> by running the following
+    commands:</para>
+
+<screen><userinput>./configure --prefix=/usr &&
+make</userinput></screen>
+
+    <!-- There's some test scripts, but I don't know what to run -->
+    <para>This package does not come with a test suite.</para>
+
+    <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
+
+<screen role="root"><userinput>make install</userinput></screen>
+
+  </sect2>
+
+  <sect2 role="content">
+    <title>Contents</title>
+
+    <segmentedlist>
+      <segtitle>Installed Programs</segtitle>
+      <segtitle>Installed Libraries</segtitle>
+      <segtitle>Installed Directories</segtitle>
+
+      <seglistitem>
+        <seg>None</seg>
+        <seg>PyORBit Python library module</seg>
+        <seg>/usr/include/pyorbit-2</seg>
+      </seglistitem>
+    </segmentedlist>
+
+  </sect2>
+  <!-- End PyORBit -->
+
+  <!-- Begin Gnome-Python -->
+  <sect2 id="gnome-python" xreflabel="Gnome-Python-&gnome-python-version;">
+
+    <title>Gnome-Python-&gnome-python-version;</title>
+
+    <indexterm zone="gnome-python">
+      <primary sortas="a-Gnome-Python">Gnome-Python</primary>
+    </indexterm>
+
+    <para>Gnome-Python provides <application>Python</application> modules
+    for various GNOME libraries.</para>
+
+    <bridgehead renderas="sect3">Package Information</bridgehead>
+    <itemizedlist spacing="compact">
+      <listitem>
+        <para>Download (HTTP): <ulink url="&gnome-python-download-http;"/></para>
+      </listitem>
+      <listitem>
+        <para>Download (FTP): <ulink url="&gnome-python-download-ftp;"/></para>
+      </listitem>
+      <listitem>
+        <para>Download MD5 sum: &gnome-python-md5sum;</para>
+      </listitem>
+      <listitem>
+        <para>Download size: &gnome-python-size;</para>
+      </listitem>
+      <listitem>
+        <para>Estimated disk space required: &gnome-python-buildsize;</para>
+      </listitem>
+      <listitem>
+        <para>Estimated build time: &gnome-python-time;</para>
+      </listitem>
+    </itemizedlist>
+
+    <bridgehead renderas="sect3">Gnome-Python Dependencies</bridgehead>
+
+    <bridgehead renderas="sect4">Required</bridgehead>
+    <para role="required"><xref linkend="pygtk"/> and
+    <xref linkend="libgnome"/></para>
+
+    <!-- Many modules get their deps pulled in through libgnome: libbonobo,
+         gnome-vfs, GConf -->
+
+    <bridgehead renderas="sect4">Required (gnome.ui module)</bridgehead>
+    <para role="required"><xref linkend="pyorbit"/> and
+    <xref linkend="libgnomeui"/></para>
+
+    <bridgehead renderas="sect4">Required (gnome.canvas module)</bridgehead>
+    <para role="required"><xref linkend="libgnomecanvas"/></para>
+
+    <bridgehead renderas="sect4">Required (gnomevfs module bonobo
+    support)</bridgehead>
+    <para role="required"><xref linkend="pyorbit"/></para>
+
+    <bridgehead renderas="sect4">Required (bonobo.ui module)</bridgehead>
+    <para role="required"><xref linkend="libbonoboui"/></para>
+
+    <para condition="html" role="usernotes">User Notes:
+    <ulink url="&blfs-wiki;/gnome-python"/></para>
+
+  </sect2>
+
+  <sect2 role="installation">
+    <title>Installation of Gnome-Python</title>
+
+    <para>Install <application>Gnome-Python</application> by running the following
+    commands:</para>
+
+<screen><userinput>./configure --prefix=/usr &&
+make</userinput></screen>
+
+    <!-- Tests were crashing on me; need to figure out why -->
+    <para>This package does not come with a test suite.</para>
+
+    <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
+
+<screen role="root"><userinput>make install</userinput></screen>
+
+  </sect2>
+
+  <sect2 role="content">
+    <title>Contents</title>
+
+    <segmentedlist>
+      <segtitle>Installed Programs</segtitle>
+      <segtitle>Installed Libraries</segtitle>
+      <segtitle>Installed Directories</segtitle>
+
+      <seglistitem>
+        <seg>None</seg>
+        <seg>Gnome-Python library modules</seg>
+        <seg>/usr/include/gnome-python-2.0</seg>
+      </seglistitem>
+    </segmentedlist>
+
+  </sect2>
+  <!-- End Gnome-Python -->
+
+  <!-- Begin Gnome-Python-Desktop -->
+  <sect2 id="gnome-python-desktop" xreflabel="Gnome-Python-Desktop-&gnome-python-desktop-version;">
+
+    <title>Gnome-Python-Desktop-&gnome-python-desktop-version;</title>
+
+    <indexterm zone="gnome-python-desktop">
+      <primary sortas="a-Gnome-Python-Desktop">Gnome-Python-Desktop</primary>
+    </indexterm>
+
+    <para>Gnome-Python-Desktop provides additional <application>Python</application>
+    modules for GNOME libraries.</para>
+
+    <bridgehead renderas="sect3">Package Information</bridgehead>
+    <itemizedlist spacing="compact">
+      <listitem>
+        <para>Download (HTTP): <ulink url="&gnome-python-desktop-download-http;"/></para>
+      </listitem>
+      <listitem>
+        <para>Download (FTP): <ulink url="&gnome-python-desktop-download-ftp;"/></para>
+      </listitem>
+      <listitem>
+        <para>Download MD5 sum: &gnome-python-desktop-md5sum;</para>
+      </listitem>
+      <listitem>
+        <para>Download size: &gnome-python-desktop-size;</para>
+      </listitem>
+      <listitem>
+        <para>Estimated disk space required: &gnome-python-desktop-buildsize;</para>
+      </listitem>
+      <listitem>
+        <para>Estimated build time: &gnome-python-desktop-time;</para>
+      </listitem>
+    </itemizedlist>
+
+    <bridgehead renderas="sect3">Gnome-Python-Desktop Dependencies</bridgehead>
+
+    <!-- Not strictly true, but needed to find install directories and
+         by most modules -->
+    <bridgehead renderas="sect4">Required</bridgehead>
+    <para role="required"><xref linkend="gnome-python"/></para>
+
+    <bridgehead renderas="sect4">Required (gnomeapplet module)</bridgehead>
+    <para role="required"><xref linkend="gnome-panel"/></para>
+
+    <bridgehead renderas="sect4">Required (gnomeprint module)</bridgehead>
+    <para role="required"><xref linkend="libgnomeprint"/></para>
+
+    <bridgehead renderas="sect4">Required (gnomeprint.ui module)</bridgehead>
+    <para role="required"><xref linkend="libgnomeprintui"/></para>
+
+    <bridgehead renderas="sect4">Required (gtksourceview module)</bridgehead>
+    <para role="required"><xref linkend="gtksourceview"/></para>
+
+    <bridgehead renderas="sect4">Required (wnck module)</bridgehead>
+    <para role="required"><xref linkend="libwnck"/></para>
+
+    <bridgehead renderas="sect4">Required (totem.plparser module)</bridgehead>
+    <para role="required"><xref linkend="totem"/></para>
+
+    <bridgehead renderas="sect4">Required (gtop module)</bridgehead>
+    <para role="required"><xref linkend="libgtop"/></para>
+
+    <bridgehead renderas="sect4">Required (nautilusburn module)</bridgehead>
+    <para role="required"><xref linkend="nautilus-cd-burner"/></para>
+
+    <bridgehead renderas="sect4">Required (mediaprofiles module)</bridgehead>
+    <para role="required"><xref linkend="gnome-media"/></para>
+
+    <bridgehead renderas="sect4">Required (rsvg module)</bridgehead>
+    <para role="required"><xref linkend="librsvg"/></para>
+
+    <bridgehead renderas="sect4">Required (metacity module)</bridgehead>
+    <para role="required"><xref linkend="metacity"/></para>
+
+    <bridgehead renderas="sect4">Required (gnomekeyring module)</bridgehead>
+    <para role="required"><xref linkend="gnome-keyring"/></para>
+
+    <bridgehead renderas="sect4">Required (gnomedesktop module)</bridgehead>
+    <para role="required"><xref linkend="gnome-desktop"/></para>
+
+    <bridgehead renderas="sect4">Required (bugbuddy module)</bridgehead>
+    <para role="required"><xref linkend="bug-buddy"/></para>
+
+    <para condition="html" role="usernotes">User Notes:
+    <ulink url="&blfs-wiki;/gnome-python-desktop"/></para>
+
+  </sect2>
+
+  <sect2 role="installation">
+    <title>Installation of Gnome-Python-Desktop</title>
+
+    <para>Install <application>Gnome-Python-Desktop</application> by running
+    the following commands:</para>
+
+<screen><userinput>./configure --prefix=/usr &&
+make</userinput></screen>
+
+    <!-- Tests were crashing on me; need to figure out why -->
+    <para>This package does not come with a test suite.</para>
+
+    <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
+
+<screen role="root"><userinput>make install</userinput></screen>
+
+  </sect2>
+
+  <sect2 role="commands">
+    <title>Command Explanations</title>
+
+    <para><parameter>--enable-metacity</parameter>: This option enables
+    building the metacity module if <xref linkend="metacity"/> is
+    installed.</para>
+
+  </sect2>
+
+  <sect2 role="content">
+    <title>Contents</title>
+
+    <segmentedlist>
+      <segtitle>Installed Programs</segtitle>
+      <segtitle>Installed Libraries</segtitle>
+      <segtitle>Installed Directories</segtitle>
+
+      <seglistitem>
+        <seg>None</seg>
+        <seg>Gnome-Python-Desktop library modules</seg>
+        <seg>None</seg>
+      </seglistitem>
+    </segmentedlist>
+
+  </sect2>
+  <!-- End Gnome-Python-Desktop -->
+
+</sect1>

Deleted: trunk/BOOK/general/prog/pyxml.xml
===================================================================
--- trunk/BOOK/general/prog/pyxml.xml	2007-08-12 14:34:20 UTC (rev 7046)
+++ trunk/BOOK/general/prog/pyxml.xml	2007-08-12 16:35:36 UTC (rev 7047)
@@ -1,152 +0,0 @@
-<?xml version="1.0" encoding="ISO-8859-1"?>
-<!DOCTYPE sect1 PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
-   "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
-  <!ENTITY % general-entities SYSTEM "../../general.ent">
-  %general-entities;
-
-  <!ENTITY pyxml-download-http "http://downloads.sourceforge.net/pyxml/PyXML-&pyxml-version;.tar.gz">
-  <!ENTITY pyxml-download-ftp  "&gentoo-ftp-repo;/PyXML-&pyxml-version;.tar.gz">
-  <!ENTITY pyxml-md5sum        "1f7655050cebbb664db976405fdba209">
-  <!ENTITY pyxml-size          "734 KB">
-  <!ENTITY pyxml-buildsize     "14.6 MB">
-  <!ENTITY pyxml-time          "less than 0.1 SBU">
-]>
-
-<sect1 id="pyxml" xreflabel="PyXML-&pyxml-version;">
-  <?dbhtml filename="pyxml.html"?>
-
-  <sect1info>
-    <othername>$LastChangedBy$</othername>
-    <date>$Date$</date>
-  </sect1info>
-
-  <title>PyXML-&pyxml-version;</title>
-
-  <indexterm zone="pyxml">
-    <primary sortas="a-PyXML">PyXML</primary>
-  </indexterm>
-
-  <sect2 role="package">
-    <title>Introduction to PyXML</title>
-
-    <para>The <application>PyXML</application> package contains a validating
-    XML parser, an implementation of the SAX and DOM programming interfaces,
-    an interface to the Expat parser, and a C helper module that can speed up
-    <filename>xmllib.py</filename> by a factor of five. This is useful for
-    validating, parsing and manipulating XML files using Python
-    programs.</para>
-
-    <bridgehead renderas="sect3">Package Information</bridgehead>
-    <itemizedlist spacing="compact">
-      <listitem>
-        <para>Download (HTTP): <ulink url="&pyxml-download-http;"/></para>
-      </listitem>
-      <listitem>
-        <para>Download (FTP): <ulink url="&pyxml-download-ftp;"/></para>
-      </listitem>
-      <listitem>
-        <para>Download MD5 sum: &pyxml-md5sum;</para>
-      </listitem>
-      <listitem>
-        <para>Download size: &pyxml-size;</para>
-      </listitem>
-      <listitem>
-        <para>Estimated disk space required: &pyxml-buildsize;</para>
-      </listitem>
-      <listitem>
-        <para>Estimated build time: &pyxml-time;</para>
-      </listitem>
-    </itemizedlist>
-
-    <bridgehead renderas="sect3">PyXML Dependencies</bridgehead>
-
-    <bridgehead renderas="sect4">Required</bridgehead>
-    <para role="required"><xref linkend="python"/></para>
-
-    <para condition="html" role="usernotes">User Notes:
-    <ulink url="&blfs-wiki;/pyxml"/></para>
-
-  </sect2>
-
-  <sect2 role="installation">
-    <title>Installation of PyXML</title>
-
-    <para>Install <application>PyXML</application> by running the following
-    commands:</para>
-
-<screen><userinput>python setup.py build</userinput></screen>
-
-    <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
-
-<screen role="root"><userinput>python setup.py install &&
-install -v -m644 doc/man/xmlproc_*.1 /usr/share/man/man1 &&
-install -v -m755 -d /usr/share/doc/PyXML-&pyxml-version; &&
-cp -v -R doc demo test /usr/share/doc/PyXML-&pyxml-version; &&
-install -v -m644 README* /usr/share/doc/PyXML-&pyxml-version;</userinput></screen>
-
-    <para>To run the regression tests, the package must first be installed.
-    Then, as an unprivileged user, issue the following commands:</para>
-
-<screen><userinput>cd test &&
-python regrtest.py &&
-cd ..</userinput></screen>
-
-  </sect2>
-
-  <sect2 role="commands">
-    <title>Command Explanations</title>
-
-    <para><command>python setup.py build</command>: This command copies the
-    <filename>*.py</filename> files to a staging area and compiles the C
-    extensions.</para>
-
-    <para><command>python setup.py install</command>: This command installs
-    the package.</para>
-
-  </sect2>
-
-  <sect2 role="content">
-    <title>Contents</title>
-
-    <segmentedlist>
-      <segtitle>Installed Programs</segtitle>
-      <segtitle>Installed Libraries</segtitle>
-      <segtitle>Installed Directories</segtitle>
-
-      <seglistitem>
-        <seg>xmlproc_parse and xmlproc_val</seg>
-        <seg>PyXML Python library modules</seg>
-        <seg>/usr/lib/python&python-libdir;/site-packages/_xmlplus and
-        /usr/share/doc/PyXML-&pyxml-version;</seg>
-      </seglistitem>
-    </segmentedlist>
-
-    <variablelist>
-      <bridgehead renderas="sect3">Short Descriptions</bridgehead>
-      <?dbfo list-presentation="list"?>
-      <?dbhtml list-presentation="table"?>
-
-      <varlistentry id="xmlproc_parse">
-        <term><command>xmlproc_parse</command></term>
-        <listitem>
-          <para>is a simple XML file parser using the xmlproc parser.</para>
-          <indexterm zone="pyxml xmlproc_parse">
-            <primary sortas="b-xmlproc_parse">xmlproc_parse</primary>
-          </indexterm>
-        </listitem>
-      </varlistentry>
-
-      <varlistentry id="xmlproc_val">
-        <term><command>xmlproc_val</command></term>
-        <listitem>
-          <para>is a validating XML file parser using the xmlproc parser.</para>
-          <indexterm zone="pyxml xmlproc_val">
-            <primary sortas="b-xmlproc_val">xmlproc_val</primary>
-          </indexterm>
-        </listitem>
-      </varlistentry>
-    </variablelist>
-
-  </sect2>
-
-</sect1>

Modified: trunk/BOOK/general/sysutils/hal.xml
===================================================================
--- trunk/BOOK/general/sysutils/hal.xml	2007-08-12 14:34:20 UTC (rev 7046)
+++ trunk/BOOK/general/sysutils/hal.xml	2007-08-12 16:35:36 UTC (rev 7047)
@@ -214,131 +214,11 @@
     <ulink url="http://cvsweb.freedesktop.org/pm-utils/pm-utils/">pm-utils</ulink>.</para>
 
     <para>The <xref linkend="hal-device-manager"/> program requires several
-    additional packages to be installed before it will run. The list is
-    significant and requires a substantial commitment to install them. It is
-    left up to you to determine if the time and effort spent installing the
-    following packages is worth using the <command>hal-device-manager</command>
-    program.</para>
+    additional <application>Python</application> modules to be available.
+    These are <xref linkend="dbus-python"/>,
+    <xref linkend="pygtk"/> (including the gtk and gtk.libglade modules), and
+    <xref linkend="gnome-python"/> (including the gnome.ui module).</para>
 
-    <para>Though the only requirement to run the
-    <command>hal-device-manager</command> program is installing
-    <ulink url="&gnome-download-http;/gnome-python/">
-    GNOME-Python</ulink> and <xref linkend="dbus-python"/>, the dependency
-    list is staggering. The following list does not include the dependencies
-    already identified in the BLFS book. For example,
-    <application>libgnome</application> already lists
-    <application>GNOME VFS</application>, <application>GConf</application>,
-    etc., so they are not repeated here. Note that some of the dependencies
-    have their own dependencies, which have their own, and so forth and so
-    on.</para>
-
-    <itemizedlist>
-      <listitem>
-        <para id="gnome-python-dependencies"
-              xreflabel="GNOME-Python dependency list"><ulink
-          url="&gnome-download-http;/gnome-python/">GNOME-Python</ulink>
-        </para>
-
-        <itemizedlist>
-          <listitem>
-            <para><ulink
-              url="http://www.pygtk.org/">PyGTK</ulink> (required)
-            </para>
-
-            <itemizedlist>
-              <listitem>
-                <para><xref linkend="libglade"/> (required)</para>
-              </listitem>
-              <listitem>
-                <para><ulink
-                url="&gnome-download-http;/pygobject/">PyGObject</ulink> (required)</para>
-              </listitem>
-              <listitem>
-                <para><ulink
-                  url="http://www.cairographics.org/pycairo">Pycairo</ulink> (optional)
-                </para>
-
-                <!-- Removing these dependencies as they are now obsolete
-                     See the pycairo docs for full details
-                <itemizedlist>
-                  <listitem>
-                    <para><ulink
-                      url="http://www.cairographics.org/snapshots/">libsvg-cairo</ulink> (optional)
-                    </para>
-
-                    <itemizedlist>
-                      <listitem>
-                        <para><ulink
-                          url="http://www.cairographics.org/snapshots/">libsvg</ulink> (required)
-                        </para>
-                      </listitem>
-                    </itemizedlist>
-
-                  </listitem>
-                  <listitem>
-                    <para><ulink
-                      url="http://www.pygtk.org/">PyGTK</ulink> (optional, and circular)
-                    </para>
-                  </listitem>
-                  <listitem>
-                    <para><ulink
-                      url="http://sourceforge.net/projects/numpy">Numerical Python</ulink> (optional)
-                    </para>
-                  </listitem>
-                </itemizedlist>
-                -->
-
-              </listitem>
-              <listitem>
-                <para><ulink
-                  url="http://sourceforge.net/projects/numpy">Old Numeric</ulink> (optional)
-                </para>
-              </listitem>
-            </itemizedlist>
-
-          </listitem>
-          <listitem>
-            <para><xref linkend="libgnomeui"/> (optional)</para>
-          </listitem>
-          <listitem>
-            <para><xref linkend="libgnome"/> (required)</para>
-          </listitem>
-          <listitem>
-            <para><ulink
-              url="&gnome-download-http;/pyorbit/">PyORBit</ulink> (optional)
-            </para>
-
-            <itemizedlist>
-              <listitem>
-                <para><xref linkend="ORBit2"/> (required)</para>
-              </listitem>
-            </itemizedlist>
-
-          </listitem>
-        </itemizedlist>
-
-      </listitem>
-      <listitem>
-        <para><xref linkend="dbus-python"/> (required)</para>
-      </listitem>
-    </itemizedlist>
-
-    <note>
-      <para>The dependency list is designed to start at the bottom and work
-      your way up until the last package to install is
-      <application>GNOME-Python</application>. Note that the dependencies
-      marked as <quote>required</quote> are required for the package it is
-      listed under. For example, you don't need to install
-      <application>ORBit</application> if you don't plan on installing
-      <application>PyORBit</application>. The minimum packages you could
-      install to support running <xref linkend="hal-device-manager"/> would be
-      (in this order): <xref linkend="dbus-python"/>, <xref linkend="ORBit2"/>,
-      <xref linkend="libgnome"/>, <xref linkend="libglade"/>,
-      <ulink url="&gnome-download-http;/pygobject/">PyGObject</ulink>,
-      <ulink url="http://www.pygtk.org/">PyGTK</ulink> and <ulink
-      url="&gnome-download-http;/gnome-python/">GNOME-Python</ulink>.</para>
-    </note>
-
   </sect2>
 
   <sect2 role="configuration">
@@ -595,8 +475,7 @@
         <term><command>hal-device-manager</command></term>
         <listitem>
           <para>shows a graphical representation of all the devices
-          <application>HAL</application> is aware of. This program requires
-          the <xref linkend="gnome-python-dependencies"/>. Here is a <ulink
+          <application>HAL</application> is aware of. Here is a <ulink
           url="http://cvs.freedesktop.org/*checkout*/hal/hal/doc/spec/hal-devices1.png">
           screenshot</ulink> of <command>hal-device-manager</command>
           communicating with the HAL daemon and displaying a tree of device

Modified: trunk/BOOK/general.ent
===================================================================
--- trunk/BOOK/general.ent	2007-08-12 14:34:20 UTC (rev 7046)
+++ trunk/BOOK/general.ent	2007-08-12 16:35:36 UTC (rev 7047)
@@ -215,7 +215,6 @@
 <!ENTITY php-version                  "5.2.3">
 <!ENTITY Python-version               "2.5.1">
 <!ENTITY python-libdir                "2.5">
-<!ENTITY pyxml-version                "0.8.4">
 <!ENTITY ruby-version                 "1.8.6">
 <!ENTITY tcl-version                  "8.4.15">
 <!ENTITY tk-version                   "8.4.15">
@@ -300,8 +299,17 @@
 <!ENTITY NDF-version                  "1.45">
 <!ENTITY GSD-version                  "1.13">
 <!ENTITY Starlink-Config-version      "1.00">
+
+<!-- Python module versions used in the Python Modules instructions -->
+<!ENTITY pyxml-version                "0.8.4">
+<!ENTITY pycairo-version              "1.4.0">
+<!ENTITY pygobject-version            "2.12.3">
+<!ENTITY pygtk-version                "2.10.6">
+<!ENTITY pyorbit-version              "2.14.3">
+<!ENTITY gnome-python-version         "2.18.2">
+<!ENTITY gnome-python-desktop-version "2.18.0">
+
 <!-- Part IV -->
-
 <!-- Chapter 13 -->
 <!ENTITY ppp-version                  "2.4.4">
 <!ENTITY wvdial-version               "1.54.0">

Modified: trunk/BOOK/gnome/add/epiphany.xml
===================================================================
--- trunk/BOOK/gnome/add/epiphany.xml	2007-08-12 14:34:20 UTC (rev 7046)
+++ trunk/BOOK/gnome/add/epiphany.xml	2007-08-12 16:35:36 UTC (rev 7047)
@@ -69,11 +69,12 @@
     <xref linkend="thunderbird"/> or
     <ulink url="http://www.mozilla.org/products/mozilla1.x/">Mozilla</ulink>)</para>
 
+    <bridgehead renderas="sect4">Optional for Python Support</bridgehead>
+    <para role="optional"><xref linkend="pygtk"/> (including the gtk module)
+    and <xref linkend="gnome-python"/>.</para>
+
     <bridgehead renderas="sect4">Optional</bridgehead>
-    <para role="optional"><xref linkend="intltool"/>,
-    <ulink url="&gnome-download-http;/gnome-python/">GNOME-Python</ulink>
-    (requires <ulink url="http://www.pygtk.org/">PyGTK</ulink>,
-    see the <xref linkend="gnome-python-dependencies"/>), and
+    <para role="optional"><xref linkend="intltool"/> and
     <xref linkend="gtk-doc"/></para>
 
     <para condition="html" role="usernotes">User Notes:

Modified: trunk/BOOK/gnome/add/gedit.xml
===================================================================
--- trunk/BOOK/gnome/add/gedit.xml	2007-08-12 14:34:20 UTC (rev 7046)
+++ trunk/BOOK/gnome/add/gedit.xml	2007-08-12 16:35:36 UTC (rev 7047)
@@ -67,14 +67,16 @@
     <para role="optional"><xref linkend="iso-codes"/> and
     <ulink url="http://www.abisource.com/projects/enchant/">Enchant</ulink>*</para>
 
+    <bridgehead renderas="sect4">Optional (to Provide Python Bindings and Plugins)</bridgehead>
+    <para role="optional"><xref linkend="pygtk"/> (including the gtk, pango
+    and gtk.libglade modules) and
+    <xref linkend="gnome-python-desktop"/> (including the gtksourceview
+    module)</para>
+
     <bridgehead renderas="sect4">Optional</bridgehead>
     <para role="optional"><xref linkend="intltool"/>,
     <xref linkend="gtk-doc"/>,
-    <ulink url="ftp://oss.sgi.com/projects/xfs/cmd_tars/">libattr</ulink>, and
-    <ulink url="&gnome-download-http;/gnome-python-desktop">gnome-python-desktop</ulink>
-    (requires <ulink url="http://www.pygtk.org/">PyGTK</ulink> and can use
-    <ulink url="&gnome-download-http;/gnome-python/">GNOME-Python</ulink> and
-    <ulink url="&gnome-download-http;/pyorbit/">PyORBit</ulink>)</para>
+    <ulink url="ftp://oss.sgi.com/projects/xfs/cmd_tars/">libattr</ulink></para>
 
     <para>* <xref linkend="aspell"/> is just one of many backend spell libraries
     <application>Enchant</application> can use. See the

Modified: trunk/BOOK/gnome/add/gnome-mag.xml
===================================================================
--- trunk/BOOK/gnome/add/gnome-mag.xml	2007-08-12 14:34:20 UTC (rev 7046)
+++ trunk/BOOK/gnome/add/gnome-mag.xml	2007-08-12 16:35:36 UTC (rev 7047)
@@ -63,10 +63,12 @@
 
     <bridgehead renderas="sect4">Optional (to Build the Colorblind Applet)</bridgehead>
     <para role="optional"><xref linkend="gnome-desktop"/>,
-    <ulink url="http://people.debian.org/~ruoso/">colorblind</ulink>, and
-    <ulink url="&gnome-download-http;/gnome-python/">GNOME-Python</ulink>
-    (requires <ulink url="http://www.pygtk.org/">PyGTK</ulink>,
-    see the <xref linkend="gnome-python-dependencies"/>)</para>
+    <ulink url="http://people.debian.org/~ruoso/">colorblind</ulink>,
+    <xref linkend="pygtk"/> (including the gtk and gtk.libglade modules),
+    <xref linkend="pyorbit"/>,
+    <xref linkend="gnome-python"/> (including the gnome.ui module) and
+    <xref linkend="gnome-python-desktop"/> (includeing the gnomeapplet
+    module)</para>
 
     <bridgehead renderas="sect4">Optional</bridgehead>
     <para role="optional"><xref linkend="intltool"/> and

Modified: trunk/BOOK/gnome/add/orca.xml
===================================================================
--- trunk/BOOK/gnome/add/orca.xml	2007-08-12 14:34:20 UTC (rev 7046)
+++ trunk/BOOK/gnome/add/orca.xml	2007-08-12 16:35:36 UTC (rev 7047)
@@ -60,10 +60,8 @@
 
     <bridgehead renderas="sect4">Required</bridgehead>
     <para role="required"><xref linkend="at-spi"/>,
-    <ulink url="&gnome-download-http;/pyorbit/">PyORBit</ulink>, and
-    <ulink url="&gnome-download-http;/gnome-python/">GNOME-Python</ulink>
-      (requires <ulink url="http://www.pygtk.org/">PyGTK</ulink>, see the
-    <xref linkend="gnome-python-dependencies"/>)</para>
+    <xref linkend="pyorbit"/>, and
+    <xref linkend="gnome-python"/></para>
 
     <bridgehead renderas="sect4">Optional</bridgehead>
     <para role="optional"><xref linkend="intltool"/>,

Modified: trunk/BOOK/gnome/core/gnome-applets.xml
===================================================================
--- trunk/BOOK/gnome/core/gnome-applets.xml	2007-08-12 14:34:20 UTC (rev 7046)
+++ trunk/BOOK/gnome/core/gnome-applets.xml	2007-08-12 16:35:36 UTC (rev 7047)
@@ -63,6 +63,11 @@
     <xref linkend="gnome-icon-theme"/>,
     <xref linkend="gnome-panel"/></para>
 
+    <bridgehead renderas="sect4">Optional to Build the Invest Applet</bridgehead>
+    <para role="optional"><xref linkend="pygtk"/> (including the gtk and
+    gtk.libglade modules) and <xref linkend="gnome-python-desktop"/>
+    (including the gnomeapplet module)</para>
+
     <bridgehead renderas="sect4">Optional</bridgehead>
     <para role="optional"><xref linkend="libgtop"/>,
     <xref linkend="control-center"/>,
@@ -71,10 +76,6 @@
     <xref linkend="libgnomekbd"/>,
     <xref linkend="gucharmap"/>,
     <xref linkend="system-tools-backends"/>,
-    <ulink url="&gnome-download-http;/gnome-python-desktop/">gnome-python-desktop</ulink>,
-    <ulink url="&gnome-download-http;/gnome-python/">GNOME-Python</ulink>
-    (requires <ulink url="http://www.pygtk.org/">PyGTK</ulink>,
-    see the <xref linkend="gnome-python-dependencies"/>),
     <xref linkend="docbook-utils"/>,
     <ulink url="http://club.pep.ne.jp/~ishioka/Software/Linux/libapm-e.html">libapm</ulink>, and
     <ulink url="http://www.galago-project.org/news/index.php">libnotify</ulink></para>

Modified: trunk/BOOK/gnome/core/vte.xml
===================================================================
--- trunk/BOOK/gnome/core/vte.xml	2007-08-12 14:34:20 UTC (rev 7046)
+++ trunk/BOOK/gnome/core/vte.xml	2007-08-12 16:35:36 UTC (rev 7047)
@@ -63,8 +63,7 @@
     <bridgehead renderas="sect4">Optional</bridgehead>
     <para role="optional"><xref linkend="gtk-doc"/>,
     <xref linkend="intltool"/>, and
-    <ulink url="http://www.pygtk.org/">PyGTK</ulink>
-    (requires <xref linkend="python"/>)</para>
+    <xref linkend="pygtk"/> (including the gtk module)</para>
 
     <para condition="html" role="usernotes">User Notes:
     <ulink url="&blfs-wiki;/vte"/></para>

Modified: trunk/BOOK/introduction/welcome/changelog.xml
===================================================================
--- trunk/BOOK/introduction/welcome/changelog.xml	2007-08-12 14:34:20 UTC (rev 7046)
+++ trunk/BOOK/introduction/welcome/changelog.xml	2007-08-12 16:35:36 UTC (rev 7047)
@@ -45,6 +45,10 @@
       <para>August 12th, 2007</para>
       <itemizedlist>
         <listitem>
+          <para>[dnicholson] - Added the Python Modules page with Gnome-Python
+          and it's dependencies.</para>
+        </listitem>
+        <listitem>
           <para>[randy] - Added instructions to create an X11R6 symlink to the
           X Windows Components page.</para>
         </listitem>

Modified: trunk/BOOK/xsoft/office/gimp.xml
===================================================================
--- trunk/BOOK/xsoft/office/gimp.xml	2007-08-12 14:34:20 UTC (rev 7046)
+++ trunk/BOOK/xsoft/office/gimp.xml	2007-08-12 16:35:36 UTC (rev 7047)
@@ -105,8 +105,7 @@
     <xref linkend="alsa"/>,
     <xref linkend="libgtkhtml"/> (required to build the help system browser plugin),
     <ulink url="http://wvware.sourceforge.net/libwmf.html">libwmf</ulink>,
-    <ulink url="http://www.pygtk.org/">PyGTK</ulink> (requires
-    <xref linkend="python"/>),
+    <xref linkend="pygtk"/> (including the gtk and pango modules),
     <ulink url="http://gimp-print.sourceforge.net/">Gimp-Print version 4.2.7</ulink>,
     an <xref linkend="server-mail"/> (that provides a
     <command>sendmail</command> program), and

Modified: trunk/BOOK/xsoft/office/gnumeric.xml
===================================================================
--- trunk/BOOK/xsoft/office/gnumeric.xml	2007-08-12 14:34:20 UTC (rev 7046)
+++ trunk/BOOK/xsoft/office/gnumeric.xml	2007-08-12 16:35:36 UTC (rev 7047)
@@ -62,7 +62,7 @@
     url="&gnome-download-http;/goffice/0.2/">GOffice <0.3.0</ulink>)</para>
 
     <bridgehead renderas="sect4">Optional</bridgehead>
-    <para role="optional"><ulink url="http://www.pygtk.org/">PyGTK</ulink>,
+    <para role="optional"><xref linkend="pygtk"/>,
     <xref linkend="libgnomeui"/> (combined with the
     <filename class='libraryfile'>libgsf-gnome-1</filename> library from the
     <xref linkend="libgsf"/> package will provide GNOME-2 support),




More information about the blfs-book mailing list