r7034 - in trunk/BOOK: gnome/add introduction/welcome

randy at linuxfromscratch.org randy at linuxfromscratch.org
Wed Aug 8 09:49:50 PDT 2007


Author: randy
Date: 2007-08-08 10:49:50 -0600 (Wed, 08 Aug 2007)
New Revision: 7034

Modified:
   trunk/BOOK/gnome/add/at-spi.xml
   trunk/BOOK/gnome/add/gnome-mag.xml
   trunk/BOOK/gnome/add/gnome-speech.xml
   trunk/BOOK/gnome/add/gok.xml
   trunk/BOOK/gnome/add/java-access-bridge.xml
   trunk/BOOK/gnome/add/libgail-gnome.xml
   trunk/BOOK/introduction/welcome/changelog.xml
Log:
Updated all the GNOME Assistive Technology (Accessibility) packages to GNOME-2.18 versions

Modified: trunk/BOOK/gnome/add/at-spi.xml
===================================================================
--- trunk/BOOK/gnome/add/at-spi.xml	2007-08-08 16:46:14 UTC (rev 7033)
+++ trunk/BOOK/gnome/add/at-spi.xml	2007-08-08 16:49:50 UTC (rev 7034)
@@ -6,10 +6,10 @@
 
   <!ENTITY at-spi-download-http "&gnome-download-http;/at-spi/1.18/at-spi-&at-spi-version;.tar.bz2">
   <!ENTITY at-spi-download-ftp  "&gnome-download-ftp;/at-spi/1.18/at-spi-&at-spi-version;.tar.bz2">
-  <!ENTITY at-spi-md5sum        "2988cd21d9f292fd404a8c532fe2723d">
-  <!ENTITY at-spi-size          "696 KB">
-  <!ENTITY at-spi-buildsize     "19.7 MB">
-  <!ENTITY at-spi-time          "0.6 SBU">
+  <!ENTITY at-spi-md5sum        "46c531204df5d39f7e83822372b0ce69">
+  <!ENTITY at-spi-size          "780 KB">
+  <!ENTITY at-spi-buildsize     "22 MB">
+  <!ENTITY at-spi-time          "0.5 SBU">
 ]>
 
 <sect1 id="at-spi" xreflabel="AT SPI-&at-spi-version;">
@@ -82,9 +82,13 @@
             --variable=prefix ORBit-2.0)/lib/at-spi &&
 make</userinput></screen>
 
-    <para>The test suite cannot be run until after the package is installed.
+    <para>This package does not come with a functional test suite. Review the
+    <filename>README</filename> file for additional information about testing
+    the package.</para>
+
+    <!-- The test suite cannot be run until after the package is installed.
     To run the test suite after installation, issue:
-    <command>make check</command>.</para>
+    <command>make check</command>.</para> -->
 
     <para>Now, as the <systemitem class='username'>root</systemitem> user:</para>
 
@@ -104,6 +108,9 @@
     <filename class="directory">$GNOME_PREFIX/lib/at-spi</filename> instead of
     <filename class="directory">$GNOME_PREFIX/libexec</filename>.</para>
 
+    <xi:include xmlns:xi="http://www.w3.org/2003/XInclude"
+    href="../../xincludes/gtk-doc-rebuild.xml"/>
+
   </sect2>
 
   <sect2 role="content">

Modified: trunk/BOOK/gnome/add/gnome-mag.xml
===================================================================
--- trunk/BOOK/gnome/add/gnome-mag.xml	2007-08-08 16:46:14 UTC (rev 7033)
+++ trunk/BOOK/gnome/add/gnome-mag.xml	2007-08-08 16:49:50 UTC (rev 7034)
@@ -6,10 +6,10 @@
 
   <!ENTITY gnome-mag-download-http "&gnome-download-http;/gnome-mag/0.14/gnome-mag-&gnome-mag-version;.tar.bz2">
   <!ENTITY gnome-mag-download-ftp  "&gnome-download-ftp;/gnome-mag/0.14/gnome-mag-&gnome-mag-version;.tar.bz2">
-  <!ENTITY gnome-mag-md5sum        "c402b06408d3b40843720ae09ad74234">
-  <!ENTITY gnome-mag-size          "608 KB">
-  <!ENTITY gnome-mag-buildsize     "16.7 MB">
-  <!ENTITY gnome-mag-time          "0.2 SBU">
+  <!ENTITY gnome-mag-md5sum        "c5eafb3c492d2b84c37b9a12e3b7a19e">
+  <!ENTITY gnome-mag-size          "468 KB">
+  <!ENTITY gnome-mag-buildsize     "20 MB (includes building reference docs)">
+  <!ENTITY gnome-mag-time          "0.3 SBU">
 ]>
 
 <sect1 id="gnome-mag" xreflabel="GNOME Magnifier-&gnome-mag-version;">
@@ -61,8 +61,16 @@
     <bridgehead renderas="sect4">Required</bridgehead>
     <para role="required"><xref linkend="at-spi"/></para>
 
+    <bridgehead renderas="sect4">Optional (to Build the Colorblind Applet)</bridgehead>
+    <para role="optional"><xref linkend="gnome-desktop"/>,
+    <ulink url="http://people.debian.org/~ruoso/">colorblind</ulink>, and
+    <ulink url="&gnome-download-http;/gnome-python/">GNOME-Python</ulink>
+    (requires <ulink url="http://www.pygtk.org/">PyGTK</ulink>,
+    see the <xref linkend="gnome-python-dependencies"/>)</para>
+
     <bridgehead renderas="sect4">Optional</bridgehead>
-    <para role="optional"><xref linkend="intltool"/></para>
+    <para role="optional"><xref linkend="intltool"/> and
+    <xref linkend="doxygen"/></para>
 
     <bridgehead renderas="sect4">Optional (For
     <application>XFree86</application> Only)</bridgehead>
@@ -88,10 +96,13 @@
   <sect2 role="installation">
     <title>Installation of GNOME Magnifier</title>
 
-    <para>Install <application>GNOME Magnifier</application> by
+    <para>If <xref linkend="doxygen"/> is installed, the reference
+    documentation is automatically generated. Install
+    <application>GNOME Magnifier</application> by
     running the following commands:</para>
 
-<screen><userinput>./configure --prefix=$(pkg-config --variable=prefix ORBit-2.0) &&
+<screen><userinput>./configure --prefix=$(pkg-config --variable=prefix ORBit-2.0) \
+            --sysconfdir=&gnome-etc-dir; &&
 make</userinput></screen>
 
     <para>This package does not come with a test suite.</para>
@@ -100,6 +111,9 @@
 
 <screen role='root'><userinput>make install</userinput></screen>
 
+    <para>For full functionality of this package, you should install the
+    <xref linkend="libgail-gnome"/> package.</para>
+
   </sect2>
 
   <sect2 role="commands">
@@ -108,6 +122,9 @@
     <xi:include xmlns:xi="http://www.w3.org/2003/XInclude"
     href="../../xincludes/gnome-prefix.xml"/>
 
+    <xi:include xmlns:xi="http://www.w3.org/2003/XInclude"
+    href="../../xincludes/gnome-sysconfdir.xml"/>
+
   </sect2>
 
   <sect2 role="content">
@@ -123,8 +140,9 @@
         <seg>libgnome-mag.so</seg>
         <seg>The following subdirectories of <envar>$GNOME_PREFIX</envar>/:
         include/gnome-mag-1.0,
-        share/{doc/gnome-mag-&gnome-mag-version;,gnome-mag,
-        idl/gnome-mag-1.0}</seg>
+        lib/colorblind-applet,
+        lib/python&python-libdir;/site-packages/colorblind,
+        share/{colorblind,doc/gnome-mag-&gnome-mag-version;,gnome-mag,idl/gnome-mag-1.0}</seg>
       </seglistitem>
     </segmentedlist>
 

Modified: trunk/BOOK/gnome/add/gnome-speech.xml
===================================================================
--- trunk/BOOK/gnome/add/gnome-speech.xml	2007-08-08 16:46:14 UTC (rev 7033)
+++ trunk/BOOK/gnome/add/gnome-speech.xml	2007-08-08 16:49:50 UTC (rev 7034)
@@ -6,9 +6,9 @@
 
   <!ENTITY gnome-speech-download-http "&gnome-download-http;/gnome-speech/0.4/gnome-speech-&gnome-speech-version;.tar.bz2">
   <!ENTITY gnome-speech-download-ftp  "&gnome-download-ftp;/gnome-speech/0.4/gnome-speech-&gnome-speech-version;.tar.bz2">
-  <!ENTITY gnome-speech-md5sum        "df06441a5b560830264c0557e3d3c376">
-  <!ENTITY gnome-speech-size          "309 KB">
-  <!ENTITY gnome-speech-buildsize     "5.3 MB">
+  <!ENTITY gnome-speech-md5sum        "381e2e9126e102ace9abb452c9087141">
+  <!ENTITY gnome-speech-size          "308 KB">
+  <!ENTITY gnome-speech-buildsize     "6 MB">
   <!ENTITY gnome-speech-time          "0.2 SBU">
 ]>
 
@@ -73,14 +73,18 @@
     <bridgehead renderas="sect4">Required</bridgehead>
     <para role="required"><xref linkend="libbonobo"/></para>
 
-    <bridgehead renderas="sect4">Optional</bridgehead>
+    <bridgehead renderas="sect4">Optional Backend Drivers</bridgehead>
     <para role="optional"><xref linkend="java-access-bridge"/>,
     <xref linkend="freetts"/>,
+    <ulink url="http://www.fonixspeech.com/pages/index.php">DECtalk</ulink>,
+    <ulink url="http://espeak.sourceforge.net/">eSpeak</ulink>,
     <ulink url="http://www.cstr.ed.ac.uk/projects/festival/">Festival</ulink>,
-    <ulink url="http://www.ibm.com/software/voice/viavoice/">ViaVoice</ulink>,
-    <ulink url="http://www.scansoft.com/">Eloquence</ulink>,
-    <ulink url="http://www.fonix.com/">DECTalk</ulink>, and
-    <ulink url="http://www.cepstral.com/">Theta</ulink></para>
+    <ulink url="http://voice-software.loquendo.com/interactive-tts.htm">Loquendo</ulink>,
+    <ulink url="http://www.freebsoft.org/speechd">Speech Dispatcher</ulink>,
+    <ulink url="http://www.nuance.com/">Speechworks ETI Eloquence</ulink>,
+    <ulink url="http://www.cepstral.com/">Swift</ulink>,
+    <ulink url="http://www.cepstral.com/">Theta</ulink>, and
+    <ulink url="http://www.ibm.com/software/voice/viavoice/">ViaVoice</ulink></para>
 
     <para condition="html" role="usernotes">User Notes:
     <ulink url="&blfs-wiki;/gnome-speech"/></para>

Modified: trunk/BOOK/gnome/add/gok.xml
===================================================================
--- trunk/BOOK/gnome/add/gok.xml	2007-08-08 16:46:14 UTC (rev 7033)
+++ trunk/BOOK/gnome/add/gok.xml	2007-08-08 16:49:50 UTC (rev 7034)
@@ -6,9 +6,9 @@
 
   <!ENTITY gok-download-http "&gnome-download-http;/gok/1.2/gok-&gok-version;.tar.bz2">
   <!ENTITY gok-download-ftp  "&gnome-download-ftp;/gok/1.2/gok-&gok-version;.tar.bz2">
-  <!ENTITY gok-md5sum        "de6cceaca780e7ad0702c4b3c0fd8d1f">
-  <!ENTITY gok-size          "1.1 MB">
-  <!ENTITY gok-buildsize     "45.0 MB">
+  <!ENTITY gok-md5sum        "2ef1f171385a37f93408dbca7ecfdf11">
+  <!ENTITY gok-size          "1.2 MB">
+  <!ENTITY gok-buildsize     "50 MB">
   <!ENTITY gok-time          "0.6 SBU">
 ]>
 
@@ -59,14 +59,15 @@
 
     <bridgehead renderas="sect4">Required</bridgehead>
     <para role="required"><xref linkend="esound"/>,
-    <xref linkend="libgnomeui"/>,
     <xref linkend="scrollkeeper"/>,
+    <xref linkend="at-spi"/>,
     <xref linkend="libwnck"/>,
-    <xref linkend="at-spi"/>, and
+    <xref linkend="libgnomeui"/>, and
     <xref linkend="gnome-speech"/></para>
 
     <bridgehead renderas="sect4">Optional</bridgehead>
-    <para role="optional"><xref linkend="intltool"/> and
+    <para role="optional"><xref linkend="libusb"/>,
+    <xref linkend="intltool"/>, and
     <xref linkend="gtk-doc"/></para>
 
     <para condition="html" role="usernotes">User Notes:
@@ -91,8 +92,11 @@
 
 <screen role='root'><userinput>make install &&
 chmod -v 644 $(pkg-config --variable=prefix
-      ORBit-2.0)/share/gnome/help/gok/C/{gok,legal}.xml</userinput></screen>
+      ORBit-2.0)/share/gnome/help/gok/C/legal.xml</userinput></screen>
 
+    <para>For full functionality of this package, you should install the
+    <xref linkend="libgail-gnome"/> package.</para>
+
   </sect2>
 
   <sect2 role="commands">

Modified: trunk/BOOK/gnome/add/java-access-bridge.xml
===================================================================
--- trunk/BOOK/gnome/add/java-access-bridge.xml	2007-08-08 16:46:14 UTC (rev 7033)
+++ trunk/BOOK/gnome/add/java-access-bridge.xml	2007-08-08 16:49:50 UTC (rev 7034)
@@ -6,10 +6,10 @@
 
   <!ENTITY java-access-bridge-download-http "&gnome-download-http;/java-access-bridge/1.18/java-access-bridge-&java-access-bridge-version;.tar.bz2">
   <!ENTITY java-access-bridge-download-ftp  "&gnome-download-ftp;/java-access-bridge/1.18/java-access-bridge-&java-access-bridge-version;.tar.bz2">
-  <!ENTITY java-access-bridge-md5sum        "5099b2c8634d190df15e32f5fcb2a588">
-  <!ENTITY java-access-bridge-size          "121 KB">
-  <!ENTITY java-access-bridge-buildsize     "6.6 MB">
-  <!ENTITY java-access-bridge-time          "1.1 SBU">
+  <!ENTITY java-access-bridge-md5sum        "9d250af333d03a091be06d2baab8cad4">
+  <!ENTITY java-access-bridge-size          "108 KB">
+  <!ENTITY java-access-bridge-buildsize     "7 MB">
+  <!ENTITY java-access-bridge-time          "1.2 SBU">
 ]>
 
 <sect1 id="java-access-bridge"
@@ -106,8 +106,8 @@
     file required for <application>Java Access Bridge</application>.</para>
 
     <para><command>ln -v -sf $(pkg-config ...</command>: This command creates
-    a link from the Access Bridge <filename>jar</filename> file to the Java
-    runtime library extensions directory.</para>
+    a link from the Access Bridge <filename class='extension'>jar</filename>
+    file to the Java runtime library extensions directory.</para>
 
   </sect2>
 

Modified: trunk/BOOK/gnome/add/libgail-gnome.xml
===================================================================
--- trunk/BOOK/gnome/add/libgail-gnome.xml	2007-08-08 16:46:14 UTC (rev 7033)
+++ trunk/BOOK/gnome/add/libgail-gnome.xml	2007-08-08 16:49:50 UTC (rev 7034)
@@ -6,9 +6,9 @@
 
   <!ENTITY libgail-gnome-download-http "&gnome-download-http;/libgail-gnome/1.18/libgail-gnome-&libgail-gnome-version;.tar.bz2">
   <!ENTITY libgail-gnome-download-ftp  "&gnome-download-ftp;/libgail-gnome/1.18/libgail-gnome-&libgail-gnome-version;.tar.bz2">
-  <!ENTITY libgail-gnome-md5sum        "1d12c5375b3404f4f20b214b763e5225">
-  <!ENTITY libgail-gnome-size          "215 KB">
-  <!ENTITY libgail-gnome-buildsize     "2.6 MB">
+  <!ENTITY libgail-gnome-md5sum        "2dd239118bf252c7b1e3d1701cd8a954">
+  <!ENTITY libgail-gnome-size          "223 KB">
+  <!ENTITY libgail-gnome-buildsize     "3 MB">
   <!ENTITY libgail-gnome-time          "0.1 SBU">
 ]>
 

Modified: trunk/BOOK/introduction/welcome/changelog.xml
===================================================================
--- trunk/BOOK/introduction/welcome/changelog.xml	2007-08-08 16:46:14 UTC (rev 7033)
+++ trunk/BOOK/introduction/welcome/changelog.xml	2007-08-08 16:49:50 UTC (rev 7034)
@@ -45,6 +45,10 @@
       <para>August 8th, 2007</para>
       <itemizedlist>
         <listitem>
+          <para>[randy] - Updated all the GNOME Assistive Technology
+          (Accessibility) packages to GNOME-2.18 versions.</para>
+        </listitem>
+        <listitem>
           <para>[randy] - Added new package Orca-2.18.1 as a replacement for
           the obsolete Gnopernicus package.</para>
         </listitem>




More information about the blfs-book mailing list