r7014 - in trunk/BOOK: . general/genlib general/prog introduction/welcome xsoft/office

randy at linuxfromscratch.org randy at linuxfromscratch.org
Sun Aug 5 11:42:43 PDT 2007


Author: randy
Date: 2007-08-05 12:42:42 -0600 (Sun, 05 Aug 2007)
New Revision: 7014

Modified:
   trunk/BOOK/general.ent
   trunk/BOOK/general/genlib/libgsf.xml
   trunk/BOOK/general/prog/perl-modules.xml
   trunk/BOOK/introduction/welcome/changelog.xml
   trunk/BOOK/introduction/welcome/credits.xml
   trunk/BOOK/xsoft/office/gnucash.xml
Log:
Updated to GnuCash-2.2.0

Modified: trunk/BOOK/general/genlib/libgsf.xml
===================================================================
--- trunk/BOOK/general/genlib/libgsf.xml	2007-08-04 10:08:46 UTC (rev 7013)
+++ trunk/BOOK/general/genlib/libgsf.xml	2007-08-05 18:42:42 UTC (rev 7014)
@@ -73,9 +73,10 @@
     library which provides GNOME-2 support), and
     <xref linkend="gtk-doc"/></para>
 
-    <para>Note: you need to build the
+    <para>Note: you should build the
     <filename class='libraryfile'>libgsf-gnome-1.so</filename> library if you
-    plan on building <xref linkend="gnumeric"/> with GNOME support.</para>
+    plan on building <xref linkend="gnucash"/> or
+    <xref linkend="gnumeric"/> with GNOME support.</para>
 
     <para condition="html" role="usernotes">User Notes:
     <ulink url="&blfs-wiki;/libgsf"/></para>

Modified: trunk/BOOK/general/prog/perl-modules.xml
===================================================================
--- trunk/BOOK/general/prog/perl-modules.xml	2007-08-04 10:08:46 UTC (rev 7013)
+++ trunk/BOOK/general/prog/perl-modules.xml	2007-08-05 18:42:42 UTC (rev 7014)
@@ -556,7 +556,8 @@
             <para><xref linkend="perl-compress-zlib"/></para>
           </listitem>
           <listitem>
-            <para id="perl-crypt-ssleay"><ulink
+            <para id="perl-crypt-ssleay"
+            xreflabel="Crypt::SSLeay-&Crypt-SSLeay-version;"><ulink
             url="http://cpan.org/authors/id/D/DL/DLAND/Crypt-SSLeay-&Crypt-SSLeay-version;.tar.gz">
             Crypt-SSLeay-&Crypt-SSLeay-version;</ulink> (optional, for HTTPS
             support)</para>

Modified: trunk/BOOK/general.ent
===================================================================
--- trunk/BOOK/general.ent	2007-08-04 10:08:46 UTC (rev 7013)
+++ trunk/BOOK/general.ent	2007-08-05 18:42:42 UTC (rev 7014)
@@ -3,7 +3,7 @@
 $Date$
 -->
 
-<!ENTITY day          "04">                   <!-- Always 2 digits -->
+<!ENTITY day          "05">                   <!-- Always 2 digits -->
 <!ENTITY month        "08">                   <!-- Always 2 digits -->
 <!ENTITY year         "2007">
 <!ENTITY version      "svn-&year;&month;&day;">
@@ -566,7 +566,7 @@
 <!-- Chapter 34 -->
 <!ENTITY AbiWord-version              "2.4.4">
 <!ENTITY gnumeric-version             "1.6.3">
-<!ENTITY gnucash-version              "1.8.12">
+<!ENTITY gnucash-version              "2.2.0">
 <!ENTITY gimp-version                 "2.2.17">
 <!ENTITY evolution-version            "2.10.3">
 

Modified: trunk/BOOK/introduction/welcome/changelog.xml
===================================================================
--- trunk/BOOK/introduction/welcome/changelog.xml	2007-08-04 10:08:46 UTC (rev 7013)
+++ trunk/BOOK/introduction/welcome/changelog.xml	2007-08-05 18:42:42 UTC (rev 7014)
@@ -42,6 +42,15 @@
 -->
 
     <listitem>
+      <para>August 5th, 2007</para>
+      <itemizedlist>
+        <listitem>
+          <para>[randy] - Updated to GnuCash-2.2.0.</para>
+        </listitem>
+      </itemizedlist>
+    </listitem>
+
+    <listitem>
       <para>August 3rd, 2007</para>
       <itemizedlist>
         <listitem>
@@ -54,11 +63,8 @@
           <para>[randy] - Updated to SLIB-3a4.</para>
         </listitem>
         <listitem>
-          <para>[randy] - Updated to Guile-1.8.2. This update effectively
-          breaks the current GnuCash instructions, so a note has been placed
-          on the GnuCash page to use the stable BLFS book to install the
-          package. This note is temporary and will be removed when GnuCash
-          is updated to version 2.x. Since no other BLFS packages depend on the
+          <para>[randy] - Updated to Guile-1.8.2. This breaks the GnuCash
+          package instructions and since no other BLFS packages depend on the
           GNOME-1.4 libraries, the entire GNOME-1.4 section of the book has
           been commented out.</para>
         </listitem>

Modified: trunk/BOOK/introduction/welcome/credits.xml
===================================================================
--- trunk/BOOK/introduction/welcome/credits.xml	2007-08-04 10:08:46 UTC (rev 7013)
+++ trunk/BOOK/introduction/welcome/credits.xml	2007-08-05 18:42:42 UTC (rev 7014)
@@ -204,8 +204,8 @@
       </listitem>
 
       <listitem>
-        <para>Dash:
-        <emphasis>Agathoklis Hatzimanikas</emphasis></para>
+        <para>Dash and rxvt-unicode:
+        <emphasis>Ag Hatzimanikas</emphasis></para>
       </listitem>
 
       <listitem>
@@ -273,7 +273,7 @@
         additions), Expect, FOP, FreeTTS, FriBidi, GC, GCC (rewrite), GMime,
         gnome-audio, gnome-backgrounds, gnome-menus, gnome-mount,
         gnome-screensaver, gnome-volume-manager, GNOME Doc Utils,
-        GNOME Keyring Manager, GnuCash (many additions), GOffice, Graphviz,
+        GNOME Keyring Manager, GnuCash (version 2), GOffice, Graphviz,
         GStreamer Base Plug-ins, GStreamer Good Plug-ins, GStreamer Ugly
         Plug-ins, HAL, Heimdal, HTML Tidy, icon-naming-utils, ISO Codes,
         JadeTeX, Java Access Bridge, JUnit, K3b, LessTif (rewrite), libexif,

Modified: trunk/BOOK/xsoft/office/gnucash.xml
===================================================================
--- trunk/BOOK/xsoft/office/gnucash.xml	2007-08-04 10:08:46 UTC (rev 7013)
+++ trunk/BOOK/xsoft/office/gnucash.xml	2007-08-05 18:42:42 UTC (rev 7014)
@@ -6,13 +6,14 @@
 
   <!ENTITY gnucash-download-http "http://www.gnucash.org/pub/gnucash/sources/stable/gnucash-&gnucash-version;.tar.gz">
   <!ENTITY gnucash-download-ftp  "ftp://ftp.at.gnucash.org/pub/gnucash/gnucash/sources/stable/gnucash-&gnucash-version;.tar.gz">
-  <!ENTITY gnucash-src-md5sum    "81e7c703db56bb203e106664157779cc">
-  <!ENTITY gnucash-size          "8.2 MB">
-  <!ENTITY gnucash-buildsize     "123 MB (additional 22 MB for Help documentation)">
-  <!ENTITY gnucash-time          "3.2 SBU (additional 0.3 SBU to run the test suite)">
-  <!ENTITY gnucash-docs-version  "1.8.5">
+  <!ENTITY gnucash-src-md5sum    "6e8c1602b365d76ec19ef211857d3ece">
+  <!ENTITY gnucash-size          "7.0 MB">
+  <!ENTITY gnucash-buildsize     "300 MB (includes running test suite; additional 120 MB for API docs)">
+  <!ENTITY gnucash-time          "4.1 SBU (additional 1.8 SBU to run the test suite)">
+  <!ENTITY gnucash-docs-version  "2.2.0">
   <!ENTITY gnucash-docs-download "http://www.gnucash.org/pub/gnucash/sources/stable/gnucash-docs-&gnucash-docs-version;.tar.gz">
-  <!ENTITY gnucash-docs-md5sum   "9758d8e523530c2509912761e327a9d5">
+  <!ENTITY gnucash-docs-md5sum   "97a29e499baca1807a3944ae3c0ad61e">
+  <!ENTITY gnucash-docs-size     "10.0 MB">
 ]>
 
 <sect1 id="gnucash" xreflabel="GnuCash-&gnucash-version;">
@@ -33,12 +34,7 @@
     <title>Introduction to GnuCash</title>
 
     <para><application>GnuCash</application> is a personal finance
-    manager. The BLFS team is in the process of updating GnuCash
-    to version 2.x. This is a major change. Many of the dependency
-    packages for version 2.x are not compatible with the current
-    version. Some of these dependency packages have already been updated
-    which means these instructions are obsolete. Please see the stable
-    BLFS book for instructions to build GnuCash version 1.8.x.</para>
+    manager.</para>
 
     <bridgehead renderas="sect3">Package Information</bridgehead>
     <itemizedlist spacing="compact">
@@ -70,27 +66,28 @@
       <listitem>
         <para>Download MD5 sum: &gnucash-docs-md5sum;</para>
       </listitem>
+      <listitem>
+        <para>Download size: &gnucash-docs-size;</para>
+      </listitem>
     </itemizedlist>
 
     <bridgehead renderas="sect3">GnuCash Dependencies</bridgehead>
 
     <bridgehead renderas="sect4">Required</bridgehead>
     <para role="required"><xref linkend="guile"/>,
-    <xref linkend="slib"/>, and
-    <!-- <xref linkend="gtkhtml1"/>,
-    <xref linkend="libghttp"/>,
-    <xref linkend="gwrap"/>, and -->
-    <xref linkend="perl-xml-parser"/></para>
+    <xref linkend="slib"/>,
+    <xref linkend="libgnomeui"/>,
+    <xref linkend="goffice"/>, and
+    <xref linkend="gtkhtml"/></para>
 
     <bridgehead renderas="sect4">Optional</bridgehead>
     <para role="optional"><xref linkend="postgresql"/>,
-    <!-- <xref linkend="guppi"/>, -->
-    <xref linkend="scrollkeeper"/>,
-    <xref linkend="doxygen"/>,
-    <xref linkend="graphviz"/>,
     <ulink url="ftp://ftp.gnu.org/pub/gnu/guile/">Guile-www</ulink>, and
     <ulink url="http://perens.com/FreeSoftware/">Electric Fence</ulink></para>
 
+    <bridgehead renderas="sect4">Optional (Required for the Help System)</bridgehead>
+    <para role="optional"><xref linkend="scrollkeeper"/></para>
+
     <bridgehead renderas="sect4">Optional (for On-Line Banking)</bridgehead>
     <para role="optional"><ulink
     url="http://libofx.sourceforge.net/">LibOFX</ulink>
@@ -99,8 +96,7 @@
     and <ulink url="http://www.aquamaniac.de/aqbanking/">AqBanking</ulink>
     (requires <ulink
     url="http://gwenhywfar.sourceforge.net/">Gwenhywfar</ulink>
-    and also see <ulink
-    url="http://www.libchipcard.de/">libchipcard2</ulink>)</para>
+    and <ulink url="http://www.libchipcard.de/">libchipcard3</ulink>)</para>
 
     <para condition="html" role="usernotes">User Notes:
     <ulink url="&blfs-wiki;/gnucash"/></para>
@@ -113,93 +109,136 @@
     <para>Install <application>GnuCash</application> by running the following
     commands:</para>
 
-<screen><userinput>sed -i 's/^host_os=.*$/&-gnu/' configure &&
-./configure --prefix=/opt/gnome-1.4 \
-            --sysconfdir=/etc \
-            --disable-guppi \
-            --disable-error-on-warning &&
+<screen><userinput>sed -i 's|xml::${sysconfdir}|xml::&gnome-etc-dir;|' configure &&
+
+./configure \
+    --prefix=/usr \
+    --sysconfdir=/etc \
+    --libexecdir=/usr/lib \
+    --with-gconf-schema-file-dir=&gnome-etc-dir;/gconf/schemas &&
 make</userinput></screen>
 
+    <para>If you wish to create the API documentation in HTML format, you must
+    have <xref linkend="doxygen"/> and <xref linkend="graphviz"/> installed,
+    then issue: <command>make doc</command>. If you wish to create the API
+    Design Guide in several formats, you must have <xref linkend="tetex"/>
+    installed and issue:
+    <command>make -C src/doc/design html pdf ps</command>.</para>
+
     <para>To test the results, issue <command>make check</command>. All tests
     should pass. An easy way to look at the results of the tests is to issue
     <command>grep -A1 ============== check.log</command> (this is assuming you
-    redirected the output from the tests to the aforementioned filename).</para>
+    redirected the output from the tests to the indicated filename).</para>
 
     <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
 
-<screen role='root'><userinput>make install</userinput></screen>
+<screen role='root'><userinput>make install &&
 
-    <para>If desired, create a symbolic link from the
-    <application>GnuCash</application> documentation directory to the
-    system-wide documentation directory using the following command as the
-    <systemitem class="username">root</systemitem> user:</para>
+mv -v /usr/share/gnucash/doc /usr/share/doc/gnucash-&gnucash-version; &&
+ln -v -s ../doc/gnucash-&gnucash-version; /usr/share/gnucash/doc &&
 
-<screen role='root'><userinput>ln -v -s /opt/gnome-1.4/share/gnucash/doc \
-         /usr/share/doc/gnucash-&gnucash-version;</userinput></screen>
+for FILENAME in doc/{misc*,gnome*,generic*,build*}.txt \
+                doc/{gtkrc*,TRANSLATION_HOWTO,README.translator.txt} \
+                doc/README.{build-system,OFX,HBCI}
+do
+    install -v -m644 ${FILENAME} /usr/share/doc/gnucash-&gnucash-version;
+done &&
 
-    <para>If desired, create symbolic links to the
-    <application>GnuCash</application> <filename>.desktop</filename> and icon
-    files in the system-wide directories using the following commands as the
-    <systemitem class="username">root</systemitem> user:</para>
+install -v -m755 -d /usr/share/doc/gnucash-&gnucash-version;/api/engine &&
+install -v -m644    src/doc/{TODO*,*.txt,*.html} \
+                    /usr/share/doc/gnucash-&gnucash-version;/api &&
+install -v -m644    src/engine/*.txt \
+                    /usr/share/doc/gnucash-&gnucash-version;/api/engine</userinput></screen>
 
-<screen role='root'><userinput>install -v -m755 -d /usr/share/pixmaps/gnucash &&
-ln -v -s /opt/gnome-1.4/share/pixmaps/gnucash/gnucash-icon.png \
-         /usr/share/pixmaps/gnucash &&
-ln -v -s /opt/gnome-1.4/share/gnome/apps/Applications/gnucash.desktop \
-         /usr/share/applications</userinput></screen>
+    <para>If you built the API HTML or Design Guide documentation, issue the
+    following commands (modified as necessary, depending on what docs are
+    being installed) as the <systemitem class="username">root</systemitem>
+    user:</para>
 
-    <para>If you want to install the Help documentation (requires
-    <xref linkend="scrollkeeper"/> to be installed), unpack the additional
+<screen role='root'><userinput>install -v -m755 -d /usr/share/doc/gnucash-&gnucash-version;/{design,api}/html &&
+install -v -m644    src/doc/design/gnucash-design.html/* \
+                    /usr/share/doc/gnucash-&gnucash-version;/design/html &&
+install -v -m644    src/doc/design/gnucash-design.{pdf,ps,dvi} \
+                    /usr/share/doc/gnucash-&gnucash-version;/design &&
+install -v -m644    src/doc/html/* \
+                    /usr/share/doc/gnucash-&gnucash-version;/api/html</userinput></screen>
+
+    <para>If you want to install the Help documentation system, you must have
+    <xref linkend="scrollkeeper"/> installed. Then unpack the additional
     tarball, change into the
     <filename class='directory'>gnucash-docs-&gnucash-docs-version;</filename>
     source directory and issue the following commands as an unprivileged
     user:</para>
 
-<screen><userinput>./configure --prefix=/opt/gnome-1.4 \
+<screen><userinput>./configure --prefix=/usr \
             --localstatedir=/var/lib &&
 make</userinput></screen>
 
+    <para>HTML versions of the Help Manual and Users Guide can be created if
+    the DocBook XML tools are installed (<xref linkend="libxslt"/>,
+    <xref linkend="DocBook"/> and <xref linkend="docbook-xsl"/>). A PDF version
+    of the Users Guide can be created if you have <xref linkend="docbook-utils"/>
+    and <xref linkend="jadetex"/> installed. Issue the following commands to
+    create the documentation (modify as appropriate for your desires):</para>
+
+<screen><userinput>make -C help  html &&
+make -C guide html &&
+make -C guide pdf</userinput></screen>
+
     <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
 
 <screen role='root'><userinput>make install</userinput></screen>
 
+    <para>If you built the Help Manual or Users Guide, install them using the
+    following commands as the <systemitem class="username">root</systemitem>
+    user (modify as necessary):</para>
+
+<screen role='root'><userinput>install -v -m755 -d /usr/share/doc/gnucash-&gnucash-version;/{users_guide,help} &&
+cp -v -R            help/C/gnucash-help/* \
+                    /usr/share/doc/gnucash-&gnucash-version;/help &&
+cp -v -R            guide/C/gnucash-guide/* \
+                    /usr/share/doc/gnucash-&gnucash-version;/users_guide &&
+install -v -m644    guide/C/gnucash-guide.pdf \
+                    /usr/share/doc/gnucash-&gnucash-version;</userinput></screen>
+
   </sect2>
 
   <sect2 role="commands">
     <title>Command Explanations</title>
 
-    <para><command>sed -i 's/^\(host_os=.*\)$/\1-gnu/' configure</command>:
-    This command is used to fix a broken <command>configure</command> script.
-    Without it, no shared libraries are built, and the program will not
-    function properly.</para>
+    <para><command>sed -i 's|xml::${sysconfdir}|xml::&gnome-etc-dir;|'
+    configure</command>: This command is used because the location of the
+    <application>GConf</application> source database is hard-coded into
+    the <command>configure</command> script as
+    <filename class='directory'><envar>$sysconfdir</envar>/gconf</filename>
+    (rendering the <option>--with-gconf-source</option> parameter useless).
+    The modification ensures that the <application>GConf</application> database
+    is properly updated while still allowing the package configuration files
+    to be installed in
+    <filename class='directory'>/etc/gnucash</filename>.</para>
 
-    <para><parameter>--prefix=/opt/gnome-1.4</parameter>:
-    <application>GnuCash</application>-&gnucash-version; is a
-    <application>GNOME</application>-1.4 application.</para>
-
     <para><parameter>--sysconfdir=/etc</parameter>: This installs configuration
     files in <filename class='directory'>/etc/gnucash</filename> instead of
-    <filename class='directory'>/opt/gnome-1.4/etc/gnucash</filename>.</para>
+    <filename class='directory'>/usr/etc/gnucash</filename>.</para>
 
+    <para><parameter>--with-gconf-schema-file-dir=&gnome-etc-dir;/gconf/schemas</parameter>:
+    This parameter ensures that the <application>GConf</application> schema
+    files are installed in the proper location instead of
+    <filename class='directory'>/etc/gconf</filename>.</para>
+
+    <para><command>mv -v /usr/share/gnucash/doc
+    /usr/share/doc/gnucash-&gnucash-version;</command> and
+    <command>ln -v -s ../doc/gnucash-&gnucash-version;
+    /usr/share/gnucash/doc</command>: These commands are used to relocate the
+    documentation files to the customary location and create a symbolic link
+    to the original location.</para>
+
     <xi:include xmlns:xi="http://www.w3.org/2003/XInclude"
     href="../../xincludes/scrollkeeper-dir.xml"/>
 
-    <para><parameter>--disable-guppi</parameter>: This compiles
-    <application>GnuCash</application> without support for creating
-    GUI graphs and plots. Remove this option if you have
-    <application>Guppi</application> installed.</para>
-
-    <para><parameter>-disable-error-on-warning</parameter>: Without this
-    parameter the build will fail because a warning is generated. This option
-    forces the build to ignore the warning.</para>
-
     <para><option>--enable-sql</option>: This parameter is required if you want
     to build in SQL support using <application>PostgreSQL</application>.</para>
 
-    <para><option>--enable-ofx</option>: This parameter is required if you want
-    to build in on-line banking support using
-    <application>LibOFX</application>.</para>
-
     <para><option>--enable-hbci</option>: This parameter is required if you
     want to build in on-line banking support using
     <application>AqBanking</application>. See
@@ -216,24 +255,17 @@
       <title>Configuration Information</title>
 
       <para>If you wish to use <application>GnuCash</application> to retrieve
-      stock price quotes and stock historical information, you'll need to
+      stock price quotes, you'll need to
       install the following <application>Perl</application> modules:
-      <xref linkend="perl-lwp"/>, <xref linkend="perl-date-manip"/>,
-      <xref linkend="perl-html-parser"/>, <xref linkend="perl-finance-quote"/>
-      and <xref linkend="perl-finance-quotehist"/>.</para>
+      <xref linkend="perl-lwp"/>,
+      <xref linkend="perl-date-manip"/>,
+      <xref linkend="perl-html-parser"/>,
+      <xref linkend="perl-html-tableextract"/>,
+      <xref linkend="perl-crypt-ssleay"/>, and
+      <xref linkend="perl-finance-quote"/>. Alternatively, you can run the
+      <command>/usr/bin/gnc-fq-update</command> script as the
+      <systemitem class="username">root</systemitem> user.</para>
 
-      <!--
-      <note>
-        <para><application>GnuCash</application> must be run as
-        <systemitem class="username">root</systemitem> once before use. Simply
-        executing <command>gnucash</command> from an <application>X</application>
-        terminal and clicking on the cancel button is sufficient. This must be
-        done prior to setting up accounts as an unprivileged user, due to the
-        fact that <application>GnuCash</application> must update scheme catalogs
-        before it is used.</para>
-      </note>
-      -->
-
     </sect3>
 
   </sect2>
@@ -247,22 +279,23 @@
       <segtitle>Installed Directories</segtitle>
 
       <seglistitem>
-        <seg>dump-finance-quote, gnc-prices, gnc-test-env, gnucash,
-        gnucash-config, gnucash-env, gnucash-make-guids, gnucash-run-script
-        and update-finance-quote</seg>
-        <seg>libcore-utils.so, libgnc-app-file-gnome.so, libgncgnome.so,
-        libgncmodule.so, libgw-core-utils.so, libgw-gnc.so and numerous
-        support libraries installed in
-        <filename class='directory'>/opt/gnome-1.4/lib/gnucash</filename></seg>
+        <seg>gnc-fq-check, gnc-fq-dump, gnc-fq-helper, gnc-fq-update,
+        gnc-test-env, gnucash, gnucash-bin, gnucash-env, gnucash-make-guids,
+        gnucash-valgrind, and update-gnucash-gconf</seg>
+        <seg>libgnc-backend-file-utils.so, libgnc-backend-postgres.so,
+        libgnc-business-ledger.so,libgnc-core-utils.so, libgnc-gnome.so,
+        libgnc-module.so, libgnc-qof.so and numerous support libraries
+        installed in
+        <filename class='directory'>/usr/lib/gnucash</filename></seg>
         <seg>/etc/gnucash,
-        /opt/gnome-1.4/include/gnucash,
-        /opt/gnome-1.4/lib/gnucash,
-        /opt/gnome-1.4/libexec/gnucash,
-        /opt/gnome-1.4/share/gnome/apps/Applications,
-        /opt/gnome-1.4/share/gnome/help/gnucash,
-        /opt/gnome-1.4/share/gnucash,
-        /opt/gnome-1.4/share/omf/gnucash-docs and
-        /opt/gnome-1.4/share/pixmaps/gnucash</seg>
+        /usr/include/gnucash,
+        /usr/lib/gnucash,
+        and the following subdirectories of /usr/share/:
+        doc/gnucash-&gnucash-version;,
+        gnome/help/gnucash,
+        gnucash,
+        omf/gnucash-docs, and
+        /xml/gnucash</seg>
       </seglistitem>
     </segmentedlist>
 




More information about the blfs-book mailing list