[BLFS Trac] #2175: gsview-4.7 cannot open .ps files with ESP Ghostscript-8.15.2

BLFS Trac trac at linuxfromscratch.org
Sun Oct 8 10:25:16 PDT 2006

#2175: gsview-4.7 cannot open .ps files with ESP Ghostscript-8.15.2
 Reporter:  rkm     |       Owner:  blfs-book at linuxfromscratch.org
     Type:  defect  |      Status:  new                           
 Priority:  normal  |   Milestone:  6.2                           
Component:  BOOK    |     Version:  SVN                           
 Severity:  normal  |    Keywords:  gsview ghostscript            
 I have a lfs 6.2 system that I built on my computer according to the lfs
 6.2 book. The blfs development book says that either AFPL Ghostscript-8.53
 or ESP Ghostscript-8.15.2 are required for Gsview-4.7. I originally
 installed ESP Ghostscript-8.15.2 because I understood from the book that
 it has support for CUPS, whereas AFPL Ghostscript-8.53 does not. However
 after installing gsview-4.7 I got the following error when trying to open
 a postscript file:
 GSview 4.7 2005-03-25
 play_sound: not implemented

 DSC Information
 At line 1527:

 Lines in DSC documents must be shorter than 255 characters.

 Wrong version of DLL found.
   Found version 81502
   Need version  704 - 919
 I also noticed in the Gsview readme file that AFPL Ghostscript was
 specifically mentioned as a requirement. So I uninstalled ESP Ghostscript
 and installed AFPL Ghostscript instead, and I was able to open the same
 postscript file
 without any problems. I'm wondering if ESP Ghostscript should be removed
 from the list of prerequisites for gsview-4.7 in the book.

Ticket URL: <http://wiki.linuxfromscratch.org/blfs/ticket/2175>
BLFS Trac <http://wiki.linuxfromscratch.org/blfs>
Beyond Linux From Scratch

More information about the blfs-book mailing list