r5761 - in trunk/BOOK: . basicnet/netprogs general/genutils general/prog postlfs/shells server/databases

randy at linuxfromscratch.org randy at linuxfromscratch.org
Mon Mar 27 15:17:02 PST 2006


Author: randy
Date: 2006-03-27 16:17:00 -0700 (Mon, 27 Mar 2006)
New Revision: 5761

Modified:
   trunk/BOOK/basicnet/netprogs/net-tools.xml
   trunk/BOOK/general.ent
   trunk/BOOK/general/genutils/imagemagick.xml
   trunk/BOOK/general/prog/pdl.xml
   trunk/BOOK/general/prog/perl-modules.xml
   trunk/BOOK/postlfs/shells/tcsh.xml
   trunk/BOOK/server/databases/db.xml
Log:
Added a section in the general entities for LFS package versions so that it is easier to locate them

Modified: trunk/BOOK/basicnet/netprogs/net-tools.xml
===================================================================
--- trunk/BOOK/basicnet/netprogs/net-tools.xml	2006-03-27 20:49:20 UTC (rev 5760)
+++ trunk/BOOK/basicnet/netprogs/net-tools.xml	2006-03-27 23:17:00 UTC (rev 5761)
@@ -11,7 +11,6 @@
   <!ENTITY net-tools-size          "194 KB">
   <!ENTITY net-tools-buildsize     "4.3 MB">
   <!ENTITY net-tools-time          "0.1 SBU">
-  <!ENTITY lfs-coreutils-version   "5.94">
 ]>
 
 <sect1 id="net-tools" xreflabel="Net-tools-&net-tools-version;">

Modified: trunk/BOOK/general/genutils/imagemagick.xml
===================================================================
--- trunk/BOOK/general/genutils/imagemagick.xml	2006-03-27 20:49:20 UTC (rev 5760)
+++ trunk/BOOK/general/genutils/imagemagick.xml	2006-03-27 23:17:00 UTC (rev 5761)
@@ -229,7 +229,7 @@
         the Magick.so Perl module, and numerous plugin modules</seg>
         <seg>/usr/include/Magick++, /usr/include/magick, /usr/include/wand,
         /usr/lib/ImageMagick-&imagemagick-version;,
-        /usr/lib/perl5/site_perl/&LFS-Perl-version;/i686-linux/auto/Image/Magick,
+        /usr/lib/perl5/site_perl/&lfs-perl-version;/i686-linux/auto/Image/Magick,
         /usr/share/ImageMagick-&imagemagick-version; and
         /usr/share/doc/ImageMagick-&imagemagick-version;</seg>
       </seglistitem>

Modified: trunk/BOOK/general/prog/pdl.xml
===================================================================
--- trunk/BOOK/general/prog/pdl.xml	2006-03-27 20:49:20 UTC (rev 5760)
+++ trunk/BOOK/general/prog/pdl.xml	2006-03-27 23:17:00 UTC (rev 5761)
@@ -483,7 +483,7 @@
       <seglistitem>
         <seg>pdl, pdldoc, perldl, and pptemplate</seg>
         <seg>90+ individual <application>Perl</application> modules</seg>
-        <seg>/usr/lib/perl5/site_perl/&LFS-Perl-version;/i686-linux/{,auto/}PDL</seg>
+        <seg>/usr/lib/perl5/site_perl/&lfs-perl-version;/i686-linux/{,auto/}PDL</seg>
       </seglistitem>
     </segmentedlist>
 

Modified: trunk/BOOK/general/prog/perl-modules.xml
===================================================================
--- trunk/BOOK/general/prog/perl-modules.xml	2006-03-27 20:49:20 UTC (rev 5760)
+++ trunk/BOOK/general/prog/perl-modules.xml	2006-03-27 23:17:00 UTC (rev 5761)
@@ -860,11 +860,11 @@
     </itemizedlist>
 
     <para>If your system's <application>Perl</application> version is different
-    than &LFS-Perl-version;, you'll need to modify the <command>sed</command>
+    than &lfs-perl-version;, you'll need to modify the <command>sed</command>
     command below to reflect the version you have installed.</para>
 
 <screen><userinput>sed -i -e "s@/usr/local/bin@/usr/bin@" \
-       -e "s@/usr/local/lib/perl5@/usr/lib/perl5/site_perl/&LFS-Perl-version;@" \
+       -e "s@/usr/local/lib/perl5@/usr/lib/perl5/site_perl/&lfs-perl-version;@" \
        -e "s@/usr/local/lib/www/docs@/usr/share/doc/perl5@" \
     Makefile</userinput></screen>
 
@@ -1010,7 +1010,7 @@
 
     <para>The Test::Simple module contains utilities designed to assist
     developers in creating tests. A version of Test::Simple was installed
-    during LFS with the <application>Perl</application>-&LFS-Perl-version;
+    during LFS with the <application>Perl</application>-&lfs-perl-version;
     installation, however, some of the sub-modules contained in Test::Simple
     have been updated (notably, the Test::More module) and these updated
     modules are now required by other modules. This updated version of

Modified: trunk/BOOK/general.ent
===================================================================
--- trunk/BOOK/general.ent	2006-03-27 20:49:20 UTC (rev 5760)
+++ trunk/BOOK/general.ent	2006-03-27 23:17:00 UTC (rev 5761)
@@ -23,6 +23,12 @@
 <!ENTITY lfs-root       "../../../../lfs/view/&lfs-version;">
 <!ENTITY publisher      "Unknown">
 
+<!-- These entities are used to identify versions of LFS
+     packages referenced throughout the BLFS book -->
+<!ENTITY lfs-bdb-version              "4.4.20">
+<!ENTITY lfs-coreutils-version        "5.94">
+<!ENTITY lfs-perl-version             "5.8.8">
+<!-- End LFS versions -->
 
 <!ENTITY blfs-bootscripts-version     "20060205">
 <!ENTITY blfs-bootscripts-download    "&downloads-root;/blfs-bootscripts-&blfs-bootscripts-version;.tar.bz2">
@@ -174,10 +180,6 @@
 <!ENTITY tcl-version                  "8.4.12">
 <!ENTITY tk-version                   "8.4.12">
 
-<!-- Used to identify the target LFS version in the
-     PDL and Perl Modules instructions -->
-<!ENTITY LFS-Perl-version             "5.8.8">
-
 <!-- Perl module versions used in the Perl Modules instructions -->
 <!ENTITY Algorithm-Diff-version       "1.1901">
 <!ENTITY Archive-Tar-version          "1.26">

Modified: trunk/BOOK/postlfs/shells/tcsh.xml
===================================================================
--- trunk/BOOK/postlfs/shells/tcsh.xml	2006-03-27 20:49:20 UTC (rev 5760)
+++ trunk/BOOK/postlfs/shells/tcsh.xml	2006-03-27 23:17:00 UTC (rev 5761)
@@ -65,7 +65,7 @@
     <bridgehead renderas="sect3">Additional Downloads</bridgehead>
     <itemizedlist spacing='compact'>
       <listitem>
-        <para>Required patch for use with Coreutils-5.93:
+        <para>Required patch for use with Coreutils-&lfs-coreutils-version;:
         <ulink url="&patch-root;/tcsh-&tcsh-version;-colorls_compat-1.patch"/>
         </para>
       </listitem>

Modified: trunk/BOOK/server/databases/db.xml
===================================================================
--- trunk/BOOK/server/databases/db.xml	2006-03-27 20:49:20 UTC (rev 5760)
+++ trunk/BOOK/server/databases/db.xml	2006-03-27 23:17:00 UTC (rev 5761)
@@ -38,7 +38,8 @@
     functions. This package is also installed during LFS and may already exist
     on your system. It is listed here in BLFS as well because you may need to
     reinstall it if you need the additional language bindings or the RPC
-    server.</para>
+    server. If you do reinstall <application>Berkeley DB</application>, ensure
+    you use the &lfs-bdb-version; version used in the LFS book.</para>
 
     <bridgehead renderas="sect3">Package Information</bridgehead>
     <itemizedlist spacing="compact">




More information about the blfs-book mailing list