[BLFS Trac] #1648: Mutt gcc4 issues

Bruce Dubbs bdubbs at swbell.net
Thu Mar 2 12:31:05 PST 2006


Dan Nicholson wrote:
> On 3/2/06, Bruce Dubbs <bdubbs at swbell.net> wrote:
>>>  This is simply my opinion though. YMMV. Don't do anything just because
>>>  of my opinion, please. Just consider it and do whatever you think is
>>>  best.
>> I agree.  I would prefer to use "stable" packages and backport patches
>> when necessary.
> 
> Then, should I not update to 1.5.11 and instead figure out a patch
> that addresses the gcc4 issues with info in Locale Issues about 1.5.11
> for UTF-8?

Well in this case, no.  I downloaded both and did a diff:

drwxrwxr-x 8 bdubbs bdubbs    4096 Feb 12  2004 mutt-1.4.2.1
-rw-rw-r-- 1 bdubbs bdubbs 2611253 Mar  2 14:24 mutt-1.4.2.1i.tar.gz
drwxrwxr-x 8 bdubbs bdubbs    4096 Sep 15 09:23 mutt-1.5.11
-rw-rw-r-- 1 bdubbs bdubbs 3187375 Mar  2 14:24 mutt-1.5.11.tar.gz
-rw-rw-r-- 1 bdubbs bdubbs 2352367 Mar  2 14:25 mutt.diff.bz2

The compressed diff is almost as big as the original.  This seems like a
case of the developer just being slow to bless a stable release.  It is
not a cvs version.

My statement was that I *preferred* to patch, but it is not an absolute
requirement.

  -- Bruce




More information about the blfs-book mailing list