r5568 - in trunk/BOOK: . general/prog introduction/welcome

randy at linuxfromscratch.org randy at linuxfromscratch.org
Mon Jan 16 17:06:33 PST 2006


Author: randy
Date: 2006-01-16 18:06:32 -0700 (Mon, 16 Jan 2006)
New Revision: 5568

Modified:
   trunk/BOOK/general.ent
   trunk/BOOK/general/prog/perl-modules.xml
   trunk/BOOK/introduction/welcome/changelog.xml
Log:
Added three new Perl Modules as dependencies of the Digest::SHA module: Devel::Symdump, Pod::Coverage and Test::Pod::Coverage

Modified: trunk/BOOK/general/prog/perl-modules.xml
===================================================================
--- trunk/BOOK/general/prog/perl-modules.xml	2006-01-16 23:03:43 UTC (rev 5567)
+++ trunk/BOOK/general/prog/perl-modules.xml	2006-01-17 01:06:32 UTC (rev 5568)
@@ -90,7 +90,7 @@
 
     <para>The Archive::Zip module allows a <application>Perl</application>
     program to create, manipulate, read, and write Zip archive files. The
-    two modules listed below can be installed using the
+    modules listed below can be installed using the standard
     <application>Perl</application> module
     <xref linkend="perl-standard-install"/>.</para>
 
@@ -198,7 +198,7 @@
     Alternatively, you can issue <command>perldoc lib/Finance/Quote.pm</command>
     after unpacking the distribution tarball and changing into the top-level
     directory. The module and dependencies can be installed using the
-    <application>Perl</application> module
+    standard <application>Perl</application> module
     <xref linkend="perl-standard-install"/>.</para>
 
     <note>
@@ -242,7 +242,7 @@
 
     <para>The Finance::QuoteHist bundle is several modules designed to fetch
     historical stock quotes from the web. The module and dependencies can be
-    installed using the <application>Perl</application> module
+    installed using the standard <application>Perl</application> module
     <xref linkend="perl-standard-install"/>.</para>
 
     <itemizedlist spacing='compact'>
@@ -287,7 +287,7 @@
     and extract information from HTML documents. In order to use the included
     HTML::HeadParser module, you will also need to install
     <xref linkend="perl-lwp"/>. The two modules listed below can be installed
-    using the <application>Perl</application> Module
+    using the standard <application>Perl</application> Module
     <xref linkend="perl-standard-install"/>.</para>
 
     <itemizedlist spacing='compact'>
@@ -360,7 +360,7 @@
     you to write WWW clients. The library also contains modules that are of
     more general use and even classes that help you implement simple HTTP
     servers. The LWP modules and all its <application>Perl</application>
-    module dependencies can be installed using the
+    module dependencies can be installed using the standard
     <application>Perl</application> Module
     <xref linkend="perl-standard-install"/>.</para>
 
@@ -486,6 +486,7 @@
     <application>Perl</application> module that uses the Module::Build build
     system) uses <xref linkend="perl-module-build-install"/>. All the
     dependencies can be installed using the standard
+    <application>Perl</application> module
     <xref linkend="perl-standard-install"/>.</para>
 
     <itemizedlist spacing='compact'>
@@ -551,8 +552,8 @@
           </listitem>
           <listitem>
             <para><xref linkend="perl-module-signature"/> (required to use the
-            Module::Build <quote>distsign</quote> method and optionally used
-            during the tests)</para>
+            Module::Build <quote>distsign</quote> run-time method and
+            optionally used during the tests)</para>
           </listitem>
           <listitem>
             <para><ulink
@@ -597,6 +598,7 @@
     can tell you what version of a module is installed and what dependencies
     are required for it. You can even use Module::Info to gather dependencies
     of uninstalled modules. The Module::Info module installs using the standard
+    <application>Perl</application> module
     <xref linkend="perl-standard-install"/>. The version module requires using
     the Module::Build installation method.</para>
 
@@ -690,6 +692,64 @@
             <indexterm zone="perl-modules perl-digest-sha">
               <primary sortas="g-Digest-SHA">Digest::SHA</primary>
             </indexterm>
+
+            <itemizedlist>
+              <listitem>
+                <para id="perl-test-pod-coverage"><ulink
+                url="http://cpan.org/authors/id/P/PE/PETDANCE/Test-Pod-Coverage-&Test-Pod-Coverage-version;.tar.gz">
+                Test-Pod-Coverage-&Test-Pod-Coverage-version;</ulink>
+                (optionally used during the tests).</para>
+                <indexterm zone="perl-modules perl-test-pod-coverage">
+                  <primary sortas="g-Test-Pod-Coverage">Test::Pod::Coverage</primary>
+                </indexterm>
+
+                <itemizedlist>
+                  <listitem>
+                    <para id="perl-test-builder-tester">
+                    <xref linkend="perl-test-simple"/> or
+                    <ulink
+                    url="http://cpan.org/authors/id/M/MA/MARKF/Test-Builder-Tester-&Test-Builder-Tester-version;.tar.gz">
+                    Test-Builder-Tester-&Test-Builder-Tester-version;</ulink></para>
+                    <indexterm zone="perl-modules perl-test-builder-tester">
+                      <primary sortas="g-Test-Builder-Tester">Test::Builder::Tester</primary>
+                    </indexterm>
+                  </listitem>
+                  <listitem>
+                    <para id="perl-pod-coverage"><ulink
+                    url="http://cpan.org/authors/id/R/RC/RCLAMP/Pod-Coverage-0.17.tar.gz">
+                    Pod-Coverage-&Pod-Coverage-version;</ulink></para>
+                    <indexterm zone="perl-modules perl-pod-coverage">
+                      <primary sortas="g-Pod-Coverage">Pod::Coverage</primary>
+                    </indexterm>
+
+                    <itemizedlist>
+                      <listitem>
+                        <para id="perl-devel-symdump"><ulink
+                        url="http://cpan.org/authors/id/A/AN/ANDK/Devel-Symdump-&Devel-Symdump-version;.tar.gz">
+                        Devel-Symdump-&Devel-Symdump-version;</ulink></para>
+                        <indexterm zone="perl-modules perl-devel-symdump">
+                          <primary sortas="g-Devel-Symdump">Devel::Symdump</primary>
+                        </indexterm>
+
+                        <itemizedlist>
+                          <listitem>
+                            <para><xref linkend="perl-test-pod"/> (optionally
+                            used during the tests)</para>
+                          </listitem>
+                        </itemizedlist>
+
+                      </listitem>
+                      <listitem>
+                        <para><xref linkend="perl-module-build"/></para>
+                      </listitem>
+                    </itemizedlist>
+
+                  </listitem>
+                </itemizedlist>
+
+              </listitem>
+            </itemizedlist>
+
           </listitem>
           <listitem>
             <para><xref linkend="gnupg"/></para>
@@ -711,7 +771,7 @@
     <para>Net::DNS is a DNS resolver implemented in
     <application>Perl</application>. It can be used to perform nearly any type
     of DNS query from a <application>Perl</application> script. The Net::DNS
-    module and all its dependencies can be installed using the
+    module and all its dependencies can be installed using the standard
     <application>Perl</application> Module
     <xref linkend="perl-standard-install"/>.</para>
 
@@ -837,7 +897,8 @@
     modules during the build process to check the validity of POD (Plain Old
     Documentation) files. The Test::Pod module is typically included by module
     authors to automatically find and check all POD files in a module
-    distribution. This module and all the dependencies can be installed using the
+    distribution. This module and all the dependencies can be installed using
+    the standard <application>Perl</application> Module
     <xref linkend="perl-standard-install"/>.</para>
 
     <itemizedlist spacing='compact'>
@@ -974,7 +1035,7 @@
     support via <application>Perl</application>'s and
     core-<application>Tk</application>'s use of UTF-8. Tk-&Tk-Perl-version;
     builds and loads into a threaded <application>Perl</application> but is NOT
-    yet thread safe. The module can be installed using the
+    yet thread safe. The module can be installed using the standard
     <application>Perl</application> Module
     <xref linkend="perl-standard-install"/>.</para>
 
@@ -1005,7 +1066,7 @@
     <para>The XML::Parser module is a <application>Perl</application> extension
     interface to James Clark's XML parser,
     <application>expat</application>. The module can be installed using the
-    <application>Perl</application> Module
+    standard <application>Perl</application> Module
     <xref linkend="perl-standard-install"/>.</para>
 
     <itemizedlist spacing='compact'>

Modified: trunk/BOOK/general.ent
===================================================================
--- trunk/BOOK/general.ent	2006-01-16 23:03:43 UTC (rev 5567)
+++ trunk/BOOK/general.ent	2006-01-17 01:06:32 UTC (rev 5568)
@@ -1,4 +1,4 @@
-<!ENTITY day          "16">
+<!ENTITY day          "17">
 <!ENTITY month        "01">
 <!ENTITY year         "2006">
 <!ENTITY version      "svn-&year;&month;&day;">
@@ -179,6 +179,7 @@
 <!ENTITY Compress-Zlib-version        "1.41">
 <!ENTITY Crypt-SSLeay-version         "0.51">
 <!ENTITY DateManip-version            "5.44">
+<!ENTITY Devel-Symdump-version        "2.05">
 <!ENTITY Digest-BubbleBabble-version  "0.01">
 <!ENTITY Digest-HMAC-version          "1.01">
 <!ENTITY Digest-SHA-version           "5.32">
@@ -201,12 +202,15 @@
 <!ENTITY Net-IP-version               "1.23">
 <!ENTITY PAR-Dist-version             "0.07">
 <!ENTITY Tk-Perl-version              "804.027">
+<!ENTITY Pod-Coverage-version         "0.17">
 <!ENTITY Pod-Escapes-version          "1.04">
 <!ENTITY Pod-Simple-version           "3.03">
 <!ENTITY SGMLSpm-version              "1.03ii">
 <!ENTITY Socket6-version              "0.18">
 <!ENTITY Spiffy-version               "0.25">
+<!ENTITY Test-Builder-Tester-version  "1.01">
 <!ENTITY Test-Pod-version             "1.22">
+<!ENTITY Test-Pod-Coverage-version    "1.06">
 <!ENTITY Test-Prereq-version          "1.028">
 <!ENTITY Test-Simple-version          "0.62">
 <!ENTITY Text-CSV_XS-version          "0.23">
@@ -215,7 +219,6 @@
 <!ENTITY version-perl-version         "0.53">
 <!ENTITY XML-Parser-version           "2.34">
 <!ENTITY YAML-version                 "0.50">
-<!-- <!ENTITY Test-Builder-Tester-version  "1.01"> -->
 
 <!-- Perl module versions used in the PDL instructions -->
 <!ENTITY Filter-version               "1.30">

Modified: trunk/BOOK/introduction/welcome/changelog.xml
===================================================================
--- trunk/BOOK/introduction/welcome/changelog.xml	2006-01-16 23:03:43 UTC (rev 5567)
+++ trunk/BOOK/introduction/welcome/changelog.xml	2006-01-17 01:06:32 UTC (rev 5568)
@@ -42,6 +42,17 @@
 -->
 
     <listitem>
+      <para>January 17th, 2006</para>
+      <itemizedlist>
+        <listitem>
+          <para>[randy] - Added three new Perl Modules as dependencies of the
+          Digest::SHA module: Devel::Symdump, Pod::Coverage and
+          Test::Pod::Coverage.</para>
+        </listitem>
+      </itemizedlist>
+    </listitem>
+
+    <listitem>
       <para>January 16th, 2006</para>
       <itemizedlist>
         <listitem>




More information about the blfs-book mailing list