r5662 - trunk/BOOK/gnome/add

randy at linuxfromscratch.org randy at linuxfromscratch.org
Wed Feb 8 09:39:46 PST 2006


Author: randy
Date: 2006-02-08 10:39:45 -0700 (Wed, 08 Feb 2006)
New Revision: 5662

Modified:
   trunk/BOOK/gnome/add/at-spi.xml
   trunk/BOOK/gnome/add/gnome-mag.xml
   trunk/BOOK/gnome/add/gnome-speech.xml
   trunk/BOOK/gnome/add/gnopernicus.xml
   trunk/BOOK/gnome/add/gok.xml
   trunk/BOOK/gnome/add/libgail-gnome.xml
Log:
Final cleanup of the GNOME Accessibility packages after the 2.12.2 update

Modified: trunk/BOOK/gnome/add/at-spi.xml
===================================================================
--- trunk/BOOK/gnome/add/at-spi.xml	2006-02-08 05:49:21 UTC (rev 5661)
+++ trunk/BOOK/gnome/add/at-spi.xml	2006-02-08 17:39:45 UTC (rev 5662)
@@ -4,8 +4,8 @@
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
 
-  <!ENTITY at-spi-download-http "http://ftp.gnome.org/pub/GNOME/sources/at-spi/1.6/at-spi-&at-spi-version;.tar.bz2">
-  <!ENTITY at-spi-download-ftp  "ftp://ftp.gnome.org/pub/GNOME/sources/at-spi/1.6/at-spi-&at-spi-version;.tar.bz2">
+  <!ENTITY at-spi-download-http "&gnome-download-http;/at-spi/1.6/at-spi-&at-spi-version;.tar.bz2">
+  <!ENTITY at-spi-download-ftp  "&gnome-download-ftp;/at-spi/1.6/at-spi-&at-spi-version;.tar.bz2">
   <!ENTITY at-spi-md5sum        "9669ee9e3633ffb43a70795edd748e4d">
   <!ENTITY at-spi-size          "541 KB">
   <!ENTITY at-spi-buildsize     "14.2 MB">
@@ -63,7 +63,8 @@
     <bridgehead renderas="sect3">AT SPI Dependencies</bridgehead>
 
     <bridgehead renderas="sect4">Required</bridgehead>
-    <para role="required"><xref linkend="gail"/> and <xref linkend="libbonobo"/></para>
+    <para role="required"><xref linkend="gail"/> and
+    <xref linkend="libbonobo"/></para>
 
     <bridgehead renderas="sect4">Optional</bridgehead>
     <para role="optional"><xref linkend="gtk-doc"/></para>
@@ -77,7 +78,8 @@
     following commands:</para>
 
 <screen><userinput>./configure --prefix=`pkg-config --variable=prefix ORBit-2.0` \
-    --libexecdir=`pkg-config --variable=prefix ORBit-2.0`/sbin &&
+            --libexecdir=`pkg-config \
+            --variable=prefix ORBit-2.0`/lib/at-spi &&
 make</userinput></screen>
 
     <para>The test suite cannot be run until after the package is installed.
@@ -94,8 +96,8 @@
     <title>Command Explanations</title>
 
     <para><parameter>--libexecdir=`pkg-config --variable=prefix
-    ORBit-2.0`/sbin</parameter>: This switch puts libexec files in
-    <filename class="directory">$GNOME_PREFIX/sbin</filename> instead of
+    ORBit-2.0`/lib/at-spi</parameter>: This switch puts libexec files in
+    <filename class="directory">$GNOME_PREFIX/lib/at-spi</filename> instead of
     <filename class="directory">$GNOME_PREFIX/libexec</filename>.</para>
 
   </sect2>
@@ -113,9 +115,10 @@
         <seg>libspi.[so,a], libcspi.[so,a], libloginhelper.[so,a], the
         libatk-bridge.so <application>GTK+</application> module, and
         <application>ORBit</application>-2.0 Accessibility modules</seg>
-        <seg>$GNOME_PREFIX/include/at-spi-1.0,
-        $GNOME_PREFIX/share/gtk-doc/html/at-spi-cspi and
-        $GNOME_PREFIX/share/idl/at-spi-1.0</seg>
+        <seg>The following subdirectories of $GNOME_PREFIX/:
+        include/at-spi-1.0,
+        lib/at-spi,
+        share/[gtk-doc/html/at-spi-cspi, idl/at-spi-1.0]</seg>
       </seglistitem>
     </segmentedlist>
 

Modified: trunk/BOOK/gnome/add/gnome-mag.xml
===================================================================
--- trunk/BOOK/gnome/add/gnome-mag.xml	2006-02-08 05:49:21 UTC (rev 5661)
+++ trunk/BOOK/gnome/add/gnome-mag.xml	2006-02-08 17:39:45 UTC (rev 5662)
@@ -60,16 +60,6 @@
       </listitem>
     </itemizedlist>
 
-    <!--
-    <bridgehead renderas="sect3">Additional Downloads</bridgehead>
-    <itemizedlist spacing="compact">
-      <listitem>
-        <para>Required patch: <ulink
-        url="&patch-root;/gnome-mag-&gnome-mag-version;-Xdamage-1.patch"/></para>
-      </listitem>
-    </itemizedlist>
-    -->
-
     <bridgehead renderas="sect3">GNOME Magnifier Dependencies</bridgehead>
 
     <bridgehead renderas="sect4">Required</bridgehead>
@@ -123,9 +113,7 @@
         <seg>libgnome-mag.so</seg>
         <seg>The following subdirectories of $GNOME_PREFIX/:
         include/gnome-mag-1.0,
-        share/doc/gnome-mag-0.12.3,
-        share/gnome-mag and
-        share/idl/gnome-mag-1.0</seg>
+        share/[doc/gnome-mag-0.12.3,gnome-mag,idl/gnome-mag-1.0]</seg>
       </seglistitem>
     </segmentedlist>
 

Modified: trunk/BOOK/gnome/add/gnome-speech.xml
===================================================================
--- trunk/BOOK/gnome/add/gnome-speech.xml	2006-02-08 05:49:21 UTC (rev 5661)
+++ trunk/BOOK/gnome/add/gnome-speech.xml	2006-02-08 17:39:45 UTC (rev 5662)
@@ -111,8 +111,8 @@
 
 <screen role='root'><userinput>make install &&
 install -v -m644 -D doc/gnome-speech.html \
-    `pkg-config --variable=prefix ORBit-2.0`\
-/share/doc/gnome-speech-&gnome-speech-version;/gnome-speech.html</userinput></screen>
+    `pkg-config --variable=prefix \
+    ORBit-2.0`/share/doc/gnome-speech-&gnome-speech-version;/gnome-speech.html</userinput></screen>
 
   </sect2>
 
@@ -166,9 +166,9 @@
         installed if you have enabled additional backends.</seg>
         <seg>The following subdirectories of $GNOME_PREFIX:
         include/gnome-speech-1.0,
-        share/doc/gnome-speech-&gnome-speech-version;,
-        share/gnome-speech, and
-        share/idl/gnome-speech-1.0</seg>
+        share/[doc/gnome-speech-&gnome-speech-version;,
+        gnome-speech,
+        idl/gnome-speech-1.0]</seg>
       </seglistitem>
     </segmentedlist>
 

Modified: trunk/BOOK/gnome/add/gnopernicus.xml
===================================================================
--- trunk/BOOK/gnome/add/gnopernicus.xml	2006-02-08 05:49:21 UTC (rev 5661)
+++ trunk/BOOK/gnome/add/gnopernicus.xml	2006-02-08 17:39:45 UTC (rev 5662)
@@ -112,7 +112,7 @@
     <filename class="directory">/var/lib/scrollkeeper</filename> instead of
     <filename class="directory">$GNOME_PREFIX/var/scrollkeeper</filename>.</para>
 
-    <!-- Commented out as the default X font dir is not /usr/share/fonts
+    <!-- Commented out as the default X font dir is now /usr/share/fonts
     <para><parameter>-with-default-fonts-path=/usr/X11R6/lib/X11/fonts/Type1</parameter>:
     This switch installs Braille fonts into
     <filename class='directory'>/usr/X11R6/lib/X11/fonts/Type1</filename> instead
@@ -132,15 +132,13 @@
       <seglistitem>
         <seg>gnopernicus, gnopernicus-mag-config and srcore</seg>
         <seg><application>Gnopernicus</application> support libraries</seg>
-        <seg>&gnome-etc-dir;/gconf/gconf.xml.defaults/apps/gnopernicus,
-        &gnome-etc-dir;/gconf/gconf.xml.defaults/schemas/apps/gnopernicus,
-        &gnome-etc-dir;/gnopernicus-1.0, and the following subdirectories of
+        <seg>&gnome-etc-dir;/[gconf/gconf.xml.defaults/[,schemas/]apps/gnopernicus,
+        gnopernicus-1.0], and the following subdirectories of
         $GNOME_PREFIX/:
         include/gnopernicus-1.0,
         lib/gnopernicus-1.0,
-        share/gnome/help/{brlmonitor,gnopernicus},
-        share/gnopernicus and
-        share/omf/gnopernicus</seg>
+        share/[gnome/help/[brlmonitor,gnopernicus], gnopernicus,
+        omf/gnopernicus]</seg>
       </seglistitem>
     </segmentedlist>
 

Modified: trunk/BOOK/gnome/add/gok.xml
===================================================================
--- trunk/BOOK/gnome/add/gok.xml	2006-02-08 05:49:21 UTC (rev 5661)
+++ trunk/BOOK/gnome/add/gok.xml	2006-02-08 17:39:45 UTC (rev 5662)
@@ -4,8 +4,8 @@
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
 
-  <!ENTITY gok-download-http "http://ftp.gnome.org/pub/GNOME/sources/gok/1.0/gok-&gok-version;.tar.bz2">
-  <!ENTITY gok-download-ftp  "ftp://ftp.gnome.org/pub/GNOME/sources/gok/1.0/gok-&gok-version;.tar.bz2">
+  <!ENTITY gok-download-http "&gnome-download-http;/gok/1.0/gok-&gok-version;.tar.bz2">
+  <!ENTITY gok-download-ftp  "&gnome-download-ftp;/gok/1.0/gok-&gok-version;.tar.bz2">
   <!ENTITY gok-md5sum        "a9334a0e1dc11bbba817c128503260b0">
   <!ENTITY gok-size          "1.3 MB">
   <!ENTITY gok-buildsize     "40.3 MB">
@@ -65,7 +65,7 @@
     <para role="required"><xref linkend="libgnomeui"/>,
     <xref linkend="scrollkeeper"/>,
     <xref linkend="libwnck"/>,
-    <xref linkend="at-spi"/> and
+    <xref linkend="at-spi"/>, and
     <xref linkend="gnome-speech"/></para>
 
     <bridgehead renderas="sect4">Optional</bridgehead>
@@ -80,7 +80,8 @@
     the following commands:</para>
 
 <screen><userinput>./configure --prefix=`pkg-config --variable=prefix ORBit-2.0` \
-    --sysconfdir=&gnome-etc-dir; --localstatedir=/var/lib &&
+            --sysconfdir=&gnome-etc-dir; \
+            --localstatedir=/var/lib &&
 make</userinput></screen>
 
     <para>To test the results, issue: <command>make check</command>.</para>
@@ -88,8 +89,8 @@
     <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
 
 <screen role='root'><userinput>make install &&
-chmod -v 644 `pkg-config --variable=prefix ORBit-2.0`\
-/share/gnome/help/gok/C/legal.xml</userinput></screen>
+chmod -v 644 `pkg-config --variable=prefix
+      ORBit-2.0`/share/gnome/help/gok/C/legal.xml</userinput></screen>
 
   </sect2>
 
@@ -139,12 +140,9 @@
       <seglistitem>
         <seg>gok and create-branching-keyboard</seg>
         <seg>None</seg>
-        <seg>&gnome-etc-dir;/gconf/gconf.xml.defaults/apps/gok,
-        &gnome-etc-dir;/gconf/gconf.xml.defaults/schemas/apps/gok,
-        $GNOME_PREFIX/share/gnome/help/gok,
-        $GNOME_PREFIX/share/gok,
-        $GNOME_PREFIX/share/gtk-doc/html/gok and
-        $GNOME_PREFIX/share/omf/gok</seg>
+        <seg>&gnome-etc-dir;/gconf/gconf.xml.defaults/[,schemas/]apps/gok,
+        and the following subdirectories of $GNOME_PREFIX/:
+        share/[,gnome/help/, gtk-doc/html, omf]gok</seg>
       </seglistitem>
     </segmentedlist>
 

Modified: trunk/BOOK/gnome/add/libgail-gnome.xml
===================================================================
--- trunk/BOOK/gnome/add/libgail-gnome.xml	2006-02-08 05:49:21 UTC (rev 5661)
+++ trunk/BOOK/gnome/add/libgail-gnome.xml	2006-02-08 17:39:45 UTC (rev 5662)
@@ -5,7 +5,7 @@
   %general-entities;
 
   <!ENTITY libgail-gnome-download-http "&gnome-download-http;/libgail-gnome/1.1/libgail-gnome-&libgail-gnome-version;.tar.bz2">
-  <!ENTITY libgail-gnome-download-ftp  "&gnome-download-http;/libgail-gnome/1.1/libgail-gnome-&libgail-gnome-version;.tar.bz2">
+  <!ENTITY libgail-gnome-download-ftp  "&gnome-download-ftp;/libgail-gnome/1.1/libgail-gnome-&libgail-gnome-version;.tar.bz2">
   <!ENTITY libgail-gnome-md5sum        "1d12c5375b3404f4f20b214b763e5225">
   <!ENTITY libgail-gnome-size          "215 KB">
   <!ENTITY libgail-gnome-buildsize     "2.6 MB">




More information about the blfs-book mailing list