r5633 - in trunk/BOOK: . gnome/core

randy at linuxfromscratch.org randy at linuxfromscratch.org
Thu Feb 2 22:07:50 PST 2006


Author: randy
Date: 2006-02-02 23:07:48 -0700 (Thu, 02 Feb 2006)
New Revision: 5633

Modified:
   trunk/BOOK/general.ent
   trunk/BOOK/gnome/core/gnome-applets.xml
   trunk/BOOK/gnome/core/gnome-backgrounds.xml
   trunk/BOOK/gnome/core/gnome-desktop-file-utils.xml
   trunk/BOOK/gnome/core/gnome-desktop.xml
   trunk/BOOK/gnome/core/gnome-doc-utils.xml
   trunk/BOOK/gnome/core/gnome-icon-theme.xml
   trunk/BOOK/gnome/core/gnome-keyring.xml
   trunk/BOOK/gnome/core/gnome-menus.xml
   trunk/BOOK/gnome/core/gnome-mime-data.xml
   trunk/BOOK/gnome/core/gnome-panel.xml
   trunk/BOOK/gnome/core/gnome-session.xml
   trunk/BOOK/gnome/core/gnome-terminal.xml
   trunk/BOOK/gnome/core/gnome-themes.xml
   trunk/BOOK/gnome/core/gnome-vfs.xml
   trunk/BOOK/gnome/core/gnome2-user-docs.xml
Log:
Update GNOME Core packages to the 2.12.2 version - Commit #1

Modified: trunk/BOOK/general.ent
===================================================================
--- trunk/BOOK/general.ent	2006-02-03 05:59:21 UTC (rev 5632)
+++ trunk/BOOK/general.ent	2006-02-03 06:07:48 UTC (rev 5633)
@@ -257,7 +257,7 @@
 <!ENTITY curl-version                 "7.15.1">
 <!ENTITY wvstreams-version            "4.0.1">
 <!ENTITY gnet-version                 "2.0.7">
-<!ENTITY libsoup-version              "2.2.6.1">
+<!ENTITY libsoup-version              "2.2.7">
 <!ENTITY libpcap-version              "0.9.4">
 
 <!-- Chapter 17 -->
@@ -346,7 +346,7 @@
 <!ENTITY gtk2-version                 "2.8.11">
 <!ENTITY lesstif-version              "0.94.4">
 <!ENTITY startup-notification-version "0.8">
-<!ENTITY libwnck-version              "2.12.1">
+<!ENTITY libwnck-version              "2.12.2">
 <!ENTITY shared-mime-info-version     "0.16">
 <!ENTITY hicolor-icon-theme-version   "0.8">
 <!ENTITY libxklavier-version          "2.1">
@@ -356,7 +356,7 @@
 <!-- Chapter 27 -->
 <!ENTITY sawfish-version              "1.3">
 <!ENTITY fluxbox-version              "0.9.14">
-<!ENTITY metacity-version             "2.12.1">
+<!ENTITY metacity-version             "2.12.2">
 <!ENTITY xfce-version                 "4.2.3">
 
 <!-- Part VIII -->
@@ -372,37 +372,41 @@
 <!ENTITY kdevelop-version             "3.3.0">
 
 <!-- Part IX -->
+<!ENTITY gnome-version                "2.12">
+<!ENTITY gnome-minor-version          ".2">
+<!ENTITY gnome-etc-dir                "/etc/gnome/&gnome-version;&gnome-minor-version;">
+<!ENTITY gnome-download-http          "http://ftp.gnome.org/pub/gnome/sources">
+<!ENTITY gnome-download-ftp           "ftp://ftp.gnome.org/pub/gnome/sources">
+
 <!-- Chapter 30 -->
-<!ENTITY gnome-version                "2.12">
-<!ENTITY gnome-minor-version          ".1">
 <!ENTITY ORBit2-version               "2.12.4">
 <!ENTITY libbonobo-version            "2.10.1">
 <!ENTITY GConf-version                "2.12.1">
 <!ENTITY gnome-mime-data-version      "2.4.2">
-<!ENTITY gnome-vfs-version            "2.12.1">
+<!ENTITY gnome-vfs-version            "2.12.2">
 <!ENTITY libgnome-version             "2.12.0.1">
 <!ENTITY libgnomecanvas-version       "2.12.0">
 <!ENTITY libbonoboui-version          "2.10.1">
 <!ENTITY gnome-icon-theme-version     "2.12.1">
-<!ENTITY gnome-keyring-version        "0.4.5">
+<!ENTITY gnome-keyring-version        "0.4.6">
 <!ENTITY libgnomeui-version           "2.12.0">
-<!ENTITY gtk-engines-version          "2.6.5">
+<!ENTITY gtk-engines-version          "2.6.6">
 <!ENTITY gnome-themes-version         "2.12.1">
 <!ENTITY scrollkeeper-version         "0.3.14">
 <!ENTITY gnome-doc-utils-version      "0.4.4">
-<!ENTITY gnome-desktop-version        "2.12.1">
-<!ENTITY gnome-backgrounds-version    "2.12.1">
+<!ENTITY gnome-desktop-version        "2.12.2">
+<!ENTITY gnome-backgrounds-version    "2.12.2">
 <!ENTITY gnome-menus-version          "2.12.0">
-<!ENTITY gnome-panel-version          "2.12.1">
+<!ENTITY gnome-panel-version          "2.12.2">
 <!ENTITY gnome-session-version        "2.12.0">
 <!ENTITY vte-version                  "0.11.15">
 <!ENTITY gnome-terminal-version       "2.12.0">
 <!ENTITY libgtop-version              "2.12.0">
-<!ENTITY gail-version                 "1.8.5">
-<!ENTITY gnome-applets-version        "2.12.0">
-<!ENTITY eel-version                  "2.12.1">
-<!ENTITY nautilus-version             "2.12.1">
-<!ENTITY yelp-version                 "2.12.1">
+<!ENTITY gail-version                 "1.8.8">
+<!ENTITY gnome-applets-version        "2.12.2">
+<!ENTITY eel-version                  "2.12.2">
+<!ENTITY nautilus-version             "2.12.2">
+<!ENTITY yelp-version                 "2.12.2">
 <!ENTITY control-center-version       "2.12.1">
 <!ENTITY gnome2-user-docs-version     "2.8.1">
 
@@ -416,41 +420,41 @@
 <!ENTITY libgtkhtml-version           "2.6.3">
 <!ENTITY evolution-data-server-version "1.4.1.1">
 <!ENTITY gtksourceview-version        "1.4.2">
-<!ENTITY system-tools-backends-version "1.4.0">
+<!ENTITY system-tools-backends-version "1.4.1">
 <!ENTITY gnome-audio-version          "2.0.0">
 
 <!-- Utilities -->
 <!ENTITY bug-buddy-version            "2.12.1">
 <!ENTITY gedit-version                "2.12.1">
-<!ENTITY eog-version                  "2.12.1">
+<!ENTITY eog-version                  "2.12.2">
 <!ENTITY ggv-version                  "2.12.0">
 <!ENTITY evince-version               "0.4.0">
-<!ENTITY file-roller-version          "2.12.1">
+<!ENTITY file-roller-version          "2.12.2">
 <!ENTITY gconf-editor-version         "2.12.0">
-<!ENTITY gnome-utils-version          "2.12.1">
+<!ENTITY gnome-utils-version          "2.12.2">
 <!ENTITY gnome-system-monitor-version "2.12.1">
-<!ENTITY nautilus-cd-burner-version   "2.12.1">
+<!ENTITY nautilus-cd-burner-version   "2.12.2">
 <!ENTITY gnome-media-version          "2.12.0">
 <!ENTITY gnome-netstatus-version      "2.12.0">
 <!ENTITY gcalctool-version            "5.6.31">
 <!ENTITY gucharmap-version            "1.4.4">
 <!ENTITY zenity-version               "2.12.1">
-<!ENTITY epiphany-version             "1.8.2">
+<!ENTITY epiphany-version             "1.8.3">
 <!ENTITY gnomemeeting-version         "1.2.2">
 <!ENTITY gnome-keyring-manager-version "2.12.0">
-<!ENTITY gnome-volume-manager-version "1.5.1">
-<!ENTITY gnome-games-version          "2.12.1">
-<!ENTITY sound-juicer-version         "2.12.2">
+<!ENTITY gnome-volume-manager-version "1.5.4">
+<!ENTITY gnome-games-version          "2.12.2">
+<!ENTITY sound-juicer-version         "2.12.3">
 <!ENTITY totem-version                "1.2.0">
-<!ENTITY gdm-version                  "2.8.0.5">
+<!ENTITY gdm-version                  "2.8.0.7">
 
 <!-- Accessibility -->
 <!ENTITY at-spi-version               "1.6.6">
-<!ENTITY java-access-bridge-version   "1.4.5">
-<!ENTITY libgail-gnome-version        "1.1.1">
-<!ENTITY gnome-speech-version         "0.3.8">
+<!ENTITY java-access-bridge-version   "1.4.7">
+<!ENTITY libgail-gnome-version        "1.1.2">
+<!ENTITY gnome-speech-version         "0.3.9">
 <!ENTITY gnome-mag-version            "0.12.2">
-<!ENTITY gnopernicus-version          "0.12.0">
+<!ENTITY gnopernicus-version          "0.11.8">
 <!ENTITY gok-version                  "1.0.5">
 
 <!-- Obsolete -->

Modified: trunk/BOOK/gnome/core/gnome-applets.xml
===================================================================
--- trunk/BOOK/gnome/core/gnome-applets.xml	2006-02-03 05:59:21 UTC (rev 5632)
+++ trunk/BOOK/gnome/core/gnome-applets.xml	2006-02-03 06:07:48 UTC (rev 5633)
@@ -4,12 +4,12 @@
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
 
-  <!ENTITY gnome-applets-download-http "http://ftp.gnome.org/pub/GNOME/sources/gnome-applets/&gnome-version;/gnome-applets-&gnome-applets-version;.tar.bz2">
-  <!ENTITY gnome-applets-download-ftp  "ftp://ftp.gnome.org/pub/GNOME/sources/gnome-applets/&gnome-version;/gnome-applets-&gnome-applets-version;.tar.bz2">
-  <!ENTITY gnome-applets-md5sum        "06dd0b634d7092fa8af2ce302f68f912">
-  <!ENTITY gnome-applets-size          "5.3 MB">
-  <!ENTITY gnome-applets-buildsize     "97.1 MB">
-  <!ENTITY gnome-applets-time          "1.0 SBU">
+  <!ENTITY gnome-applets-download-http "&gnome-download-http;/gnome-applets/&gnome-version;/gnome-applets-&gnome-applets-version;.tar.bz2">
+  <!ENTITY gnome-applets-download-ftp  "&gnome-download-ftp;/gnome-applets/&gnome-version;/gnome-applets-&gnome-applets-version;.tar.bz2">
+  <!ENTITY gnome-applets-md5sum        "41aa44df2b0477594e59f59245c7d052">
+  <!ENTITY gnome-applets-size          "5.4 MB">
+  <!ENTITY gnome-applets-buildsize     "103 MB">
+  <!ENTITY gnome-applets-time          "0.9 SBU">
 ]>
 
 <sect1 id="gnome-applets" xreflabel="GNOME Applets-&gnome-applets-version;">
@@ -63,7 +63,7 @@
 
     <bridgehead renderas="sect4">Required</bridgehead>
     <para role="required"><xref linkend="gail"/>,
-    <xref linkend="gnome-panel"/> and
+    <xref linkend="gnome-panel"/>, and
     <xref linkend="libxklavier"/></para>
 
     <bridgehead renderas="sect4">Optional</bridgehead>
@@ -73,8 +73,11 @@
     <xref linkend="gucharmap"/>,
     <xref linkend="system-tools-backends"/>,
     <xref linkend="docbook-utils"/>,
-    <ulink url="http://club.pep.ne.jp/~ishioka/Software/Linux/libapm-e.html">libapm</ulink>
-    and <ulink url="http://www.galago-project.org/news/index.php">libnotify</ulink></para>
+    <ulink
+    url="http://club.pep.ne.jp/~ishioka/Software/Linux/libapm-e.html">libapm</ulink>,
+    and <ulink
+    url="http://www.galago-project.org/files/releases/source/libnotify/libnotify-0.2.2.tar.gz">
+    libnotify-0.2.2</ulink></para>
 
   </sect2>
 
@@ -84,36 +87,29 @@
     <para>Install <application>GNOME Applets</application> by
     running the following commands:</para>
 
-<screen><userinput>export PRE=`pkg-config --variable=prefix ORBit-2.0` &&
-./configure --prefix=$PRE --libexecdir=$PRE/sbin \
-    --localstatedir=/var/lib --sysconfdir=/etc/gnome &&
-make tooldir=$PRE/lib/gnome-applets</userinput></screen>
+<screen><userinput>./configure --prefix=`pkg-config --variable=prefix ORBit-2.0` \
+    --libexecdir=`pkg-config \
+    --variable=prefix ORBit-2.0`/lib/gnome-applets \
+    --localstatedir=/var/lib \
+    --sysconfdir=&gnome-etc-dir; &&
+make</userinput></screen>
 
     <para>This package does not come with a test suite.</para>
 
     <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
 
-    <note>
-      <para>If you switch to the <systemitem class="username">root</systemitem>
-      user in a manner which causes the <envar>PRE</envar> environment variable
-      to be unset, ensure you set it again before installing the package.</para>
-    </note>
-
-<screen role="root"><userinput>make tooldir=$PRE/lib/gnome-applets install &&
+<screen role="root"><userinput>make install &&
 make -C man install-man</userinput></screen>
 
-    <para>Remove the variable from the unprivileged user's environment using
-    the following command:</para>
-
-<screen><userinput>unset PRE</userinput></screen>
-
   </sect2>
 
   <sect2 role="commands">
     <title>Command Explanations</title>
 
-    <para><parameter>--libexecdir=$PRE/sbin</parameter>: This switch puts libexec
-    files in <filename class="directory">$GNOME_PREFIX/sbin</filename> instead of
+    <para><parameter>--libexecdir=`pkg-config --variable=prefix
+    ORBit-2.0`/lib/gnome-applets</parameter>: This switch puts libexec files
+    in <filename class="directory">$GNOME_PREFIX/lib/gnome-applets</filename>
+    instead of
     <filename class="directory">$GNOME_PREFIX/libexec</filename>.</para>
 
     <para><parameter>--localstatedir=/var/lib</parameter>: This switch
@@ -121,17 +117,12 @@
     <filename class="directory">/var/lib/scrollkeeper</filename> instead of
     <filename class="directory">$GNOME_PREFIX/var/scrollkeeper</filename>.</para>
 
-    <para><parameter>--sysconfdir=/etc/gnome</parameter>: This switch
-    puts configuration files in <filename class="directory">/etc/gnome</filename>
+    <para><parameter>--sysconfdir=&gnome-etc-dir;</parameter>: This switch puts
+    configuration files in <filename class="directory">&gnome-etc-dir;</filename>
     instead of <filename class="directory">$GNOME_PREFIX/etc</filename>.</para>
 
-    <para><parameter>tooldir=$PRE/lib/gnome-applets</parameter>: This puts the
-    mini-commander applet files in
-    <filename class='directory'>$PRE/lib/gnome-applets</filename> instead of
-    <filename class='directory'>$PRE/sbin/gnome-applets</filename>.</para>
-
     <para><command>make -C man install-man</command>: This installs the man-pages
-    in <filename class='directory'>$PRE/man</filename>.</para>
+    that are not installed during <command>make install</command>.</para>
 
   </sect2>
 
@@ -152,7 +143,7 @@
         stickynotes_applet, and trashapplet</seg>
         <seg>None</seg>
         <seg>several config directories under the
-        /etc/gnome/gconf/gconf.xml.defaults/ hierarchy,
+        &gnome-etc-dir;/gconf/gconf.xml.defaults/ hierarchy,
         $GNOME_PREFIX/include/libgswitchit,
         $GNOME_PREFIX/lib/gnome-applets,
         several help directories under the $GNOME_PREFIX/share/gnome/help/ hierarchy,

Modified: trunk/BOOK/gnome/core/gnome-backgrounds.xml
===================================================================
--- trunk/BOOK/gnome/core/gnome-backgrounds.xml	2006-02-03 05:59:21 UTC (rev 5632)
+++ trunk/BOOK/gnome/core/gnome-backgrounds.xml	2006-02-03 06:07:48 UTC (rev 5633)
@@ -4,11 +4,11 @@
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
 
-  <!ENTITY gnome-backgrounds-download-http "http://ftp.gnome.org/pub/GNOME/sources/gnome-backgrounds/&gnome-version;/gnome-backgrounds-&gnome-backgrounds-version;.tar.bz2">
-  <!ENTITY gnome-backgrounds-download-ftp  "ftp://ftp.gnome.org/pub/GNOME/sources/gnome-backgrounds/&gnome-version;/gnome-backgrounds-&gnome-backgrounds-version;.tar.bz2">
-  <!ENTITY gnome-backgrounds-md5sum        "3f84adbe8c22e18033f10e8c506d601f">
+  <!ENTITY gnome-backgrounds-download-http "&gnome-download-http;/gnome-backgrounds/&gnome-version;/gnome-backgrounds-&gnome-backgrounds-version;.tar.bz2">
+  <!ENTITY gnome-backgrounds-download-ftp  "&gnome-download-ftp;/gnome-backgrounds/&gnome-version;/gnome-backgrounds-&gnome-backgrounds-version;.tar.bz2">
+  <!ENTITY gnome-backgrounds-md5sum        "8c0533d438721ed1923d5dfa87885f53">
   <!ENTITY gnome-backgrounds-size          "1.7 MB">
-  <!ENTITY gnome-backgrounds-buildsize     "5.0 MB">
+  <!ENTITY gnome-backgrounds-buildsize     "5.2 MB">
   <!ENTITY gnome-backgrounds-time          "less than 0.1 SBU">
 ]>
 
@@ -62,7 +62,7 @@
     <bridgehead renderas="sect3">gnome-backgrounds Dependencies</bridgehead>
 
     <bridgehead renderas="sect4">Required</bridgehead>
-    <para role="required"><xref linkend="intltool"/></para>
+    <para role="required"><xref linkend="perl-xml-parser"/></para>
 
   </sect2>
 

Modified: trunk/BOOK/gnome/core/gnome-desktop-file-utils.xml
===================================================================
--- trunk/BOOK/gnome/core/gnome-desktop-file-utils.xml	2006-02-03 05:59:21 UTC (rev 5632)
+++ trunk/BOOK/gnome/core/gnome-desktop-file-utils.xml	2006-02-03 06:07:48 UTC (rev 5633)
@@ -16,10 +16,9 @@
   <title>desktop-file-utils-&desktop-file-utils-version;</title>
 
   <para>The <xref linkend="desktop-file-utils"/> package is located in
-  Chapter 10 – General Utilities, however it is now required by
-  <application>GNOME-2</application> starting with version 2.8.
-  <application>desktop-file-utils</application> is not a direct dependency
-  of any <application>GNOME-2</application> package, therefore the package
+  Chapter 10 — General Utilities and is required by
+  <application>GNOME-2</application> but is not a direct dependency of any
+  <application>GNOME-2</application> package, therefore the package
   is mentioned within the <application>GNOME-2</application> Core Packages
   chapter to ensure it is installed.</para>
 

Modified: trunk/BOOK/gnome/core/gnome-desktop.xml
===================================================================
--- trunk/BOOK/gnome/core/gnome-desktop.xml	2006-02-03 05:59:21 UTC (rev 5632)
+++ trunk/BOOK/gnome/core/gnome-desktop.xml	2006-02-03 06:07:48 UTC (rev 5633)
@@ -4,11 +4,11 @@
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
 
-  <!ENTITY gnome-desktop-download-http "http://ftp.gnome.org/pub/GNOME/sources/gnome-desktop/&gnome-version;/gnome-desktop-&gnome-desktop-version;.tar.bz2">
-  <!ENTITY gnome-desktop-download-ftp  "ftp://ftp.gnome.org/pub/GNOME/sources/gnome-desktop/&gnome-version;/gnome-desktop-&gnome-desktop-version;.tar.bz2">
-  <!ENTITY gnome-desktop-md5sum        "e6841d3a401ec2f5aa17a0529ba4bf55">
+  <!ENTITY gnome-desktop-download-http "&gnome-download-http;/gnome-desktop/&gnome-version;/gnome-desktop-&gnome-desktop-version;.tar.bz2">
+  <!ENTITY gnome-desktop-download-ftp  "&gnome-download-ftp;/gnome-desktop/&gnome-version;/gnome-desktop-&gnome-desktop-version;.tar.bz2">
+  <!ENTITY gnome-desktop-md5sum        "8f92b61ff20c00d6c475e93fce81b3c7">
   <!ENTITY gnome-desktop-size          "1.0 MB">
-  <!ENTITY gnome-desktop-buildsize     "11.3 MB">
+  <!ENTITY gnome-desktop-buildsize     "11.4 MB">
   <!ENTITY gnome-desktop-time          "0.2 SBU">
 ]>
 
@@ -78,7 +78,7 @@
     running the following commands:</para>
 
 <screen><userinput>./configure --prefix=`pkg-config --variable=prefix ORBit-2.0` \
-    --sysconfdir=/etc/gnome --localstatedir=/var/lib &&
+    --sysconfdir=&gnome-etc-dir; --localstatedir=/var/lib &&
 make</userinput></screen>
 
     <para>This package does not come with a test suite.</para>
@@ -92,8 +92,8 @@
   <sect2 role="commands">
     <title>Command Explanations</title>
 
-    <para><parameter>--sysconfdir=/etc/gnome</parameter>: This switch
-    puts configuration files in <filename class="directory">/etc/gnome</filename>
+    <para><parameter>--sysconfdir=&gnome-etc-dir;</parameter>: This switch puts
+    configuration files in <filename class="directory">&gnome-etc-dir;</filename>
     instead of <filename class="directory">$GNOME_PREFIX/etc</filename>.</para>
 
     <para><option>--with-gnome-distributor="Some Name"</option>: Use this

Modified: trunk/BOOK/gnome/core/gnome-doc-utils.xml
===================================================================
--- trunk/BOOK/gnome/core/gnome-doc-utils.xml	2006-02-03 05:59:21 UTC (rev 5632)
+++ trunk/BOOK/gnome/core/gnome-doc-utils.xml	2006-02-03 06:07:48 UTC (rev 5633)
@@ -4,8 +4,8 @@
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
 
-  <!ENTITY gnome-doc-utils-download-http "http://ftp.gnome.org/pub/GNOME/sources/gnome-doc-utils/0.4/gnome-doc-utils-&gnome-doc-utils-version;.tar.bz2">
-  <!ENTITY gnome-doc-utils-download-ftp  "ftp://ftp.gnome.org/pub/GNOME/sources/gnome-doc-utils/0.4/gnome-doc-utils-&gnome-doc-utils-version;.tar.bz2">
+  <!ENTITY gnome-doc-utils-download-http "&gnome-download-http;/gnome-doc-utils/0.4/gnome-doc-utils-&gnome-doc-utils-version;.tar.bz2">
+  <!ENTITY gnome-doc-utils-download-ftp  "&gnome-download-ftp;/gnome-doc-utils/0.4/gnome-doc-utils-&gnome-doc-utils-version;.tar.bz2">
   <!ENTITY gnome-doc-utils-md5sum        "b89d9e9830f5b3e0ead295104637a207">
   <!ENTITY gnome-doc-utils-size          "382 KB">
   <!ENTITY gnome-doc-utils-buildsize     "6.5 MB">
@@ -69,8 +69,9 @@
     <bridgehead renderas="sect3">GNOME Doc Utils Dependencies</bridgehead>
 
     <bridgehead renderas="sect4">Required</bridgehead>
-    <para role="required"><xref linkend="python"/> and
-    <xref linkend="scrollkeeper"/></para>
+    <para role="required"><xref linkend="python"/>,
+    <xref linkend="scrollkeeper"/>, and
+    <xref linkend="perl-xml-parser"/></para>
 
     <bridgehead renderas="sect4">Optional</bridgehead>
     <para role="optional"><xref linkend="pkgconfig"/></para>

Modified: trunk/BOOK/gnome/core/gnome-icon-theme.xml
===================================================================
--- trunk/BOOK/gnome/core/gnome-icon-theme.xml	2006-02-03 05:59:21 UTC (rev 5632)
+++ trunk/BOOK/gnome/core/gnome-icon-theme.xml	2006-02-03 06:07:48 UTC (rev 5633)
@@ -4,8 +4,8 @@
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
 
-  <!ENTITY gnome-icon-theme-download-http "http://ftp.gnome.org/pub/GNOME/sources/gnome-icon-theme/&gnome-version;/gnome-icon-theme-&gnome-icon-theme-version;.tar.bz2">
-  <!ENTITY gnome-icon-theme-download-ftp  "ftp://ftp.gnome.org/pub/GNOME/sources/gnome-icon-theme/&gnome-version;/gnome-icon-theme-&gnome-icon-theme-version;.tar.bz2">
+  <!ENTITY gnome-icon-theme-download-http "&gnome-download-http;/gnome-icon-theme/&gnome-version;/gnome-icon-theme-&gnome-icon-theme-version;.tar.bz2">
+  <!ENTITY gnome-icon-theme-download-ftp  "&gnome-download-ftp;/gnome-icon-theme/&gnome-version;/gnome-icon-theme-&gnome-icon-theme-version;.tar.bz2">
   <!ENTITY gnome-icon-theme-md5sum        "a5401d6f085979fe6601f2241743af86">
   <!ENTITY gnome-icon-theme-size          "3.1 MB">
   <!ENTITY gnome-icon-theme-buildsize     "29.7 MB">

Modified: trunk/BOOK/gnome/core/gnome-keyring.xml
===================================================================
--- trunk/BOOK/gnome/core/gnome-keyring.xml	2006-02-03 05:59:21 UTC (rev 5632)
+++ trunk/BOOK/gnome/core/gnome-keyring.xml	2006-02-03 06:07:48 UTC (rev 5633)
@@ -4,11 +4,11 @@
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
 
-  <!ENTITY gnome-keyring-download-http "http://ftp.gnome.org/pub/GNOME/sources/gnome-keyring/0.4/gnome-keyring-&gnome-keyring-version;.tar.bz2">
-  <!ENTITY gnome-keyring-download-ftp  "ftp://ftp.gnome.org/pub/GNOME/sources/gnome-keyring/0.4/gnome-keyring-&gnome-keyring-version;.tar.bz2">
-  <!ENTITY gnome-keyring-md5sum        "4de9c720ed46ff1a5d0f59b3b7a0864f">
-  <!ENTITY gnome-keyring-size          "376 KB">
-  <!ENTITY gnome-keyring-buildsize     "5.4 MB">
+  <!ENTITY gnome-keyring-download-http "&gnome-download-http;/gnome-keyring/0.4/gnome-keyring-&gnome-keyring-version;.tar.bz2">
+  <!ENTITY gnome-keyring-download-ftp  "&gnome-download-ftp;/gnome-keyring/0.4/gnome-keyring-&gnome-keyring-version;.tar.bz2">
+  <!ENTITY gnome-keyring-md5sum        "7d94fc9598035ea1a92f4e777dfc4194">
+  <!ENTITY gnome-keyring-size          "379 KB">
+  <!ENTITY gnome-keyring-buildsize     "5.5 MB">
   <!ENTITY gnome-keyring-time          "0.1 SBU">
 ]>
 
@@ -75,7 +75,8 @@
     following commands:</para>
 
 <screen><userinput>./configure --prefix=`pkg-config --variable=prefix ORBit-2.0` \
-    --libexecdir=`pkg-config --variable=prefix ORBit-2.0`/sbin &&
+    --libexecdir=`pkg-config \
+    --variable=prefix ORBit-2.0`/lib/gnome-keyring &&
 make</userinput></screen>
 
     <para>This package does not come with a test suite.</para>
@@ -90,8 +91,9 @@
     <title>Command Explanations</title>
 
     <para><parameter>--libexecdir=`pkg-config --variable=prefix
-    ORBit-2.0`/sbin</parameter>: This switch puts libexec files in
-    <filename class="directory">$GNOME_PREFIX/sbin</filename> instead of
+    ORBit-2.0`/lib/gnome-keyring</parameter>: This switch puts libexec files in
+    <filename class="directory">$GNOME_PREFIX/lib/gnome-keyring</filename>
+    instead of
     <filename class="directory">$GNOME_PREFIX/libexec</filename>.</para>
 
   </sect2>
@@ -105,9 +107,10 @@
       <segtitle>Installed Directory</segtitle>
 
       <seglistitem>
-        <seg>gnome-keyring-ask and gnome-keyring-daemon</seg>
+        <seg>gnome-keyring-daemon</seg>
         <seg>libgnome-keyring.so</seg>
-        <seg>$GNOME_PREFIX/include/gnome-keyring-1</seg>
+        <seg>$GNOME_PREFIX/include/gnome-keyring-1 and
+        $GNOME_PREFIX/lib/gnome-keyring</seg>
       </seglistitem>
     </segmentedlist>
 

Modified: trunk/BOOK/gnome/core/gnome-menus.xml
===================================================================
--- trunk/BOOK/gnome/core/gnome-menus.xml	2006-02-03 05:59:21 UTC (rev 5632)
+++ trunk/BOOK/gnome/core/gnome-menus.xml	2006-02-03 06:07:48 UTC (rev 5633)
@@ -4,8 +4,8 @@
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
 
-  <!ENTITY gnome-menus-download-http "http://ftp.gnome.org/pub/GNOME/sources/gnome-menus/&gnome-version;/gnome-menus-&gnome-menus-version;.tar.bz2">
-  <!ENTITY gnome-menus-download-ftp  "ftp://ftp.gnome.org/pub/GNOME/sources/gnome-menus/&gnome-version;/gnome-menus-&gnome-menus-version;.tar.bz2">
+  <!ENTITY gnome-menus-download-http "&gnome-download-http;/gnome-menus/&gnome-version;/gnome-menus-&gnome-menus-version;.tar.bz2">
+  <!ENTITY gnome-menus-download-ftp  "&gnome-download-ftp;/gnome-menus/&gnome-version;/gnome-menus-&gnome-menus-version;.tar.bz2">
   <!ENTITY gnome-menus-md5sum        "615392c4f729f70c03aa3aa7dbe40a95">
   <!ENTITY gnome-menus-size          "393 KB">
   <!ENTITY gnome-menus-buildsize     "7.0 MB">
@@ -67,7 +67,7 @@
 
     <bridgehead renderas="sect4">Required</bridgehead>
     <para role="required"><xref linkend="glib2"/> and
-    <xref linkend="intltool"/></para>
+    <xref linkend="perl-xml-parser"/></para>
 
     <bridgehead renderas="sect4">Optional</bridgehead>
     <para role="optional"><xref linkend="python"/> and
@@ -85,7 +85,7 @@
     following commands:</para>
 
 <screen><userinput>./configure --prefix=`pkg-config --variable=prefix ORBit-2.0` \
-    --sysconfdir=/etc/gnome &&
+    --sysconfdir=&gnome-etc-dir; &&
 make</userinput></screen>
 
     <para>This package does not come with a test suite.</para>
@@ -118,7 +118,7 @@
       profiles as shown below (you may add additional directories, separated
       with colons, if desired):</para>
 
-<screen><literal>export XDG_CONFIG_DIRS=/etc/gnome/xdg</literal></screen>
+<screen><literal>export XDG_CONFIG_DIRS=/usr/share:&gnome-etc-dir;/xdg</literal></screen>
 
     </sect3>
 
@@ -135,7 +135,7 @@
       <seglistitem>
         <seg>gnome-menu-spec-test</seg>
         <seg>libgnome-menu.[so,a]</seg>
-        <seg>/etc/gnome/xdg, $GNOME_PREFIX/include/gnome-menus,
+        <seg>&gnome-etc-dir;/xdg, $GNOME_PREFIX/include/gnome-menus,
         $GNOME_PREFIX/lib/python2.4/site-packages/GMenuSimpleEditor and
         $GNOME_PREFIX/share/desktop-directories</seg>
       </seglistitem>

Modified: trunk/BOOK/gnome/core/gnome-mime-data.xml
===================================================================
--- trunk/BOOK/gnome/core/gnome-mime-data.xml	2006-02-03 05:59:21 UTC (rev 5632)
+++ trunk/BOOK/gnome/core/gnome-mime-data.xml	2006-02-03 06:07:48 UTC (rev 5633)
@@ -4,8 +4,8 @@
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
 
-  <!ENTITY gnome-mime-data-download-http "http://ftp.gnome.org/pub/GNOME/sources/gnome-mime-data/2.4/gnome-mime-data-&gnome-mime-data-version;.tar.bz2">
-  <!ENTITY gnome-mime-data-download-ftp  "ftp://ftp.gnome.org/pub/GNOME/sources/gnome-mime-data/2.4/gnome-mime-data-&gnome-mime-data-version;.tar.bz2">
+  <!ENTITY gnome-mime-data-download-http "&gnome-download-http;/gnome-mime-data/2.4/gnome-mime-data-&gnome-mime-data-version;.tar.bz2">
+  <!ENTITY gnome-mime-data-download-ftp  "&gnome-download-ftp;/gnome-mime-data/2.4/gnome-mime-data-&gnome-mime-data-version;.tar.bz2">
   <!ENTITY gnome-mime-data-md5sum        "37242776b08625fa10c73c18b790e552">
   <!ENTITY gnome-mime-data-size          "849 KB">
   <!ENTITY gnome-mime-data-buildsize     "12 MB">
@@ -76,7 +76,7 @@
     the following commands:</para>
 
 <screen><userinput>./configure --prefix=`pkg-config --variable=prefix ORBit-2.0` \
-    --sysconfdir=/etc/gnome &&
+    --sysconfdir=&gnome-etc-dir; &&
 make</userinput></screen>
 
     <para>This package does not come with a test suite.</para>
@@ -92,8 +92,8 @@
   <sect2 role="commands">
     <title>Command Explanations</title>
 
-    <para><parameter>--sysconfdir=/etc/gnome</parameter>: This switch
-    puts configuration files in <filename class="directory">/etc/gnome</filename>
+    <para><parameter>--sysconfdir=&gnome-etc-dir;</parameter>: This switch
+    puts configuration files in <filename class="directory">&gnome-etc-dir;</filename>
     instead of <filename class="directory">$GNOME_PREFIX/etc</filename>.</para>
 
   </sect2>

Modified: trunk/BOOK/gnome/core/gnome-panel.xml
===================================================================
--- trunk/BOOK/gnome/core/gnome-panel.xml	2006-02-03 05:59:21 UTC (rev 5632)
+++ trunk/BOOK/gnome/core/gnome-panel.xml	2006-02-03 06:07:48 UTC (rev 5633)
@@ -4,11 +4,11 @@
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
 
-  <!ENTITY gnome-panel-download-http "http://ftp.gnome.org/pub/GNOME/sources/gnome-panel/&gnome-version;/gnome-panel-&gnome-panel-version;.tar.bz2">
-  <!ENTITY gnome-panel-download-ftp  "ftp://ftp.gnome.org/pub/GNOME/sources/gnome-panel/&gnome-version;/gnome-panel-&gnome-panel-version;.tar.bz2">
-  <!ENTITY gnome-panel-md5sum        "a532717e8ac7f67b7198c256909cd7dd">
+  <!ENTITY gnome-panel-download-http "&gnome-download-http;/gnome-panel/&gnome-version;/gnome-panel-&gnome-panel-version;.tar.bz2">
+  <!ENTITY gnome-panel-download-ftp  "&gnome-download-ftp;/gnome-panel/&gnome-version;/gnome-panel-&gnome-panel-version;.tar.bz2">
+  <!ENTITY gnome-panel-md5sum        "b48ebb9a2eecc9bcda7d3083e7b16db8">
   <!ENTITY gnome-panel-size          "2.4 MB">
-  <!ENTITY gnome-panel-buildsize     "57.2 MB">
+  <!ENTITY gnome-panel-buildsize     "57.5 MB">
   <!ENTITY gnome-panel-time          "0.8 SBU">
 ]>
 
@@ -62,12 +62,12 @@
 
     <bridgehead renderas="sect4">Required</bridgehead>
     <para role="required"><xref linkend="gnome-desktop"/>,
-    <xref linkend="libwnck"/> and
+    <xref linkend="libwnck"/>, and
     <xref linkend="gnome-menus"/></para>
 
     <bridgehead renderas="sect4">Optional</bridgehead>
-    <para role="optional"><xref linkend="evolution-data-server"/> (required if
-    you plan on installing <application>Evolution</application> or
+    <para role="optional"><xref linkend="evolution-data-server"/>
+    (required if you plan to install <application>Evolution</application> or
     <application>GnomeMeeting</application>) and
     <xref linkend="gtk-doc"/></para>
 
@@ -80,8 +80,9 @@
     running the following commands:</para>
 
 <screen><userinput>./configure --prefix=`pkg-config --variable=prefix ORBit-2.0` \
-    --libexecdir=`pkg-config --variable=prefix ORBit-2.0`/sbin \
-    --localstatedir=/var/lib --sysconfdir=/etc/gnome &&
+    --libexecdir=`pkg-config \
+    --variable=prefix ORBit-2.0`/lib/gnome-panel \
+    --localstatedir=/var/lib --sysconfdir=&gnome-etc-dir; &&
 make</userinput></screen>
 
     <para>This package does not come with a test suite.</para>
@@ -96,12 +97,13 @@
     <title>Command Explanations</title>
 
     <para><parameter>--libexecdir=`pkg-config --variable=prefix
-    ORBit-2.0`/sbin</parameter>: This switch puts libexec files in
-    <filename class="directory">$GNOME_PREFIX/sbin</filename> instead of
+    ORBit-2.0`/lib/gnome-panel</parameter>: This switch puts libexec files in
+    <filename class="directory">$GNOME_PREFIX/lib/gnome-panel</filename>
+    instead of
     <filename class="directory">$GNOME_PREFIX/libexec</filename>.</para>
 
-    <para><parameter>--sysconfdir=/etc/gnome</parameter>: This switch
-    puts configuration files in <filename class="directory">/etc/gnome</filename>
+    <para><parameter>--sysconfdir=&gnome-etc-dir;</parameter>: This switch puts
+    configuration files in <filename class="directory">&gnome-etc-dir;</filename>
     instead of <filename class="directory">$GNOME_PREFIX/etc</filename>.</para>
 
   </sect2>
@@ -118,7 +120,7 @@
         <seg>clock-applet, fish-applet-2, gnome-desktop-item-edit, gnome-panel,
         gnome-desktop-item-edit, notification-area-applet, and wnck-applet</seg>
         <seg>libpanel-applet-2.[so,a] and bonobo servers</seg>
-        <seg>/etc/gnome/gconf/gconf.xml.defaults/[,schemas]/apps,
+        <seg>&gnome-etc-dir;/gconf/gconf.xml.defaults/[,schemas]/apps,
         $GNOME_PREFIX/include/panel-2.0,
         $GNOME_PREFIX/share/idl/gnome-panel-2.0,
         some help directories under the $GNOME_PREFIX/share/gnome/help hierarchy,

Modified: trunk/BOOK/gnome/core/gnome-session.xml
===================================================================
--- trunk/BOOK/gnome/core/gnome-session.xml	2006-02-03 05:59:21 UTC (rev 5632)
+++ trunk/BOOK/gnome/core/gnome-session.xml	2006-02-03 06:07:48 UTC (rev 5633)
@@ -4,8 +4,8 @@
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
 
-  <!ENTITY gnome-session-download-http "http://ftp.gnome.org/pub/GNOME/sources/gnome-session/&gnome-version;/gnome-session-&gnome-session-version;.tar.bz2">
-  <!ENTITY gnome-session-download-ftp  "ftp://ftp.gnome.org/pub/GNOME/sources/gnome-session/&gnome-version;/gnome-session-&gnome-session-version;.tar.bz2">
+  <!ENTITY gnome-session-download-http "&gnome-download-http;/gnome-session/&gnome-version;/gnome-session-&gnome-session-version;.tar.bz2">
+  <!ENTITY gnome-session-download-ftp  "&gnome-download-ftp;/gnome-session/&gnome-version;/gnome-session-&gnome-session-version;.tar.bz2">
   <!ENTITY gnome-session-md5sum        "835e9340d23e139430224b931ff4c597">
   <!ENTITY gnome-session-size          "864 KB">
   <!ENTITY gnome-session-buildsize     "11.8 MB">
@@ -75,7 +75,7 @@
     running the following commands:</para>
 
 <screen><userinput>./configure --prefix=`pkg-config --variable=prefix ORBit-2.0` \
-    --sysconfdir=/etc/gnome  &&
+    --sysconfdir=&gnome-etc-dir; &&
 make</userinput></screen>
 
     <para>This package does not come with a test suite.</para>
@@ -89,8 +89,8 @@
   <sect2 role="commands">
     <title>Command Explanations</title>
 
-    <para><parameter>--sysconfdir=/etc/gnome</parameter>: This switch puts
-    configuration files in <filename class="directory">/etc/gnome</filename>
+    <para><parameter>--sysconfdir=&gnome-etc-dir;</parameter>: This switch puts
+    configuration files in <filename class="directory">&gnome-etc-dir;</filename>
     instead of <filename class="directory">$GNOME_PREFIX/etc</filename>.</para>
 
   </sect2>
@@ -107,8 +107,8 @@
         <seg>gnome-session, gnome-session-properties, gnome-session-remove,
         gnome-session-save, gnome-smproxy, and gnome-wm</seg>
         <seg>None</seg>
-        <seg>/etc/gnome/gconf/gconf.xml.defaults/schemas/apps/gnome-session,
-        /etc/gnome/gconf/gconf.xml.defaults/apps/gnome-session,
+        <seg>&gnome-etc-dir;/gconf/gconf.xml.defaults/schemas/apps/gnome-session,
+        &gnome-etc-dir;/gconf/gconf.xml.defaults/apps/gnome-session,
         and $GNOME_PREFIX/share/pixmaps/splash</seg>
       </seglistitem>
     </segmentedlist>

Modified: trunk/BOOK/gnome/core/gnome-terminal.xml
===================================================================
--- trunk/BOOK/gnome/core/gnome-terminal.xml	2006-02-03 05:59:21 UTC (rev 5632)
+++ trunk/BOOK/gnome/core/gnome-terminal.xml	2006-02-03 06:07:48 UTC (rev 5633)
@@ -4,8 +4,8 @@
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
 
-  <!ENTITY gnome-terminal-download-http "http://ftp.gnome.org/pub/GNOME/sources/gnome-terminal/&gnome-version;/gnome-terminal-&gnome-terminal-version;.tar.bz2">
-  <!ENTITY gnome-terminal-download-ftp  "ftp://ftp.gnome.org/pub/GNOME/sources/gnome-terminal/&gnome-version;/gnome-terminal-&gnome-terminal-version;.tar.bz2">
+  <!ENTITY gnome-terminal-download-http "&gnome-download-http;/gnome-terminal/&gnome-version;/gnome-terminal-&gnome-terminal-version;.tar.bz2">
+  <!ENTITY gnome-terminal-download-ftp  "&gnome-download-ftp;/gnome-terminal/&gnome-version;/gnome-terminal-&gnome-terminal-version;.tar.bz2">
   <!ENTITY gnome-terminal-md5sum        "483c9397dd165845e2528a80e3df6dfc">
   <!ENTITY gnome-terminal-size          "1.6 MB">
   <!ENTITY gnome-terminal-buildsize     "34.6 MB">
@@ -63,7 +63,7 @@
     <bridgehead renderas="sect4">Required</bridgehead>
     <para role="required"><xref linkend="libgnomeui"/>,
     <xref linkend="scrollkeeper"/>,
-    <xref linkend="vte"/> and
+    <xref linkend="vte"/>, and
     <xref linkend="startup-notification"/></para>
 
   </sect2>
@@ -75,7 +75,7 @@
     running the following commands:</para>
 
 <screen><userinput>./configure --prefix=`pkg-config --variable=prefix ORBit-2.0` \
-    --localstatedir=/var/lib --sysconfdir=/etc/gnome &&
+    --localstatedir=/var/lib --sysconfdir=&gnome-etc-dir; &&
 make</userinput></screen>
 
     <para>This package does not come with a test suite.</para>
@@ -94,8 +94,8 @@
     <filename class="directory">/var/lib/scrollkeeper</filename> instead of
     <filename class="directory">$GNOME_PREFIX/var/scrollkeeper</filename>.</para>
 
-    <para><parameter>--sysconfdir=/etc/gnome</parameter>: This switch
-    puts configuration files in <filename class="directory">/etc/gnome</filename>
+    <para><parameter>--sysconfdir=&gnome-etc-dir;</parameter>: This switch puts
+    configuration files in <filename class="directory">&gnome-etc-dir;</filename>
     instead of <filename class="directory">$GNOME_PREFIX/etc</filename>.</para>
 
   </sect2>
@@ -111,8 +111,8 @@
       <seglistitem>
         <seg>gnome-terminal</seg>
         <seg>None</seg>
-        <seg>/etc/gnome/gconf/gconf.xml.defaults/schemas/apps/gnome-terminal,
-        /etc/gnome/gconf/gconf.xml.defaults/apps/gnome-terminal,
+        <seg>&gnome-etc-dir;/gconf/gconf.xml.defaults/schemas/apps/gnome-terminal,
+        &gnome-etc-dir;/gconf/gconf.xml.defaults/apps/gnome-terminal,
         $GNOME_PREFIX/share/gnome/help/gnome-terminal,
         $GNOME_PREFIX/share/gnome-terminal, and
         $GNOME_PREFIX/share/omf/gnome-terminal</seg>

Modified: trunk/BOOK/gnome/core/gnome-themes.xml
===================================================================
--- trunk/BOOK/gnome/core/gnome-themes.xml	2006-02-03 05:59:21 UTC (rev 5632)
+++ trunk/BOOK/gnome/core/gnome-themes.xml	2006-02-03 06:07:48 UTC (rev 5633)
@@ -4,8 +4,8 @@
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
 
-  <!ENTITY gnome-themes-download-http "http://ftp.gnome.org/pub/GNOME/sources/gnome-themes/&gnome-version;/gnome-themes-&gnome-themes-version;.tar.bz2">
-  <!ENTITY gnome-themes-download-ftp  "ftp://ftp.gnome.org/pub/GNOME/sources/gnome-themes/&gnome-version;/gnome-themes-&gnome-themes-version;.tar.bz2">
+  <!ENTITY gnome-themes-download-http "&gnome-download-http;/gnome-themes/&gnome-version;/gnome-themes-&gnome-themes-version;.tar.bz2">
+  <!ENTITY gnome-themes-download-ftp  "&gnome-download-ftp;/gnome-themes/&gnome-version;/gnome-themes-&gnome-themes-version;.tar.bz2">
   <!ENTITY gnome-themes-md5sum        "ab6d63ecb304506153fac3e958995ef4">
   <!ENTITY gnome-themes-size          "2.5 MB">
   <!ENTITY gnome-themes-buildsize     "19.6 MB">
@@ -61,7 +61,7 @@
     <bridgehead renderas="sect3">GNOME Themes Dependencies</bridgehead>
 
     <bridgehead renderas="sect4">Required</bridgehead>
-    <para role="required"><xref linkend="intltool"/> and
+    <para role="required"><xref linkend="perl-xml-parser"/> and
     <xref linkend="gtk-engines"/></para>
 
   </sect2>
@@ -87,7 +87,8 @@
     <title>Command Explanations</title>
 
     <para><option>--enable-all-themes</option>: Using this parameter enables
-    the installation of additional accessibility themes.</para>
+    the installation of additional accessibility themes. Omit this parameter if
+    you have no desire for additional accessibility themes.</para>
 
   </sect2>
 

Modified: trunk/BOOK/gnome/core/gnome-vfs.xml
===================================================================
--- trunk/BOOK/gnome/core/gnome-vfs.xml	2006-02-03 05:59:21 UTC (rev 5632)
+++ trunk/BOOK/gnome/core/gnome-vfs.xml	2006-02-03 06:07:48 UTC (rev 5633)
@@ -4,12 +4,12 @@
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
 
-  <!ENTITY gnome-vfs-download-http "http://ftp.gnome.org/pub/GNOME/sources/gnome-vfs/&gnome-version;/gnome-vfs-&gnome-vfs-version;.tar.bz2">
-  <!ENTITY gnome-vfs-download-ftp  "ftp://ftp.gnome.org/pub/GNOME/sources/gnome-vfs/&gnome-version;/gnome-vfs-&gnome-vfs-version;.tar.bz2">
-  <!ENTITY gnome-vfs-md5sum        "95b0308d49aba17b9cb36c84f8467017">
-  <!ENTITY gnome-vfs-size          "1.7 MB">
-  <!ENTITY gnome-vfs-buildsize     "51.6 MB">
-  <!ENTITY gnome-vfs-time          "1.3 SBU">
+  <!ENTITY gnome-vfs-download-http "&gnome-download-http;/gnome-vfs/&gnome-version;/gnome-vfs-&gnome-vfs-version;.tar.bz2">
+  <!ENTITY gnome-vfs-download-ftp  "&gnome-download-ftp;/gnome-vfs/&gnome-version;/gnome-vfs-&gnome-vfs-version;.tar.bz2">
+  <!ENTITY gnome-vfs-md5sum        "4d7b9c14af29a9bf813ab4831eeeacbb">
+  <!ENTITY gnome-vfs-size          "1.5 MB">
+  <!ENTITY gnome-vfs-buildsize     "52.2 MB">
+  <!ENTITY gnome-vfs-time          "1.4 SBU">
 ]>
 
 <sect1 id="gnome-vfs" xreflabel="GNOME Virtual File System-&gnome-vfs-version;">
@@ -59,23 +59,12 @@
       </listitem>
     </itemizedlist>
 
-    <bridgehead renderas="sect3">Additional Downloads</bridgehead>
-    <itemizedlist spacing='compact'>
-      <listitem>
-        <para>Required patch if <application>Samba</application> version
-        greater than 3.0.14 is installed: <ulink
-        url="&patch-root;/gnome-vfs-&gnome-vfs-version;-samba_3.0.20-1.patch"/></para>
-      </listitem>
-    </itemizedlist>
-
     <bridgehead renderas="sect3">GNOME Virtual File System Dependencies</bridgehead>
 
     <bridgehead renderas="sect4">Required</bridgehead>
-    <para role="required"><xref linkend="intltool"/>,
-    <xref linkend="GConf"/>,
-    <xref linkend="libbonobo"/>,
-    <xref linkend="gnome-mime-data"/> and
-    <xref linkend="shared-mime-info"/></para>
+    <para role="required"><xref linkend="GConf"/>,
+    <xref linkend="libbonobo"/>, and
+    <xref linkend="gnome-mime-data"/></para>
 
     <bridgehead renderas="sect4">Optional</bridgehead>
     <para role="optional"><xref linkend="samba3"/>,
@@ -85,9 +74,13 @@
     <xref linkend="gtk-doc"/>,
     <xref linkend="openssh"/>,
     <xref linkend="openssl"/> or
-    <ulink url="http://www.gnu.org/software/gnutls/">GnuTLS</ulink>,
+    <ulink url="http://www.gnu.org/software/gnutls/">GnuTLS</ulink>
+    (which needs <ulink
+    url="http://www.gnupg.org/(en)/download/index.html#libgpg-error">libgpg-error</ulink>
+    then <ulink
+    url="http://www.gnupg.org/(en)/download/index.html#libgcrypt">libgcrypt</ulink>),
     <xref linkend="heimdal"/> or <xref linkend="mitkrb"/>,
-    <ulink url="http://www.openafs.org/">OpenAFS</ulink> and
+    <ulink url="http://www.openafs.org/">OpenAFS</ulink>, and
     <ulink url="http://www.porchdogsoft.com/products/howl/">Howl</ulink></para>
 
   </sect2>
@@ -98,10 +91,10 @@
     <para>Install <application>GNOME Virtual File System</application>
     by running the following commands:</para>
 
-<screen><userinput>patch -Np1 -i ../gnome-vfs-&gnome-vfs-version;-samba_3.0.20-1.patch &&
-./configure --prefix=`pkg-config --variable=prefix ORBit-2.0` \
-    --libexecdir=`pkg-config --variable=prefix ORBit-2.0`/sbin \
-    --sysconfdir=/etc/gnome &&
+<screen><userinput>./configure --prefix=`pkg-config --variable=prefix ORBit-2.0` \
+    --libexecdir=`pkg-config \
+    --variable=prefix ORBit-2.0`/lib/gnome-vfs-2.0 \
+    --sysconfdir=&gnome-etc-dir; &&
 make</userinput></screen>
 
     <para>To test the results, issue: <command>make check</command>.</para>
@@ -115,13 +108,14 @@
   <sect2 role="commands">
     <title>Command Explanations</title>
 
-    <para><parameter>--sysconfdir=/etc/gnome</parameter>: This switch puts
-    configuration files in <filename class="directory">/etc/gnome</filename>
+    <para><parameter>--sysconfdir=&gnome-etc-dir;</parameter>: This switch puts
+    configuration files in <filename class="directory">&gnome-etc-dir;</filename>
     instead of <filename class="directory">$GNOME_PREFIX/etc</filename>.</para>
 
     <para><parameter>--libexecdir=`pkg-config --variable=prefix
-    ORBit-2.0`/sbin</parameter>: This switch puts libexec files in
-    <filename class="directory">$GNOME_PREFIX/sbin</filename> instead of
+    ORBit-2.0`/lib/gnome-vfs-2.0</parameter>: This switch puts libexec files in
+    <filename class="directory">$GNOME_PREFIX/lib/gnome-vfs-2.0</filename>
+    instead of
     <filename class="directory">$GNOME_PREFIX/libexec</filename>.</para>
 
     <para><command>rmdir `pkg-config --variable=prefix ORBit-2.0`/doc</command>:
@@ -134,6 +128,10 @@
     url="http://ca.geocities.com/jefftranter@rogers.com/eject.html">Eject</ulink>
     installed as the <command>eject</command> program is used by default.</para>
 
+    <para><option>--enable-gtk-doc</option>: Use this option if you have
+    <application>GTK-Doc</application> installed and wish to build the API
+    documentation.</para>
+
   </sect2>
 
   <sect2 role="content">
@@ -148,9 +146,9 @@
         <seg>gnomevfs-cat, gnomevfs-copy, gnomevfs-info, gnomevfs-ls,
         gnomevfs-mkdir, gnomevfs-mv, gnomevfs-rm, and gnome-vfs-daemon</seg>
         <seg>libgnomevfs-2.[so,a] and modules</seg>
-        <seg>/etc/gnome/gconf/schemas,
-        /etc/gnome/gconf/gconf.xml.defaults/[desktop,schemas,system],
-        /etc/gnome/gnome-vfs-2.0,
+        <seg>&gnome-etc-dir;/gconf/schemas,
+        &gnome-etc-dir;/gconf/gconf.xml.defaults/[desktop,schemas,system],
+        &gnome-etc-dir;/gnome-vfs-2.0,
         $GNOME_PREFIX/include/gnome-vfs-2.0,
         $GNOME_PREFIX/include/gnome-vfs-module-2.0,
         $GNOME_PREFIX/lib/gnome-vfs-2.0, and

Modified: trunk/BOOK/gnome/core/gnome2-user-docs.xml
===================================================================
--- trunk/BOOK/gnome/core/gnome2-user-docs.xml	2006-02-03 05:59:21 UTC (rev 5632)
+++ trunk/BOOK/gnome/core/gnome2-user-docs.xml	2006-02-03 06:07:48 UTC (rev 5633)
@@ -4,8 +4,8 @@
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
 
-  <!ENTITY gnome2-user-docs-download-http "http://ftp.gnome.org/pub/GNOME/sources/gnome2-user-docs/2.8/gnome2-user-docs-&gnome2-user-docs-version;.tar.bz2">
-  <!ENTITY gnome2-user-docs-download-ftp  "ftp://ftp.gnome.org/pub/GNOME/sources/gnome2-user-docs/2.8/gnome2-user-docs-&gnome2-user-docs-version;.tar.bz2">
+  <!ENTITY gnome2-user-docs-download-http "&gnome-download-http;/gnome2-user-docs/2.8/gnome2-user-docs-&gnome2-user-docs-version;.tar.bz2">
+  <!ENTITY gnome2-user-docs-download-ftp  "&gnome-download-ftp;/gnome2-user-docs/2.8/gnome2-user-docs-&gnome2-user-docs-version;.tar.bz2">
   <!ENTITY gnome2-user-docs-md5sum        "90bdd21ea3e3e794f641dd805216f275">
   <!ENTITY gnome2-user-docs-size          "1.0 MB">
   <!ENTITY gnome2-user-docs-buildsize     "6 MB">
@@ -86,7 +86,8 @@
     <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
 
 <screen role="root"><userinput>make install &&
-chmod -v 644 `pkg-config --variable=prefix ORBit-2.0`/share/gnome/help/\
+chmod -v 644 `pkg-config \
+--variable=prefix ORBit-2.0`/share/gnome/help/\
 {gnome-access-guide,system-admin-guide,user-guide}/C/*.xml</userinput></screen>
 
   </sect2>




More information about the blfs-book mailing list