r5275 - in trunk/BOOK: . introduction/welcome xsoft/suites

dj at linuxfromscratch.org dj at linuxfromscratch.org
Tue Nov 15 19:17:38 PST 2005


Author: dj
Date: 2005-11-15 20:17:35 -0700 (Tue, 15 Nov 2005)
New Revision: 5275

Modified:
   trunk/BOOK/general.ent
   trunk/BOOK/introduction/welcome/changelog.xml
   trunk/BOOK/xsoft/suites/openoffice.xml
Log:
Updated to OpenOffice-2.0.0

Modified: trunk/BOOK/general.ent
===================================================================
--- trunk/BOOK/general.ent	2005-11-14 05:42:00 UTC (rev 5274)
+++ trunk/BOOK/general.ent	2005-11-16 03:17:35 UTC (rev 5275)
@@ -1,4 +1,4 @@
-<!ENTITY day          "14">
+<!ENTITY day          "15">
 <!ENTITY month        "11">
 <!ENTITY year         "2005">
 <!ENTITY version      "svn-&year;&month;&day;">
@@ -466,7 +466,7 @@
 
 <!-- Chapter 34 -->
 <!ENTITY koffice-version              "1.4.1">
-<!ENTITY openoffice-version           "1.1.5">
+<!ENTITY openoffice-version           "2.0.0">
 
 <!-- Chapter 35 -->
 <!ENTITY mozilla-version              "1.7.11">

Modified: trunk/BOOK/introduction/welcome/changelog.xml
===================================================================
--- trunk/BOOK/introduction/welcome/changelog.xml	2005-11-14 05:42:00 UTC (rev 5274)
+++ trunk/BOOK/introduction/welcome/changelog.xml	2005-11-16 03:17:35 UTC (rev 5275)
@@ -42,6 +42,15 @@
 -->
 
     <listitem>
+      <para>November 15th, 2005</para>
+      <itemizedlist>
+        <listitem>
+          <para>[dj] - Updated to OpenOffice-2.0.0</para>
+        </listitem>
+      </itemizedlist>
+    </listitem>
+
+    <listitem>
       <para>November 14th, 2005</para>
       <itemizedlist>
         <listitem>

Modified: trunk/BOOK/xsoft/suites/openoffice.xml
===================================================================
--- trunk/BOOK/xsoft/suites/openoffice.xml	2005-11-14 05:42:00 UTC (rev 5274)
+++ trunk/BOOK/xsoft/suites/openoffice.xml	2005-11-16 03:17:35 UTC (rev 5275)
@@ -6,10 +6,10 @@
 
   <!ENTITY openoffice-download-http "http://download.openoffice.org/&openoffice-version;/source.html">
   <!ENTITY openoffice-download-ftp "ftp://ftp.ussg.iu.edu/pub/openoffice/stable/&openoffice-version;/OOo_&openoffice-version;_src.tar.gz">
-  <!ENTITY openoffice-md5sum        "1c8e860adae05087a53bdba5646962a9">
-  <!ENTITY openoffice-size          "213 MB">
-  <!ENTITY openoffice-buildsize     "3120 MB">
-  <!ENTITY openoffice-time          "70 SBU">
+  <!ENTITY openoffice-md5sum        "a68933afc2bf432d11b2043ac99ba0aa">
+  <!ENTITY openoffice-size          "263 MB">
+  <!ENTITY openoffice-buildsize     "5.7 GB">
+  <!ENTITY openoffice-time          "117 SBU">
 ]>
 
 <sect1 id="openoffice" xreflabel="OpenOffice-&openoffice-version;">
@@ -57,7 +57,7 @@
     <bridgehead renderas="sect3">Additional Downloads</bridgehead>
     <itemizedlist spacing='compact'>
       <listitem>
-        <para>Required patch for gcc-&gcc-version;: <ulink
+        <para>Required patch for use with gcc-&gcc-version;: <ulink
         url="&patch-root;/OOo_&openoffice-version;-gcc4-1.patch"/>
         </para>
       </listitem>
@@ -66,64 +66,82 @@
         url="&patch-root;/OOo_&openoffice-version;-nptl-1.patch"/></para>
       </listitem>
       <listitem>
-        <para>Required patch if compiling with
+        <para>Required patch for use  with
         <application>JDK</application>-&jdk-src-version;: <ulink
         url="&patch-root;/OOo_&openoffice-version;-jdk_1.5.0_fix-1.patch"/>
         </para>
       </listitem>
       <listitem>
-        <para>Required patch for STLport-4.6.2: <ulink
-        url="&patch-root;/OOo_&openoffice-version;-STLport_4.6.2-1.patch"/></para>
-      </listitem>
-      <listitem>
-        <para>Required patch for use with glibc-2.3.5: <ulink
-        url="&patch-root;/OOo_&openoffice-version;-doublefree-1.patch"/></para>
-      </listitem>
-      <listitem>
         <para>Optional patch if you wish to use the system freetype:
         <ulink
         url="&patch-root;/OOo_&openoffice-version;-freetype-1.patch"/></para>
       </listitem>
+
+<!--  To be added after verification
       <listitem>
         <para>Optional patch if
-        <application>Linux-PAM</application>-&Linux_PAM-version; is not installed:
-        <ulink
+        <application>Linux-PAM</application>-&Linux_PAM-version; is not 
+        installed: <ulink
         url="&patch-root;/OOo_&openoffice-version;-no_pam-1.patch"/></para>
-      </listitem>
+      </listitem> 
+-->
+
+<!--  Will be added after patch header is corrected. 
       <listitem>
-        <para>STLport-4.6.2: <ulink
-        url="http://www.stlport.org/archive/STLport-4.6.2.tar.gz"/></para>
+        <para>Optional patch if building against the system installed 
+        <application>Firefox</application>: <ulink 
+        url="&patch-root;/OOo_&openoffice-version;-xmlsec_no_mozilla-1.patch"/>
+        </para>
       </listitem>
+-->
       <listitem>
-        <para>The source TAR ball only contains English
-        language help. A localized help content file may be available at: <ulink
-        url="http://ftp.services.openoffice.org/pub/OpenOffice.org/contrib/helpcontent/"/>
+        <para>Required update for use with 
+        <application>JDK-&jdk-src-version;</application>.  <ulink 
+        url="ftp://anduin.linuxfromscratch.org/BLFS/svn/b/bsh-2.0b4-src.tar.bz2"/>
         </para>
       </listitem>
+      <listitem>
+        <para>Optional download if not using the system
+        <application>Mozilla</application>
+<!--        or <application>Firefox</application>  -->
+        browser.  <ulink 
+        url="ftp://ftp.mozilla.org/pub/mozilla.org/mozilla/releases/mozilla1.7.5/source/mozilla-source-1.7.5.tar.gz"/></para>
+      </listitem>
     </itemizedlist>
 
     <bridgehead renderas="sect3">OpenOffice Dependencies</bridgehead>
 
     <bridgehead renderas="sect4">Required</bridgehead>
-    <para>X (<xref linkend="xfree86"/> or <xref linkend="xorg"/>),
-    <xref linkend="zip"/>,
+    <para><xref linkend="zip"/>,
     <xref linkend="unzip"/>,
-    <xref linkend="tcsh"/>, and
-    <xref linkend="which"/>.</para>
+    <xref linkend="tcsh"/>,
+    <xref linkend="which"/>,
+    <xref linkend="jdk"/>,
+    <xref linkend="apache-ant"/>,
+    <xref linkend="pkgconfig"/>,
+    <xref linkend="perl-xml-parser"/>,
+    <xref linkend="perl-archive-zip"/>,
+    <xref linkend="libidl"/>, and
+    <xref linkend="libxml2"/>.</para>
 
     <bridgehead renderas="sect4">Recommended</bridgehead>
-    <para><xref linkend="jdk"/>,
-    <xref linkend="freetype2"/>,
-    <xref linkend="pkgconfig"/>,
+    <para><xref linkend="freetype2"/>,
     <xref linkend="startup-notification"/>,
     <xref linkend="desktop-file-utils"/>,
-    <xref linkend="apache-ant"/>,
     <xref linkend="libart_lgpl"/>, and
-    <xref linkend="curl"/>.</para>
+    <xref linkend="curl"/>, 
+    <xref linkend="libjpeg"/>, and
+    <xref linkend="libtiff"/>.</para>
 
     <bridgehead renderas="sect4">Optional</bridgehead>
-    <para><xref linkend="Linux_PAM"/> and
-    <xref linkend="nas"/>.</para>
+    <para><xref linkend="Linux_PAM"/>,
+    <xref linkend="nas"/>,
+    <xref linkend="python"/>,
+    <ulink url="http://www.webdav.org/neon/">neon-0.25.4</ulink>,
+    <xref linkend="unixodbc"/>,
+    <xref linkend="mozilla"/>, and
+<!--    <xref linkend="mozilla"/> or <xref linkend="firefox"/>, and -->
+    <xref linkend="sane"/>.</para>
 
   </sect2>
 
@@ -136,27 +154,49 @@
     do patch -Np1 -i ${PATCH}
 done</userinput></screen>
 
-    <para>Copy the STLport TAR ball into the source tree:</para>
+    <para>Copy the <application>Beanshell</application> TAR ball into the 
+    source tree and uncompress it:</para>
 
-<screen><userinput>cp ../STLport-4.6.2.tar.gz stlport/download/</userinput></screen>
+<screen><userinput>cp ../bsh-2.0b4.tar.bz2 beanshell/download/ &&
+bzip2 -d beanshell/download/bsh-2.0b4.tar.bz2</userinput></screen>
 
-    <para>STLport looks for the c++ headers in the wrong location. Put a
-    temporary symlink in place to satisfy STLport:</para>
+    <para>If not using the system-installed <application>Mozilla</application>
+    or <application>Firefox</application>, copy the 
+    <application>Mozilla</application> source TAR ball into the source 
+    tree:</para>
 
-    <para>As the <systemitem class="username">root</systemitem> user:</para>
+<screen><userinput>cp ../mozilla-1.7.5.tar.gz moz/download/</userinput></screen>
 
-<screen role="root"><userinput>ln -sf /usr/include/c++/&gcc-version; /usr/g++-v3</userinput></screen>
-
     <para>If you want to optimize the build, edit
-    <filename>solenv/inc/unxlngi4.mk</filename> and add the desired optimization
+    <filename>solenv/inc/unxlngi6.mk</filename> and add the desired optimization
     flags to the <envar>CFLAGSOPT</envar> variable. Some users have reported
     problems with <option>-fomit-frame-pointer</option>. The best option
     is to not use any custom optimizations. The following command removes an
     incorrect <option>-mcpu</option> option in the above file:</para>
 
 <screen><userinput>sed -i "s:\-mcpu=pentiumpro::" \
-    solenv/inc/unxlngi4.mk</userinput></screen>
+    solenv/inc/unxlngi6.mk</userinput></screen>
 
+<!-- To be removed before final release -->
+
+    <note><para>If you have previously installed Mozilla 
+<!--    or Firefox, -->
+    a change
+    may be needed to the installed headers.  As the root user, use these
+    commands to make the change if needed.</para></note>
+
+<!--    <para>Mozilla:</para> -->
+<screen role="root"><userinput>cd /usr/include/mozilla-&mozilla-version; &&
+grep "xptinfo_enum_1" xpcom/xptinfo.h || \
+    sed -i 's at enum@enum xptinfo_enum_1@' xpcom/xptinfo.h</userinput></screen>
+
+<!--    <para>Firefox:</para>
+<screen role="root"><userinput>cd /usr/include/firefox-&firefox-version; &&
+grep "xptinfo_enum_1" xpcom/xptinfo.h || \
+    sed -i 's at enum@enum xptinfo_enum_1@' xpcom/xptinfo.h</userinput></screen>
+-->
+<!-- End TBR -->
+
     <para>Configure <application>OpenOffice</application> using the following
     commands. You may build install sets for specific languages based on your
     preferences. Supply a comma separated list to the 
@@ -165,13 +205,34 @@
     If you need other languages, be sure to add <parameter>ENUS</parameter> 
     to the list; otherwise the build will fail:</para>
 
+<!--  To be added after xmlsec_no_mozilla patch header is corrected
+    <note><para>If you intend to use the system-installed 
+    <application>Mozilla</application> or 
+    <application>Firefox</application>, replace the 
+    <parameter> - - enable-build-mozilla</parameter> switch with
+    <parameter>- -with-system-mozilla</parameter>.  Additionally for 
+    <application>Firefox</application>, add the 
+    <parameter>- -with-firefox</parameter> switch. You will also be 
+    unable to use a <application>Thunderbird</application> address 
+    book as a data source if built against 
+    <application>Firefox</application>.</para></note>
+-->
+
+    <note><para>If you intend to use the system-installed
+    <application>Mozilla</application>, replace the
+    <parameter>--enable-build-mozilla</parameter> switch with
+    <parameter>--with-system-mozilla</parameter>.</para></note>
+
 <screen><userinput>cd config_office/ &&
-./configure --with-lang=ENUS \
-    --with-dict=ENUS --without-fonts \
-    --enable-libsn --with-system-zlib \
-    --with-system-freetype \
-    --with-system-curl --disable-fontooo \
-    --enable-libart &&
+./configure --prefix=/opt/openoffice-2.0.0 \
+    --enable-libart --enable-libsn \
+    --disable-fontooo --without-fonts \
+    --with-system-stdlibs --with-system-freetype \
+    --with-system-zlib --with-system-jpeg \
+    --with-system-expat --with-system-libxml \
+    --with-system-curl --enable-build-mozilla \
+    --with-build-version=BLFS \
+    --with-package-format=native --disable-binfilter &&
 cd ..</userinput></screen>
 
     <para><application>OpenOffice</application> fails to compile if
@@ -190,31 +251,31 @@
 . LinuxIntelEnv.Set.sh &&
 dmake</userinput></screen>
 
-    <para>If you have downloaded localized help content <filename>tgz</filename>
-    files, you will need to untar them to the appropriate directory as shown
-    below and then recreate the installation set:</para>
+    <para>Install <application>OpenOffice</application> as the 
+    <systemitem class="username">root</systemitem> user with the 
+    following commands:</para>
 
-<screen><userinput>for i in ../helpcontent_*_unix.tgz
-  do tar -C solver/645/unxlngi4.pro/pck -zxf $i
-  done &&
-rm -rf instsetoo/unxlngi4.pro &&
-bash -c "source LinuxIntelEnv.Set.sh ; dmake"</userinput></screen>
+<screen role="root"><userinput>cd instsetoo_native/unxlngi6.pro/OpenOffice/\
+install/en-US/linux-2.6-intel/buildroot/opt &&
+cp -a openoffice.org2.0 /opt/openoffice-2.0.0</userinput></screen>
 
-    <para>Install <application>OpenOffice</application> using the following
-    commands to install the US English language set. To install a localized
-    version, replace the 01 with the international telephone country code for
-    your country:</para>
+    <para>Still as the <systemitem class="username">root</systemitem> 
+    user:</para>
 
-<screen><userinput>cd instsetoo/unxlngi4.pro/01/normal &&
-sed -i "s:^oo_home=.*:oo_home=openoffice:" install</userinput></screen>
+<screen role="root"><userinput>for appl in sbase scalc sdraw simpress smath soffice spadmin swriter
+do 
+    ln -v -sf /opt/openoffice-2.0.0/program/$appl /usr/bin/$appl
+done</userinput></screen>
 
-    <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
+    <para>The icons are not installed by default.  While still the 
+    <systemitem class="username">root</systemitem> user, install the icons
+    with the following commands:</para>
 
-<screen role="root"><userinput>./install --prefix=/opt &&
-for appl in sagenda scalc sdraw sfax simpress slabel sletter \
-    smaster smath smemo soffice spadmin svcard sweb swriter
-  do ln -v -sf /opt/openoffice/program/$appl /usr/bin/$appl
-  done</userinput></screen>
+<screen role="root"><userinput>cd ../../../../../../../../sysui/desktop/icons &&
+install -v -d /usr/share/icons/{HighContrast,hicolor,locolor} -m755 &&
+cp -a HighContrast/*x* /usr/share/icons/HighContrast &&
+cp -a hicolor/*x* /usr/share/icons/hicolor &&
+cp -a locolor/*x* /usr/share/icons/locolor</userinput></screen>
 
     <para>If you have installed <xref linkend="desktop-file-utils"/> and use
     <application>KDE</application>, there is no furthur configuration
@@ -224,51 +285,81 @@
     commands as the <systemitem class="username">root</systemitem> user:</para>
 
 <screen role="root"><userinput>install -v -d /usr/share/applications -m 755 &&
-cp -v /opt/openoffice/share/gnome/net/ooo645*.desktop \
-    /usr/share/applications/ &&
-rename -v ooo645 ooo /usr/share/applications/ooo645*.desktop</userinput></screen>
+cd /opt/openoffice-2.0.0/share/xdg/ &&
+for appl in *.desktop
+do
+    sed -i '/Exec/d' $appl
+    echo "Exec=/usr/bin/s`echo $appl | sed 's/.desktop//'`" >> $appl
+    sed -i '/Icon/d' $appl
+    echo "Icon=`echo $appl | sed 's/.desktop//'`" >> $appl
+done &&
+sed -i 's at bin/sprinteradmin at bin/spadmin@' printeradmin.desktop &&
+cp *.desktop /usr/share/applications</userinput></screen>
 
+    <para>Finally, if you'd like to edit <application>OpenOffice</application>
+    documents directly from <application>Mozilla</application> or
+    <application>Firefox</application>, create a symbolic link in your 
+    plugins directory to 
+    <filename>/opt/openoffice-2.0.0/program/libnpsoplugin.so</filename>.
+    Additionally, you must enable the plugin from the 
+    <parameter>Internet Options</parameter> within any 
+    <application>OpenOffice</application> application.</para>
+
   </sect2>
 
   <sect2 role="commands">
     <title>Command Explanations</title>
 
-    <para><parameter>--with-lang=ENUS</parameter>: Make install set for the
-    US English language.</para>
-
-    <para><parameter>--with-dict=ENUS</parameter>: Install dictionaries for
-    the US English language.</para>
-
     <para><parameter>--enable-libart</parameter>: Use libart instead of gpc for
     polygon clipping.</para>
 
     <para><parameter>--enable-libsn</parameter>: Use
     <application>startup-notification</application>.</para>
 
+    <para><parameter>--disable-fontooo</parameter>: Use 
+    <application>Fontconfig</application> instead of FontOOo.</para>
+
     <para><parameter>--without-fonts</parameter>: Do not install Bitstream Vera
-    fonts since they are already bundled with <application>X</application>.</para>
+    fonts since they are already bundled with 
+    <application>X</application>.</para>
 
-    <para><parameter>--with-system-curl</parameter>: Use the system
-    installed curl.</para>
+    <para><parameter>--with-system-*</parameter>: Use the system libraries
+    and programs instead of building the packagees included in the build 
+    tree.</para>
 
-    <para><option>--disable-java</option>: Do not build components that need
-    java.</para>
+    <para><parameter>--enable-build-mozilla</parameter>: Build the in-tree
+    <application>Mozilla</application> suite.</para>
 
-    <para><option>--without-gpc</option>: Do not use gpc. Removes polygon
-    clipping capability.</para>
+    <para><parameter>--with-build-version=BLFS</parameter>:
+     appends "BLFS" to the end of the version string.</para>
 
-    <para><command>./bootstrap</command>: Create packages required to bootstrap
-    the build.</para>
+    <para><parameter>--with-package-format=native</parameter>: diables the
+    build of <application>RPM</application> packages.</para>
 
+    <para><parameter>--disable-binfilter</parameter>: disables the build of
+    legacy <application>StarOffice-5</application> import filters.</para>
+
+    <para><parameter>--with-firefox</parameter>: enables the use of 
+    <application>Firefox</application> in place of the full
+    <application>Mozilla</application> suite.  This will disable the use
+    of a <application>Thunderbird</application> address book as a data
+    source.</para>
+
+    <para><parameter>--with-lang=<replaceable>[LANG]</replaceable></parameter>:
+    Make install set for the desired language. ENUS is the default.</para>
+
+    <para><parameter>--with-dict=<replaceable>[LANG]</replaceable></parameter>:
+     Install dictionaries for the desired language. ENUS is the default.</para>
+
+    <para><command>./bootstrap</command>: Build the 
+    <application>dmake</application> utility required to complete the 
+    build.</para>
+
     <para><command>dmake</command>: Compile the package.</para>
 
-    <para><command>sed -i "s:^oo_home=...</command>: Remove version specific
-    installation directory.</para>
+    <para><command>for appl in *.desktop...</command>: Edit the *.desktop
+    files for use with a standard BLFS system.</para>
 
-    <para><command>for appl in sagenda scalc sdraw sfax ...;
-    do ...</command>: Create links so that the package can be started from the
-    command-line without changes to the existing path.</para>
-
   </sect2>
 
   <sect2 role="content">
@@ -280,11 +371,9 @@
       <segtitle>Installed Directory</segtitle>
 
       <seglistitem>
-        <seg>sagenda, scalc, sdraw, sfax, simpress, slabel,
-        sletter, smaster, smath, smemo, soffice, spadmin,
-        svcard, sweb, swriter, and support utilities</seg>
+        <seg>scalc, sdraw, simpress, smath, soffice, spadmin, and swriter.</seg>
         <seg><application>OpenOffice</application> libraries</seg>
-        <seg>/opt/openoffice</seg>
+        <seg>/opt/openoffice-2.0.0</seg>
       </seglistitem>
     </segmentedlist>
 
@@ -293,13 +382,12 @@
       <?dbfo list-presentation="list"?>
       <?dbhtml list-presentation="table"?>
 
-      <varlistentry id="sagenda">
-        <term><command>sagenda</command></term>
+      <varlistentry id="sbase">
+        <term><command>sbase</command></term>
         <listitem>
-          <para>create an agenda template and start
-          <command>swriter</command>.</para>
-          <indexterm zone="openoffice sagenda">
-            <primary sortas="b-sagenda">sagenda</primary>
+          <para>database application.</para>
+          <indexterm zone="openoffice sbase">
+            <primary sortas="b-sbase">sbase</primary>
           </indexterm>
         </listitem>
       </varlistentry>
@@ -324,17 +412,6 @@
         </listitem>
       </varlistentry>
 
-      <varlistentry id="sfax">
-        <term><command>sfax</command></term>
-        <listitem>
-          <para>create a fax template and start
-          <command>swriter</command>.</para>
-          <indexterm zone="openoffice sfax">
-            <primary sortas="b-sfax">sfax</primary>
-          </indexterm>
-        </listitem>
-      </varlistentry>
-
       <varlistentry id="simpress">
         <term><command>simpress</command></term>
         <listitem>
@@ -345,38 +422,6 @@
         </listitem>
       </varlistentry>
 
-      <varlistentry id="slabel">
-        <term><command>slabel</command></term>
-        <listitem>
-          <para>create a label template and start
-          <command>swriter</command>.</para>
-          <indexterm zone="openoffice slabel">
-            <primary sortas="b-slabel">slabel</primary>
-          </indexterm>
-        </listitem>
-      </varlistentry>
-
-      <varlistentry id="sletter">
-        <term><command>sletter</command></term>
-        <listitem>
-          <para>create a letter template and start
-          <command>swriter</command>.</para>
-          <indexterm zone="openoffice sletter">
-            <primary sortas="b-sletter">sletter</primary>
-          </indexterm>
-        </listitem>
-      </varlistentry>
-
-      <varlistentry id="smaster">
-        <term><command>smaster</command></term>
-        <listitem>
-          <para>creates a new master document.</para>
-          <indexterm zone="openoffice smaster">
-            <primary sortas="b-smaster">smaster</primary>
-          </indexterm>
-        </listitem>
-      </varlistentry>
-
       <varlistentry id="smath">
         <term><command>smath</command></term>
         <listitem>
@@ -387,17 +432,6 @@
         </listitem>
       </varlistentry>
 
-      <varlistentry id="smemo">
-        <term><command>smemo</command></term>
-        <listitem>
-          <para>create a memo template and start
-          <command>swriter</command>.</para>
-          <indexterm zone="openoffice smemo">
-            <primary sortas="b-smemo">smemo</primary>
-          </indexterm>
-        </listitem>
-      </varlistentry>
-
       <varlistentry id="soffice">
         <term><command>soffice</command></term>
         <listitem>
@@ -421,26 +455,6 @@
         </listitem>
       </varlistentry>
 
-      <varlistentry id="svcard">
-        <term><command>svcard</command></term>
-        <listitem>
-          <para>business card application.</para>
-          <indexterm zone="openoffice svcard">
-            <primary sortas="b-svcard">svcard</primary>
-          </indexterm>
-        </listitem>
-      </varlistentry>
-
-      <varlistentry id="sweb">
-        <term><command>sweb</command></term>
-        <listitem>
-          <para>an HTML editor.</para>
-          <indexterm zone="openoffice sweb">
-            <primary sortas="b-sweb">sweb</primary>
-          </indexterm>
-        </listitem>
-      </varlistentry>
-
       <varlistentry id="swriter">
         <term><command>swriter</command></term>
         <listitem>




More information about the blfs-book mailing list