r4595 - trunk/BOOK/gnome/otherlibs

randy at linuxfromscratch.org randy at linuxfromscratch.org
Mon Jun 13 18:12:13 PDT 2005


Author: randy
Date: 2005-06-13 19:12:12 -0600 (Mon, 13 Jun 2005)
New Revision: 4595

Modified:
   trunk/BOOK/gnome/otherlibs/gal1.xml
   trunk/BOOK/gnome/otherlibs/gconf1.xml
   trunk/BOOK/gnome/otherlibs/gdk.xml
   trunk/BOOK/gnome/otherlibs/gtkhtml1.xml
   trunk/BOOK/gnome/otherlibs/guppi.xml
   trunk/BOOK/gnome/otherlibs/libcapplet.xml
   trunk/BOOK/gnome/otherlibs/libghttp.xml
   trunk/BOOK/gnome/otherlibs/libglade14.xml
   trunk/BOOK/gnome/otherlibs/oaf.xml
   trunk/BOOK/gnome/otherlibs/otherlibs.xml
   trunk/BOOK/gnome/otherlibs/soup.xml
Log:
Updated GNOME-1.4 libraries to include: modification of the installation path to /opt/gnome-1.4, updated installed programs, libraries and directories, separated building and root installation instructions, adding test suite notes, updated build entities and added installation of documentation (where applicable) - commit 2 of 2

Modified: trunk/BOOK/gnome/otherlibs/gal1.xml
===================================================================
--- trunk/BOOK/gnome/otherlibs/gal1.xml	2005-06-14 01:11:21 UTC (rev 4594)
+++ trunk/BOOK/gnome/otherlibs/gal1.xml	2005-06-14 01:12:12 UTC (rev 4595)
@@ -5,11 +5,11 @@
   %general-entities;
 
   <!ENTITY gal1-download-http "http://ftp.gnome.org/pub/GNOME/sources/gal/&gal1-version;/gal-&gal1-version;.tar.bz2">
-  <!ENTITY gal1-download-ftp "ftp://ftp.gnome.org/pub/GNOME/sources/gal/&gal1-version;/gal-&gal1-version;.tar.bz2">
-  <!ENTITY gal1-md5sum "9f9790d4e8763c4ce74e5d59f47aa509">
-  <!ENTITY gal1-size "1.0 MB">
-  <!ENTITY gal1-buildsize "48 MB">
-  <!ENTITY gal1-time "1.04 SBU">
+  <!ENTITY gal1-download-ftp  "ftp://ftp.gnome.org/pub/GNOME/sources/gal/&gal1-version;/gal-&gal1-version;.tar.bz2">
+  <!ENTITY gal1-md5sum        "9f9790d4e8763c4ce74e5d59f47aa509">
+  <!ENTITY gal1-size          "1.0 MB">
+  <!ENTITY gal1-buildsize     "52 MB">
+  <!ENTITY gal1-time          "1.0 SBU">
 ]>
 
 <sect1 id="gal1" xreflabel="GAL-&gal1-version;">
@@ -59,10 +59,12 @@
     <bridgehead renderas="sect3">GAL Dependencies</bridgehead>
 
     <bridgehead renderas="sect4">Required</bridgehead>
-    <para><xref linkend="gnome-print"/> and <xref linkend="libglade14"/></para>
+    <para><xref linkend="gnome-print"/> and
+    <xref linkend="libglade14"/></para>
 
     <bridgehead renderas="sect4">Optional</bridgehead>
-    <para><xref linkend="gnome-vfs1"/></para>
+    <para><xref linkend="gnome-vfs1"/> and
+    <xref linkend="gtk-doc"/></para>
 
   </sect2>
 
@@ -72,16 +74,30 @@
     <para>Install <application>GAL</application> by running the
     following commands:</para>
 
-<screen><userinput>./configure --prefix=/opt/gnome --disable-gtk-doc &&
-make &&
-make install</userinput></screen>
+<screen><userinput>./configure --prefix=/opt/gnome-1.4 &&
+make</userinput></screen>
 
+    <para>If you have <application>GTK-Doc</application> installed and wish
+    to build the HTML documentation, issue the following commands:</para>
+
+<screen><userinput>cd docs &&
+make templates &&
+make sgml &&
+make html &&
+cd ..</userinput></screen>
+
+    <para>This package does not come with a test suite.</para>
+
+    <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
+
+<screen role='root'><userinput>make install</userinput></screen>
+
   </sect2>
 
   <sect2 role="commands">
     <title>Command Explanations</title>
 
-    <para><parameter>--prefix=/opt/gnome</parameter>: Installs
+    <para><parameter>--prefix=/opt/gnome-1.4</parameter>: Installs
     <application>GAL</application> in the
     <application>GNOME</application> 1.4 directory structure.</para>
 
@@ -98,7 +114,9 @@
       <seglistitem>
         <seg>None</seg>
         <seg>libgal.[so,a]</seg>
-        <seg>Not determined at this time</seg>
+        <seg>/opt/gnome-1.4/include/gal-1.0,
+        /opt/gnome-1.4/share/etable and
+        /opt/gnome-1.4/share/gal</seg>
       </seglistitem>
     </segmentedlist>
 

Modified: trunk/BOOK/gnome/otherlibs/gconf1.xml
===================================================================
--- trunk/BOOK/gnome/otherlibs/gconf1.xml	2005-06-14 01:11:21 UTC (rev 4594)
+++ trunk/BOOK/gnome/otherlibs/gconf1.xml	2005-06-14 01:12:12 UTC (rev 4595)
@@ -5,11 +5,11 @@
   %general-entities;
 
   <!ENTITY GConf1-download-http "http://ftp.gnome.org/pub/GNOME/sources/GConf/1.0/GConf-&GConf1-version;.tar.bz2">
-  <!ENTITY GConf1-download-ftp "ftp://ftp.gnome.org/pub/GNOME/sources/GConf/1.0/GConf-&GConf1-version;.tar.bz2">
-  <!ENTITY GConf1-md5sum "613aea1d9b7a9c504f52217451c7bf99">
-  <!ENTITY GConf1-size "772 KB">
-  <!ENTITY GConf1-buildsize "15 MB">
-  <!ENTITY GConf1-time "0.36">
+  <!ENTITY GConf1-download-ftp  "ftp://ftp.gnome.org/pub/GNOME/sources/GConf/1.0/GConf-&GConf1-version;.tar.bz2">
+  <!ENTITY GConf1-md5sum        "613aea1d9b7a9c504f52217451c7bf99">
+  <!ENTITY GConf1-size          "784 KB">
+  <!ENTITY GConf1-buildsize     "17 MB">
+  <!ENTITY GConf1-time          "0.3">
 ]>
 
 <sect1 id="GConf1" xreflabel="GConf-&GConf1-version;">
@@ -69,26 +69,41 @@
 
     <bridgehead renderas="sect4">Optional</bridgehead>
     <para><xref linkend="GTK"/>,
-    <xref linkend="db"/> and
-    <xref linkend="guile"/></para>
+    <xref linkend="db"/>,
+    <xref linkend="guile"/> and
+    <xref linkend="gtk-doc"/></para>
 
   </sect2>
 
   <sect2 role="installation">
     <title>Installation of GConf</title>
 
-    <para>If you have Berkeley DB installed apply the following
-    patch:</para>
+    <para>If you have <application>Berkeley DB</application> installed,
+    apply the following patch:</para>
 
 <screen><userinput>patch -Np1 -i ../GConf-&GConf1-version;-db43-2.patch</userinput></screen>
 
     <para>Install <application>GConf</application> by running the following
     commands:</para>
 
-<screen><userinput>./configure --prefix=/opt/gnome &&
-make &&
-make install</userinput></screen>
+<screen><userinput>./configure --prefix=/opt/gnome-1.4 &&
+make</userinput></screen>
 
+    <para>If you have <application>GTK-Doc</application> installed and wish to
+    build the HTML documentation, issue the following commands:</para>
+
+<screen><userinput>cd doc/gconf &&
+make templates &&
+make sgml &&
+make html &&
+cd ../..</userinput></screen>
+
+    <para>This package does not come with a test suite.</para>
+
+    <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
+
+<screen role='root'><userinput>make install</userinput></screen>
+
   </sect2>
 
   <sect2 role="content">
@@ -100,10 +115,14 @@
       <segtitle>Installed Directories</segtitle>
 
       <seglistitem>
-        <seg>gconf-config, gconfd-1, gconftool-1, and
-        gconf-sanity-check-1</seg>
-        <seg>libgconf.[so,a]</seg>
-        <seg>Not determined at this time</seg>
+        <seg>gconf-config, gconf-config-1, gconf-sanity-check-1, gconfd-1,
+        gconftool, gconftool-1</seg>
+        <seg>libgconf-1.[so,a], libgconf-gtk-1.[so,a] and
+        <application>GConf</application> backend modules</seg>
+        <seg>/opt/gnome-1.4/etc/gconf,
+        /opt/gnome-1.4/include/gconf,
+        /opt/gnome-1.4/lib/GConf and
+        /opt/gnome-1.4/share/gconf</seg>
       </seglistitem>
     </segmentedlist>
 
@@ -112,13 +131,13 @@
       <?dbfo list-presentation="list"?>
       <?dbhtml list-presentation="table"?>
 
-      <varlistentry id="libgconf1">
-        <term><filename class='libraryfile'>libgconf.[so,a]</filename></term>
+      <varlistentry id="libgconf-1">
+        <term><filename class='libraryfile'>libgconf-1.[so,a]</filename></term>
         <listitem>
           <para>provide the functions necessary to maintain the
           configuration database.</para>
-          <indexterm zone="GConf1 libgconf1">
-            <primary sortas="c-libgconf">libgconf.[so,a]</primary>
+          <indexterm zone="GConf1 libgconf-1">
+            <primary sortas="c-libgconf-1">libgconf-1.[so,a]</primary>
           </indexterm>
         </listitem>
       </varlistentry>

Modified: trunk/BOOK/gnome/otherlibs/gdk.xml
===================================================================
--- trunk/BOOK/gnome/otherlibs/gdk.xml	2005-06-14 01:11:21 UTC (rev 4594)
+++ trunk/BOOK/gnome/otherlibs/gdk.xml	2005-06-14 01:12:12 UTC (rev 4595)
@@ -5,11 +5,11 @@
   %general-entities;
 
   <!ENTITY gdk-download-http "http://ftp.gnome.org/pub/GNOME/sources/gdk-pixbuf/0.22/gdk-pixbuf-&gdk-version;.tar.bz2">
-  <!ENTITY gdk-download-ftp "ftp://ftp.gnome.org/pub/GNOME/sources/gdk-pixbuf/0.22/gdk-pixbuf-&gdk-version;.tar.bz2">
-  <!ENTITY gdk-md5sum "05fcb68ceaa338614ab650c775efc2f2">
-  <!ENTITY gdk-size "396 KB">
-  <!ENTITY gdk-buildsize "8.9 MB">
-  <!ENTITY gdk-time "0.32 SBU">
+  <!ENTITY gdk-download-ftp  "ftp://ftp.gnome.org/pub/GNOME/sources/gdk-pixbuf/0.22/gdk-pixbuf-&gdk-version;.tar.bz2">
+  <!ENTITY gdk-md5sum        "05fcb68ceaa338614ab650c775efc2f2">
+  <!ENTITY gdk-size          "398 KB">
+  <!ENTITY gdk-buildsize     "9 MB">
+  <!ENTITY gdk-time          "0.3 SBU">
 ]>
 
 <sect1 id="gdk" xreflabel="GDK Pixel Buffer-&gdk-version;">
@@ -77,10 +77,15 @@
     <para>Install <application>GDK Pixel Buffer</application>
     by running the following commands:</para>
 
-<screen><userinput>./configure --prefix=/opt/gnome --disable-gtk-doc &&
-make &&
-make install</userinput></screen>
+<screen><userinput>./configure --prefix=/opt/gnome-1.4 --disable-gtk-doc &&
+make</userinput></screen>
 
+    <para>To test the results, issue: <command>make check</command>.</para>
+
+    <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
+
+<screen role='root'><userinput>make install</userinput></screen>
+
   </sect2>
 
   <sect2 role="content">
@@ -92,10 +97,12 @@
       <segtitle>Installed Directories</segtitle>
 
       <seglistitem>
-        <seg>None</seg>
-        <seg>libgdk_pixbuf.[so,a], libgnomecanvaspixbuf.[so,a], and
-        many gdk-pixbuf loader modules</seg>
-        <seg>Not determined at this time</seg>
+        <seg>gdk-pixbuf-config</seg>
+        <seg>libgdk_pixbuf.[so,a], libgdk_pixbuf_xlib.[so,a],
+        libgnomecanvaspixbuf.[so,a], and many gdk-pixbuf loader modules</seg>
+        <seg>/opt/gnome-1.4/include/gdk-pixbuf-1.0,
+        /opt/gnome-1.4/lib/gdk-pixbuf and
+        /opt/gnome-1.4/share/gnome/html/gdk-pixbuf</seg>
       </seglistitem>
     </segmentedlist>
 
@@ -107,7 +114,7 @@
       <varlistentry id="libgdk_pixbuf1">
         <term><filename class='libraryfile'>libgdk_pixbuf.[so,a]</filename></term>
         <listitem>
-          <para>contain the <application>GTK+</application> pixel buffer
+          <para>contains the <application>GTK+</application> pixel buffer
           libraries for the <application>GIMP</application> Toolkit.</para>
           <indexterm zone="gdk libgdk_pixbuf1">
             <primary sortas="c-libgdk_pixbuf">libgdk_pixbuf.[so,a]</primary>

Modified: trunk/BOOK/gnome/otherlibs/gtkhtml1.xml
===================================================================
--- trunk/BOOK/gnome/otherlibs/gtkhtml1.xml	2005-06-14 01:11:21 UTC (rev 4594)
+++ trunk/BOOK/gnome/otherlibs/gtkhtml1.xml	2005-06-14 01:12:12 UTC (rev 4595)
@@ -5,11 +5,11 @@
   %general-entities;
 
   <!ENTITY gtkhtml1-download-http "http://ftp.gnome.org/pub/GNOME/sources/gtkhtml/1.1/gtkhtml-&gtkhtml1-version;.tar.bz2">
-  <!ENTITY gtkhtml1-download-ftp "ftp://ftp.gnome.org/pub/GNOME/sources/gtkhtml/1.1/gtkhtml-&gtkhtml1-version;.tar.bz2">
-  <!ENTITY gtkhtml1-md5sum "83cd60ab9a108d2a0d65b3bf760affa4">
-  <!ENTITY gtkhtml1-size "1.1 MB">
-  <!ENTITY gtkhtml1-buildsize "36 MB">
-  <!ENTITY gtkhtml1-time "1.51 SBU">
+  <!ENTITY gtkhtml1-download-ftp  "ftp://ftp.gnome.org/pub/GNOME/sources/gtkhtml/1.1/gtkhtml-&gtkhtml1-version;.tar.bz2">
+  <!ENTITY gtkhtml1-md5sum        "83cd60ab9a108d2a0d65b3bf760affa4">
+  <!ENTITY gtkhtml1-size          "1.0 MB">
+  <!ENTITY gtkhtml1-buildsize     "36 MB">
+  <!ENTITY gtkhtml1-time          "1.4 SBU">
 ]>
 
 <sect1 id="gtkhtml1" xreflabel="GtkHTML-&gtkhtml1-version;">
@@ -57,8 +57,7 @@
     <bridgehead renderas="sect3">Additional Downloads</bridgehead>
     <itemizedlist spacing='compact'>
       <listitem>
-        <para>Required Patch (if compiled with
-        <application>GCC</application>-3.4.x): <ulink
+        <para>Required Patch: <ulink
         url="&patch-root;/gtkhtml-&gtkhtml1-version;-gcc34-1.patch"/></para>
       </listitem>
     </itemizedlist>
@@ -84,16 +83,21 @@
     running the following commands:</para>
 
 <screen><userinput>patch -Np1 -i ../gtkhtml-&gtkhtml1-version;-gcc34-1.patch &&
-./configure --prefix=/opt/gnome --disable-gtk-doc &&
-make &&
-make install</userinput></screen>
+./configure --prefix=/opt/gnome-1.4 --disable-gtk-doc &&
+make</userinput></screen>
 
+    <para>This package does not come with a test suite.</para>
+
+    <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
+
+<screen role='root'><userinput>make install</userinput></screen>
+
   </sect2>
 
   <sect2 role="commands">
     <title>Command Explanations</title>
 
-    <para><parameter>--prefix=/opt/gnome</parameter>: Install
+    <para><parameter>--prefix=/opt/gnome-1.4</parameter>: Install
     <application>GtkHTML</application> in the
     <application>GNOME</application> 1.4 directory structure.</para>
 
@@ -108,9 +112,16 @@
       <segtitle>Installed Directories</segtitle>
 
       <seglistitem>
-        <seg>None</seg>
-        <seg><application>GNOME</application> 1.4 HTML rendering engine</seg>
-        <seg>Not determined at this time</seg>
+        <seg>ebrowser, gnome-gtkhtml-editor-1.1 and
+        gtkhtml-properties-capplet</seg>
+        <seg>libgtkhtml-1.1.[so,a], <application>Bonobo</application>
+        plugin modules and <application>Glade</application> rendering
+        components</seg>
+        <seg>/opt/gnome-1.4/include/gtkhtml-1.1,
+        /opt/gnome-1.4/share/control-center,
+        /opt/gnome-1.4/share/gnome/apps,
+        /opt/gnome-1.4/share/gnome/html/gtkhtml and
+        /opt/gnome-1.4/share/gtkhtml-1.1</seg>
       </seglistitem>
     </segmentedlist>
 

Modified: trunk/BOOK/gnome/otherlibs/guppi.xml
===================================================================
--- trunk/BOOK/gnome/otherlibs/guppi.xml	2005-06-14 01:11:21 UTC (rev 4594)
+++ trunk/BOOK/gnome/otherlibs/guppi.xml	2005-06-14 01:12:12 UTC (rev 4595)
@@ -5,11 +5,11 @@
   %general-entities;
 
   <!ENTITY guppi-download-http "http://ftp.gnome.org/pub/GNOME/sources/Guppi/0.40/Guppi-&guppi-version;.tar.bz2">
-  <!ENTITY guppi-download-ftp "ftp://ftp.gnome.org/pub/GNOME/sources/Guppi/0.40/Guppi-&guppi-version;.tar.bz2">
-  <!ENTITY guppi-md5sum "26ec6eb5b6fe7fb4e32ecff64d4f1b16">
-  <!ENTITY guppi-size "1.0 MB">
-  <!ENTITY guppi-buildsize "33 MB">
-  <!ENTITY guppi-time "1.35 SBU">
+  <!ENTITY guppi-download-ftp  "ftp://ftp.gnome.org/pub/GNOME/sources/Guppi/0.40/Guppi-&guppi-version;.tar.bz2">
+  <!ENTITY guppi-md5sum        "26ec6eb5b6fe7fb4e32ecff64d4f1b16">
+  <!ENTITY guppi-size          "1.0 MB">
+  <!ENTITY guppi-buildsize     "32 MB">
+  <!ENTITY guppi-time          "1.3 SBU">
 ]>
 
 <sect1 id="guppi" xreflabel="Guppi-&guppi-version;">
@@ -30,7 +30,7 @@
     <title>Introduction to Guppi</title>
 
     <para>The <application>Guppi</application> package contains a
-    <application>Guile</application> scriptable plot program with
+    <application>Guile</application> scriptable plot library with
     integrated statistics capabilities.</para>
 
     <bridgehead renderas="sect3">Package Information</bridgehead>
@@ -58,12 +58,11 @@
     <bridgehead renderas="sect3">Additional Downloads</bridgehead>
     <itemizedlist spacing='compact'>
       <listitem>
-        <para>Required Patch (if compiled with
-        <application>GCC</application>-3.4.x): <ulink
+        <para>Required Patch: <ulink
         url="&patch-root;/Guppi-&guppi-version;-gcc34-1.patch"/></para>
       </listitem>
       <listitem>
-        <para>Required Patch <ulink
+        <para>Required Patch: <ulink
         url="&patch-root;/Guppi-&guppi-version;-legend_fix-1.patch"/></para>
       </listitem>
     </itemizedlist>
@@ -71,7 +70,8 @@
     <bridgehead renderas="sect3">Guppi Dependencies</bridgehead>
 
     <bridgehead renderas="sect4">Required</bridgehead>
-    <para><xref linkend="gnome-print"/> and <xref linkend="libglade14"/></para>
+    <para><xref linkend="gnome-print"/> and
+    <xref linkend="libglade14"/></para>
 
     <bridgehead renderas="sect4">Optional</bridgehead>
     <para><xref linkend="bonobo14"/>,
@@ -88,16 +88,21 @@
 
 <screen><userinput>patch -Np1 -i ../Guppi-&guppi-version;-gcc34-1.patch &&
 patch -Np1 -i ../Guppi-&guppi-version;-legend_fix-1.patch &&
-./configure --prefix=/opt/gnome &&
-make &&
-make install</userinput></screen>
+./configure --prefix=/opt/gnome-1.4 &&
+make</userinput></screen>
 
+    <para>This package does not come with a test suite.</para>
+
+    <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
+
+<screen role='root'><userinput>make install</userinput></screen>
+
   </sect2>
 
   <sect2 role="commands">
     <title>Command Explanations</title>
 
-    <para><parameter>--prefix=/opt/gnome</parameter>: Installs
+    <para><parameter>--prefix=/opt/gnome-1.4</parameter>: Installs
     <application>Guppi</application> in the
     <application>GNOME</application> 1.4 directory structure.</para>
 
@@ -113,13 +118,16 @@
 
       <seglistitem>
         <seg>None</seg>
-        <seg>plotting libraries and plugins for
-        <application>GNOME</application> 1.4</seg>
-        <seg>Not determined at this time</seg>
+        <seg>libguppi.so, libguppitank.so and numerous plotting plugin
+        modules</seg>
+        <seg>/opt/gnome-1.4/include/gnome-1.0/libguppi,
+        /opt/gnome-1.4/lib/guppi,
+        /opt/gnome-1.4/share/gnome/help/guppi,
+        /opt/gnome-1.4/share/guppi and
+        /opt/gnome-1.4/share/pixmaps/guppi</seg>
       </seglistitem>
     </segmentedlist>
 
   </sect2>
 
 </sect1>
-

Modified: trunk/BOOK/gnome/otherlibs/libcapplet.xml
===================================================================
--- trunk/BOOK/gnome/otherlibs/libcapplet.xml	2005-06-14 01:11:21 UTC (rev 4594)
+++ trunk/BOOK/gnome/otherlibs/libcapplet.xml	2005-06-14 01:12:12 UTC (rev 4595)
@@ -5,11 +5,11 @@
   %general-entities;
 
   <!ENTITY libcapplet-download-http "http://ftp.gnome.org/pub/GNOME/sources/libcapplet/1.5/libcapplet-&libcapplet-version;.tar.bz2">
-  <!ENTITY libcapplet-download-ftp "ftp://ftp.gnome.org/pub/GNOME/sources/libcapplet/1.5/libcapplet-&libcapplet-version;.tar.bz2">
-  <!ENTITY libcapplet-md5sum "c6ba2bd6a08d82cba6b2b5360baab23c">
-  <!ENTITY libcapplet-size "312 KB">
-  <!ENTITY libcapplet-buildsize "2.8 MB">
-  <!ENTITY libcapplet-time "0.06 SBU">
+  <!ENTITY libcapplet-download-ftp  "ftp://ftp.gnome.org/pub/GNOME/sources/libcapplet/1.5/libcapplet-&libcapplet-version;.tar.bz2">
+  <!ENTITY libcapplet-md5sum        "c6ba2bd6a08d82cba6b2b5360baab23c">
+  <!ENTITY libcapplet-size          "312 KB">
+  <!ENTITY libcapplet-buildsize     "2.7 MB">
+  <!ENTITY libcapplet-time          "less than 0.1 SBU">
 ]>
 
 <sect1 id="libcapplet" xreflabel="libcapplet-&libcapplet-version;">
@@ -70,16 +70,21 @@
     <para>Install <application>libcapplet</application> by running the
     following commands:</para>
 
-<screen><userinput>./configure --prefix=/opt/gnome &&
-make &&
-make install</userinput></screen>
+<screen><userinput>./configure --prefix=/opt/gnome-1.4 &&
+make</userinput></screen>
 
+    <para>This package does not come with a test suite.</para>
+
+    <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
+
+<screen role='root'><userinput>make install</userinput></screen>
+
   </sect2>
 
   <sect2 role="commands">
     <title>Command Explanations</title>
 
-    <para><parameter>--prefix=/opt/gnome</parameter>: Installs
+    <para><parameter>--prefix=/opt/gnome-1.4</parameter>: Installs
     <application>libcapplet</application> in the
     <application>GNOME</application> 1.4 directory structure.</para>
 
@@ -90,17 +95,16 @@
 
     <segmentedlist>
       <segtitle>Installed Programs</segtitle>
-      <segtitle>Installed Libraries</segtitle>
-      <segtitle>Installed Directories</segtitle>
+      <segtitle>Installed Library</segtitle>
+      <segtitle>Installed Directory</segtitle>
 
       <seglistitem>
         <seg>None</seg>
-        <seg>libcapplet.[so,a</seg>
-        <seg>Not determined at this time</seg>
+        <seg>libcapplet.[so,a]</seg>
+        <seg>/opt/gnome-1.4/include/libcapplet-1.4</seg>
       </seglistitem>
     </segmentedlist>
 
   </sect2>
 
 </sect1>
-

Modified: trunk/BOOK/gnome/otherlibs/libghttp.xml
===================================================================
--- trunk/BOOK/gnome/otherlibs/libghttp.xml	2005-06-14 01:11:21 UTC (rev 4594)
+++ trunk/BOOK/gnome/otherlibs/libghttp.xml	2005-06-14 01:12:12 UTC (rev 4595)
@@ -5,11 +5,11 @@
   %general-entities;
 
   <!ENTITY libghttp-download-http "http://ftp.gnome.org/pub/GNOME/sources/libghttp/1.0/libghttp-&libghttp-version;.tar.gz">
-  <!ENTITY libghttp-download-ftp "ftp://ftp.gnome.org/pub/GNOME/sources/libghttp/1.0/libghttp-&libghttp-version;.tar.gz">
-  <!ENTITY libghttp-md5sum "0690e7456f9a15c635f240f3d6d5dab2">
-  <!ENTITY libghttp-size "148 KB">
-  <!ENTITY libghttp-buildsize "1.8 MB">
-  <!ENTITY libghttp-time "0.05 SBU">
+  <!ENTITY libghttp-download-ftp  "ftp://ftp.gnome.org/pub/GNOME/sources/libghttp/1.0/libghttp-&libghttp-version;.tar.gz">
+  <!ENTITY libghttp-md5sum        "0690e7456f9a15c635f240f3d6d5dab2">
+  <!ENTITY libghttp-size          "147 KB">
+  <!ENTITY libghttp-buildsize     "1.5 MB">
+  <!ENTITY libghttp-time          "less than 0.1 SBU">
 ]>
 
 <sect1 id="libghttp" xreflabel="libghttp-&libghttp-version;">
@@ -62,16 +62,23 @@
     <para>Install <application>libghttp</application> by running the following
     commands:</para>
 
-<screen><userinput>./configure --prefix=/opt/gnome &&
-make &&
-make install</userinput></screen>
+<screen><userinput>./configure --prefix=/opt/gnome-1.4 &&
+make</userinput></screen>
 
+    <para>This package does not come with a test suite.</para>
+
+    <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
+
+<screen role='root'><userinput>make install &&
+install -v -m644 -D doc/ghttp.html \
+    /opt/gnome-1.4/share/doc/libghttp-&libghttp-version;/ghttp.html</userinput></screen>
+
   </sect2>
 
   <sect2 role="commands">
     <title>Command Explanations</title>
 
-    <para><parameter>--prefix=/opt/gnome</parameter>: Installs
+    <para><parameter>--prefix=/opt/gnome-1.4</parameter>: Installs
     <application>libghttp</application> in the
     <application>GNOME</application> 1.4 directory structure.</para>
 
@@ -82,13 +89,13 @@
 
     <segmentedlist>
       <segtitle>Installed Programs</segtitle>
-      <segtitle>Installed Libraries</segtitle>
-      <segtitle>Installed Directories</segtitle>
+      <segtitle>Installed Library</segtitle>
+      <segtitle>Installed Directory</segtitle>
 
       <seglistitem>
         <seg>None</seg>
         <seg>libghttp.[so,a]</seg>
-        <seg>Not determined at this time</seg>
+        <seg>/opt/gnome-1.4/share/doc/libghttp-&libghttp-version;</seg>
       </seglistitem>
     </segmentedlist>
 

Modified: trunk/BOOK/gnome/otherlibs/libglade14.xml
===================================================================
--- trunk/BOOK/gnome/otherlibs/libglade14.xml	2005-06-14 01:11:21 UTC (rev 4594)
+++ trunk/BOOK/gnome/otherlibs/libglade14.xml	2005-06-14 01:12:12 UTC (rev 4595)
@@ -5,11 +5,11 @@
   %general-entities;
 
   <!ENTITY libglade14-download-http "http://ftp.gnome.org/pub/GNOME/sources/libglade/0.17/libglade-&libglade14-version;.tar.gz">
-  <!ENTITY libglade14-download-ftp "ftp://ftp.gnome.org/pub/GNOME/sources/libglade/0.17/libglade-&libglade14-version;.tar.gz">
-  <!ENTITY libglade14-md5sum "38b2e2cfd813783fe157617813bfe3b3">
-  <!ENTITY libglade14-size "416 KB">
-  <!ENTITY libglade14-buildsize "5.8 MB">
-  <!ENTITY libglade14-time "0.22 SBU">
+  <!ENTITY libglade14-download-ftp  "ftp://ftp.gnome.org/pub/GNOME/sources/libglade/0.17/libglade-&libglade14-version;.tar.gz">
+  <!ENTITY libglade14-md5sum        "38b2e2cfd813783fe157617813bfe3b3">
+  <!ENTITY libglade14-size          "418 KB">
+  <!ENTITY libglade14-buildsize     "5.9 MB">
+  <!ENTITY libglade14-time          "0.2 SBU">
 ]>
 
 <sect1 id="libglade14" xreflabel="libglade-&libglade14-version;">
@@ -62,8 +62,8 @@
     <bridgehead renderas="sect4">Optional</bridgehead>
     <para><xref linkend="gnome-libs"/>,
     <xref linkend="bonobo14"/>,
-    <xref linkend="python"/> and
-    <xref linkend="gtk-doc"/></para>
+    <xref linkend="python"/> (to run the <command>libglade-xgettext</command>
+    script) and <xref linkend="gtk-doc"/></para>
 
   </sect2>
 
@@ -78,10 +78,15 @@
     <para>Install <application>libglade</application> by running the following
     commands:</para>
 
-<screen><userinput>./configure --prefix=/opt/gnome --disable-gtk-doc &&
-make &&
-make install</userinput></screen>
+<screen><userinput>./configure --prefix=/opt/gnome-1.4 --disable-gtk-doc &&
+make</userinput></screen>
 
+    <para>This package does not come with a test suite.</para>
+
+    <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
+
+<screen role='root'><userinput>make install</userinput></screen>
+
   </sect2>
 
   <sect2 role="commands">
@@ -101,9 +106,11 @@
       <segtitle>Installed Directories</segtitle>
 
       <seglistitem>
-        <seg>None</seg>
-        <seg>libglade.[so,a]</seg>
-        <seg>Not determined at this time</seg>
+        <seg>libglade-config and libglade-xgettext</seg>
+        <seg>libglade.[so,a] and optionally, libglade-bonobo.[so,a] and
+        libglade-gnome.[so,a]</seg>
+        <seg>/opt/gnome-1.4/include/libglade-1.0 and
+        /opt/gnome-1.4/share/gnome/html/libglade</seg>
       </seglistitem>
     </segmentedlist>
 

Modified: trunk/BOOK/gnome/otherlibs/oaf.xml
===================================================================
--- trunk/BOOK/gnome/otherlibs/oaf.xml	2005-06-14 01:11:21 UTC (rev 4594)
+++ trunk/BOOK/gnome/otherlibs/oaf.xml	2005-06-14 01:12:12 UTC (rev 4595)
@@ -5,11 +5,11 @@
   %general-entities;
 
   <!ENTITY oaf-download-http "http://ftp.gnome.org/pub/GNOME/sources/oaf/0.6/oaf-&oaf-version;.tar.bz2">
-  <!ENTITY oaf-download-ftp "ftp://ftp.gnome.org/pub/GNOME/sources/oaf/0.6/oaf-&oaf-version;.tar.bz2">
-  <!ENTITY oaf-md5sum "ed9aa2ceb70bba34034b3134b22d2729">
-  <!ENTITY oaf-size "432 KB">
-  <!ENTITY oaf-buildsize "6.6 MB">
-  <!ENTITY oaf-time "0.23">
+  <!ENTITY oaf-download-ftp  "ftp://ftp.gnome.org/pub/GNOME/sources/oaf/0.6/oaf-&oaf-version;.tar.bz2">
+  <!ENTITY oaf-md5sum        "ed9aa2ceb70bba34034b3134b22d2729">
+  <!ENTITY oaf-size          "435 KB">
+  <!ENTITY oaf-buildsize     "7 MB">
+  <!ENTITY oaf-time          "0.2">
 ]>
 
 <sect1 id="oaf" xreflabel="OAF-&oaf-version;">
@@ -73,10 +73,23 @@
     following commands:</para>
 
 <screen><userinput>ldconfig &&
-./configure --prefix=/opt/gnome --disable-gtk-doc &&
-make &&
-make install</userinput></screen>
+./configure --prefix=/opt/gnome-1.4 --disable-gtk-doc &&
+make</userinput></screen>
 
+    <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
+
+<screen role='root'><userinput>make install &&
+install -v -m755 -d /opt/gnome-1.4/share/gtk-doc/html/oaf-&oaf-version; \
+                    /opt/gnome-1.4/share/doc/oaf-&oaf-version; &&
+install -v -m644 api-docs/html/* \
+    /opt/gnome-1.4/share/gtk-doc/html/oaf-&oaf-version; &&
+install -v -m644 docs/{INTERNALS,*.txt} \
+    /opt/gnome-1.4/share/doc/oaf-&oaf-version;</userinput></screen>
+
+    <para>To test the results, issue: <command>make check</command> as an
+    unprivileged user (the package must be installed before running the
+    tests, else many tests fail).</para>
+
   </sect2>
 
   <sect2 role="content">
@@ -88,13 +101,16 @@
       <segtitle>Installed Directories</segtitle>
 
       <seglistitem>
-        <seg>None</seg>
-        <seg>liboaf.[so,a]</seg>
-        <seg>Not determined at this time</seg>
+        <seg>oaf-client, oaf-config, oaf-empty-server, oaf-run-query,
+        oaf-slay, oaf-sysconf and oafd</seg>
+        <seg>liboaf.so</seg>
+        <seg>/opt/gnome-1.4/etc/oaf,
+        /opt/gnome-1.4/include/liboaf,
+        /opt/gnome-1.4/share/doc/oaf-0.6.10 and
+        /opt/gnome-1.4/share/gtk-doc/html/oaf-0.6.10</seg>
       </seglistitem>
     </segmentedlist>
 
   </sect2>
 
 </sect1>
-

Modified: trunk/BOOK/gnome/otherlibs/otherlibs.xml
===================================================================
--- trunk/BOOK/gnome/otherlibs/otherlibs.xml	2005-06-14 01:11:21 UTC (rev 4594)
+++ trunk/BOOK/gnome/otherlibs/otherlibs.xml	2005-06-14 01:12:12 UTC (rev 4595)
@@ -10,10 +10,10 @@
 
   <title>GNOME 1.4 Libraries</title>
 
-  <para>This section contains additional <application>GNOME</application> 1.4
+  <para>This section contains <application>GNOME</application> 1.4
   libraries, needed by some applications that have not yet been ported to
   <application>GNOME</application> 2.x. None of these libraries are needed for
-  a <application>GNOME</application> desktop install.</para>
+  a <application>GNOME</application> desktop installation.</para>
 
   <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="otherlibs-config.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2003/XInclude" href="orbit.xml"/>

Modified: trunk/BOOK/gnome/otherlibs/soup.xml
===================================================================
--- trunk/BOOK/gnome/otherlibs/soup.xml	2005-06-14 01:11:21 UTC (rev 4594)
+++ trunk/BOOK/gnome/otherlibs/soup.xml	2005-06-14 01:12:12 UTC (rev 4595)
@@ -5,11 +5,11 @@
   %general-entities;
 
   <!ENTITY soup-download-http "http://ftp.gnome.org/pub/GNOME/sources/soup/0.7/soup-&soup-version;.tar.bz2">
-  <!ENTITY soup-download-ftp "ftp://ftp.gnome.org/pub/GNOME/sources/soup/0.7/soup-&soup-version;.tar.bz2">
-  <!ENTITY soup-md5sum "61bb2fef816ce164af62f8a3a5bd782e">
-  <!ENTITY soup-size "324 KB">
-  <!ENTITY soup-buildsize "9.4 MB">
-  <!ENTITY soup-time "0.27">
+  <!ENTITY soup-download-ftp  "ftp://ftp.gnome.org/pub/GNOME/sources/soup/0.7/soup-&soup-version;.tar.bz2">
+  <!ENTITY soup-md5sum        "61bb2fef816ce164af62f8a3a5bd782e">
+  <!ENTITY soup-size          "323 KB">
+  <!ENTITY soup-buildsize     "7.8 MB">
+  <!ENTITY soup-time          "0.2">
 ]>
 
 <sect1 id="soup" xreflabel="Soup-&soup-version;">
@@ -57,8 +57,7 @@
     <bridgehead renderas="sect3">Additional Downloads</bridgehead>
     <itemizedlist spacing='compact'>
       <listitem>
-        <para>Required Patch (if compiled with
-        <application>GCC</application>-3.4.x): <ulink
+        <para>Required Patch: <ulink
         url="&patch-root;/soup-&soup-version;-gcc_3.4-1.patch"/></para>
       </listitem>
     </itemizedlist>
@@ -86,16 +85,21 @@
     commands:</para>
 
 <screen><userinput>patch -Np1 -i ../soup-&soup-version;-gcc_3.4-1.patch &&
-./configure --prefix=/opt/gnome &&
-make &&
-make install</userinput></screen>
+./configure --prefix=/opt/gnome-1.4 --disable-gtk-doc &&
+make</userinput></screen>
 
+    <para>This package does not come with a test suite.</para>
+
+    <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
+
+<screen role='root'><userinput>make install</userinput></screen>
+
   </sect2>
 
   <sect2 role="commands">
     <title>Command Explanations</title>
 
-    <para><parameter>--prefix=/opt/gnome</parameter>: Installs
+    <para><parameter>--prefix=/opt/gnome-1.4</parameter>: Installs
     <application>Soup</application> in the
     <application>GNOME</application> 1.4 directory structure.</para>
 
@@ -113,13 +117,13 @@
       <segtitle>Installed Directories</segtitle>
 
       <seglistitem>
-        <seg>None</seg>
-        <seg>SOAP libraries</seg>
-        <seg>Not determined at this time</seg>
+        <seg>soup-config, soup-httpd, soup-ssl-proxy and soup-wsdl</seg>
+        <seg>libsoup.[so,a], libsoup-apache.[so,a] and libwsdl.[so,a]</seg>
+        <seg>/opt/gnome-1.4/include/soup and
+        /opt/gnome-1.4/share/gtk-doc/html/soup</seg>
       </seglistitem>
     </segmentedlist>
 
   </sect2>
 
 </sect1>
-




More information about the blfs-book mailing list