r4733 - in trunk/BOOK: . introduction/welcome xsoft/office

randy at linuxfromscratch.org randy at linuxfromscratch.org
Sun Jul 17 12:48:28 PDT 2005


Author: randy
Date: 2005-07-17 13:48:28 -0600 (Sun, 17 Jul 2005)
New Revision: 4733

Modified:
   trunk/BOOK/general.ent
   trunk/BOOK/introduction/welcome/changelog.xml
   trunk/BOOK/xsoft/office/gnucash.xml
Log:
Updated to GnuCash-1.8.11

Modified: trunk/BOOK/general.ent
===================================================================
--- trunk/BOOK/general.ent	2005-07-17 15:16:23 UTC (rev 4732)
+++ trunk/BOOK/general.ent	2005-07-17 19:48:28 UTC (rev 4733)
@@ -424,7 +424,7 @@
 <!-- Chapter 33 -->
 <!ENTITY AbiWord-version              "2.2.8">
 <!ENTITY gnumeric-version             "1.4.3">
-<!ENTITY gnucash-version              "1.8.10">
+<!ENTITY gnucash-version              "1.8.11">
 <!ENTITY gimp-version                 "2.2.8">
 <!ENTITY evolution-version            "2.2.2">
 

Modified: trunk/BOOK/introduction/welcome/changelog.xml
===================================================================
--- trunk/BOOK/introduction/welcome/changelog.xml	2005-07-17 15:16:23 UTC (rev 4732)
+++ trunk/BOOK/introduction/welcome/changelog.xml	2005-07-17 19:48:28 UTC (rev 4733)
@@ -24,11 +24,15 @@
 
   <itemizedlist>
     
-	<listitem>
-		<para>July 17th 2005 [tushar]: Updated Notes on Building Software.</para>
-	</listitem>
+    <listitem>
+      <para>July 17th 2005 [randy]: Updated to GnuCash-1.8.11.</para>
+    </listitem>
 
     <listitem>
+      <para>July 17th 2005 [tushar]: Updated Notes on Building Software.</para>
+    </listitem>
+
+    <listitem>
       <para>July 14th, 2005 [randy]: Added Finance::QuoteHist module and
       dependencies to Perl Modules instructions.</para>
     </listitem>

Modified: trunk/BOOK/xsoft/office/gnucash.xml
===================================================================
--- trunk/BOOK/xsoft/office/gnucash.xml	2005-07-17 15:16:23 UTC (rev 4732)
+++ trunk/BOOK/xsoft/office/gnucash.xml	2005-07-17 19:48:28 UTC (rev 4733)
@@ -6,11 +6,11 @@
 
   <!ENTITY gnucash-download-http "http://www.gnucash.org/pub/gnucash/sources/stable/gnucash-&gnucash-version;.tar.gz">
   <!ENTITY gnucash-download-ftp  "ftp://ftp.at.gnucash.org/pub/gnucash/gnucash/sources/stable/gnucash-&gnucash-version;.tar.gz">
-  <!ENTITY gnucash-src-md5sum    "3ce22a3e4a1af75e3e206f073d923cfe">
+  <!ENTITY gnucash-src-md5sum    "62f94331936e37ed1b1d28b5a1863bb3">
   <!ENTITY gnucash-docs-md5sum   "9758d8e523530c2509912761e327a9d5">
-  <!ENTITY gnucash-size          "7.7 MB">
-  <!ENTITY gnucash-buildsize     "108 MB (additional 24 MB for Help documentation)">
-  <!ENTITY gnucash-time          "2.95 SBU">
+  <!ENTITY gnucash-size          "7.8 MB">
+  <!ENTITY gnucash-buildsize     "110 MB (additional 22 MB for Help documentation)">
+  <!ENTITY gnucash-time          "2.9 SBU">
   <!ENTITY gnucash-docs-version  "1.8.5">
   <!ENTITY gnucash-docs-download "http://www.gnucash.org/pub/gnucash/sources/stable/gnucash-docs-&gnucash-docs-version;.tar.gz">
 ]>
@@ -73,22 +73,22 @@
     <para><xref linkend="oaf"/>,
     <xref linkend="gal1"/>,
     <xref linkend="gtkhtml1"/>,
-    <xref linkend="libghttp"/> and
-    <xref linkend="gwrap"/></para>
+    <xref linkend="libghttp"/>,
+    <xref linkend="gwrap"/> and
+    <xref linkend="slib"/></para>
 
     <bridgehead renderas="sect4">Optional</bridgehead>
     <para><xref linkend="postgresql"/>,
     <xref linkend="guppi"/>,
     <xref linkend="scrollkeeper"/>,
+    <xref linkend="doxygen"/>,
+    <ulink url="http://www.graphviz.org/">GraphViz</ulink>,
     <ulink url="ftp://ftp.gnu.org/pub/gnu/guile/">Guile-www</ulink>,
-    <xref linkend="perl-modules"/>:
-    (LWP, HTML-Parser, DateManip and Finance-Quote),
-    <ulink url="http://www.graphviz.org/">GraphViz</ulink>,
-    <xref linkend="doxygen"/>,
     <ulink url="http://perens.com/FreeSoftware/">Electric Fence</ulink></para>
 
     <bridgehead renderas="sect4">Optional (for On-Line Banking)</bridgehead>
-    <para><ulink url="http://libofx.sourceforge.net/">LibOFX</ulink>,
+    <para><ulink url="http://libofx.sourceforge.net/">LibOFX</ulink> (requires
+    <xref linkend="opensp"/> and <xref linkend="curl"/>),
     <ulink url="http://sourceforge.net/projects/ktoblzcheck">KtoBlzCheck</ulink>,
     <ulink url="http://sourceforge.net/projects/aqhbci">AqHBCI</ulink>
     (requires
@@ -107,51 +107,60 @@
     <para>Install <application>GnuCash</application> by running the following
     commands:</para>
 
-<screen><userinput>./configure --prefix=/opt/gnome \
-    --sysconfdir=/etc --disable-guppi \
-    --disable-error-on-warning &&
-make &&
-make install &&
-chown -R root:root /opt/gnome/share/gnucash/doc/html/html</userinput></screen>
+<screen><userinput>./configure --prefix=/opt/gnome-1.4 \
+    --sysconfdir=/etc --disable-guppi &&
+make</userinput></screen>
 
-    <para><emphasis>Note:</emphasis> If you run <command>make check</command>
-    before installing the package, you may need to do it as the
-    <systemitem class="username">root</systemitem> user so that the
-    <application>Slib</application> catalog in <filename
-    class='directory'>/usr/share/guile</filename> can be updated.</para>
+    <para>To test the results, issue <command>make check</command> as the
+    <systemitem class="username">root</systemitem> user as the test suite will
+    attempt to update the <application>SLIB</application> catalog in
+    <filename class='directory'>/usr/share/guile</filename>.</para>
 
-    <para>If you want to install the Help documentation, and you have
-    <xref linkend="scrollkeeper"/> installed, unpack the additional tarball,
-    change into the <application>GnuCash Docs</application> source directory
-    and issue the following commands:</para>
+    <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
 
-<screen><userinput>./configure --prefix=/opt/gnome \
+<screen role='root'><userinput>make install &&
+chown -v -R root:root /opt/gnome-1.4/share/gnucash/doc/html/html</userinput></screen>
+
+    <para>If you want to install the Help documentation (requires
+    <xref linkend="scrollkeeper"/> to be installed), unpack the additional
+    tarball, change into the
+    <filename class='directory'>gnucash-docs-&gnucash-docs-version;</filename>
+    source directory and issue the following commands as an unprivileged
+    user:</para>
+
+<screen><userinput>./configure --prefix=/opt/gnome-1.4 \
     --localstatedir=/var/lib &&
-make &&
-make install</userinput></screen>
+make</userinput></screen>
 
+    <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
+
+<screen role='root'><userinput>make install</userinput></screen>
+
   </sect2>
 
   <sect2 role="commands">
     <title>Command Explanations</title>
 
-    <para><parameter>--prefix=/opt/gnome</parameter>:
+    <para><parameter>--prefix=/opt/gnome-1.4</parameter>:
     <application>GnuCash</application>-&gnucash-version; is a
-    <application>GNOME</application> 1.4 application.</para>
+    <application>GNOME</application>-1.4 application.</para>
 
     <para><parameter>--sysconfdir=/etc</parameter>: This installs configuration
     files in <filename class='directory'>/etc/gnucash</filename> instead of
-    <filename class='directory'>/opt/gnome/etc/gnucash</filename>.</para>
+    <filename class='directory'>/opt/gnome-1.4/etc/gnucash</filename>.</para>
 
     <para><parameter>--disable-guppi</parameter>: This compiles
     <application>GnuCash</application> without support for creating
     GUI graphs and plots. Remove this option if you have
     <application>Guppi</application> installed.</para>
 
-    <para><parameter>--disable-error-on-warning</parameter>: The build will fail
-    if you used <option>--enable-hbci</option>, as a warning is generated. This
-    option forces the build to ignore the warning.</para>
+    <!-- <para><parameter>-disable-error-on-warning</parameter>: The build will fail
+    if you used <option>-enable-hbci</option>, as a warning is generated. This
+    option forces the build to ignore the warning.</para> -->
 
+    <para><option>--enable-sql</option>: This parameter is required if you want
+    to build in SQL support using <application>PostgreSQL</application>.</para>
+
     <para><option>--enable-ofx</option>: This parameter is required if you want
     to build in on-line banking support using
     <application>LibOFX</application>.</para>
@@ -162,12 +171,6 @@
     <filename>doc/README.HBCI</filename> in the
     <application>GnuCash</application> source tree for complete information.</para>
 
-    <para><command>chown -R root:root
-    /opt/gnome/share/gnucash/doc/html/html</command>: If the package is built
-    by any user other than <systemitem class="username">root</systemitem>, the
-    ownership of the installed documentation files are set incorrectly. This
-    command changes the ownership to root:root.</para>
-
   </sect2>
 
   <sect2 role="configuration">
@@ -176,6 +179,13 @@
     <sect3>
       <title>Configuration Information</title>
 
+      <para>If you wish to use <application>GnuCash</application> to retrieve
+      stock price quotes and stock historical information, you'll need to 
+      install the following <application>Perl</application> modules:
+      <xref linkend="perl-lwp"/>, <xref linkend="perl-date-manip"/>,
+      <xref linkend="perl-html-parser"/>, <xref linkend="perl-finance-quote"/>
+      and <xref linkend="perl-finance-quotehist"/>.</para>
+
       <note>
         <para><application>GnuCash</application> must be run as
         <systemitem class="username">root</systemitem> once before use. Simply
@@ -199,9 +209,22 @@
       <segtitle>Installed Directories</segtitle>
 
       <seglistitem>
-        <seg>gnucash</seg>
-        <seg>None</seg>
-        <seg>Not determined at this time</seg>
+        <seg>dump-finance-quote, gnc-prices, gnc-test-env, gnucash,
+        gnucash-config, gnucash-env, gnucash-make-guids, gnucash-run-script
+        and update-finance-quote</seg>
+        <seg>libcore-utils.so, libgnc-app-file-gnome.so, libgncgnome.so,
+        libgncmodule.so, libgw-core-utils.so, libgw-gnc.so and numerous
+        support libraries installed in
+        <filename class='directory'>/opt/gnome-1.4/lib/gnucash</filename></seg>
+        <seg>/etc/gnucash,
+        /opt/gnome-1.4/include/gnucash,
+        /opt/gnome-1.4/lib/gnucash,
+        /opt/gnome-1.4/libexec/gnucash,
+        /opt/gnome-1.4/share/gnome/apps/Applications,
+        /opt/gnome-1.4/share/gnome/help/gnucash,
+        /opt/gnome-1.4/share/gnucash,
+        /opt/gnome-1.4/share/omf/gnucash-docs and
+        /opt/gnome-1.4/share/pixmaps/gnucash</seg>
       </seglistitem>
     </segmentedlist>
 




More information about the blfs-book mailing list