[Bug 1157] Linux-PAM has cracklib listed as optional dependency

blfs-bugs at linuxfromscratch.org blfs-bugs at linuxfromscratch.org
Wed Jan 12 20:08:06 PST 2005


http://blfs-bugs.linuxfromscratch.org/show_bug.cgi?id=1157





------- Additional Comments From dj at linuxfromscratch.org  2005-01-12 21:08 -------
Adding untested patch.  Currently unable to test, but it will work to kill the
error, but I don't know about the build.  Assumptons are bad, but I'd assume if
HAVE_LIBCRACK were set to "NO" then the cracklib module would not be built...if
that is not the case, then it should be extended to make the check for
"HAVE_LIBCRACK" in the cracklib dir makefile.  This could easily be attached to
the linkage patch with the rest of them.

--- Linux-PAM-0.78/configure.in.old  2005-01-11 22:46:04.679482864 -0600
+++ Linux-PAM-0.78/configure.in  2005-01-11 22:46:53.381079096 -0600 @@ -278,7
+278,7 @@
       done
 done
 if test -z "$CRACKLIB_DICTPATH" ; then
-      AC_MSG_ERROR(none found)
+      AC_MSG_RESULT(none found)
 else
       AC_MSG_RESULT($CRACKLIB_DICTPATH)
 fi





------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.
You are the QA contact for the bug, or are watching the QA contact.



More information about the blfs-book mailing list