[Bug 1157] Linux-PAM has cracklib listed as optional dependency

DJ Lucas dj at linuxfromscratch.org
Tue Jan 11 20:50:45 PST 2005


On Tue, 2005-01-11 at 22:42 -0600, DJ Lucas wrote:

> 
> Well my explanation was just plain wrong in the previous post WRT to
> HAVE_FASCIST_CHECK, but anyways, looks like the exit1's were not in the
> old version, and don't look to be necessary in this version either on
> first look.

How simple that was....this should work.  Just apply before running
autoconf:

--- Linux-PAM-0.78/configure.in.old     2005-01-11 22:46:04.679482864
-0600
+++ Linux-PAM-0.78/configure.in 2005-01-11 22:46:53.381079096 -0600
@@ -278,7 +278,7 @@
       done
 done
 if test -z "$CRACKLIB_DICTPATH" ; then
-      AC_MSG_ERROR(none found)
+      AC_MSG_RESULT(none found)
 else
       AC_MSG_RESULT($CRACKLIB_DICTPATH)
 fi



-- DJ Lucas




More information about the blfs-book mailing list