r3249 - in trunk: BOOK BOOK/content/databases BOOK/content/web BOOK/general/prog BOOK/gnome/otherlibs BOOK/introduction/welcome BOOK/kde/add BOOK/server/mail BOOK/template patches

igor at linuxfromscratch.org igor at linuxfromscratch.org
Mon Jan 10 14:41:28 PST 2005


Author: igor
Date: 2005-01-10 15:41:26 -0700 (Mon, 10 Jan 2005)
New Revision: 3249

Added:
   trunk/patches/GConf-1.0.9-db43.patch
   trunk/patches/Python-2.4-db43.patch
   trunk/patches/exim-4.43-db43.patch
   trunk/patches/kdesdk-3.3.2-db43.patch
   trunk/patches/php-5.0.3-db43.patch
Modified:
   trunk/BOOK/content/databases/db.xml
   trunk/BOOK/content/web/php.xml
   trunk/BOOK/general.ent
   trunk/BOOK/general/prog/python.xml
   trunk/BOOK/gnome/otherlibs/gconf1.xml
   trunk/BOOK/introduction/welcome/changelog.xml
   trunk/BOOK/kde/add/kdesdk.xml
   trunk/BOOK/server/mail/exim.xml
   trunk/BOOK/template/template.xml
   trunk/patches/gcc-3.3.4-no_fixincludes-1.patch
Log:
Updated to Berkeley DB-4.3.27.

Modified: trunk/BOOK/content/databases/db.xml
===================================================================
--- trunk/BOOK/content/databases/db.xml	2005-01-10 21:43:20 UTC (rev 3248)
+++ trunk/BOOK/content/databases/db.xml	2005-01-10 22:41:26 UTC (rev 3249)
@@ -5,10 +5,10 @@
   %general-entities;
 
   <!ENTITY db-download-http " ">
-  <!ENTITY db-download-ftp  "ftp://sleepycat1.inetu.net/releases/db-4.2.52.tar.gz">
-  <!ENTITY db-size          "4.1 MB">
+  <!ENTITY db-download-ftp  "ftp://sleepycat1.inetu.net/releases/db-&db-version;.tar.gz">
+  <!ENTITY db-size          "5.7 MB">
   <!ENTITY db-buildsize     "68 MB">
-  <!ENTITY db-time          "1.22 SBU">
+  <!ENTITY db-time          "1.23 SBU">
 ]>
 
 <sect1 id="db" xreflabel="Berkeley DB-&db-version;">
@@ -39,15 +39,6 @@
 &db-time;</para></listitem></itemizedlist>
 </sect3>
 
-<sect3><title>Additional downloads</title>   
-<itemizedlist spacing='compact'>    
-<listitem><para>Required Patch: <ulink     
-url="http://www.sleepycat.com/update/4.2.52/patch.4.2.52.1"/></para></listitem>   
-<listitem><para>Required Patch: <ulink   
-url="http://www.sleepycat.com/update/4.2.52/patch.4.2.52.2"/></para>    
-</listitem></itemizedlist>     
-</sect3>
-
 <sect3><title><application>Berkeley DB</application> dependencies</title>
 <sect4><title>Optional</title>
 <para><xref linkend="tcl"/> and <xref linkend="j2sdk"/>
@@ -62,9 +53,7 @@
 <para>Install <application>Berkeley DB</application> by running the following 
 commands:</para>
 
-<screen><userinput><command>patch -Np0 -i ../patch.4.2.52.1 &&
-patch -Np0 -i ../patch.&db-version; &&
-cd build_unix &&
+<screen><userinput><command>cd build_unix &&
 ../dist/configure --prefix=/usr \
     --enable-compat185 \
     --enable-cxx &&
@@ -79,7 +68,7 @@
 
 <screen><userinput><command>chown root:root /usr/bin/db_* \
 /usr/lib/libdb* /usr/include/db* &&
-chown -R root:root /usr/share/doc/db-4.2.52.2</command></userinput></screen>
+chown -R root:root /usr/share/doc/db-&db-version;</command></userinput></screen>
 
 </sect2>
 

Modified: trunk/BOOK/content/web/php.xml
===================================================================
--- trunk/BOOK/content/web/php.xml	2005-01-10 21:43:20 UTC (rev 3248)
+++ trunk/BOOK/content/web/php.xml	2005-01-10 22:41:26 UTC (rev 3249)
@@ -36,6 +36,13 @@
 <listitem><para>Estimated build time: &php-time;</para></listitem></itemizedlist>
 </sect3>
 
+<sect3><title>Additional downloads</title>
+<itemizedlist spacing="compact">
+<listitem><para>Required patch for Berkeley DB: <ulink 
+url="&patch-root;/php-&php-version;-db43-1.patch"/></para>
+</listitem></itemizedlist>
+</sect3>
+
 <sect3><title><application><acronym>PHP</acronym></application> dependencies</title>
 <sect4><title>Required</title>
 <para>
@@ -103,6 +110,11 @@
 setting up <application><acronym>PHP</acronym></application> for
 server-side scripting as it is the most common form.</para></note>
 
+<para>If you have Berkeley DB installed and wish to utilize it, apply
+the following patch:</para>
+
+<screen><userinput><command>patch -Np1 ../php-&php-version;-db43-1.patch</command></userinput></screen>
+
 <para>Install <application><acronym>PHP</acronym></application> by
 running the following commands:</para>
 

Modified: trunk/BOOK/general/prog/python.xml
===================================================================
--- trunk/BOOK/general/prog/python.xml	2005-01-10 21:43:20 UTC (rev 3248)
+++ trunk/BOOK/general/prog/python.xml	2005-01-10 22:41:26 UTC (rev 3249)
@@ -40,6 +40,8 @@
 <itemizedlist spacing='compact'>
 <listitem><para>Required patch: <ulink
 url="&patch-root;/Python-&Python-version;-gdbm-1.patch"/></para></listitem>
+<listitem><para>Required patch for Berkeley DB: <ulink
+url="&patch-root;/Python-&Python-version;-db43-1.patch"/></para></listitem>
 </itemizedlist>
 </sect3>
 
@@ -57,6 +59,11 @@
 <sect2>
 <title>Installation of <application>Python</application></title>
 
+<para>If you have Berkeley DB installed and wish to utilize it, apply
+the following patch:</para>
+
+<screen><userinput><command>patch -Np1 ../Python-&Python-version;-db43-1.patch</command></userinput></screen>
+
 <para>Install <application>Python</application> by running the following
 commands:</para>
 

Modified: trunk/BOOK/general.ent
===================================================================
--- trunk/BOOK/general.ent	2005-01-10 21:43:20 UTC (rev 3248)
+++ trunk/BOOK/general.ent	2005-01-10 22:41:26 UTC (rev 3249)
@@ -258,7 +258,7 @@
                                      
 <!-- Part VII -->                    
 <!-- Chapter 23 -->                  
-<!ENTITY db-version                   "4.2.52.2">  
+<!ENTITY db-version                   "4.3.27">  
 <!ENTITY db-3.3-version               "3.3.11">  
 <!ENTITY mysql-version                "4.1.8a">   
 <!ENTITY postgresql-version           "7.4.6"> 

Modified: trunk/BOOK/gnome/otherlibs/gconf1.xml
===================================================================
--- trunk/BOOK/gnome/otherlibs/gconf1.xml	2005-01-10 21:43:20 UTC (rev 3248)
+++ trunk/BOOK/gnome/otherlibs/gconf1.xml	2005-01-10 22:41:26 UTC (rev 3249)
@@ -40,6 +40,13 @@
 &GConf1-time;</para></listitem></itemizedlist>
 </sect3>
 
+<sect3><title>Additional downloads</title>
+<itemizedlist spacing="compact">
+<listitem><para>Required patch for Berkeley DB: <ulink 
+url="&patch-root;/GConf-&GConf1-version;-db43-1.patch"/></para>
+</listitem></itemizedlist>
+</sect3>
+
 <sect3><title><application>GConf</application> dependencies</title>
 <sect4><title>Required</title>
 <para><xref linkend="oaf"/> and <xref linkend="popt"/></para>
@@ -47,7 +54,7 @@
 
 <sect4><title>Optional</title>
 <para><xref linkend="GTK"/>, 
-<xref linkend="db-3.3"/> and 
+<xref linkend="db"/> and 
 <xref linkend="guile"/></para>
 </sect4>
 </sect3>
@@ -57,6 +64,11 @@
 <sect2>
 <title>Installation of <application>GConf</application></title>
 
+<para>If you have Berkeley DB installed apply the following
+patch:</para>
+
+<screen><userinput><command>patch -Np1 ../GConf-&GConf1-version;-db43-1.patch</command></userinput></screen>
+
 <para>Install <application>GConf</application> by running the following 
 commands:</para>
 

Modified: trunk/BOOK/introduction/welcome/changelog.xml
===================================================================
--- trunk/BOOK/introduction/welcome/changelog.xml	2005-01-10 21:43:20 UTC (rev 3248)
+++ trunk/BOOK/introduction/welcome/changelog.xml	2005-01-10 22:41:26 UTC (rev 3249)
@@ -23,7 +23,7 @@
 <itemizedlist>
 
 <listitem><para>January 10th, 2005 [igor]: Updated to
-OpenLDAP-2.2.20.</para></listitem>
+OpenLDAP-2.2.20 and Berkeley DB-4.3.27.</para></listitem>
 
 <listitem><para>January 10th, 2005 [randy]: Updated to Sendmail-8.13.2; 
 added index tags to the ASH, ZSH and Tcsh instructions.</para></listitem>

Modified: trunk/BOOK/kde/add/kdesdk.xml
===================================================================
--- trunk/BOOK/kde/add/kdesdk.xml	2005-01-10 21:43:20 UTC (rev 3248)
+++ trunk/BOOK/kde/add/kdesdk.xml	2005-01-10 22:41:26 UTC (rev 3249)
@@ -37,6 +37,13 @@
 &kdesdk-time;</para></listitem></itemizedlist>
 </sect3>
 
+<sect3><title>Additional downloads</title>
+<itemizedlist spacing="compact">
+<listitem><para>Required patch for Berkeley DB: <ulink 
+url="&patch-root;/kdesdk-&kdesdk-version;-db43-1.patch"/></para>
+</listitem></itemizedlist>
+</sect3>
+
 <sect3><title><application>kdesdk</application> dependencies</title>
 <sect4><title>Required</title>
 <para><xref linkend="kdebase"/></para>
@@ -54,6 +61,11 @@
 <sect2>
 <title>Installation of <application>kdesdk</application></title>
 
+<para>If you have Berkeley DB installed, apply
+the following patch:</para>
+
+<screen><userinput><command>patch -Np1 ../kdesdk-&kdesdk-version;-db43-1.patch</command></userinput></screen>
+
 <para>Install <application>kdesdk</application> with:</para>
 
 <screen><userinput><command>./configure --prefix=&kde-dir; --disable-debug \

Modified: trunk/BOOK/server/mail/exim.xml
===================================================================
--- trunk/BOOK/server/mail/exim.xml	2005-01-10 21:43:20 UTC (rev 3248)
+++ trunk/BOOK/server/mail/exim.xml	2005-01-10 22:41:26 UTC (rev 3249)
@@ -40,6 +40,13 @@
 &exim-time;</para></listitem></itemizedlist>
 </sect3>
 
+<sect3><title>Additional downloads</title>
+<itemizedlist spacing="compact">
+<listitem><para>Required patch for Berkeley DB: <ulink 
+url="&patch-root;/exim-&exim-version;-db43-1.patch"/></para>
+</listitem></itemizedlist>
+</sect3>
+
 <sect3><title><application>Exim</application> dependencies</title>
 <sect4><title>Required</title>
 <para><xref linkend="db"/> or 
@@ -69,6 +76,11 @@
 create the group and user exim which will run the 
 <command>exim</command> daemon:</para>
 
+<para>If you have Berkeley DB installed, apply
+the following patch:</para>
+
+<screen><userinput><command>patch -Np1 ../exim-&exim-version;-db43-1.patch</command></userinput></screen>
+
 <screen><userinput><command>groupadd exim &&
 useradd -d /dev/null -c "Exim Daemon" -g exim -s /bin/false exim</command></userinput></screen>
 

Modified: trunk/BOOK/template/template.xml
===================================================================
--- trunk/BOOK/template/template.xml	2005-01-10 21:43:20 UTC (rev 3248)
+++ trunk/BOOK/template/template.xml	2005-01-10 22:41:26 UTC (rev 3249)
@@ -50,7 +50,7 @@
 
 <sect3><title>Additional downloads</title>
 <itemizedlist spacing="compact">
-<listitem><para>Required Patch: <ulink 
+<listitem><para>Required patch: <ulink 
 url="&patch-root;/TEMPLATE-&TEMPLATE-version;-patch_name-patch_version.patch"/></para>
 </listitem></itemizedlist>
 </sect3>

Added: trunk/patches/GConf-1.0.9-db43.patch
===================================================================
--- trunk/patches/GConf-1.0.9-db43.patch	2005-01-10 21:43:20 UTC (rev 3248)
+++ trunk/patches/GConf-1.0.9-db43.patch	2005-01-10 22:41:26 UTC (rev 3249)
@@ -0,0 +1,84 @@
+Submitted By:            Igor Zivkovic <igor at linuxfromscratch.org>
+Date:                    2005-01-10
+Initial Package Version: 1.0.9
+Upstream Status:         Not submitted.
+Origin:                  http://www.sleepycat.com/docs/ref/upgrade.4.0/lock.html
+                         http://www.sleepycat.com/docs/ref/upgrade.4.1/fop.html
+Description:             Adds support for Berkeley DB-4.3.x.
+
+$LastChangedBy$
+$Date$
+
+--- GConf-1.0.9/configure.orig	2005-01-10 16:11:34.673838384 +0000
++++ GConf-1.0.9/configure	2005-01-10 16:11:48.740699896 +0000
+@@ -7945,7 +7945,7 @@
+ BDB_LIBS=
+ BDB_CFLAGS=
+ 
+-for dblib in db-3.3 db-3.2 db-3.1 db-3; do
++for dblib in db db-3.3 db-3.2 db-3.1 db-3; do
+   as_ac_Lib=`echo "ac_cv_lib_$dblib''_db_env_create" | $as_tr_sh`
+ echo "$as_me:7950: checking for db_env_create in -l$dblib" >&5
+ echo $ECHO_N "checking for db_env_create in -l$dblib... $ECHO_C" >&6
+@@ -8010,7 +8010,7 @@
+ echo "$as_me: WARNING: No db3 library found. Not building bdb backend." >&2;}
+ else
+ 
+-for ac_header in db3/db.h
++for ac_header in db.h
+ do
+ as_ac_Header=`echo "ac_cv_header_$ac_header" | $as_tr_sh`
+ echo "$as_me:8016: checking for $ac_header" >&5
+--- GConf-1.0.9/backends/bdb.h.orig	2005-01-10 16:13:16.876301248 +0000
++++ GConf-1.0.9/backends/bdb.h	2005-01-10 16:13:35.797424800 +0000
+@@ -116,11 +116,7 @@
+ 
+ #ifndef BDB_H
+ 
+-#ifdef HAVE_DB3_DB_H
+-#include <db3/db.h>
+-#else
+ #include <db.h>
+-#endif
+ #include <glib.h>
+ #include <gconf/gconf.h>
+ 
+--- GConf-1.0.9/backends/bdb.c.orig	2001-10-17 03:43:01.000000000 +0000
++++ GConf-1.0.9/backends/bdb.c	2005-01-10 21:24:49.676852808 +0000
+@@ -154,7 +154,7 @@
+ 	       dbname);
+ #endif
+     }
+-  if ((ret = dbp->open (dbp, dbname, NULL, DB_BTREE, flags, 0664)) != 0)
++  if ((ret = dbp->open (dbp, NULL, dbname, NULL, DB_BTREE, flags | DB_AUTO_COMMIT, 0664)) != 0)
+     {
+       dbp->err (dbp, ret, "%s: open", dbname);
+       goto err1;
+@@ -433,7 +433,7 @@
+ 
+   if (!inited)
+     {
+-      lock_id (bdb_db_env, &id);
++      bdb_db_env->lock_id(bdb_db_env, &id); 
+       inited = 1;
+     }
+   return id;
+@@ -455,8 +455,7 @@
+   init_dbt_int (&kdir_id, &dir_id);
+ 
+ #if LOCKING
+-  if (lock_get
+-      (bdb_db_env, get_lock_id (), 0, &dir, DB_LOCK_WRITE, &lock) != 0)
++  if (bdb_db_env->lock_get(bdb_db_env, get_lock_id(), 0, &dir, DB_LOCK_WRITE, &lock) != 0)
+     {
+       /* TODO: error failed to lock id row of DB_DIR table */
+ #ifdef GCONF_ERROR_VERBOSE
+@@ -541,7 +540,7 @@
+   ret = dir_id;
+ unlock_and_return:
+ #ifdef LOCKING
+-  if (lock_put (bdb_db_env, &lock) != 0)
++  if (bdb_db_env->lock_put(bdb_db_env, &lock) != 0)
+     {
+ #ifdef GCONF_ERROR_VERBOSE
+       fprintf (stderr, "%s: CRITICAL failed to unlock BDB dir database\n",


Property changes on: trunk/patches/GConf-1.0.9-db43.patch
___________________________________________________________________
Name: svn:keywords
   + LastChangedBy Date

Added: trunk/patches/Python-2.4-db43.patch
===================================================================
--- trunk/patches/Python-2.4-db43.patch	2005-01-10 21:43:20 UTC (rev 3248)
+++ trunk/patches/Python-2.4-db43.patch	2005-01-10 22:41:26 UTC (rev 3249)
@@ -0,0 +1,91 @@
+Submitted By:            Igor Zivkovic <igor at linuxfromscratch.org>
+Date:                    2004-12-09
+Initial Package Version: 2.3.4
+Upstream Status:         Submitted at Python patch tracker.
+Origin:                  Michal Cihar and Suzuki Hisao
+Description:             Adds support for Berkeley DB-4.3.x.
+
+$LastChangedBy$
+$Date$
+
+--- Python-2.3.4/Modules/_bsddb.c.orig	2004-12-09 15:26:24.807332600 +0000
++++ Python-2.3.4/Modules/_bsddb.c	2004-12-09 15:26:39.966028128 +0000
+@@ -422,7 +422,15 @@
+ /* Callback used to save away more information about errors from the DB
+  * library. */
+ static char _db_errmsg[1024];
+-static void _db_errorCallback(const char* prefix, char* msg)
++static void _db_errorCallback(
++#if (DBVER >= 43)
++        const DB_ENV *dbenv,
++#endif
++        const char* prefix, 
++#if (DBVER >= 43)
++        const 
++#endif
++        char* msg)
+ {
+     strcpy(_db_errmsg, msg);
+ }
+@@ -1987,7 +1995,11 @@
+ 
+     MYDB_BEGIN_ALLOW_THREADS;
+ #if (DBVER >= 33)
+-    err = self->db->stat(self->db, &sp, flags);
++    err = self->db->stat(self->db, 
++#if (DBVER >= 43)
++            NULL /*txnid*/,
++#endif
++            &sp, flags);
+ #else
+     err = self->db->stat(self->db, &sp, NULL, flags);
+ #endif
+@@ -2249,7 +2261,11 @@
+ 
+     MYDB_BEGIN_ALLOW_THREADS;
+ #if (DBVER >= 33)
+-    err = self->db->stat(self->db, &sp, flags);
++    err = self->db->stat(self->db, 
++#if (DBVER >= 43)
++            NULL /*txnid*/,
++#endif
++            &sp, flags);
+ #else
+     err = self->db->stat(self->db, &sp, NULL, flags);
+ #endif
+@@ -2375,7 +2391,11 @@
+     err = self->db->get(self->db, txn, &key, &data, 0);
+     MYDB_END_ALLOW_THREADS;
+     FREE_DBT(key);
++#if (DBVER >= 43)
++    return PyInt_FromLong((err == DB_BUFFER_SMALL) || (err == 0));
++#else
+     return PyInt_FromLong((err == ENOMEM) || (err == 0));
++#endif
+ }
+ 
+ 
+@@ -4527,7 +4547,12 @@
+ 
+ #if (DBVER >= 33)
+     ADD_INT(d, DB_LSTAT_ABORTED);
++#if (DBVER < 43)
+     ADD_INT(d, DB_LSTAT_ERR);
++#endif
++#if (DBVER >= 42)
++    ADD_INT(d, DB_LSTAT_EXPIRED);
++#endif
+     ADD_INT(d, DB_LSTAT_FREE);
+     ADD_INT(d, DB_LSTAT_HELD);
+ #if (DBVER == 33)
+--- Python-2.3.4/setup.py.orig	2004-12-09 15:26:30.007542048 +0000
++++ Python-2.3.4/setup.py	2004-12-09 15:26:39.971027368 +0000
+@@ -480,7 +480,7 @@
+         # when sorted in reverse order, keys for this dict must appear in the
+         # order you wish to search - e.g., search for db4 before db3
+         db_try_this = {
+-            'db4': {'libs': ('db-4.2', 'db42', 'db-4.1', 'db41', 'db-4.0', 'db4',),
++            'db4': {'libs': ('db-4.3', 'db43', 'db-4.2', 'db42', 'db-4.1', 'db41', 'db-4.0', 'db4',),
+                     'libdirs': ('/usr/local/BerkeleyDB.4.2/lib',
+                                 '/usr/local/BerkeleyDB.4.1/lib',
+                                 '/usr/local/BerkeleyDB.4.0/lib',


Property changes on: trunk/patches/Python-2.4-db43.patch
___________________________________________________________________
Name: svn:keywords
   + LastChangedBy Date

Added: trunk/patches/exim-4.43-db43.patch
===================================================================
--- trunk/patches/exim-4.43-db43.patch	2005-01-10 21:43:20 UTC (rev 3248)
+++ trunk/patches/exim-4.43-db43.patch	2005-01-10 22:41:26 UTC (rev 3249)
@@ -0,0 +1,54 @@
+Submitted By:            Igor Zivkovic <igor at linuxfromscratch.org>
+Date:                    2005-01-10
+Initial Package Version: 4.43
+Upstream Status:         Not submitted.
+Origin:                  http://www.sleepycat.com/docs/ref/upgrade.4.3/toc.html
+Description:             Adds support for Berkeley DB-4.3.x.
+
+$LastChangedBy$
+$Date$
+
+--- exim-4.43/src/exim_dbmbuild.c.orig	2005-01-10 15:16:40.841577000 +0000
++++ exim-4.43/src/exim_dbmbuild.c	2005-01-10 15:16:56.367216744 +0000
+@@ -60,7 +60,7 @@
+ 
+ #if defined(USE_DB) && defined(DB_VERSION_STRING)
+ void
+-dbfn_bdb_error_callback(const char *pfx, char *msg)
++dbfn_bdb_error_callback(const DB_ENV *dbenv, const char *pfx, const char *msg)
+ {
+ pfx = pfx;
+ printf("Berkeley DB error: %s\n", msg);
+--- exim-4.43/src/exim_dbutil.c.orig	2005-01-10 15:16:49.594246392 +0000
++++ exim-4.43/src/exim_dbutil.c	2005-01-10 15:16:56.368216592 +0000
+@@ -79,7 +79,7 @@
+ 
+ #if defined(USE_DB) && defined(DB_VERSION_STRING)
+ void
+-dbfn_bdb_error_callback(const char *pfx, char *msg)
++dbfn_bdb_error_callback(const DB_ENV *dbenv, const char *pfx, const char *msg)
+ {
+ pfx = pfx;
+ printf("Berkeley DB error: %s\n", msg);
+--- exim-4.43/src/dbfn.c.orig	2005-01-10 15:17:10.322095280 +0000
++++ exim-4.43/src/dbfn.c	2005-01-10 15:17:14.602444568 +0000
+@@ -42,7 +42,7 @@
+ 
+ #if defined(USE_DB) && defined(DB_VERSION_STRING)
+ void
+-dbfn_bdb_error_callback(const char *pfx, char *msg)
++dbfn_bdb_error_callback(const DB_ENV *dbenv, const char *pfx, const char *msg)
+ {
+ pfx = pfx;
+ log_write(0, LOG_MAIN, "Berkeley DB error: %s", msg);
+--- exim-4.43/src/dbfunctions.h.orig	2005-01-10 15:17:21.159447752 +0000
++++ exim-4.43/src/dbfunctions.h	2005-01-10 15:17:25.472792024 +0000
+@@ -22,7 +22,7 @@
+ /* Berkeley DB uses a callback function to pass back error details. */
+ 
+ #if defined(USE_DB) && defined(DB_VERSION_STRING)
+-void     dbfn_bdb_error_callback(const char *, char *);
++void     dbfn_bdb_error_callback(const DB_ENV *, const char *, const char *);
+ #endif
+ 
+ /* End of dbfunctions.h */


Property changes on: trunk/patches/exim-4.43-db43.patch
___________________________________________________________________
Name: svn:keywords
   + LastChangedBy Date


Property changes on: trunk/patches/gcc-3.3.4-no_fixincludes-1.patch
___________________________________________________________________
Name: svn:keywords
   + LastChangedBy Date

Added: trunk/patches/kdesdk-3.3.2-db43.patch
===================================================================
--- trunk/patches/kdesdk-3.3.2-db43.patch	2005-01-10 21:43:20 UTC (rev 3248)
+++ trunk/patches/kdesdk-3.3.2-db43.patch	2005-01-10 22:41:26 UTC (rev 3249)
@@ -0,0 +1,30 @@
+Submitted By:            Igor Zivkovic <igor at linuxfromscratch.org>
+Date:                    2005-01-10
+Initial Package Version: 3.3.2
+Upstream Status:         Not submitted.
+Origin:                  http://www.sleepycat.com/docs/ref/upgrade.4.3/toc.html
+Description:             Adds support for Berkeley DB-4.3.x.
+
+$LastChangedBy$
+$Date$
+
+--- kdesdk-3.3.2/kbabel/kbabeldict/modules/dbsearchengine/database.cpp.orig	2005-01-10 15:58:10.523087880 +0000
++++ kdesdk-3.3.2/kbabel/kbabeldict/modules/dbsearchengine/database.cpp	2005-01-10 15:58:14.681455712 +0000
+@@ -728,7 +728,7 @@
+ DataBaseManager::count ()
+ {
+     DB_BTREE_STAT *dstat = 0;
+-    db->stat (db, &dstat, DB_FAST_STAT);
++    db->stat (db, NULL, &dstat, DB_FAST_STAT);
+     int ret = dstat->bt_nkeys;
+     free (dstat);
+ 
+@@ -963,7 +963,7 @@
+     int nrec;
+     DB_BTREE_STAT *stat;
+ // memset(&stat,0,sizeof(DB_BTREE_STAT));
+-    if (infoDb->stat (infoDb, &stat, DB_FAST_STAT))
++    if (infoDb->stat (infoDb, NULL, &stat, DB_FAST_STAT))
+ 	fprintf (stderr, "Cannot stat\n");
+     nrec = stat->bt_nkeys;
+     free (stat);


Property changes on: trunk/patches/kdesdk-3.3.2-db43.patch
___________________________________________________________________
Name: svn:keywords
   + LastChangedBy Date

Added: trunk/patches/php-5.0.3-db43.patch
===================================================================
--- trunk/patches/php-5.0.3-db43.patch	2005-01-10 21:43:20 UTC (rev 3248)
+++ trunk/patches/php-5.0.3-db43.patch	2005-01-10 22:41:26 UTC (rev 3249)
@@ -0,0 +1,21 @@
+Submitted By:            Igor Zivkovic <igor at linuxfromscratch.org>
+Date:                    2005-01-10
+Initial Package Version: 5.0.3
+Upstream Status:         Not submitted.
+Origin:                  http://www.sleepycat.com/docs/ref/upgrade.4.3/toc.html
+Description:             Adds support for Berkeley DB-4.3.x.
+
+$LastChangedBy$
+$Date$
+
+--- php-5.0.3/ext/dba/dba_db4.c.orig	2005-01-10 00:10:49.798665848 +0000
++++ php-5.0.3/ext/dba/dba_db4.c	2005-01-10 00:23:10.805015760 +0000
+@@ -36,7 +36,7 @@
+ #include <db.h>
+ #endif
+ 
+-static void php_dba_db4_errcall_fcn(const char *errpfx, char *msg)
++static void php_dba_db4_errcall_fcn(const DB_ENV *dbenv, const char *errpfx, const char *msg)
+ {
+ 	TSRMLS_FETCH();
+ 	


Property changes on: trunk/patches/php-5.0.3-db43.patch
___________________________________________________________________
Name: svn:keywords
   + LastChangedBy Date




More information about the blfs-book mailing list