[Bug 1725] New: Typos and grammar fixes on the SVN XFce page

blfs-bugs at linuxfromscratch.org blfs-bugs at linuxfromscratch.org
Sun Dec 25 12:25:51 PST 2005


http://blfs-bugs.linuxfromscratch.org/show_bug.cgi?id=1725

           Summary: Typos and grammar fixes on the SVN XFce page
           Product: Beyond LinuxFromScratch
           Version: a-SVN
          Platform: All
        OS/Version: Linux
            Status: NEW
          Severity: trivial
          Priority: P4
         Component: BOOK
        AssignedTo: blfs-book at linuxfromscratch.org
        ReportedBy: randy at linuxfromscratch.org
         QAContact: blfs-book at linuxfromscratch.org


Noted in the XFce instructions are the following things that may need
to be fixed to adhere to the current BLFS standards:

1) The ?download should be removed from the download URL.

2) The comma is misplaced in the librsvg optional dependency. It should
be after the parenthesized stuff.

3) The parenthesized description for librsvg is ambiguous. Does "it"
refer to xffm or librsvg?

4) The statement "The following packages will install the bare minimum"
is inaccurate. Packages don't install anything, the readers install the
packages. Perhaps "A bare minimum XFce setup requires installation of
the following packages".

5) The semicolon in "xfce-mcs-manager; and xfwm4 like this:" should be
changed to a comma.

6) Though it is trivial, BLFS has standardized on "by issuing the following
commands" instead of "like this". If anything, it reads more professional.
There are numerous instances of this.

7) "xfce4-panel, xfdesktop and xfce-utils also need to install config
files in /etc/xdg." This reads odd as "also" refers to something additional
being installed, although nothing has been said about these packages so far
in the instructions. How about "[package-names here] require a parameter so
that the configuration files are installed in /etc/xdg".

8)  "If you use GDM-2.8.0.5 as your display manager and would like to be
able to log into an xfce session from the login prompt, pass the
--enable-gdm option to the xfce-utils-4.2.3 configure script (requires
which to be installed at run time)."

The following items in this text could be changed:

  a) configure should be encapsulated in <command></command> tags
  b) which should probably be an <xref> tag to the BLFS 'which' page

9)"Almost all of these compile with these commands". This sentence is
referring to a following './configure - make' block. However, just 
prior to this, a similar './configure - make' block is described as
being "configured". There should be consistency within the text to
describe the same exact instructions.

10) "The exceptions are xfce4-session  which needs to be configured like this".
Two things: one) "The exceptions are" should be changed to "The exception is"
as this sentence references a singular item. Also two) this sentence should
have a colon at the end of it. Currently there is no punctuation.

11) The screen block directly after the text in #10 is too long to
fit on a PDF rendered page. The current limit using the BLFS PDF
stylesheet is 71 characters. This line exceeds that length. The
command should be split onto two lines.

12) "mv -f /usr/share/xfce4/doc /usr/share/doc/xfce" This command should 
have a -v in it (mv -v -f, or mv -vf) so that the output of moving the
files can be logged.

13) In the "Installed Libraries" section, for consistency the libraries
should have their extensions annotated. Check out almost every other
BLFS package to see what I mean.

14) The "Installed directories" section should be updated to include
all the directories installed by the package, including the documentation
directory.

I realize many of these items are trivial, however, why not catch and
fix as much as we can.



------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.
You are the QA contact for the bug, or are watching the QA contact.



More information about the blfs-book mailing list