r5433 - in trunk/BOOK: . general/genlib introduction/welcome

randy at linuxfromscratch.org randy at linuxfromscratch.org
Thu Dec 15 16:50:43 PST 2005


Author: randy
Date: 2005-12-15 17:50:41 -0700 (Thu, 15 Dec 2005)
New Revision: 5433

Modified:
   trunk/BOOK/general.ent
   trunk/BOOK/general/genlib/aspell.xml
   trunk/BOOK/introduction/welcome/changelog.xml
Log:
Updated to Aspell-0.60.4

Modified: trunk/BOOK/general/genlib/aspell.xml
===================================================================
--- trunk/BOOK/general/genlib/aspell.xml	2005-12-15 20:42:00 UTC (rev 5432)
+++ trunk/BOOK/general/genlib/aspell.xml	2005-12-16 00:50:41 UTC (rev 5433)
@@ -6,10 +6,10 @@
 
   <!ENTITY aspell-download-http "http://ftp.gnu.org/gnu/aspell/aspell-&aspell-version;.tar.gz">
   <!ENTITY aspell-download-ftp  "ftp://ftp.gnu.org/gnu/aspell/aspell-&aspell-version;.tar.gz">
-  <!ENTITY aspell-md5sum        "ca44ac2fcfdc7213e03d3b5610ce141a">
+  <!ENTITY aspell-md5sum        "4f1737e726d66476b9c7388831305510">
   <!ENTITY aspell-size          "1.6 MB">
-  <!ENTITY aspell-buildsize     "26.0 MB (Additional 8 MB for en dict)">
-  <!ENTITY aspell-time          "0.62 SBU">
+  <!ENTITY aspell-buildsize     "40.0 MB (Additional 8.1 MB for EN dictionary)">
+  <!ENTITY aspell-time          "0.7 SBU">
 ]>
 
 <sect1 id="aspell" xreflabel="Aspell-&aspell-version;">
@@ -76,6 +76,9 @@
     <bridgehead renderas="sect4">Required</bridgehead>
     <para role="required"><xref linkend="which"/></para>
 
+    <bridgehead renderas="sect4">Optional</bridgehead>
+    <para role="optional"><xref linkend="tex"/></para>
+
   </sect2>
 
   <sect2 role="installation">
@@ -87,10 +90,37 @@
 <screen><userinput>./configure --prefix=/usr &&
 make</userinput></screen>
 
+    <para>Pre-built HTML documentation is included in the package. If you have
+    <application>TeX</application> installed and you wish to build additional
+    formats of the documentation, issue any or all of the following
+    commands:</para>
+
+<screen><userinput>make -C manual pdf &&
+make -C manual pdf &&
+make -C manual ps &&
+cd manual &&
+makeinfo --plaintext -o aspell.txt aspell.texi &&
+makeinfo --plaintext -o aspell-dev.txt aspell-dev.texi &&
+cd ..</userinput></screen>
+
+    <para>This package does not come with a test suite.</para>
+
     <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
 
-<screen role="root"><userinput>make install</userinput></screen>
+<screen role="root"><userinput>make install &&
+install -v -m755 -d /usr/share/doc/aspell-&aspell-version;/aspell{,-dev}.html &&
+install -v -m644 manual/aspell.html/* \
+    /usr/share/doc/aspell-&aspell-version;/aspell.html &&
+install -v -m644 manual/aspell-dev.html/* \
+    /usr/share/doc/aspell-&aspell-version;/aspell-dev.html</userinput></screen>
 
+  <para>If you built additional formats of the documentation, install them
+  by issuing the following command as the
+  <systemitem class="username">root</systemitem> user:</para>
+
+<screen role="root"><userinput>install -v -m644 manual/aspell{,-dev}.{ps,pdf,dvi,txt} \
+    /usr/share/doc/aspell-&aspell-version;</userinput></screen>
+
   <para>If you do not plan to install <application>Ispell</application>,
   then copy the wrapper script <command>ispell</command>:</para>
 
@@ -101,6 +131,16 @@
 
 <screen role="root"><userinput>install -v -m 755 scripts/spell /usr/bin/</userinput></screen>
 
+ </sect2>
+
+ <sect2 role="commands">
+    <title>Command Explanations</title>
+    
+    <para><command>make -C manual pdf</command>: This command is listed twice
+    as the first time it runs it will display an error and abort, although it
+    creates the requested file. Running the command again ensures the other
+    file is also created.</para>
+
   </sect2>
 
   <sect2 role="configuration">
@@ -109,9 +149,9 @@
     <sect3>
       <title>Configuration Information</title>
 
-      <para>After <application>Aspell</application> is installed, you must set up at
-      least one dictionary. Install one or more dictionaries by running the following
-      commands:</para>
+      <para>After <application>Aspell</application> is installed, you must set
+      up at least one dictionary. Install one or more dictionaries by running
+      the following commands:</para>
 
 <screen><userinput>./configure &&
 make</userinput></screen>
@@ -150,8 +190,9 @@
         <term><command>aspell</command></term>
         <listitem>
           <para>is a utility that can function as an
-          <command>ispell -a</command> replacement, as an independent spell checker, as
-          a test utility to test out <application>Aspell</application> features, and as
+          <command>ispell -a</command> replacement, as an independent spell
+          checker, as a test utility to test out
+          <application>Aspell</application> features, and as
           a utility for managing dictionaries.</para>
           <indexterm zone="aspell aspell-prog">
             <primary sortas="b-aspell">aspell</primary>
@@ -239,8 +280,8 @@
         <term><command>pspell-config</command></term>
         <listitem>
           <para>displays information about the
-          <filename class='libraryfile'>libpspell</filename> installation, mostly for use
-          in build scripts.</para>
+          <filename class='libraryfile'>libpspell</filename> installation,
+          mostly for use in build scripts.</para>
           <indexterm zone="aspell pspell-config">
             <primary sortas="b-pspell-config">pspell-config</primary>
           </indexterm>
@@ -283,10 +324,10 @@
         <term><filename class='libraryfile'>libpspell.so</filename></term>
         <listitem>
           <para>is an interface to the
-          <filename class='libraryfile'>libaspell</filename> library. All the spell
-          checking functionality is now in
-          <filename class='libraryfile'>libaspell</filename> but this library is
-          included for backward compatibility.</para>
+          <filename class='libraryfile'>libaspell</filename> library. All the
+          spell checking functionality is now in
+          <filename class='libraryfile'>libaspell</filename> but this library
+          is included for backward compatibility.</para>
           <indexterm zone="aspell libpspell">
             <primary sortas="c-libpspell">libpspell.so</primary>
           </indexterm>
@@ -298,4 +339,3 @@
   </sect2>
 
 </sect1>
-

Modified: trunk/BOOK/general.ent
===================================================================
--- trunk/BOOK/general.ent	2005-12-15 20:42:00 UTC (rev 5432)
+++ trunk/BOOK/general.ent	2005-12-16 00:50:41 UTC (rev 5433)
@@ -83,7 +83,7 @@
 <!ENTITY libglade-version             "2.5.1">
 <!ENTITY expat-version                "1.95.8">
 <!ENTITY libesmtp-version             "1.0.3r1">
-<!ENTITY aspell-version               "0.60.3">
+<!ENTITY aspell-version               "0.60.4">
 <!ENTITY ispell-version               "3.2.06.epa7">
 <!ENTITY slib-version                 "3a2">
 <!ENTITY gwrap-version                "1.3.4">

Modified: trunk/BOOK/introduction/welcome/changelog.xml
===================================================================
--- trunk/BOOK/introduction/welcome/changelog.xml	2005-12-15 20:42:00 UTC (rev 5432)
+++ trunk/BOOK/introduction/welcome/changelog.xml	2005-12-16 00:50:41 UTC (rev 5433)
@@ -45,14 +45,17 @@
       <para>December 15, 2005</para>
       <itemizedlist>
         <listitem>
-          <para>[randy] - Added a sed command to the FOP instructions to fix
-          a tail command with obsolete syntax in the JAI binary.</para>
+          <para>[randy] - Updated to Aspell-0.60.4.</para>
         </listitem>
         <listitem>
+          <para>[randy] - Added a sed command to the FOP instructions which
+          fixes an obsolete tail command in the JAI binary.</para>
+        </listitem>
+        <listitem>
           <para>[randy] - Updated to Gamin-0.1.7.</para>
         </listitem>
         <listitem>
-          <para>[bdubbs] - Removed section on newsserver..</para>
+          <para>[bdubbs] - Removed section on newsserver.</para>
         </listitem>
         <listitem>
           <para>[randy] - Updated to Apache HTTP Server-2.2.0.</para>




More information about the blfs-book mailing list