r4931 - in trunk/BOOK: . introduction/welcome postlfs/security

randy at linuxfromscratch.org randy at linuxfromscratch.org
Sun Aug 14 17:29:22 PDT 2005


Author: randy
Date: 2005-08-14 18:29:21 -0600 (Sun, 14 Aug 2005)
New Revision: 4931

Modified:
   trunk/BOOK/general.ent
   trunk/BOOK/introduction/welcome/changelog.xml
   trunk/BOOK/postlfs/security/shadow.xml
Log:
Updated to Shadow-4.0.11.1

Modified: trunk/BOOK/general.ent
===================================================================
--- trunk/BOOK/general.ent	2005-08-14 23:26:05 UTC (rev 4930)
+++ trunk/BOOK/general.ent	2005-08-15 00:29:21 UTC (rev 4931)
@@ -37,7 +37,7 @@
 
 <!ENTITY cracklib-version             "2.8.3">
 <!ENTITY Linux_PAM-version            "0.80">
-<!ENTITY shadow-version               "4.0.9">
+<!ENTITY shadow-version               "4.0.11.1">
 <!ENTITY iptables-version             "1.3.3">
 <!ENTITY gnupg-version                "1.4.1">
 <!ENTITY tripwire-version             "portable-0.9">

Modified: trunk/BOOK/introduction/welcome/changelog.xml
===================================================================
--- trunk/BOOK/introduction/welcome/changelog.xml	2005-08-14 23:26:05 UTC (rev 4930)
+++ trunk/BOOK/introduction/welcome/changelog.xml	2005-08-15 00:29:21 UTC (rev 4931)
@@ -32,8 +32,8 @@
     </listitem>
 
     <listitem>
-      <para>August 14th, 2005 [randy]: Updated to GTK-Doc-1.4 and HTML
-      Tidy-050803.</para>
+      <para>August 14th, 2005 [randy]: Updated to GTK-Doc-1.4, HTML
+      Tidy-050803 and Shadow-4.0.11.1.</para>
     </listitem>
 
     <listitem>

Modified: trunk/BOOK/postlfs/security/shadow.xml
===================================================================
--- trunk/BOOK/postlfs/security/shadow.xml	2005-08-14 23:26:05 UTC (rev 4930)
+++ trunk/BOOK/postlfs/security/shadow.xml	2005-08-15 00:29:21 UTC (rev 4931)
@@ -4,11 +4,11 @@
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
 
-  <!ENTITY shadow-download-http " ">
-  <!ENTITY shadow-download-ftp  "ftp://ftp.pld.org.pl/software/shadow/old/shadow-&shadow-version;.tar.bz2">
-  <!ENTITY shadow-md5sum        "66e3a3a60ea6b021a7babff311b07607">
+  <!ENTITY shadow-download-http "http://ftp.pld.org.pl/software/shadow/shadow-&shadow-version;.tar.bz2">
+  <!ENTITY shadow-download-ftp  "ftp://ftp.pld.org.pl/software/shadow/shadow-&shadow-version;.tar.bz2">
+  <!ENTITY shadow-md5sum        "e60b7b16128b9e00576073389a0ff1e6">
   <!ENTITY shadow-size          "1.1 MB">
-  <!ENTITY shadow-buildsize     "13 MB">
+  <!ENTITY shadow-buildsize     "13.6 MB">
   <!ENTITY shadow-time          "0.3 SBU">
 ]>
 
@@ -56,6 +56,7 @@
       </listitem>
     </itemizedlist>
 
+<!--
     <bridgehead renderas="sect3">Additional Downloads</bridgehead>
     <itemizedlist spacing='compact'>
       <listitem>
@@ -64,6 +65,7 @@
         url="&patch-root;/shadow-&shadow-version;-Linux_PAM_fixes-1.patch"/></para>
       </listitem>
     </itemizedlist>
+-->
 
     <bridgehead renderas="sect3">Shadow Dependencies</bridgehead>
 
@@ -78,13 +80,18 @@
     <para>Reinstall <application>Shadow</application> by running the following
     commands:</para>
 
+<!--
 <screen><userinput>patch -Np1 -i ../shadow-&shadow-version;-Linux_PAM_fixes-1.patch &&
-./configure --libdir=/lib --enable-shared \
+<-->
+
+<screen><userinput>./configure --libdir=/lib --enable-shared --enable-shadowgrp \
     --with-libpam --without-libcrack &&
 sed -i 's/groups$(EXEEXT) //' src/Makefile &&
 sed -i '/groups/d' man/Makefile &&
 make</userinput></screen>
 
+    <para>This package does not come with a test suite.</para>
+
     <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
 
 <screen role="root"><userinput>make install &&
@@ -104,6 +111,11 @@
     <application>Linux-PAM</application> already contains
     <filename class='libraryfile'>libcrack</filename>.</para>
 
+    <para><parameter>--enable-shadowgrp</parameter>: This version of
+    <application>Shadow</application> defaults to not enabling
+    its group functionality, which causes <command>grpconv</command> to
+    fail.</para>
+
     <para><command>sed -i ...</command>: These commands are used to suppress
     the installation of the <command>groups</command> program as the version
     from the <application>Coreutils</application> package installed during
@@ -423,7 +435,7 @@
 
           <note><para>ENV_SUPATH is no longer supported.  You must create 
           a valid <filename>/root/.bashrc</filename> file to provide a 
-          modified path for the super user.</para></note>
+          modified path for the super-user.</para></note>
 
       </sect4>
 




More information about the blfs-book mailing list