r2734 - in trunk/BOOK: basicnet/netlibs introduction/welcome

randy at linuxfromscratch.org randy at linuxfromscratch.org
Fri Sep 10 13:38:11 PDT 2004


Author: randy
Date: 2004-09-10 14:38:09 -0600 (Fri, 10 Sep 2004)
New Revision: 2734

Modified:
   trunk/BOOK/basicnet/netlibs/libsoup.xml
   trunk/BOOK/introduction/welcome/changelog.xml
Log:
Added an optional dependency and a note about a build problem to the libsoup instructions

Modified: trunk/BOOK/basicnet/netlibs/libsoup.xml
===================================================================
--- trunk/BOOK/basicnet/netlibs/libsoup.xml	2004-09-10 16:52:53 UTC (rev 2733)
+++ trunk/BOOK/basicnet/netlibs/libsoup.xml	2004-09-10 20:38:09 UTC (rev 2734)
@@ -2,7 +2,7 @@
    "http://www.oasis-open.org/docbook/xml/4.3/docbookx.dtd" [
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
- 
+
   <!ENTITY libsoup-download-http "http://ftp.gnome.org/pub/gnome/sources/libsoup/1.99/libsoup-&libsoup-version;.tar.bz2">
   <!ENTITY libsoup-download-ftp  "ftp://ftp.gnome.org/pub/gnome/sources/libsoup/1.99/libsoup-&libsoup-version;.tar.bz2">
   <!ENTITY libsoup-size          "365 KB">
@@ -43,7 +43,8 @@
 </para></sect4>
 <sect4><title>Optional</title>
 <para>
-<xref linkend="gtk-doc"/> and 
+<xref linkend="gtk-doc"/>, 
+<xref linkend="docbook-utils"/> and 
 <ulink url="http://www.gnu.org/software/gnutls/">GnuTLS</ulink> (which
 needs <ulink
 url="ftp://ftp.gnupg.org/gcrypt/alpha/libgpg-error/">libgpg-error</ulink>,
@@ -59,12 +60,21 @@
 <sect2>
 <title>Installation of <application>libsoup</application></title>
 
-<para>Install <application>libsoup</application> by running the following commands:</para>
+<para>Install <application>libsoup</application> by running the following 
+commands:</para>
 
 <screen><userinput><command>./configure --prefix=/usr --libexecdir=/usr/sbin &&
 make &&
 make install</command></userinput></screen>
 
+<note><para>Some versions of <application>GnuTLS</application> will cause the 
+<application>libsoup</application> build to fail. You can use the following
+<command>sed</command> command before the build to fix this problem.</para>
+</note>
+
+<screen><userinput><command>sed -i -e "s at status \& GNUTLS_CERT_CORRUPTED ||@/* status \& GNUTLS_CERT_CORRUPTED || */@" \
+    libsoup/soup-gnutls.c</command></userinput></screen>
+
 </sect2>
 
 <sect2>

Modified: trunk/BOOK/introduction/welcome/changelog.xml
===================================================================
--- trunk/BOOK/introduction/welcome/changelog.xml	2004-09-10 16:52:53 UTC (rev 2733)
+++ trunk/BOOK/introduction/welcome/changelog.xml	2004-09-10 20:38:09 UTC (rev 2734)
@@ -24,7 +24,8 @@
 
 <listitem><para>September 10th, 2004 [randy]: Corrected OpenSP instructions  
 to fix hard-coded version (replaced with version entity) as suggested by
-Nico Roeser.</para></listitem>
+Nico Roeser; added optional dependencies and a note to fix a build problem
+to the libsoup instructions.</para></listitem>
 
 <listitem><para>September 10th, 2004 [randy]: Added gcc34 patch to 
 GNOME-Terminal to fix an LFS-6.0 build problem; added required




More information about the blfs-book mailing list