DHCP Commit

Randy McMurchy randy at linuxfromscratch.org
Sat Oct 2 20:29:02 PDT 2004


[sorry for the new thread here, I tried to reply but my message
bounced due to "suspicious headers"]

dj at linuxfromscratch.org wrote:

 >  <sect3><title><application><acronym>RP</acronym>-<acronym>PPPoE</acronym></application> dependencies</title>
 >  <sect4><title>Required</title>
 > -<para><xref linkend="ppp"/></para></sect4>
 > +<para><xref linkend="ppp"/></para>
 > +<para><xref linkend="net-tools"/></para></sect4>
 >  </sect3>


This would probably look better with just one paragraph for the
two dependencies, with "and" between them.


 > @@ -1,8 +1,8 @@
 > -<!ENTITY day          "27">
 > -<!ENTITY month        "09">
 > +<!ENTITY day          "02">
 > +<!ENTITY month        "10">
 >  <!ENTITY year         "2004">
 >  <!ENTITY version      "svn-&year;&month;&day;">
 > -<!ENTITY releasedate  "September &day;th, &year;">
 > +<!ENTITY releasedate  "September &day;nd, &year;">


Perhaps   s/September/October/    :-)


 > +<listitem><para>October 2nd, 2004 [dj]: Added net-tools as a dependacy
 > +for RP-PPPoE.  Made iproute2 patch to optional for dhcp.</para></listitem>


s/dependacy/dependency/


 > ===================================================================
 > --- trunk/BOOK/server/other/dhcp.xml    2004-10-02 17:57:32 UTC (rev 2759)
 > +++ trunk/BOOK/server/other/dhcp.xml    2004-10-03 02:20:23 UTC (rev 2760)
 > @@ -43,9 +43,15 @@
 >  &dhcp-time;</para></listitem></itemizedlist>
 >  </sect3>
 >
 > +<sect3><title><application>dhcp</application> dependencies</title>
 > +<sect4><title>Required</title>
 > +<para><xref linkend="net-tools"/></para></sect4>
 > +</sect3>
 > +
 >  <sect3><title>Additional downloads</title>
 >  <itemizedlist spacing='compact'>
 > -<listitem><para>Required Patch:
 > +<listitem><para>Optional Patch to use iproute2 (this removes the
 > +dependacy on net-tools):
 >  <ulink url="&patch-root;/dhcp-&dhcp-version;-iproute2-1.patch"/></para></listitem>
 >  </itemizedlist>
 >  </sect3>


For sure s/dependacy/dependency/

Also, you may want to eliminate the whole "Additional Downloads"
section, as this somewhat violates the "only required and
recommended patches go in the book" thing.

I suggest putting something like "you may omit installing net-tools
by using the following patch to utilize iproute" in parenthesis,
right after the net-tools dependency, with the patch listed below that.

-- 
Randy



More information about the blfs-book mailing list