r3022 - in trunk/BOOK: . basicnet/netlibs gnome/core introduction/welcome

randy at linuxfromscratch.org randy at linuxfromscratch.org
Tue Nov 23 13:47:02 PST 2004


Author: randy
Date: 2004-11-23 14:47:01 -0700 (Tue, 23 Nov 2004)
New Revision: 3022

Modified:
   trunk/BOOK/basicnet/netlibs/libsoup.xml
   trunk/BOOK/general.ent
   trunk/BOOK/gnome/core/gnome-applets.xml
   trunk/BOOK/introduction/welcome/changelog.xml
Log:
Updated to libsoup-2.2.1

Modified: trunk/BOOK/basicnet/netlibs/libsoup.xml
===================================================================
--- trunk/BOOK/basicnet/netlibs/libsoup.xml	2004-11-23 21:05:30 UTC (rev 3021)
+++ trunk/BOOK/basicnet/netlibs/libsoup.xml	2004-11-23 21:47:01 UTC (rev 3022)
@@ -3,11 +3,12 @@
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
 
-  <!ENTITY libsoup-download-http "http://ftp.gnome.org/pub/gnome/sources/libsoup/1.99/libsoup-&libsoup-version;.tar.bz2">
-  <!ENTITY libsoup-download-ftp  "ftp://ftp.gnome.org/pub/gnome/sources/libsoup/1.99/libsoup-&libsoup-version;.tar.bz2">
-  <!ENTITY libsoup-size          "365 KB">
-  <!ENTITY libsoup-buildsize     "13 MB">
-  <!ENTITY libsoup-time          "0.41 SBU">
+  <!ENTITY libsoup-download-http "http://ftp.gnome.org/pub/gnome/sources/libsoup/2.2/libsoup-&libsoup-version;.tar.bz2">
+  <!ENTITY libsoup-download-ftp  "ftp://ftp.gnome.org/pub/gnome/sources/libsoup/2.2/libsoup-&libsoup-version;.tar.bz2">
+  <!ENTITY libsoup-md5sum        "8132b0bce469affed688c4863702aa41">
+  <!ENTITY libsoup-size          "403 KB">
+  <!ENTITY libsoup-buildsize     "9.0 MB">
+  <!ENTITY libsoup-time          "0.32 SBU">
 ]>
 
 <sect1 id="libsoup" xreflabel="libsoup-&libsoup-version;">
@@ -28,31 +29,33 @@
 
 <sect3><title>Package information</title>
 <itemizedlist spacing='compact'>
-<listitem><para>Download (HTTP): <ulink url="&libsoup-download-http;"/></para></listitem>
-<listitem><para>Download (FTP): <ulink url="&libsoup-download-ftp;"/></para></listitem>
+<listitem><para>Download (HTTP): 
+<ulink url="&libsoup-download-http;"/></para></listitem>
+<listitem><para>Download (FTP): 
+<ulink url="&libsoup-download-ftp;"/></para></listitem>
+<listitem><para>Download MD5 sum: &libsoup-md5sum;</para></listitem>
 <listitem><para>Download size: &libsoup-size;</para></listitem>
-<listitem><para>Estimated Disk space required: &libsoup-buildsize;</para></listitem>
-<listitem><para>Estimated build time: &libsoup-time;</para></listitem></itemizedlist>
+<listitem><para>Estimated disk space required: 
+&libsoup-buildsize;</para></listitem>
+<listitem><para>Estimated build time: 
+&libsoup-time;</para></listitem></itemizedlist>
 </sect3>
 
 <sect3><title><application>libsoup</application> dependencies</title>
 <sect4><title>Required</title>
-<para>
-<xref linkend="GLib2"/> and
-<xref linkend="libxml2"/>
-</para></sect4>
+<para><xref linkend="GLib2"/> and <xref linkend="libxml2"/></para>
+</sect4>
+
 <sect4><title>Optional</title>
-<para>
-<xref linkend="gtk-doc"/>, 
-<xref linkend="docbook-utils"/> and 
-<ulink url="http://www.gnu.org/software/gnutls/">GnuTLS</ulink> (which
-needs <ulink
-url="ftp://ftp.gnupg.org/gcrypt/alpha/libgpg-error/">libgpg-error</ulink>,
-<ulink url="ftp://ftp.gnupg.org/gcrypt/libgcrypt/">libgcrypt</ulink> and
-<ulink
-url="ftp://ftp.gnupg.org/gcrypt/alpha/gnutls/opencdk/">opencdk</ulink>,
-in that order.)
-</para></sect4>
+<para><xref linkend="gtk-doc"/> and 
+<ulink url="http://www.gnu.org/software/gnutls/">GnuTLS</ulink> (which 
+needs <ulink 
+url="ftp://ftp.gnupg.org/gcrypt/alpha/libgpg-error/">libgpg-error</ulink>, 
+<ulink url="ftp://ftp.gnupg.org/gcrypt/libgcrypt/">libgcrypt</ulink> and 
+<ulink 
+url="ftp://ftp.gnupg.org/gcrypt/alpha/gnutls/opencdk/">opencdk</ulink>, 
+in that order.)</para>
+</sect4>
 </sect3>
 
 </sect2>
@@ -63,10 +66,11 @@
 <para>Install <application>libsoup</application> by running the following 
 commands:</para>
 
-<screen><userinput><command>./configure --prefix=/usr --libexecdir=/usr/sbin &&
+<screen><userinput><command>./configure --prefix=/usr &&
 make &&
 make install</command></userinput></screen>
 
+<!-- 
 <note><para>Some versions of <application>GnuTLS</application> will cause the 
 <application>libsoup</application> build to fail. You can use the following
 <command>sed</command> command before the build to fix this problem.</para>
@@ -74,6 +78,7 @@
 
 <screen><userinput><command>sed -i -e "s at status \& GNUTLS_CERT_CORRUPTED ||@/* status \& GNUTLS_CERT_CORRUPTED || */@" \
     libsoup/soup-gnutls.c</command></userinput></screen>
+ -->
 
 </sect2>
 
@@ -88,8 +93,9 @@
 <sect2><title>Description</title>
 
 <sect3><title>libsoup libraries</title>
-<para><filename class="libraryfile">libsoup</filename> libraries provide functions for
-asynchronous <acronym>HTTP</acronym> connections.</para></sect3>
+<para><filename class="libraryfile">libsoup</filename> libraries provide 
+functions for asynchronous <acronym>HTTP</acronym> connections.</para>
+</sect3>
 
 </sect2>
 

Modified: trunk/BOOK/general.ent
===================================================================
--- trunk/BOOK/general.ent	2004-11-23 21:05:30 UTC (rev 3021)
+++ trunk/BOOK/general.ent	2004-11-23 21:47:01 UTC (rev 3022)
@@ -168,7 +168,7 @@
 <!ENTITY curl-version                 "7.12.2"> 
 <!ENTITY wvstreams-version            "3.75.0">  
 <!ENTITY gnet-version                 "2.0.5">   
-<!ENTITY libsoup-version              "1.99.28"> 
+<!ENTITY libsoup-version              "2.2.1"> 
                                   
 <!-- Chapter 17 -->               
 <!ENTITY Links-version                "2.1pre15">  

Modified: trunk/BOOK/gnome/core/gnome-applets.xml
===================================================================
--- trunk/BOOK/gnome/core/gnome-applets.xml	2004-11-23 21:05:30 UTC (rev 3021)
+++ trunk/BOOK/gnome/core/gnome-applets.xml	2004-11-23 21:47:01 UTC (rev 3022)
@@ -41,7 +41,7 @@
 <listitem><para>Estimated build time:
 &gnome-applets-time;</para></listitem></itemizedlist>
 </sect3>
-                                                                                
+
 <sect3><title>Additional downloads</title>
 <itemizedlist spacing='compact'>
 <listitem><para>Required patch: <ulink 
@@ -53,7 +53,7 @@
 dependencies</title>
 <sect4><title>Required</title>
 <para><xref linkend="gail"/>, 
-<xref linkend="gnome-panel"/> and
+<xref linkend="gnome-panel"/> and 
 <xref linkend="libxklavier"/></para>
 </sect4>
 
@@ -98,12 +98,12 @@
 files in <filename class="directory">$GNOME_PREFIX/sbin</filename> instead of 
 <filename class="directory">$GNOME_PREFIX/libexec</filename>.</para>
 
-<para><parameter>--localstatedir=/var/lib</parameter>: This switch
+<para><parameter>--localstatedir=/var/lib</parameter>: This switch 
 puts <application>ScrollKeeper</application> files in 
 <filename class="directory">/var/lib/scrollkeeper</filename> instead of 
 <filename class="directory">$GNOME_PREFIX/var/scrollkeeper</filename>.</para>
 
-<para><parameter>--sysconfdir=/etc/gnome</parameter>: This switch
+<para><parameter>--sysconfdir=/etc/gnome</parameter>: This switch 
 puts configuration files in <filename class="directory">/etc/gnome</filename> 
 instead of <filename class="directory">$GNOME_PREFIX/etc</filename>.</para>
 
@@ -122,10 +122,10 @@
 
 <para>The <application><acronym>GNOME</acronym> Applets</application> package 
 contains <command>battstat</command>, <command>cdplayer</command>, 
-<command>charpick</command>, <command>drivemount</command>,
-<command>geyes</command>, <command>gkb</command>,
-<command>gtik2</command>, <command>gweather</command>,
-<command>mini-commander</command>, <command>mixer</command>,
+<command>charpick</command>, <command>drivemount</command>, 
+<command>geyes</command>, <command>gkb</command>, 
+<command>gtik2</command>, <command>gweather</command>, 
+<command>mini-commander</command>, <command>mixer</command>, 
 <command>modemlights</command> and <command>multiload</command> applets.</para>
 
 </sect2>

Modified: trunk/BOOK/introduction/welcome/changelog.xml
===================================================================
--- trunk/BOOK/introduction/welcome/changelog.xml	2004-11-23 21:05:30 UTC (rev 3021)
+++ trunk/BOOK/introduction/welcome/changelog.xml	2004-11-23 21:47:01 UTC (rev 3022)
@@ -24,7 +24,7 @@
 
 <listitem><para>November 23rd, 2004 [randy]: Added new package 
 libgnomecups-0.1.13; updated to libgnomeprint-2.8.0.1, libgnomeprintui-2.8.0, 
-GAL-2.2.3 and GtkHTML-3.2.3.</para></listitem>
+GAL-2.2.3, GtkHTML-3.2.3 and libsoup-2.2.1.</para></listitem>
 
 <listitem><para>November 22nd, 2004 [randy]: Changed GConf dependency in 
 Metacity instructions to required, reported by Denis 




More information about the blfs-book mailing list