r2949 - in trunk/BOOK: . content/databases introduction/welcome

igor at linuxfromscratch.org igor at linuxfromscratch.org
Tue Nov 16 18:58:29 PST 2004


Author: igor
Date: 2004-11-16 19:58:27 -0700 (Tue, 16 Nov 2004)
New Revision: 2949

Modified:
   trunk/BOOK/content/databases/db.xml
   trunk/BOOK/general.ent
   trunk/BOOK/introduction/welcome/changelog.xml
Log:
Updated to Berkeley DB-4.3.21.

Modified: trunk/BOOK/content/databases/db.xml
===================================================================
--- trunk/BOOK/content/databases/db.xml	2004-11-16 22:17:10 UTC (rev 2948)
+++ trunk/BOOK/content/databases/db.xml	2004-11-17 02:58:27 UTC (rev 2949)
@@ -4,10 +4,10 @@
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
 
-  <!ENTITY db-download-http " ">
-  <!ENTITY db-download-ftp  "ftp://sleepycat1.inetu.net/releases/db-4.2.52.tar.gz">
-  <!ENTITY db-size          "4.1 MB">
-  <!ENTITY db-buildsize     "68 MB">
+  <!ENTITY db-download-http "http://www.arte.unipi.it/Public/UNIX/db-&db-version;.tar.gz">
+  <!ENTITY db-download-ftp "ftp://sleepycat1.inetu.net/releases/db-&db-version;.tar.gz">
+  <!ENTITY db-size          "5.7 MB">
+  <!ENTITY db-buildsize     "71 MB">
   <!ENTITY db-time          "1.22 SBU">
 ]>
 
@@ -33,21 +33,12 @@
 <listitem><para>Download (FTP): <ulink
 url="&db-download-ftp;"/></para></listitem>
 <listitem><para>Download size: &db-size;</para></listitem>
-<listitem><para>Estimated Disk space required:
+<listitem><para>Estimated disk space required:
 &db-buildsize;</para></listitem>
 <listitem><para>Estimated build time:
 &db-time;</para></listitem></itemizedlist>
 </sect3>
 
-<sect3><title>Additional downloads</title>
-<itemizedlist spacing='compact'>
-<listitem><para>Required Patch: <ulink
-url="http://www.sleepycat.com/update/4.2.52/patch.4.2.52.1"/></para></listitem>
-<listitem><para>Required Patch: <ulink
-url="http://www.sleepycat.com/update/4.2.52/patch.&db-version;"/></para>
-</listitem></itemizedlist>
-</sect3>
-
 <sect3><title><application>Berkeley DB</application> dependencies</title>
 <sect4><title>Optional</title>
 <para><xref linkend="tcl"/> and <xref linkend="j2sdk"/>
@@ -62,9 +53,7 @@
 <para>Install <application>Berkeley DB</application> by running the following 
 commands:</para>
 
-<screen><userinput><command>patch -Np0 -i ../patch.4.2.52.1 &&
-patch -Np0 -i ../patch.&db-version; &&
-cd build_unix &&
+<screen><userinput><command>cd build_unix &&
 ../dist/configure --prefix=/usr \
     --enable-compat185 \
     --enable-cxx &&
@@ -81,14 +70,6 @@
 /usr/lib/libdb* /usr/include/db* &&
 chown -R root:root /usr/share/doc/db-4.2.52.2</command></userinput></screen>
 
-<!-- <note><para>If you wish to enable <application>Java</application>
-support in <application>Berkeley DB</application>-&db-version;, add
-<parameter>-enable-java</parameter> to the configure options. This requires a
-Java compiler.
-<application>Java</application> support is needed
-if you plan to use system installed <application>Berkeley DB</application> when 
-compiling <xref linkend="openoffice"/>.</para></note> -->
-
 </sect2>
 
 <sect2>
@@ -100,6 +81,12 @@
 <application>Berkeley DB</application> comes with various 
 build directories for different platforms.</para>
 
+<para><parameter>--enable-compat185</parameter>: This switch enables
+building DB 1.85 compatibility <acronym>API</acronym>.</para>
+
+<para><parameter>--enable-cxx</parameter>: This switch enables building
+C++ <acronym>API</acronym>.</para>
+
 <para><command>make LIBSO_LIBS="-lpthread"
 LIBXSO_LIBS="-lpthread"</command>:  configure does not correctly handle 
 <acronym>NPTL</acronym>.  These variables force it to properly link 

Modified: trunk/BOOK/general.ent
===================================================================
--- trunk/BOOK/general.ent	2004-11-16 22:17:10 UTC (rev 2948)
+++ trunk/BOOK/general.ent	2004-11-17 02:58:27 UTC (rev 2949)
@@ -226,7 +226,7 @@
                                      
 <!-- Part VII -->                    
 <!-- Chapter 23 -->                  
-<!ENTITY db-version                   "4.2.52.2">  
+<!ENTITY db-version                   "4.3.21">  
 <!ENTITY db-3.3-version               "3.3.11">  
 <!ENTITY mysql-version                "4.0.21">   
 <!ENTITY postgresql-version           "7.4.6"> 

Modified: trunk/BOOK/introduction/welcome/changelog.xml
===================================================================
--- trunk/BOOK/introduction/welcome/changelog.xml	2004-11-16 22:17:10 UTC (rev 2948)
+++ trunk/BOOK/introduction/welcome/changelog.xml	2004-11-17 02:58:27 UTC (rev 2949)
@@ -22,6 +22,9 @@
 
 <itemizedlist>
 
+<listitem><para>November 16th, 2004 [igor]: Updated to Berkeley
+DB-4.3.21.</para></listitem>
+
 <listitem><para>November 16th, 2004 [randy]: Removed id3lib and added
 DocBook-utils to FLAC dependencies.</para></listitem>
 




More information about the blfs-book mailing list