[Bug 644] Problems with ESP Ghostscript 7.07.1 and a system libpng

blfs-bugs at linuxfromscratch.org blfs-bugs at linuxfromscratch.org
Thu Mar 11 14:46:14 PST 2004


http://blfs-bugs.linuxfromscratch.org/show_bug.cgi?id=644





------- Additional Comments From lizardo at linuxfromscratch.org  2004-03-11 15:46 -------
> The bug is with libpng. libpng.so should link against libz.so and libm.so.

Yep, I know. But the espgs developers opted for not depending on libpng being
linked against libz, so decided to explictly add "-lz" to the libpng check. I
just picked the fix from the CVS (which soo will become 7.07.2). See the
resolution of this bug:

http://www.cups.org/str.php?L396

> The patch mentioned in the espgs bugzilla works perfectly. Can you submit
> that to the patches project?

Certainly. But the modified instruction I suggested above has the same effect,
and avoids an additional third patch. As soon as 7.07.2 is released, both
patches (libpngcheck and libpngsupport) will not be needed anymore.



------- You are receiving this mail because: -------
You are the QA contact for the bug, or are watching the QA contact.



More information about the blfs-book mailing list