r3099 - in trunk/BOOK: . introduction/welcome xsoft/graphweb xsoft/other

randy at linuxfromscratch.org randy at linuxfromscratch.org
Mon Dec 13 22:07:49 PST 2004


Author: randy
Date: 2004-12-13 23:07:48 -0700 (Mon, 13 Dec 2004)
New Revision: 3099

Modified:
   trunk/BOOK/general.ent
   trunk/BOOK/introduction/welcome/changelog.xml
   trunk/BOOK/xsoft/graphweb/firefox.xml
   trunk/BOOK/xsoft/graphweb/mozilla.xml
   trunk/BOOK/xsoft/other/thunderbird.xml
Log:
Updated to Mozilla-1.7.3 and Thunderbird-1.0; modified Firefox instructions

Modified: trunk/BOOK/general.ent
===================================================================
--- trunk/BOOK/general.ent	2004-12-13 21:35:37 UTC (rev 3098)
+++ trunk/BOOK/general.ent	2004-12-14 06:07:48 UTC (rev 3099)
@@ -1,4 +1,4 @@
-<!ENTITY day          "13">
+<!ENTITY day          "14">
 <!ENTITY month        "12">
 <!ENTITY year         "2004">
 <!ENTITY version      "svn-&year;&month;&day;">
@@ -380,13 +380,13 @@
 <!ENTITY openoffice-version           "1.1.2"> 
 
 <!-- Chapter 35 -->        
-<!ENTITY mozilla-version              "1.7.1">  
+<!ENTITY mozilla-version              "1.7.3">  
 <!ENTITY firefox-version              "1.0"> 
 <!ENTITY galeon-version               "1.3.14a"> 
 <!ENTITY dillo-version                "0.8.2">  
 
 <!-- Chapter 36 -->
-<!ENTITY thunderbird-version          "0.8">  
+<!ENTITY thunderbird-version          "1.0">  
 <!ENTITY pan-version                  "0.14.2"> 
 <!ENTITY balsa-version                "2.2.6">    
 

Modified: trunk/BOOK/introduction/welcome/changelog.xml
===================================================================
--- trunk/BOOK/introduction/welcome/changelog.xml	2004-12-13 21:35:37 UTC (rev 3098)
+++ trunk/BOOK/introduction/welcome/changelog.xml	2004-12-14 06:07:48 UTC (rev 3099)
@@ -22,6 +22,9 @@
 
 <itemizedlist>
 
+<listitem><para>December 14th, 2004 [randy]: Updated to Mozilla-1.7.3 and 
+Thunderbird-1.0; modified Firefox instructions.</para></listitem>
+
 <listitem><para>December 13th, 2004 [randy]: Added two acronyms 
 (NSS and NSPR) to the Glossary.</para></listitem>
 

Modified: trunk/BOOK/xsoft/graphweb/firefox.xml
===================================================================
--- trunk/BOOK/xsoft/graphweb/firefox.xml	2004-12-13 21:35:37 UTC (rev 3098)
+++ trunk/BOOK/xsoft/graphweb/firefox.xml	2004-12-14 06:07:48 UTC (rev 3099)
@@ -6,9 +6,10 @@
 
   <!ENTITY firefox-download-http "http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/&firefox-version;/source/firefox-&firefox-version;-source.tar.bz2">
   <!ENTITY firefox-download-ftp "ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/&firefox-version;/source/firefox-&firefox-version;-source.tar.bz2">
+  <!ENTITY firefox-md5sum        "49c16a71f4de014ea471be81e46b1da8">
   <!ENTITY firefox-size          "32 MB">
-  <!ENTITY firefox-buildsize     "575 MB">
-  <!ENTITY firefox-time          "11.1 SBU">
+  <!ENTITY firefox-buildsize     "564 MB">
+  <!ENTITY firefox-time          "11.3 SBU">
 ]>
 
 <sect1 id="firefox" xreflabel="Firefox-&firefox-version;">
@@ -31,6 +32,7 @@
 url="&firefox-download-http;"/></para></listitem>
 <listitem><para>Download (FTP): <ulink
 url="&firefox-download-ftp;"/></para></listitem>
+<listitem><para>Download MD5 sum: &firefox-md5sum;</para></listitem>
 <listitem><para>Download size: &firefox-size;</para></listitem>
 <listitem><para>Estimated disk space required:
 &firefox-buildsize;</para></listitem>
@@ -40,22 +42,23 @@
 
 <sect3><title><application>Firefox</application> dependencies</title>
 <sect4><title>Required</title>
-<para>
-<xref linkend="GTK2"/>, 
-<xref linkend="libIDL"/> and
-<xref linkend="zip"/>
-</para></sect4>
+<para><xref linkend="GTK2"/>, 
+<xref linkend="libIDL"/> and 
+<xref linkend="zip"/></para>
+</sect4>
+
 <sect4><title>Optional</title>
-<para>
-<xref linkend="libjpeg"/>,
-<xref linkend="unzip"/>,
-<xref linkend="gnome-vfs"/>,
-<xref linkend="mitkrb"/> or <xref linkend="heimdal"/>, 
+<para><xref linkend="libjpeg"/>, 
+<xref linkend="unzip"/>, 
+<xref linkend="gnome-vfs"/>, 
+<xref linkend="libgnome"/>, 
+<xref linkend="mitkrb"/> or <xref linkend="heimdal"/> 
+(for the GSSAPI libraries), 
 <xref linkend="doxygen"/>, 
-<ulink url="http://xprint.mozdev.org/">Xprint</ulink>,
+<ulink url="http://xprint.mozdev.org/">Xprint</ulink>, 
 <ulink url="http://perens.com/FreeSoftware/">Electric Fence</ulink> and 
-<ulink url="http://cairographics.org/">Cairo</ulink>
-</para></sect4>
+<ulink url="http://cairographics.org/">Cairo</ulink></para>
+</sect4>
 </sect3>
 
 </sect2>
@@ -75,37 +78,40 @@
 export BUILD_OFFICIAL="1" &&
 export MOZ_PHOENIX="1" &&
 ./configure --prefix=/usr \
+            --with-default-mozilla-five-home=/usr/lib/firefox-1.0
+            --with-user-appdir=.firefox \
             --with-system-zlib \
             --with-system-png \
+            --enable-application=browser \
             --enable-default-toolkit=gtk2 \
-            --disable-mailnews \
-            --disable-ldap \
+            --enable-extensions=all,-typeaheadfind \
+            --enable-crypto \
             --enable-xft \
-            --disable-freetype2 \
-            --enable-crypto \
             --enable-xinerama \
+            --enable-optimize \
+            --enable-reorder \
+            --enable-strip \
+            --enable-cpp-rtti \
             --enable-single-profile \
-            --disable-composer \
-            --enable-extensions=all,-typeaheadfind \
-            --disable-installer \
+            --disable-freetype2 \
+            --disable-accessibility \
+            --disable-debug \
             --disable-tests \
-            --disable-debug \
-            --enable-optimize \
             --disable-logging \
-            --enable-reorder \
-            --enable-strip \
             --disable-pedantic \
-            --enable-cpp-rtti \
+            --disable-installer \
+            --disable-mailnews \
+            --disable-ldap \
+            --disable-composer \
             --disable-profilesharing &&
 make &&
 make install &&
 install -d /usr/include/firefox-&firefox-version;/nss &&
 cp -Lf dist/private/nss/*.h dist/public/nss/*.h \
-    /usr/include/firefox-&firefox-version;/nss &&
-chown -R root:root /usr/include/firefox-&firefox-version;/nss</command></userinput></screen>
+    /usr/include/firefox-&firefox-version;/nss</command></userinput></screen>
 
-<para>You might want to add the <option>--with-system-jpeg</option>
-switch to the <command>configure</command> script if you have
+<para>You should add the <option>--with-system-jpeg</option> switch to the 
+<command>configure</command> script if you have 
 <application>libjpeg</application> installed.</para>
 
 <para>To enable multi-user operation, execute the following:</para>
@@ -117,11 +123,9 @@
 ./regchrome &&
 touch `find . -name *.rdf`</command></userinput></screen>
 
-<note><para>You should run 
-<command>/usr/bin/firefox</command> 
-once as the root user (or any user with write privileges) to 
-create some necessary additional files in the 
-<filename class='directory'>/usr</filename> 
+<note><para>You should run <command>/usr/bin/firefox</command> once as the 
+root user (or any user with write privileges) to create some necessary 
+additional files in the <filename class='directory'>/usr</filename> 
 hierarchy.</para></note>
 
 </sect2>

Modified: trunk/BOOK/xsoft/graphweb/mozilla.xml
===================================================================
--- trunk/BOOK/xsoft/graphweb/mozilla.xml	2004-12-13 21:35:37 UTC (rev 3098)
+++ trunk/BOOK/xsoft/graphweb/mozilla.xml	2004-12-14 06:07:48 UTC (rev 3099)
@@ -4,14 +4,15 @@
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
 
-  <!ENTITY mozilla-download-http "http://ftp.mozilla.org/pub/mozilla/releases/mozilla&mozilla-version;/src/mozilla-source-&mozilla-version;.tar.bz2">
+  <!ENTITY mozilla-download-http "http://ftp.mozilla.org/pub/mozilla.org/mozilla/releases/mozilla&mozilla-version;/src/mozilla-source-&mozilla-version;.tar.bz2">
   <!ENTITY mozilla-download-ftp  "ftp://ftp.mozilla.org/pub/mozilla.org/mozilla/releases/mozilla&mozilla-version;/src/mozilla-source-&mozilla-version;.tar.bz2">
-  <!ENTITY mozilla-size          "34 MB">
-  <!ENTITY mozilla-buildsize     "700 MB">
-  <!ENTITY mozilla-time          "10.37 SBU">
+  <!ENTITY mozilla-md5sum        "15cb68da1d58f055f871b77ff655df77">
+  <!ENTITY mozilla-size          "29 MB">
+  <!ENTITY mozilla-buildsize     "619 MB">
+  <!ENTITY mozilla-time          "13.46 SBU">
 
-  <!ENTITY enigmail-version      "0.85.0">
-  <!ENTITY ipc-version           "1.0.5">
+  <!ENTITY enigmail-version      "0.89.5">
+  <!ENTITY ipc-version           "1.1.2">
 ]>
 
 <sect1 id="mozilla" xreflabel="Mozilla-&mozilla-version;">
@@ -32,12 +33,12 @@
 
 <para>The <application>Mozilla</application> project also hosts two subprojects 
 that aim to satisfy the needs of users who don't need the complete browser 
-suite or like to have separate applications for browsing and e-mail. These 
-subprojects are
+suite or prefer to have separate applications for browsing and e-mail. These 
+subprojects are 
 <ulink url="http://www.mozilla.org/products/firefox/">Mozilla Firefox</ulink>, 
 (a stand-alone browser based on the 
 <application>Mozilla</application> source code) and <ulink 
-url="http://www.mozilla.org/projects/thunderbird/">Mozilla Thunderbird</ulink>,
+url="http://www.mozilla.org/products/thunderbird/">Mozilla Thunderbird</ulink>, 
 (a stand-alone mail client based on the <application>Mozilla</application> 
 source code). The build instructions for these two applications are discussed 
 in separate sections:</para>
@@ -53,38 +54,27 @@
 url="&mozilla-download-http;"/></para></listitem>
 <listitem><para>Download (FTP): <ulink
 url="&mozilla-download-ftp;"/></para></listitem>
+<listitem><para>Download MD5 sum: &mozilla-md5sum;</para></listitem>
 <listitem><para>Download size: &mozilla-size;</para></listitem>
-<listitem><para>Estimated Disk space required:
+<listitem><para>Estimated disk space required:
 &mozilla-buildsize;</para></listitem>
 <listitem><para>Estimated build time:
 &mozilla-time;</para></listitem></itemizedlist>
 </sect3>
 
 <sect3><title>Additional downloads</title>
-<itemizedlist spacing='compact'>
-<listitem><para>Required Patch: <ulink
-url="&patch-root;/mozilla-&mozilla-version;-freetype_fix-1.patch"/></para>
-</listitem></itemizedlist>
 
-<para>To enable the <application>Enigmail</application> extension to the 
-<application>Mozilla</application> and <application>Thunderbird</application> 
-mail clients, you'll need to download the two tarballs below. The 
-<application>Enigmail</application> extension allows users to access the 
-authentication and encryption features provided by the 
+<para>To enable the <application>Enigmail</application> extension to the
+<application>Mozilla</application> mail client, you'll need to download the
+two tarballs below. The <application>Enigmail</application> extension allows
+users to access the authentication and encryption features provided by the
 <application>GnuPG</application> package.</para>
 
 <itemizedlist spacing='compact'>
-<!-- <listitem><para><ulink url="http://enigmail.mozdev.org/">Enigmail Extension
-(Version &enigmail-version;)</ulink> 
-(Useful only if Mozilla Mail is built)</para></listitem>
-<listitem><para><ulink url="http://enigmail.mozdev.org/">Inter Process
-Communicaton Extension (Version &ipc-version;)</ulink>
-(Needed for Enigmail)</ulink></para></listitem> -->
-
-<listitem><para><ulink
+<listitem><para><ulink 
 url="http://downloads.mozdev.org/enigmail/src/enigmail-&enigmail-version;.tar.gz"/>
 </para></listitem>
-<listitem><para><ulink
+<listitem><para><ulink 
 url="http://downloads.mozdev.org/enigmail/src/ipc-&ipc-version;.tar.gz"/>
 </para></listitem>
 </itemizedlist>
@@ -94,22 +84,24 @@
 <sect4><title>Required</title>
 <para><xref linkend="zip"/>, 
 <xref linkend="GTK2"/>, 
-<xref linkend="libIDL"/>, 
-<xref linkend="libmng"/> and 
-<xref linkend="which"/></para>
+<xref linkend="libIDL"/></para>
 </sect4>
 
 <sect4><title>Recommended</title>
-<para><xref linkend="gnupg"/> (for Enigmail extension)</para>
+<para><xref linkend="gnupg"/> (for the Enigmail extension)</para>
 </sect4>
 
 <sect4><title>Optional</title>
-<para><xref linkend="gnome-vfs"/>, 
-<xref linkend="libart_lgpl"/>, 
-<xref linkend="heimdal"/> or <xref linkend="mitkrb"/> 
-(for the GSSAPI libraries), 
-<xref linkend="doxygen"/> and 
-<ulink url="http://www.hpl.hp.com/personal/Hans_Boehm/gc/">GC</ulink></para>
+<para><xref linkend="libjpeg"/>,
+<xref linkend="unzip"/>,
+<xref linkend="gnome-vfs"/>,
+<xref linkend="libart_lgpl"/>,
+<xref linkend="heimdal"/> or <xref linkend="mitkrb"/>
+(for the GSSAPI libraries),
+<xref linkend="doxygen"/>,
+<ulink url="http://xprint.mozdev.org/">Xprint</ulink>,
+<ulink url="http://perens.com/FreeSoftware/">Electric Fence</ulink> and
+<ulink url="http://cairographics.org/">Cairo</ulink></para>
 </sect4>
 </sect3>
 
@@ -118,52 +110,33 @@
 <sect2>
 <title>Installation of <application>Mozilla</application></title>
 
-<!--
-<note>
-<para>According to the financial institutions, the following hack makes your
-browser insecure. You have been warned. Many sites use an MS-IE specific tag 
-(autocomplete=off) to prevent autocomplete from working in some forms. This 
-tag is now supported in <application>Mozilla</application> to appease 
-the financial institutions. As per 
-the requirements of the financial institutions, they will not even accept a 
-solution where this a preference option. However our opinion is that it should 
-be in the hands of the user. To enable autocomplete to bypass
-this restriction, we need to make a slight modification in the code.</para>
-
-<para>Open the file <filename>extensions/wallet/src/wallet.cpp</filename> in
-the <application>Mozilla</application> source tree and search for the line:
-<screen>#define WALLET_DONT_CACHE_ALL_PASSWORDS</screen>
-Then delete or comment out the line.  Now, if anyone tells you MS-IE is user
-friendly, give them this example!</para>
-</note>
--->
-
-<warning><para>Do not install <application>Mozilla</application>, 
-<application>Mozilla Firefox</application> and 
-<application>Mozilla Thunderbird</application> with a single prefix since they 
-install identically named files. The <acronym>BLFS</acronym> Book installs 
-<application>Mozilla</application> in <filename>/usr</filename> while 
-<application>Mozilla Firefox</application> and 
-<application>Mozilla Thunderbird</application> are installed in 
-<filename>/opt</filename>.</para></warning>
-
 <para>Compile <application>Mozilla</application> by running the following 
 commands:</para>
 
 <screen><userinput><command>export MOZILLA_OFFICIAL="1" &&
 export BUILD_OFFICIAL="1" &&
-patch -Np1 -i ../mozilla-&mozilla-version;-freetype_fix-1.patch &&
 ./configure --prefix=/usr \
             --with-default-mozilla-five-home=/usr/lib/mozilla \
+            --with-system-zlib \
+            --with-system-png \
+            --enable-application=suite \
             --enable-default-toolkit=gtk2 \
-            --with-x --with-system-zlib \
-            --with-system-jpeg --with-system-png --with-system-mng \
-            --enable-xft --enable-crypto \
+            --enable-extensions=all \
+            --enable-crypto \
+            --enable-xft \
+            --enable-xinerama \
+            --enable-optimize \
+            --enable-reorder \
+            --enable-strip \
+            --enable-cpp-rtti \
+            --enable-calendar \
+            --disable-freetype2 \
             --disable-accessibility \
-            --disable-tests --disable-debug \
-            --disable-logging --enable-reorder \
-            --enable-strip --disable-pedantic \
-            --enable-cpp-rtti --enable-extensions=all &&
+            --disable-debug \
+            --disable-tests \
+            --disable-logging \
+            --disable-pedantic \
+            --disable-installer &&
 make</command></userinput></screen>
 
 <para>If you're building the <application>Mozilla</application> mail and news 
@@ -174,9 +147,7 @@
 tar zxf ../ipc-&ipc-version;.tar.gz -C extensions &&
 build/autoconf/make-makefile extensions/ipc extensions/enigmail &&
 make -C extensions/ipc &&
-make -C extensions/enigmail &&
-make -C extensions/enigmail/build xpi &&
-make -C extensions/enigmail/package xpi</command></userinput></screen>
+make -C extensions/enigmail</command></userinput></screen>
 
 <para>Install <application>Mozilla</application> as follows:</para>
 
@@ -185,60 +156,78 @@
 cp -Lf dist/private/nss/*.h dist/public/nss/*.h \
    /usr/include/mozilla-&mozilla-version;/nss &&
 ln -nsf mozilla-&mozilla-version; /usr/include/mozilla &&
+if [ -d /usr/lib/mozilla/plugins ]; then
+    mv /usr/lib/mozilla/plugins/* /usr/lib/mozilla-&mozilla-version;/plugins
+    rm -rf /usr/lib/mozilla
+fi &&
 ln -nsf mozilla-&mozilla-version; /usr/lib/mozilla</command></userinput></screen>
 
-<para>Some libraries installed by <application>Mozilla</application> are also 
-needed by other packages. These libraries should be in 
-<filename>/usr/lib</filename> so that other packages can link against them. 
-Move them as follows:</para>
+<para>If you're installing the <application>Enigmail</application> extension, 
+issue the following commands:</para>
 
+<screen><userinput><command>make -C extensions/ipc install &&
+make -C extensions/enigmail install</command></userinput></screen>
+
+<para>Some libraries, including the Netscape Portable Runtime 
+(<acronym>NSPR</acronym>) and Network Security Services 
+(<acronym>NSS</acronym>) libraries, installed by 
+<application>Mozilla</application> are also needed by other packages. These 
+libraries should be in <filename>/usr/lib</filename> so that other packages 
+can link against them. Move them as follows:</para>
+
 <screen><userinput><command>for i in lib{nspr4,plc4,plds4,nss3,smime3,softokn3,ssl3}.so libsoftokn3.chk
 do
    mv /usr/lib/mozilla-&mozilla-version;/$i /usr/lib/
    ln -sf ../$i /usr/lib/mozilla-&mozilla-version;/
 done</command></userinput></screen>
 
-<para>Install the <application>Enigmail</application> extension as 
-follows:</para>
+<para>Create the required component registries to enable multi-user installs. 
+These steps should be preformed by the root user each time a 
+<application>Mozilla</application> add-on is installed. This will allow normal 
+users to run <command>mozilla</command>. Enable multi-user operation by 
+executing the following:</para>
 
-<screen><userinput><command>make -C extensions/ipc install &&
-make -C extensions/enigmail install</command></userinput></screen>
-
-<para>To enable multi-user operation, execute the following:</para>
-
 <screen><userinput><command>cd /usr/lib/mozilla-&mozilla-version; &&
-export LD_LIBRARY_PATH="/usr/lib/mozilla-&mozilla-version;" &&
-export MOZILLA_FIVE_HOME="/usr/lib/mozilla-&mozilla-version;" &&
+export LD_LIBRARY_PATH="$PWD" &&
+export MOZILLA_FIVE_HOME="$PWD" &&
 ./regxpcom &&
 ./regchrome &&
-touch `find /usr/lib/mozilla-&mozilla-version; -name *.rdf`</command></userinput></screen>
+touch `find . -name *.rdf`</command></userinput></screen>
 
+<note><para>You should run <command>/usr/bin/mozilla</command> once as the 
+root user (or any user with write privileges) to create some necessary 
+additional files in the <filename class='directory'>/usr</filename> 
+hierarchy.</para></note>
+
 </sect2>
 
 <sect2>
 <title>Optional Extra Switches</title>
 
-<para>Each of these switches can be added to the configure line in order to
-have the described effect on the <application>Mozilla</application> 
-compile.</para>
+<para>You may wish to run <command>./configure --help</command> and review
+each of the listed options to discover what affect they have on the build.
+Feel free to add or remove options to tailor the build to your desires.
+Listed below are some common options not listed above but can be added to
+the <command>configure</command> command in order to have the described effect 
+on the <application>Mozilla</application> compile.</para>
 
-<para><option>--enable-elf-dynstr-gc</option>: Removes un-referenced
+<para><option>--with-system-jpeg</option>: Uses the system-installed copy of 
+<application>libjpeg</application> instead of the bundled copy.</para>
+
+<para><option>--enable-elf-dynstr-gc</option>: Removes un-referenced 
 strings from <acronym>ELF</acronym> shared objects generated during the build. 
 Note that this option breaks the build on alpha.</para>
 
-<para><option>--disable-mailnews</option>: Disable the mail and news
+<para><option>--disable-mailnews</option>: Disables the mail and news 
 clients.</para>
 
-<para><option>--disable-ldap</option>: Disable <acronym>LDAP</acronym> 
+<para><option>--disable-ldap</option>: Disables <acronym>LDAP</acronym> 
 support, recommended if mail is disabled.</para>
 
-<para><option>--enable-calendar</option>: Build the calendar client.</para>
+<para><option>--enable-xterm-updates</option>: Displays the current command 
+in the <command>xterm</command> window title during the compilation.</para>
 
-<para><option>--enable-xterm-updates</option>: This option is for enabling 
-the <command>xterm</command> window title with the current command when 
-compiling.</para>
-
-<para><option>--enable-plaintext-editor-only</option>: Disable support
+<para><option>--enable-plaintext-editor-only</option>: Disables support 
 for <acronym>HTML</acronym> editing. Do not use this switch if you are 
 building the mail-news component.</para>
 
@@ -247,102 +236,79 @@
 <sect2>
 <title>Command explanations</title>
 
-<para><screen><command>export MOZILLA_OFFICIAL="1" &&
-export BUILD_OFFICIAL="1"</command></screen>
-Set some variables that affect what and how the package is built. These two 
-exports specify a distribution is being built.</para>
+<para><command>export MOZILLA_OFFICIAL="1"; 
+export BUILD_OFFICIAL="1"</command>: Set some variables that affect what and 
+how the package is built. These two exports specify a distribution is being 
+built.</para>
 
-<!--
-<para> The last export specifies that we
-are ok with the <acronym>LGPL</acronym> versioned libart.</para>
--->
+<para><parameter>--with-default-mozilla-five-home=/usr/lib/mozilla</parameter>: 
+Sets the default value for <envar>MOZILLA_FIVE_HOME</envar>.</para>
 
-<para><parameter>--prefix=/usr</parameter>: Previously 
-<application>Mozilla</application> did not support the <command>make 
-install</command> option. Hence, the package was installed in 
-<filename>/opt</filename>. The package now supports 
-"<command>make install</command>" and follows the <acronym>FHS</acronym> 
-guidelines for installation. Therefore the book now recommends installation 
-in a system wide prefix such as <filename>/usr</filename>.</para>
+<para><parameter>--with-system-zlib --with-system-png </parameter>: Use the 
+system-installed versions of these packages.</para>
 
-<para><screen><option>--enable-default-toolkit=gtk2</option></screen>
-Use the gtk2 toolkit.</para>
+<para><parameter>--enable-application=suite</parameter>: Identifies the build 
+as a <application>Mozilla</application> suite build.</para>
 
-<para><screen><option>--with-system-zlib --with-system-jpeg \
---with-system-png --with-system-mng</option></screen>
-Use the system installed versions of these packages.</para>
+<para><parameter>--enable-default-toolkit=gtk2</parameter>: Use the 
+<acronym>GTK</acronym>2 toolkit for graphics rendering.</para>
 
-<para><option>--enable-xft</option>: Enable Xft support. You need 
-<application>fontconfig</application> or the latest 
-<application>XFree86</application> version to enable Xft.</para>
-
-<para><option>--enable-crypto</option>: Enable the Personal
-Security Manager to enable <acronym>SSL</acronym> connections.</para>
-
-<para><screen><option>--disable-jsd --disable-accessibility \
---disable-tests --disable-debug \
---disable-dtd-debug \
---disable-logging --enable-reorder \
---enable-strip \
---enable-cpp-rtti</option></screen>
-Various options that affect what components are built and some optimization
-options. You can pick and choose from these options. More information on them 
-can be found in the <application>Mozilla</application> 
-<command>configure</command> script help. Not all options are used in the 
-instructions given above.</para>
-
-<para><option>--enable-extensions=...</option>: Enables extensions.  If you 
-want, you can disable all extensions other than the browser by changing this 
-switch to 
-<parameter>--enable-extensions="default,-venkman,-inspector,-irc"</parameter>. 
+<para><parameter>--enable-extensions=all</parameter>: Enables all available 
+extensions. If you want, you can disable any or all extensions other than the 
+browser by changing this switch to 
+<parameter>--enable-extensions="default,-venkman,-inspector,..."</parameter>. 
 For a short description of the various extensions available with the 
 <application>Mozilla</application> source, see
 <ulink 
 url="http://linuxfromscratch.org/~tushar/downloads/mozilla-extensions.txt"/>.
 </para>
 
-<para><screen><command>install -d /usr/include/mozilla-&mozilla-version;/nss
-cp -Lf dist/private/nss/*.h dist/public/nss/*.h \
-   /usr/include/mozilla-&mozilla-version;/nss</command></screen>
-Copy the nss headers that are not copied by make install.</para>
+<para><parameter>--enable-crypto</parameter>: Enable the Personal 
+Security Manager to enable <acronym>SSL</acronym> connections.</para>
 
-<!--
-<para><userinput>install -d /usr/lib/mozilla-&mozilla-version;/openoffice</userinput> :
-Make a directory to store static libraries that openoffice needs during compilation.
-These libraries are not installed by default.</para>
--->
+<para><parameter>--enable-calendar</parameter>: Builds the calendar 
+application. Removed this parameter if you don't wish to build it.</para>
+ 
+<para><parameter>--enable-xft; --disable-freetype2</parameter>: Enable Xft 
+support which automatically pulls in the <application>FreeType</application> 
+libraries.</para> 
 
-<para><command>ln -nsf mozilla-&mozilla-version; ...</command>:
+<para><parameter>--enable-xinerama; --enable-optimize; --enable-reorder; 
+--enable-strip; --enable-cpp-rtti --disable-accessibility; --disable-debug; 
+--disable-tests; --disable-logging; --disable-pedantic; 
+--disable-installer</parameter>: Various options that affect what components 
+are built and some optimization options. You can pick and choose from these 
+options. More information on them, and many other available options, can be 
+found by running <command>./configure --help</command>.</para>
+
+<para><command>install -d /usr/include/mozilla-&mozilla-version;/nss; 
+cp -Lf ...</command>: Copy the <acronym>NSS</acronym> interface headers that 
+are not copied by <command>make install</command>.</para>
+
+<para><command>if [ -d /usr/lib/mozilla/plugins ] ... fi</command>: Some 
+applications may have already installed <application>Mozilla</application> 
+plugins. This set of commands move any existing plugins to the newly created 
+plugin directory, then removes the existing 
+<filename class='directory'>/usr/lib/mozilla</filename> directory.</para>
+
+<para><command>ln -nsf mozilla-&mozilla-version; ...</command>: 
 <application>Mozilla</application> installs headers and libraries in version 
-specific directories. This command makes symbolic links so that applications 
+specific directories. These commands makes symbolic links so that applications 
 depending on <application>Mozilla</application> (such as 
 <application>OpenOffice</application>, <application>Galeon</application>, 
 etc.) don't need to know which version of <application>Mozilla</application> 
 is installed.</para>
 
-<para><screen><command>export LD_LIBRARY_PATH="/usr/lib/mozilla-&mozilla-version;" &&
-export MOZILLA_FIVE_HOME="/usr/lib/mozilla-&mozilla-version;" &&
-./regxpcom &&
-./regchrome &&
-touch `find /usr/lib/mozilla-${VERSION} -name *.rdf`</command>
-</screen>
-Create the required component registries to enable multi-user installs. These
-steps should be preformed by the root user each time a 
-<application>Mozilla</application> add-on is installed. This will allow normal 
-users to run <command>mozilla</command>.</para>
-
 </sect2>
 
 <sect2>
 <title>Configuring <application>Mozilla</application></title>
 
 <para>No specific configuration is required as long as the 
-<command>mozilla</command> binary is in the path for the user. If 
+<command>mozilla</command> script is in the user's path. If 
 <application>Mozilla</application> is installed in a non-standard location, 
-then make a symlink to the <command>mozilla</command> binary from 
-<filename class="directory">/usr/bin</filename>. The same thing applies for 
-<application>Mozilla Firefox</application> and
-<application>Mozilla Thunderbird</application>.</para>
+then make a symlink to the <command>mozilla</command> script from 
+<filename class="directory">/usr/bin</filename>.</para>
 
 <para>Many applications look for <command>netscape</command> when they need to 
 open a browser. You may make the following symlink for convenience.</para>
@@ -358,12 +324,13 @@
 <sect2>
 <title>Contents</title>
 
-<para>The <application>Mozilla</application> package contains
+<para>The <application>Mozilla</application> package contains 
 <command>mozilla</command> and the <application>Mozilla</application> 
-libraries and plugins. The various components such as composer and mail-news 
-can be accessed from the menu after <command>mozilla</command> starts or 
-via command-line switches to the <command>mozilla</command> binary.
-</para>
+libraries and plugins. The various components such as the Composer, 
+mail-news client, calendar, <acronym>IRC</acronym> chat client and 
+address book can be accessed from the menu after <command>mozilla</command> 
+starts or via command-line switches to the <command>mozilla</command> script. 
+Issue <command>man mozilla</command> for additional information.</para>
 
 </sect2>
 

Modified: trunk/BOOK/xsoft/other/thunderbird.xml
===================================================================
--- trunk/BOOK/xsoft/other/thunderbird.xml	2004-12-13 21:35:37 UTC (rev 3098)
+++ trunk/BOOK/xsoft/other/thunderbird.xml	2004-12-14 06:07:48 UTC (rev 3099)
@@ -4,29 +4,30 @@
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
 
-  <!ENTITY thunderbird-download-http     "http://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/&thunderbird-version;/thunderbird-source-&thunderbird-version;.tar.bz2">
-  <!ENTITY thunderbird-download-ftp      "ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/&thunderbird-version;/thunderbird-source-&thunderbird-version;.tar.bz2">
-  <!ENTITY thunderbird-size              "32.9 MB">
-  <!ENTITY thunderbird-buildsize         "637 MB">
-  <!ENTITY thunderbird-time              "13.05 SBU">
-  <!ENTITY thunderbird-enigmail-version  "0.86.0">
-  <!ENTITY thunderbird-ipc-version       "1.0.8">
+  <!ENTITY thunderbird-download-http     "http://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/&thunderbird-version;/source/thunderbird-&thunderbird-version;-source.tar.bz2">
+  <!ENTITY thunderbird-download-ftp      "ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/&thunderbird-version;/source/thunderbird-&thunderbird-version;-source.tar.bz2">
+  <!ENTITY thunderbird-md5sum            "232ffe434fd65f5f0284a760d6e4ba2a">
+  <!ENTITY thunderbird-size              "33 MB">
+  <!ENTITY thunderbird-buildsize         "608 MB">
+  <!ENTITY thunderbird-time              "12.38 SBU">
+  <!ENTITY thunderbird-enigmail-version  "0.89.5">
+  <!ENTITY thunderbird-ipc-version       "1.1.2">
   <!ENTITY thunderbird-enigmail-download "http://downloads.mozdev.org/enigmail/src/enigmail-&thunderbird-enigmail-version;.tar.gz">
   <!ENTITY thunderbird-ipc-download      "http://downloads.mozdev.org/enigmail/src/ipc-&thunderbird-ipc-version;.tar.gz">
 ]>
 
-<sect1 id="thunderbird" xreflabel="MozillaThunderbird-&thunderbird-version;">
+<sect1 id="thunderbird" xreflabel="Thunderbird-&thunderbird-version;">
 <sect1info>
 <othername>$LastChangedBy$</othername>
 <date>$Date$</date>
 </sect1info>
 <?dbhtml filename="thunderbird.html" ?>
-<title>MozillaThunderbird-&thunderbird-version;</title>
+<title>Thunderbird-&thunderbird-version;</title>
 
 <sect2>
-<title>Introduction to <application>Mozilla Thunderbird</application></title>
+<title>Introduction to <application>Thunderbird</application></title>
 
-<para><application>Mozilla Thunderbird</application> is a stand-alone 
+<para><application>Thunderbird</application> is a stand-alone 
 mail/news client based on the <application>Mozilla</application> 
 codebase.</para>
 
@@ -36,18 +37,15 @@
 url="&thunderbird-download-http;"/></para></listitem>
 <listitem><para>Download (FTP): <ulink 
 url="&thunderbird-download-ftp;"/></para></listitem>
+<listitem><para>Download MD5 sum: &thunderbird-md5sum;</para></listitem>
 <listitem><para>Download size: &thunderbird-size;</para></listitem>
-<listitem><para>Estimated Disk space required: 
+<listitem><para>Estimated disk space required: 
 &thunderbird-buildsize;</para></listitem>
 <listitem><para>Estimated build time: 
 &thunderbird-time;</para></listitem></itemizedlist>
 </sect3>
 
 <sect3><title>Additional downloads</title>
-<itemizedlist spacing="compact">
-<listitem><para>Required Patch: <ulink
-url="&patch-root;/thunderbird-&thunderbird-version;-freetype_fix-1.patch"/></para>
-</listitem></itemizedlist>
 
 <para>To enable the <application>Enigmail</application> extension to the 
 <application>Thunderbird</application> mail client, you'll need to download the 
@@ -61,7 +59,7 @@
 </itemizedlist>
 </sect3>
 
-<sect3><title><application>Mozilla Thunderbird</application> 
+<sect3><title><application>Thunderbird</application> 
 dependencies</title>
 <sect4><title>Required</title>
 <para><xref linkend="zip"/>, 
@@ -70,7 +68,7 @@
 </sect4>
 
 <sect4><title>Recommended</title>
-<para><xref linkend="gnupg"/> (for <application>Enigmail</application> 
+<para><xref linkend="gnupg"/> (for the <application>Enigmail</application> 
 extension)</para>
 </sect4>
 
@@ -78,7 +76,9 @@
 <para><xref linkend="libjpeg"/>, 
 <xref linkend="unzip"/>, 
 <xref linkend="gnome-vfs"/>, 
-<xref linkend="mitkrb"/> or <xref linkend="heimdal"/>, 
+<xref linkend="libgnome"/>, 
+<xref linkend="mitkrb"/> or <xref linkend="heimdal"/> 
+(for the GSSAPI libraries), 
 <xref linkend="doxygen"/>, 
 <ulink url="http://xprint.mozdev.org/">Xprint</ulink>, 
 <ulink url="http://perens.com/FreeSoftware/">Electric Fence</ulink> 
@@ -89,57 +89,52 @@
 </sect2>
 
 <sect2>
-<title>Installation of <application>Mozilla Thunderbird</application></title>
+<title>Installation of <application>Thunderbird</application></title>
 
-<!-- <warning>
-<para>The current source tarball uses CRLF line-ending (DOS Format). This causes
-problems during the compilation. Once you extract the tarball, convert the files
-to UNIX style line endings using <xref linkend="hd2u"/>.</para>
-<screen><userinput><command>find -type f -print0 | xargs -0 dos2unix -d2u</command></userinput></screen>
-</warning> -->
-
-<para>The configuration of <application>Mozilla Thunderbird</application> is 
+<para>The configuration of <application>Thunderbird</application> is 
 very similar to <xref linkend="mozilla"/> and hence the options will not be 
 discussed. Refer to the <xref linkend="mozilla"/> instructions for
 explanations and additional configuration information.</para>
 
-<note><para>There is a known issue with the imbedded help facility in the
-<application>Thunderbird</application> build. The <quote>Release Notes</quote> 
-and <quote>Mozilla Thunderbird Help</quote> items in the drop down 
-<quote>Help</quote> menu will not work. BLFS is working to resolve this 
-issue.</para></note>
-
-<para>Compile <application>Mozilla Thunderbird</application> by
+<para>Compile <application>Thunderbird</application> by
 running the following commands:</para>
 
-<screen><userinput><command>patch -Np1 -i ../thunderbird-&thunderbird-version;-freetype_fix-1.patch &&
-export MOZILLA_OFFICIAL="1" &&
+<screen><userinput><command>export MOZILLA_OFFICIAL="1" &&
 export BUILD_OFFICIAL="1" &&
 export MOZ_THUNDERBIRD="1" &&
-./configure --prefix=/opt/thunderbird-&thunderbird-version; \
+./configure --prefix=/usr \
+            --with-default-mozilla-five-home=/usr/lib/thunderbird-&thunderbird-version; \
             --with-system-zlib \
             --with-system-png \
+            --enable-application=mail \
             --enable-default-toolkit=gtk2 \
-            --disable-ldap \
-            --enable-xft \
+            --enable-extensions=wallet,spellcheck,xmlextras,webservices \
             --enable-crypto \
+            --enable-xft \
             --enable-xinerama \
-            --enable-single-profile \
-            --enable-extensions=all \
-            --disable-installer \
-            --disable-tests \
-            --disable-debug \
             --enable-optimize \
-            --disable-logging \
             --enable-reorder \
             --enable-strip \
-            --disable-pedantic \
             --enable-cpp-rtti \
-            --disable-profilesharing &&
+            --enable-single-profile \
+            --enable-necko-protocols=http,file,jar,viewsource,res,data \
+            --enable-image-decoders=default,-xbm \
+            --disable-freetype2 \
+            --disable-accessibility \
+            --disable-debug \
+            --disable-tests \
+            --disable-logging \
+            --disable-pedantic \
+            --disable-installer \
+            --disable-profilesharing \
+            --disable-mathml \
+            --disable-oji \
+            --disable-plugins \
+            --disable-necko-disk-cache &&
 make</command></userinput></screen>
 
-<para>You may want to add the <option>--with-system-jpeg</option>
-switch to the <command>configure</command> script if you have
+<para>You should add the <option>--with-system-jpeg</option> switch to the 
+<command>configure</command> script if you have
 <application>libjpeg</application> installed.</para>
 
 <para>If you're building the <application>Enigmail</application> extension, 
@@ -149,52 +144,34 @@
 tar zxf ../ipc-&thunderbird-ipc-version;.tar.gz -C extensions &&
 build/autoconf/make-makefile extensions/ipc extensions/enigmail &&
 make -C extensions/ipc &&
-make -C extensions/enigmail &&
-make -C extensions/enigmail/build xpi &&
-make -C extensions/enigmail/package xpi</command></userinput></screen>
+make -C extensions/enigmail</command></userinput></screen>
 
 <para>Install <application>Thunderbird</application> by running the following 
 commands:</para>
 
 <screen><userinput><command>make install &&
-install -d /opt/thunderbird-&thunderbird-version;/include/thunderbird-&thunderbird-version;/nss &&
+install -d /usr/include/thunderbird-&thunderbird-version;/nss &&
 cp -Lf dist/private/nss/*.h dist/public/nss/*.h \
-    /opt/thunderbird-&thunderbird-version;/include/thunderbird-&thunderbird-version;/nss &&
-chown -R root:root /opt/thunderbird-&thunderbird-version;/include/thunderbird-&thunderbird-version;/nss &&
-ln -sf /opt/thunderbird-&thunderbird-version;/bin/thunderbird \
-    /usr/bin/MozillaThunderbird</command></userinput></screen>
+    /usr/include/thunderbird-&thunderbird-version;/nss</command></userinput></screen>
 
-<para>If desired, install the <application>Enigmail</application> extension 
-by running the following commands:</para>
+<para>If you're installing the <application>Enigmail</application> extension, 
+issue the following commands:</para>
 
 <screen><userinput><command>make -C extensions/ipc install &&
 make -C extensions/enigmail install</command></userinput></screen>
 
 <para>To enable multi-user operation, execute the following:</para>
 
-<screen><userinput><command>cd /opt/thunderbird-&thunderbird-version;/lib/thunderbird-&thunderbird-version; &&
+<screen><userinput><command>cd /usr/lib/thunderbird-&thunderbird-version; &&
 export LD_LIBRARY_PATH="$PWD" &&
 export MOZILLA_FIVE_HOME="$PWD" &&
 ./regxpcom &&
 ./regchrome &&
 touch `find . -name *.rdf`</command></userinput></screen>
 
-<para>There are three overlay definitions which cause menu functionality and  
-display problems. Remove these definitions with the following commands:</para>
-
-<screen><userinput><command>export CHROME_PATH="/opt/thunderbird-&thunderbird-version;/lib/thunderbird-&thunderbird-version;/chrome" &&
-sed -i.orig -e "/cookieContextOverlay/d" \
-    $CHROME_PATH/overlayinfo/messenger/content/overlays.rdf &&
-sed -i.orig -e "/cookieContextOverlay/d" -e "/helpMenuOverlay/d" \
-    $CHROME_PATH/overlayinfo/communicator/content/overlays.rdf &&
-unset CHROME_PATH LD_LIBRARY_PATH MOZILLA_FIVE_HOME \
-    MOZILLA_OFFICIAL BUILD_OFFICIAL MOZ_THUNDERBIRD</command></userinput></screen>
-
-<note><para>You should run 
-<command>/opt/thunderbird-&thunderbird-version;/bin/thunderbird</command> 
-once as the root user (or any user with write privileges) to 
-create some necessary additional files in the 
-<filename class='directory'>/opt/thunderbird-&thunderbird-version;</filename> 
+<note><para>You should run <command>/usr/bin/thunderbird</command> once as 
+the root user (or any user with write privileges) to create some necessary 
+additional files in the <filename class='directory'>/usr</filename> 
 hierarchy.</para></note>
 
 </sect2>




More information about the blfs-book mailing list