[Bug 238] New: Add installation of gcc2 libs

blfs-bugs at linuxfromscratch.org blfs-bugs at linuxfromscratch.org
Wed Dec 11 08:10:20 PST 2002


http://blfs-bugs.linuxfromscratch.org/show_bug.cgi?id=238

           Summary: Add installation of gcc2 libs
           Product: Beyond LinuxFromScratch
           Version: CVS
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: minor
          Priority: P4
         Component: BOOK
        AssignedTo: blfs-book at linuxfromscratch.org
        ReportedBy: tush at yahoo.com
         QAContact: blfs-book at linuxfromscratch.org


Since many commercial and precompiled packages depend on gcc2 libs, and the
question is asked n number of times on the lists, it would be better if the book
included a section on installation of gcc2 libs. I use the following that
compiles the complete gcc-2.95.3 and then copies the libs, but there may be a
shorter way to do it (never bothered to research it since it is only done once):
   ../gcc-2.95.3/configure --prefix=/var/tmp/gcc --enable-shared \
      --enable-languages=c++ --enable-threads=posix &&
   make &&
   make install &&
   mv /var/tmp/gcc/lib/*.so* /usr/lib &&
   ln -sf libstdc++-libc6.3-2.so.3 /usr/lib/libstdc++-libc6.1-1.so.2 &&
   ln -sf libstdc++-libc6.3-2.so.3 /usr/lib/libstdc++-libc6.2-2.so.3 &&
   ldconfig

Another option is to install it in a different directory e.g.
/usr/lib/gcc2-compat/ and ask the users to add the directory to LD_LIBRARY_PATH
for apps that need gcc2 libs.



------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.
You are the QA contact for the bug, or are watching the QA contact.
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-book' in the subject header of the message



More information about the blfs-book mailing list