openssl command

didbaba didbaba at free.fr
Wed Aug 15 14:31:00 PDT 2001


In the blfs-book, the command to install the ssl library seem to be
incomplete. As the openssh hint author suggest, the permission of the library
must be 644 for libcrypto.a and libssl.a, and 755 for the shared one.
Actually this is not true.

May I suggest to add :
cd /usr/lib
chmod 644 libcrypto.a libssl.a  # useless IIRC
chmod 755 libcrypto.so.0.9.6 libssl.so.0.9.6

If I remember correctly only the shared one have a permission problem

Shared library must be executable, no ?

-- 
didbaba
powered by LinuxFromScratch 2.4
http://didbaba.free.fr



More information about the blfs-book mailing list