r3619 - jhalfs/trunk/common/libs

pierre at linuxfromscratch.org pierre at linuxfromscratch.org
Thu Mar 29 01:20:53 PDT 2012


Author: pierre
Date: 2012-03-29 02:20:43 -0600 (Thu, 29 Mar 2012)
New Revision: 3619

Modified:
   jhalfs/trunk/common/libs/func_check_version.sh
Log:
Change xz version requirement to 5.0.0 as per LFS r9794

Modified: jhalfs/trunk/common/libs/func_check_version.sh
===================================================================
--- jhalfs/trunk/common/libs/func_check_version.sh	2012-03-27 05:39:27 UTC (rev 3618)
+++ jhalfs/trunk/common/libs/func_check_version.sh	2012-03-29 08:20:43 UTC (rev 3619)
@@ -61,7 +61,7 @@
   set -- $tst_version # Set positional parameters to test version values
   # Values beginning with zero are taken as octal, so that for example
   # 2.07.08 gives an error because 08 cannot be octal. The ## stuff supresses
-  # leading sero's
+  # leading zero's
   major=${1##*(0)}; minor=${2##*(0)}; revision=${3##*(0)}
   #
   # Compare against minimum acceptable version..
@@ -108,7 +108,7 @@
   check_version "5.8.8"   "$(perl -V:version | cut -f2 -d\')"                  "PERL"
   check_version "4.1.5"   "$(sed --version   | head -n1 | cut -d" " -f4)"      "SED"
   check_version "4.9"	  "$(makeinfo --version | head -n1 | awk '{ print$NF }')" "TEXINFO"
-  check_version "5.0.3"   "$(xz --version | head -n1 | cut -d" " -f4)"         "XZ"
+  check_version "5.0.0"   "$(xz --version | head -n1 | cut -d" " -f4)"         "XZ"
   # Check for minimum sudo version
   SUDO_LOC="$(whereis -b sudo | cut -d" " -f2)"
   if [ -x $SUDO_LOC ]; then




More information about the alfs-log mailing list