r3630 - jhalfs/branches/ablfs/BLFS/xsl

pierre at linuxfromscratch.org pierre at linuxfromscratch.org
Sun Apr 22 13:59:24 PDT 2012


Author: pierre
Date: 2012-04-22 14:59:19 -0600 (Sun, 22 Apr 2012)
New Revision: 3630

Modified:
   jhalfs/branches/ablfs/BLFS/xsl/gen_pkg_list.xsl
Log:
Makes xorg-driver a required dep of xterm, since the preceding-sibling
is not a unique package. In xsl/gen_pkg_list.xsl

Modified: jhalfs/branches/ablfs/BLFS/xsl/gen_pkg_list.xsl
===================================================================
--- jhalfs/branches/ablfs/BLFS/xsl/gen_pkg_list.xsl	2012-04-21 21:23:58 UTC (rev 3629)
+++ jhalfs/branches/ablfs/BLFS/xsl/gen_pkg_list.xsl	2012-04-22 20:59:19 UTC (rev 3630)
@@ -202,7 +202,7 @@
             </xsl:element>
           </xsl:if>
 <!-- Dependencies -->
-<!-- If in Xorg chapter, consider that the preceding package is
+<!-- If in Xorg or KDE chapter, consider that the preceding package is
      the first dependency (not always noted in the book) -->
           <xsl:if test="ancestor::chapter[@id='kde4-core'] or
                        (ancestor::chapter[@id='x-window-system'] and
@@ -212,8 +212,13 @@
             <xsl:element name="dependency">
               <xsl:attribute name="status">required</xsl:attribute>
               <xsl:attribute name="name">
-                <xsl:value-of
-                  select="preceding-sibling::sect1[1]/@id"/>
+                <xsl:choose>
+                  <xsl:when test="@id='xterm2'">xorg7-driver</xsl:when>
+                  <xsl:otherwise>
+                    <xsl:value-of
+                      select="preceding-sibling::sect1[1]/@id"/>
+                  </xsl:otherwise>
+                </xsl:choose>
               </xsl:attribute>
               <xsl:attribute name="type">ref</xsl:attribute>
             </xsl:element>




More information about the alfs-log mailing list