cvs commit: ALFS/profiles/BLFS/wget chapter26.urls

thomasp at linuxfromscratch.org thomasp at linuxfromscratch.org
Sat May 22 18:26:24 PDT 2004


thomasp     04/05/22 19:26:24

  Modified:    profiles/BLFS BLFS.xml runit.sh system.ent
               profiles/BLFS/misc template.xml
  Added:       profiles/BLFS/chapter26 atk.xml gtk+.xml gtk+2.xml
                        hicolor-icon-theme.xml lesstif.xml libxklavier.xml
                        pango.xml qt.xml shared-mime-info.xml
                        startup-notification.xml
               profiles/BLFS/config_standard config.ent general.ent
                        packages.ent
               profiles/BLFS/wget chapter26.urls
  Removed:     profiles/BLFS general.ent packages.ent
               profiles/BLFS/chapter27 atk.xml gtk+.xml gtk+2.xml
                        lesstif.xml pango.xml qt.xml
                        startup-notification.xml
  Log:
  Chapter 26 updated, moved several entity files to the config_standard directory where they belong
  
  Revision  Changes    Path
  1.31      +10 -5     ALFS/profiles/BLFS/BLFS.xml
  
  Index: BLFS.xml
  ===================================================================
  RCS file: /home/cvsroot/ALFS/profiles/BLFS/BLFS.xml,v
  retrieving revision 1.30
  retrieving revision 1.31
  diff -u -r1.30 -r1.31
  --- BLFS.xml	19 May 2004 15:42:43 -0000	1.30
  +++ BLFS.xml	23 May 2004 01:26:24 -0000	1.31
  @@ -11,15 +11,17 @@
   
   <!DOCTYPE alfs SYSTEM "ALFS-3.1.dtd" [
   
  -<!ENTITY % files SYSTEM "files.ent">
  +<!ENTITY % files SYSTEM "config/files.ent">
   %files;
   
  -<!ENTITY % general_entities SYSTEM "general.ent">
  -<!ENTITY % package_entities SYSTEM "packages.ent">
  +<!ENTITY % general_entities SYSTEM "config/general.ent">
  +<!ENTITY % package_entities SYSTEM "config/packages.ent">
  +<!ENTITY % config_entities SYSTEM  "config/config.ent">
   <!ENTITY % system_entities  SYSTEM "system.ent">
   
   %general_entities;
   %package_entities;
  +%config_entities;
   %system_entities;
   
   <!ENTITY apos "'">
  @@ -303,11 +305,14 @@
   
       &qt;
       >kplus;
  -    &gtkplus2;
  -    &atk;
       &pango;
  +    &atk;
  +    &gtkplus2;
       &lesstif;
       &startup-notification;
  +    &shared-mime-info;
  +    &hicolor-icon-theme;
  +    &libxklavier;
              
   </stage>
   
  
  
  
  1.3       +6 -1      ALFS/profiles/BLFS/runit.sh
  
  Index: runit.sh
  ===================================================================
  RCS file: /home/cvsroot/ALFS/profiles/BLFS/runit.sh,v
  retrieving revision 1.2
  retrieving revision 1.3
  diff -u -r1.2 -r1.3
  --- runit.sh	27 Apr 2004 04:00:16 -0000	1.2
  +++ runit.sh	23 May 2004 01:26:24 -0000	1.3
  @@ -1,11 +1,16 @@
   #!/bin/bash
   
  +if [ ! -e config ]; then
  +  echo "Attention: You must create a config directory (or link)."
  +  exit 3
  +fi
  +
   if [ ! -d /var/log/nALFS ]; then
       mkdir /var/log/nALFS
   fi
   export NALFS_STAMP_DIR=/var/log/nALFS
   
   CURRENTDIR=`pwd`
  -echo "<!ENTITY blfs-config '$CURRENTDIR/config'>" > files.ent
  +echo "<!ENTITY blfs-config '$CURRENTDIR/config'>" > config/files.ent
   
   /usr/bin/nALFS -S -l -L nalfs.log BLFS.xml
  
  
  
  1.26      +11 -8     ALFS/profiles/BLFS/system.ent
  
  Index: system.ent
  ===================================================================
  RCS file: /home/cvsroot/ALFS/profiles/BLFS/system.ent,v
  retrieving revision 1.25
  retrieving revision 1.26
  diff -u -r1.25 -r1.26
  --- system.ent	19 May 2004 15:42:43 -0000	1.25
  +++ system.ent	23 May 2004 01:26:24 -0000	1.26
  @@ -181,14 +181,17 @@
   <!ENTITY xorg      SYSTEM "./chapter25/xorg.xml">
   <!ENTITY xfree86   SYSTEM "./chapter25/xfree86.xml">
   
  -<!-- chapter 27 -->
  -<!ENTITY qt         SYSTEM "./chapter27/qt.xml">
  -<!ENTITY gtkplus    SYSTEM "./chapter27/gtk+.xml">
  -<!ENTITY gtkplus2   SYSTEM "./chapter27/gtk+2.xml">
  -<!ENTITY atk        SYSTEM "./chapter27/atk.xml">
  -<!ENTITY pango      SYSTEM "./chapter27/pango.xml">
  -<!ENTITY lesstif    SYSTEM "./chapter27/lesstif.xml">
  -<!ENTITY startup-notification  SYSTEM "./chapter27/startup-notification.xml">
  +<!-- chapter 26 -->
  +<!ENTITY qt         SYSTEM "./chapter26/qt.xml">
  +<!ENTITY gtkplus    SYSTEM "./chapter26/gtk+.xml">
  +<!ENTITY gtkplus2   SYSTEM "./chapter26/gtk+2.xml">
  +<!ENTITY atk        SYSTEM "./chapter26/atk.xml">
  +<!ENTITY pango      SYSTEM "./chapter26/pango.xml">
  +<!ENTITY lesstif    SYSTEM "./chapter26/lesstif.xml">
  +<!ENTITY startup-notification  SYSTEM "./chapter26/startup-notification.xml">
  +<!ENTITY shared-mime-info SYSTEM "./chapter26/shared-mime-info.xml">
  +<!ENTITY hicolor-icon-theme SYSTEM "./chapter26/hicolor-icon-theme.xml">
  +<!ENTITY libxklavier SYSTEM "./chapter26/libxklavier.xml">
   
   
   <!-- chapter 28 -->
  
  
  
  1.1                  ALFS/profiles/BLFS/chapter26/atk.xml
  
  Index: atk.xml
  ===================================================================
  <package name="atk" version="&atk-version;">
  
          <packageinfo>
                  <requires><name>glib2</name></requires>
  		<utilizes><name>gtk-doc</name></utilizes>
          </packageinfo>
  
  	<stage name="Unpacking a package.">
  		<unpack>
  			<archive>&packages_dir;/&atk-package;</archive>
  			<destination>&build_dir;</destination>
  		</unpack>
  	</stage>
  
  	<stage name="Installing a package.">
  		<stageinfo>
  			<base>&build_dir;/&atk-directory;</base>
  		</stageinfo>
  
  		<configure>
  			<param>--prefix=/usr</param>
  		</configure>
  
  		<make/>
  
  		<make>
  			<param>install</param>
  		</make>
  
  	</stage>
  
  	<stage name="Clean-up.">
  		<remove>&build_dir;/&atk-directory;</remove>
  	</stage>
  
  </package>
  
  
  
  1.1                  ALFS/profiles/BLFS/chapter26/gtk+.xml
  
  Index: gtk+.xml
  ===================================================================
  <?xml version="1.0" encoding="iso-8859-1"?>
  <package name="gtk+" version="&gtkplus-version;">
    <packageinfo>
      <requires>
        <name>glib</name>
      </requires>
      <requires>
        <name>libpng</name>
      </requires>
      <requires>
        <name>libtiff</name>
      </requires>
      <requires>
        <name>libjpeg</name>
      </requires>
    </packageinfo>
    <stage name="Unpacking a package.">
      <unpack>
        <archive>&packages_dir;/&gtkplus-package;</archive>
        <destination>&build_dir;</destination>
      </unpack>
    </stage>
    <stage name="Installing a package.">
      <stageinfo>
        <base>&build_dir;/&gtkplus-directory;</base>
      </stageinfo>
      <configure>
        <param>--prefix=/usr</param>
        <param>--sysconfdir=/etc</param>
      </configure>
      <make />
      <make>
        <param>install</param>
      </make>
    </stage>
    <stage name="Clean-up.">
      <remove>&build_dir;/&gtkplus-directory;</remove>
    </stage>
  </package>
  
  
  
  1.1                  ALFS/profiles/BLFS/chapter26/gtk+2.xml
  
  Index: gtk+2.xml
  ===================================================================
  <package name="gtk+2" version="&gtkplus2-version;">
  
          <packageinfo>
                  <requires><name>glib2</name></requires>
                  <requires><name>pango</name></requires>
                  <requires><name>atk</name></requires>
                  <utilizes><name>libtiff</name></utilizes>
                  <utilizes><name>libjpeg</name></utilizes>
  		<utilizes><name>gtk-doc</name></utilizes>
          </packageinfo>
  
  	<stage name="Unpacking a package.">
  		<unpack>
  			<archive>&packages_dir;/&gtkplus2-package;</archive>
  			<destination>&build_dir;</destination>
  		</unpack>
  	</stage>
  
  	<stage name="Installing a package.">
  		<stageinfo>
  			<base>&build_dir;/&gtkplus2-directory;</base>
  		</stageinfo>
  
  		<configure>
  			<param>--prefix=/usr</param>
  			<param>--sysconfdir=/etc</param>
  		</configure>
  
  		<make/>
  
  		<make>
  			<param>install</param>
  		</make>
  
  	</stage>
  
  	<stage name="Clean-up.">
  		<remove>&build_dir;/&gtkplus2-directory;</remove>
  	</stage>
  
  </package>
  
  
  
  1.1                  ALFS/profiles/BLFS/chapter26/hicolor-icon-theme.xml
  
  Index: hicolor-icon-theme.xml
  ===================================================================
  <?xml version="1.0" encoding="iso-8859-1"?>
  <package name="hicolor-icon-theme" version="&hicolor-icon-theme-version;">
    <stage name="Unpacking.">
      <unpack>
        <archive>&packages_dir;/</archive>
        <destination>&build_dir;</destination>
      </unpack>
    </stage>
    <stage name="Installing.">
      <stageinfo>
        <base>&build_dir;/&hicolor-icon-theme-directory;</base>
      </stageinfo>
      <configure>
        <param>--prefix=/usr</param>
      </configure>
      <make />
      <make>
        <param>install</param>
      </make>
      <execute command="/sbin/ldconfig" />
    </stage>
    <stage name="Cleanup.">
      <remove>&build_dir;/&hicolor-icon-theme-directory;</remove>
    </stage>
  </package>
  
  
  
  1.1                  ALFS/profiles/BLFS/chapter26/lesstif.xml
  
  Index: lesstif.xml
  ===================================================================
  <package name="lesstif" version="&lesstif-version;">
  
          <packageinfo>
          	<requires><name>xfree86</name></requires>
          </packageinfo>
  
  	<stage name="Unpacking a package.">
  		<unpack>
  			<archive>&packages_dir;/&lesstif-package;</archive>
  			<destination>&build_dir;</destination>
  		</unpack>
  	</stage>
  
  	<stage name="Installing a package.">
  		<stageinfo>
  			<base>&build_dir;/&lesstif-directory;</base>
  		</stageinfo>
  
  		<execute command="find -name Makefile.in | 
  			xargs sed -i 's@$(prefix)/LessTif@$(prefix)/share/LessTif at g'"/>
  
  		<configure>
  			<param>--prefix=/usr</param>
                          <param>--enable-build-20</param>
                          <param>--enable-build-21</param>
                          <param>--disable-debug</param>
                          <param>--enable-production</param>
                          <param>--disable-build-tests</param>
                          <param>--with-xdnd</param>
  		</configure>
  
  
  		<make/>
  
  		<make>
  			<param>install</param>
  		</make>
  
  	</stage>
  
  	<stage name="Clean-up.">
  		<remove>&build_dir;/&lesstif-directory;</remove>
  	</stage>
  
  </package>
  
  
  
  1.1                  ALFS/profiles/BLFS/chapter26/libxklavier.xml
  
  Index: libxklavier.xml
  ===================================================================
  <?xml version="1.0" encoding="iso-8859-1"?>
  <package name="libxklavier" version="&libxklavier-version;">
    <packageinfo>
      <requires>
        <name>xfree86</name>
      </requires>
      <requires>
        <name>pkgconfig</name>
      </requires>
      <requires>
        <name>libxml2</name>
      </requires>
    </packageinfo>
    <stage name="Unpacking.">
      <unpack>
        <archive>&packages_dir;/</archive>
        <destination>&build_dir;</destination>
      </unpack>
    </stage>
    <stage name="Installing.">
      <stageinfo>
        <base>&build_dir;/&libxklavier-directory;</base>
      </stageinfo>
      <configure>
        <param>--prefix=/usr</param>
      </configure>
      <make />
      <make>
        <param>install</param>
      </make>
    </stage>
    <execute command="/sbin/ldconfig" />
    <stage name="Cleanup.">
      <remove>&build_dir;/&libxklavier-directory;</remove>
    </stage>
  </package>
  
  
  
  1.1                  ALFS/profiles/BLFS/chapter26/pango.xml
  
  Index: pango.xml
  ===================================================================
  <package name="pango" version="&pango-version;">
  
          <packageinfo>
                  <requires><name>glib2</name></requires>
          	<utilizes><name>xfree86</name></utilizes>
  		<utilizes><name>freetype</name></utilizes>
  		<utilizes><name>fontconfig</name></utilizes>
  		<utilizes><name>gtk-doc</name></utilizes>
          </packageinfo>
  
  	<stage name="Unpacking a package.">
  		<unpack>
  			<archive>&packages_dir;/&pango-package;</archive>
  			<destination>&build_dir;</destination>
  		</unpack>
  	</stage>
  
  	<stage name="Installing a package.">
  		<stageinfo>
  			<base>&build_dir;/&pango-directory;</base>
  		</stageinfo>
  
  		<configure>
  			<param>--prefix=/usr</param>
  			<param>--sysconfdir=/etc</param>
  		</configure>
  
  		<make/>
  
  		<make>
  			<param>install</param>
  		</make>
  
  	</stage>
  
  	<stage name="Clean-up.">
  		<remove>&build_dir;/&pango-directory;</remove>
  	</stage>
  
  </package>
  
  
  
  1.1                  ALFS/profiles/BLFS/chapter26/qt.xml
  
  Index: qt.xml
  ===================================================================
  <?xml version="1.0" encoding="iso-8859-1"?>
  <package name="qt" version="&qt-version;">
    <packageinfo>
      <requires>
        <name>xfree86</name>
      </requires>
      <requires>
        <name>libpng</name>
      </requires>
      <requires>
        <name>libmng</name>
      </requires>
      <requires>
        <name>libjpeg</name>
      </requires>
    </packageinfo>
    <stage name="Unpacking a package.">
      <unpack>
        <archive>&packages_dir;/&qt-package;</archive>
        <destination>&build_dir;</destination>
      </unpack>
    </stage>
    <stage name="Installing a package.">
      <stageinfo>
        <environment>
          <variable name="PATH" mode="prepend">&build_dir;/&qt-directory;/bin:</variable>
          <variable name="LD_LIBRARY_PATH">&build_dir;/&qt-directory;/lib</variable>
        </environment>
        <base>&build_dir;/&qt-directory;</base>
      </stageinfo>
      <execute command="sed -i "s:cp -f:install:" mkspecs/linux-g++/qmake.conf" />
      <configure command="echo yes | ./configure">
        <param>-prefix /usr</param>
        <param>-docdir /usr/share/doc/qt</param>
        <param>-headerdir /usr/include/qt</param>
        <param>-plugindir /usr/lib/qt/plugins</param>
        <param>-datadir /usr/share/qt</param>
        <param>-translationdir /usr/share/qt/translations</param>
        <param>-sysconfdir /etc/qt</param>
        <param>-release</param>
        <param>-shared</param>
        <param>-qt-gif</param>
        <param>-system-zlib</param>
        <param>-no-g++-execeptions</param>
        <param>-thread</param>
        <param>-plugin-imgfmt-png</param>
        <param>-system-libpng</param>
      </configure>
      <make />
      <execute command="find -type f -name Makefile | xargs sed -i "s at -Wl,-rpath,/usr/lib@@g"" />
      <make>
        <param>install</param>
      </make>
      <link>
        <option>force</option>
        <target>libqt-mt.so</target>
        <name>/usr/lib/libqt.so</name>
      </link>
      <copy>
        <option>recursive</option>
        <source>doc/man</source>
        <destination>/usr/share</destination>
      </copy>
      <copy>
        <option>recursive</option>
        <source>examples</source>
        <destination>/usr/share/doc/qt</destination>
      </copy>
    </stage>
    <stage name="Clean-up.">
      <remove>&build_dir;/&qt-directory;</remove>
    </stage>
  </package>
  
  
  
  1.1                  ALFS/profiles/BLFS/chapter26/shared-mime-info.xml
  
  Index: shared-mime-info.xml
  ===================================================================
  <?xml version="1.0" encoding="iso-8859-1"?>
  <package name="shared-mime-info" version="&shared-mime-info-version;">
    <packageinfo>
      <requires>
        <name>glib2</name>
      </requires>
      <requires>
        <name>libxml2</name>
      </requires>
    </packageinfo>
    <stage name="Unpacking.">
      <unpack>
        <archive>&packages_dir;/&shared-mime-info-package;</archive>
        <destination>&build_dir;</destination>
      </unpack>
    </stage>
    <stage name="Installing.">
      <stageinfo>
        <base>&build_dir;/&shared-mime-info-directory;</base>
      </stageinfo>
      <configure>
        <param>--prefix=/usr</param>
      </configure>
      <make />
      <make>
        <param>install</param>
      </make>
      <execute command="/sbin/ldconfig" />
    </stage>
    <stage name="Cleanup.">
      <remove>&build_dir;/&shared-mime-info-directory;</remove>
    </stage>
  </package>
  
  
  
  1.1                  ALFS/profiles/BLFS/chapter26/startup-notification.xml
  
  Index: startup-notification.xml
  ===================================================================
  <package name="startup-notification" version="&startup-notification-version;">
  
          <packageinfo>
          	<requires><name>xfree86</name></requires>
          </packageinfo>
  
  	<stage name="Unpacking a package.">
  		<unpack>
  			<archive>&packages_dir;/&startup-notification-package;</archive>
  			<destination>&build_dir;</destination>
  		</unpack>
  	</stage>
  
  	<stage name="Installing a package.">
  		<stageinfo>
  			<base>&build_dir;/&startup-notification-directory;</base>
  		</stageinfo>
  
  		<configure>
  			<param>--prefix=/usr</param>
  		</configure>
  
  		<make/>
  
  		<make>
  			<param>install</param>
  		</make>
  
  	</stage>
  
  	<stage name="Clean-up.">
  		<remove>&build_dir;/&startup-notification-directory;</remove>
  	</stage>
  
  </package>
  
  
  
  1.1                  ALFS/profiles/BLFS/config_standard/config.ent
  
  Index: config.ent
  ===================================================================
  <!-- configuration for tripwire -->
  <!-- the content of the following entity should be the name of your policy file for tripwire -->
  <!ENTITY tripwire-policy-file "tripwire-policy.txt">
  <!-- these should be changed to usable values -->
  <!ENTITY tripwire-mail-domain "mail.domain.com">
  <!ENTITY tripwire-smtp-port "25">
  <!ENTITY tripwire-sitepassphrase "blahville">
  <!ENTITY tripwire-localpassphrase "blahville2">
  
  <!-- configuration for dhclient -->
  <!-- These two entities should be set to appropriate values to start and stop dhclient -->
  <!ENTITY dhclient-start-params "">
  <!ENTITY dhclient-stop-params "">
  
  <!-- configuration for dhcpcd -->
  <!-- These two entities should be set to appropriate values to start and stop dhcpcd -->
  <!ENTITY dhcpcd-start-params "">
  <!ENTITY dhcpcd-stop-params "">
  
  
  
  1.1                  ALFS/profiles/BLFS/config_standard/general.ent
  
  Index: general.ent
  ===================================================================
  <!-- directory containing the compressed packages -->
  <!ENTITY packages_dir  "/mnt/src">
  
  <!-- directory in which the packages will be compiled -->
  <!ENTITY build_dir  "/usr/src">
  
  <!-- kernel version -->
  <!ENTITY kernel-version "2.4.23">
  
  <!-- kernel directory -->
  <!ENTITY kernel-directory "/var2/factory/linux-2.4.23">
  
  <!-- entities for configuring gpm -->
  <!ENTITY mouse_device "/dev/psaux">
  <!ENTITY mouse_protocol "ps2">
  
  <!-- entities for configuring the network -->
  <!ENTITY network-interface "eth0">
  
  <!-- entities for configuring XFree86 -->
  
  <!ENTITY mouseProtocol   "IMPS/2">
  
  <!ENTITY XkbModel   "pc101">
  <!ENTITY XkbLayout  "fr">
   
  <!ENTITY HorizSync     "31.5-57.0">
  <!ENTITY VertRefresh   "50-92">
  <!ENTITY Modeline      '"1152x864"   92    1152 1208 1368 1474   864  865  875  895'>
  
  <!ENTITY Driver      "nv">
  <!ENTITY VendorName  "NVidia">
  <!ENTITY BoardName   "Riva TNT2 M64">
  <!ENTITY BusID       "PCI:1:0:0">
  
  <!-- for ALSA driver -->
  
  <!ENTITY sound-card  "cmipci">
  
  <!-- to place some configuration files 
       (e.g. ~/xpdfrc)
    -->
  <!ENTITY username  "vassili">
  
  <!-- the fully qualified host name, used by postfix -->
  <!ENTITY hostname  "vassilidzuba.net1.nerim.net">
  <!ENTITY domain "your.domain">
  
  <!-- where to put gnome -->
  <!ENTITY gnome-prefix "/opt/gnome-2.4">
  
  <!-- initial root password for mysql -->
  <!ENTITY mysql-password "alpha">
  
  
  
  1.1                  ALFS/profiles/BLFS/config_standard/packages.ent
  
  Index: packages.ent
  ===================================================================
  <!ENTITY blfs-bootscripts-version "2004-05-15">
  <!ENTITY blfs-bootscripts-package "blfs-bootscripts-&blfs-bootscripts-version;.tar.bz2">
  <!ENTITY blfs-bootscripts-directory "blfs-bootscripts-&blfs-bootscripts-version;">
  
  <!--************* packages for chapter 4 *************-->
  
  <!ENTITY cracklib-version   "2.7">
  <!ENTITY cracklib-package   "cracklib,&cracklib-version;.tar.gz">
  <!ENTITY cracklib-directory "cracklib,&cracklib-version;">
  <!ENTITY cracklib-wordlist "allwords">
  <!ENTITY cracklib-blfs-patch "cracklib-&cracklib-version;-blfs-1.patch">
  
  <!ENTITY linuxpam-version   "0.77">
  <!ENTITY linuxpam-package   "Linux-PAM-&linuxpam-version;.tar.bz2">
  <!ENTITY linuxpam-directory "Linux-PAM-&linuxpam-version;">
  
  <!ENTITY linuxpam-linkage-patch "Linux-PAM-&linuxpam-version;-linkage-3.patch">
  
  <!ENTITY shadow-version   "4.0.4.1">
  <!ENTITY shadow-package   "shadow-&shadow-version;.tar.bz2">
  <!ENTITY shadow-directory "shadow-&shadow-version;">
  
  <!ENTITY shadow-pam-patch     "shadow-&shadow-version;-pam-1.patch">
  
  <!ENTITY iptables-version   "1.2.9">
  <!ENTITY iptables-package   "iptables-&iptables-version;.tar.bz2">
  <!ENTITY iptables-directory "iptables-&iptables-version;">
  
  <!ENTITY gnupg-version      "1.2.4">
  <!ENTITY gnupg-package      "gnupg-&gnupg-version;.tar.bz2">
  <!ENTITY gnupg-directory    "gnupg-&gnupg-version;">
  
  <!ENTITY tripwire-version "2.3.1-2">
  <!ENTITY tripwire-package "tripwire-&tripwire-version;.tar.gz">
  <!ENTITY tripwire-directory "tripwire-&tripwire-version;">
  
  <!ENTITY tripwire-gcc-patch "tripwire-&tripwire-version;-gcc3-build-fixes.patch">
  
  <!--************* packages for chapter 5 *************-->
  
  <!ENTITY reiserfsutils-version   "3.6.14">
  <!ENTITY reiserfsutils-package   "reiserfsprogs-&reiserfsutils-version;.tar.gz">
  <!ENTITY reiserfsutils-directory "reiserfsprogs-&reiserfsutils-version;">
  
  <!ENTITY xfsprogs-version   "2.6.10">
  <!ENTITY xfsprogs-package   "xfsprogs-&xfsprogs-version;.src.tar.gz">
  <!ENTITY xfsprogs-directory "xfsprogs-&xfsprogs-version;">
  
  <!--************* packages for chapter 6 *************-->
  
  <!ENTITY vim-version   "6.2">
  <!ENTITY vim-package   "vim-&vim-version;.tar.bz2">
  <!ENTITY vim-directory "vim62">
  
  <!ENTITY emacs-version   "21.3">
  <!ENTITY emacs-package   "emacs-&emacs-version;.tar.gz">
  <!ENTITY emacs-directory "emacs-&emacs-version;">
  
  <!ENTITY nano-version   "1.2.3">
  <!ENTITY nano-package   "nano-&nano-version;.tar.gz">
  <!ENTITY nano-directory "nano-&nano-version;">
  
  <!ENTITY joe-version   "2.9.8">
  <!ENTITY joe-package   "joe-&joe-version;.tar.gz">
  <!ENTITY joe-directory "joe-&joe-version;">
  
  <!--************* packages for chapter 7 *************-->
  
  <!ENTITY ash-version    "0.4.0">
  <!ENTITY ash-package    "ash-&ash-version;.tar.gz">
  <!ENTITY ash-directory  "ash-&ash-version;">
  
  <!ENTITY ash-patch      "ash-&ash-version;-cumulative-fixes.patch">
   
  <!ENTITY tcsh-version   "6.12">
  <!ENTITY tcsh-package   "tcsh-&tcsh-version;.00.tar.gz">
  <!ENTITY tcsh-directory "tcsh-&tcsh-version;.00">
  
  <!ENTITY zsh-version   "4.2.0">
  <!ENTITY zsh-package   "zsh-&zsh-version;.tar.bz2">
  <!ENTITY zsh-directory "zsh-&zsh-version;">
  
  
  <!--************* packages for chapter 8 *************-->
  
  <!ENTITY openssl-version   "0.9.7d">
  <!ENTITY openssl-package   "openssl-&openssl-version;.tar.gz">
  <!ENTITY openssl-directory "openssl-&openssl-version;">
  
  <!ENTITY pcre-version   "4.5">
  <!ENTITY pcre-package   "pcre-&pcre-version;.tar.bz2">
  <!ENTITY pcre-directory "pcre-&pcre-version;">
  
  <!ENTITY popt-version   "1.7">
  <!ENTITY popt-package   "popt-&popt-version;.tar.gz">
  <!ENTITY popt-directory "popt-&popt-version;">
  
  <!ENTITY slang-version   "1.4.9">
  <!ENTITY slang-package   "slang-&slang-version;.tar.bz2">
  <!ENTITY slang-directory "slang-&slang-version;">
  
  <!ENTITY libfam-version   "2.7.0">
  <!ENTITY libfam-package   "fam-&libfam-version;.tar.gz">
  <!ENTITY libfam-directory "fam-&libfam-version;">
  
  <!ENTITY libfam-patch     "fam-&libfam-version;-dnotify.patch">
  
  <!ENTITY libxml-version   "1.8.17">
  <!ENTITY libxml-package   "libxml-&libxml-version;.tar.bz2">
  <!ENTITY libxml-directory "libxml-&libxml-version;">
  
  <!ENTITY libxml2-version   "2.6.9">
  <!ENTITY libxml2-package   "libxml2-&libxml2-version;.tar.gz">
  <!ENTITY libxml2-directory "libxml2-&libxml2-version;">
  
  <!ENTITY libxslt-version   "1.1.6">
  <!ENTITY libxslt-package   "libxslt-&libxslt-version;.tar.gz">
  <!ENTITY libxslt-directory "libxslt-&libxslt-version;">
  
  <!ENTITY readline-version   "4.3">
  <!ENTITY readline-package   "readline-&readline-version;.tar.gz">
  <!ENTITY readline-directory "readline-&readline-version;">
  
  <!ENTITY gmp-version   "4.1.2">
  <!ENTITY gmp-package   "gmp-&gmp-version;.tar.bz2">
  <!ENTITY gmp-directory "gmp-&gmp-version;">
  
  <!ENTITY gdbm-version   "1.8.3">
  <!ENTITY gdbm-package   "gdbm-&gdbm-version;.tar.gz">
  <!ENTITY gdbm-directory "gdbm-&gdbm-version;">
  
  <!ENTITY glib-version   "1.2.10">
  <!ENTITY glib-package   "glib-&glib-version;.tar.gz">
  <!ENTITY glib-directory "glib-&glib-version;">
  
  <!ENTITY glib2-version   "2.4.0">
  <!ENTITY glib2-package   "glib-&glib2-version;.tar.bz2">
  <!ENTITY glib2-directory "glib-&glib2-version;">
  
  <!ENTITY expat-version   "1.95.7">
  <!ENTITY expat-package   "expat-&expat-version;.tar.gz">
  <!ENTITY expat-directory "expat-&expat-version;">
  
  <!ENTITY libesmtp-version   "1.0.2">
  <!ENTITY libesmtp-package   "libesmtp-&libesmtp-version;.tar.bz2">
  <!ENTITY libesmtp-directory "libesmtp-&libesmtp-version;">
  
  <!ENTITY aspell-version   "0.50.5">
  <!ENTITY aspell-package   "aspell-&aspell-version;.tar.gz">
  <!ENTITY aspell-directory "aspell-&aspell-version;">
  
  <!--these should be customized to your language-->
  <!ENTITY aspell-dict-version "0.51-1">
  <!ENTITY aspell-dict-lang "en">
  <!ENTITY aspell-dict-package "aspell-&aspell-dict-lang;-&aspell-dict-version;.tar.bz2">
  <!ENTITY aspell-dict-directory "aspell-&aspell-dict-lang;-&aspell-dict-version;">
  
  <!ENTITY ispell-version   "3.2.06.epa7">
  <!ENTITY ispell-package   "ispell-&ispell-version;.tar.bz2">
  <!ENTITY ispell-directory "ispell-&ispell-version;">
  
  <!ENTITY guile-version   "1.6.4">
  <!ENTITY guile-package   "guile-&guile-version;.tar.gz">
  <!ENTITY guile-directory "guile-&guile-version;">
  
  <!ENTITY slib-version   "2d6">
  <!ENTITY slib-package   "slib&slib-version;.tar.gz">
  <!ENTITY slib-directory "slib">
  
  <!ENTITY g-wrap-version   "1.3.4">
  <!ENTITY g-wrap-package   "g-wrap-&g-wrap-version;.tar.gz">
  <!ENTITY g-wrap-directory "g-wrap-&g-wrap-version;">
  
  <!ENTITY lzo-version       "1.08">
  <!ENTITY lzo-package       "lzo-&lzo-version;.tar.gz">
  <!ENTITY lzo-directory     "lzo-&lzo-version;">
  
  <!ENTITY libpcap-version    "0.8.3">
  <!ENTITY libpcap-package    "libpcap-&libpcap-version;.tar.gz">
  <!ENTITY libpcap-directory  "libpcap-&libpcap-version;">
  
  <!--************* packages for chapter 9 *************-->
  
  <!ENTITY libjpeg-version   "6b">
  <!ENTITY libjpeg-package   "jpegsrc.v&libjpeg-version;.tar.gz">
  <!ENTITY libjpeg-directory "jpeg-&libjpeg-version;">
  
  <!ENTITY libpng-version   "1.2.5">
  <!ENTITY libpng-package   "libpng-&libpng-version;.tar.gz">
  <!ENTITY libpng-directory "libpng-&libpng-version;">
  
  <!ENTITY libpng-link-to-proper-libs-patch     "libpng-1.2.5-link-to-proper-libs.patch">
  
  <!ENTITY libtiff-version   "3.6.1">
  <!ENTITY libtiff-package   "tiff-v&libtiff-version;.tar.gz">
  <!ENTITY libtiff-directory "tiff-v&libtiff-version;">
  
  <!ENTITY libungif-version   "4.1.0b1">
  <!ENTITY libungif-package   "libungif-&libungif-version;.tar.gz">
  <!ENTITY libungif-directory "libungif-&libungif-version;">
  
  <!ENTITY libungif-patch     "libungif-4.1.0b1-va_start.patch">
  
  <!ENTITY libmng-version   "1.0.7">
  <!ENTITY libmng-package   "libmng-&libmng-version;.tar.gz">
  <!ENTITY libmng-directory "libmng-&libmng-version;">
  
  <!ENTITY lcms-version   "1.12">
  <!ENTITY lcms-package   "lcms-&lcms-version;.tar.gz">
  <!ENTITY lcms-directory "lcms-&lcms-version;">
  
  <!ENTITY freetype-version   "2.1.7">
  <!ENTITY freetype-package   "freetype-&freetype-version;.tar.bz2">
  <!ENTITY freetype-directory "freetype-&freetype-version;">
  
  <!ENTITY freetype-bytecode-interpreter-patch     "freetype-2.1.5-bytecode-interpreter.patch">
  
  <!ENTITY fontconfig-version   "2.2.2">
  <!ENTITY fontconfig-package   "fontconfig-&fontconfig-version;.tar.gz">
  <!ENTITY fontconfig-directory "fontconfig-&fontconfig-version;">
  
  <!ENTITY imlib-version   "1.9.14">
  <!ENTITY imlib-package   "imlib-&imlib-version;.tar.gz">
  <!ENTITY imlib-directory "imlib-&imlib-version;">
  
  <!ENTITY aalib-version   "1.4rc5">
  <!ENTITY aalib-package   "aalib-&aalib-version;.tar.gz">
  <!ENTITY aalib-directory "aalib-&aalib-version;">
  
  <!ENTITY svgalib-version   "1.4.3">
  <!ENTITY svgalib-package   "svgalib-&svgalib-version;.tar.gz">
  <!ENTITY svgalib-directory "svgalib-&svgalib-version;">
  
  <!ENTITY svgalib-gcc3-1-patch     "svgalib-1.4.3-gcc3-1.patch">
  
  <!ENTITY directfb-version   "0.9.20">
  <!ENTITY directfb-package   "DirectFB-&directfb-version;.tar.gz">
  <!ENTITY directfb-directory "DirectFB-&directfb-version;">
  
  <!ENTITY directfb-extra-version   "0.9.16">
  <!ENTITY directfb-extra-package   "DirectFB-extra-&directfb-extra-version;.tar.gz">
  <!ENTITY directfb-extra-directory "DirectFB-extra-&directfb-extra-version;">
  
  <!ENTITY imlib2-version   "1.1.0">
  <!ENTITY imlib2-package   "imlib2-&imlib2-version;.tar.gz">
  <!ENTITY imlib2-directory "imlib2-&imlib2-version;">
  
  <!--************* packages for chapter 10 *************-->
  
  <!ENTITY bc-version   "1.06">
  <!ENTITY bc-package   "bc-&bc-version;.tar.gz">
  <!ENTITY bc-directory "bc-&bc-version;">
  
  <!ENTITY bc-flex-invocation-patch    "bc-1.06-flex-invocation.patch">
  <!ENTITY bc-readline-patch    "bc-1.06-readline.patch">
  
  <!ENTITY rep-gtk-version   "0.18">
  <!ENTITY rep-gtk-package   "rep-gtk-&rep-gtk-version;.tar.gz">
  <!ENTITY rep-gtk-directory "rep-gtk-&rep-gtk-version;">
  
  <!ENTITY rep-gtk-gtk2.4-patch    "rep-gtk-0.18-gtk2.4.patch">
  
  <!ENTITY compface-version   "1.4">
  <!ENTITY compface-package   "compface-&compface-version;.tar.gz">
  <!ENTITY compface-directory "compface-&compface-version;">
  
  <!ENTITY compface-errno-2-patch     "compface-1.4-errno-2.patch">
  
  <!ENTITY imagemagick-version   "5.5.7-16">
  <!ENTITY imagemagick-package   "ImageMagick-&imagemagick-version;.tar.bz2">
  <!ENTITY imagemagick-directory "ImageMagick-&imagemagick-version;">
  
  <!ENTITY hd2u-version   "0.9.0">
  <!ENTITY hd2u-package   "hd2u-&hd2u-version;.tar.gz">
  <!ENTITY hd2u-directory "hd2u-&hd2u-version;">
  
  <!--************* packages for chapter 11 *************-->
  
  <!ENTITY gpm-version   "1.20.1">
  <!ENTITY gpm-package   "gpm-1.20.1.tar.bz2">
  <!ENTITY gpm-directory "gpm-1.20.1">
  
  <!ENTITY gpm-patch1    "gpm-1.20.1-segfault.patch">
  <!ENTITY gpm-patch2    "gpm-1.20.1-silent.patch">
  
  <!ENTITY fcron-version   "2.9.3">
  <!ENTITY fcron-package   "fcron-2.9.3.src.tar.gz">
  <!ENTITY fcron-directory "fcron-2.9.3">
  
  <!ENTITY hdparm-version   "5.4">
  <!ENTITY hdparm-package   "hdparm-5.4.tar.gz">
  <!ENTITY hdparm-directory "hdparm-5.4">
  <!ENTITY hdparm-patch1 "">
  
  <!ENTITY which-version   "2.14">
  <!ENTITY which-package   "which-2.14.tar.gz">
  <!ENTITY which-directory "which-2.14">
  
  <!ENTITY unzip-version   "5.50">
  <!ENTITY unzip-package   "unzip550.tar.gz">
  <!ENTITY unzip-directory "unzip-5.50">
  
  <!ENTITY unzip-patch1    "unzip-5.50-fix-Makefile.patch">
  <!ENTITY unzip-patch2    "unzip-5.50-fix-libz.patch">
  <!ENTITY unzip-patch3    "unzip-5.50-dotdot.patch">
  <!ENTITY unzip-patch4    "unzip-5.50-dont-make-noise.patch">
  
  <!ENTITY zip-version   "2.3">
  <!ENTITY zip-package   "zip23.tar.gz">
  <!ENTITY zip-directory "zip-2.3">
  
  <!ENTITY pciutils-version   "2.1.11">
  <!ENTITY pciutils-package   "pciutils-2.1.11.tar.bz2">
  <!ENTITY pciutils-directory "pciutils-2.1.11">
  
  <!ENTITY pkgconfig-version   "0.15.0">
  <!ENTITY pkgconfig-package   "pkgconfig-0.15.0.tar.gz">
  <!ENTITY pkgconfig-directory "pkgconfig-0.15.0">
  
  <!ENTITY cpio-version   "2.5">
  <!ENTITY cpio-package   "cpio-2.5.tar.gz">
  <!ENTITY cpio-directory "cpio-2.5">
  
  <!ENTITY mc-version   "4.6.0">
  <!ENTITY mc-package   "mc-4.6.0.tar.gz">
  <!ENTITY mc-directory "mc-4.6.0">
  
  <!--************* packages for chapter 12 *************-->
  
  <!ENTITY python-version   "2.3.3">
  <!ENTITY python-package   "Python-&python-version;.tar.bz2">
  <!ENTITY python-directory "Python-&python-version;">
  
  <!ENTITY python-patch     "Python-&python-version;-gdbm-2.patch">
  
  <!-- Perl Modules -->
  <!ENTITY PDL-version   "2.4.0">
  <!ENTITY PDL-package   "PDL-&PDL-version;.tar.gz">
  <!ENTITY PDL-directory "PDL-&PDL-version;">
  
  <!ENTITY Astro-FITS-Header-version   "2.8.1">
  <!ENTITY Astro-FITS-Header-package   "Astro-FITS-Header-&Astro-FITS-Header-version;.tar.gz">
  <!ENTITY Astro-FITS-Header-directory "Astro-FITS-Header-&Astro-FITS-Header-version;">
  
  <!ENTITY Gtk-Perl-version   "0.7009">
  <!ENTITY Gtk-Perl-package   "Gtk-Perl-&Gtk-Perl-version;.tar.gz">
  <!ENTITY Gtk-Perl-directory "Gtk-Perl-&Gtk-Perl-version;">
  
  <!ENTITY XML-Writer-version   "0.4.1">
  <!ENTITY XML-Writer-package   "XML-Writer-&XML-Writer-version;.tar.gz">
  <!ENTITY XML-Writer-directory "XML-Writer-&XML-Writer-version;">
  
  <!ENTITY XML-Parser-version   "2.34">
  <!ENTITY XML-Parser-package   "XML-Parser-&XML-Parser-version;.tar.gz">
  <!ENTITY XML-Parser-directory "XML-Parser-&XML-Parser-version;">
  
  <!ENTITY Parse-RecDescent-version   "1.94">
  <!ENTITY Parse-RecDescent-package   "Parse-RecDescent-&Parse-RecDescent-version;.tar.gz">
  <!ENTITY Parse-RecDescent-directory "Parse-RecDescent-&Parse-RecDescent-version;">
  
  <!ENTITY librep-version   "0.17">
  <!ENTITY librep-package   "librep-&librep-version;.tar.gz">
  <!ENTITY librep-directory "librep-&librep-version;">
  
  <!ENTITY j2sdk-binary-version   "1.4.2_03">
  <!ENTITY j2sdk-src-version "1.4.2">
  <!ENTITY j2sdk-package   "j2sdk-1_4_1_02-linux-i586.bin">
  <!ENTITY j2sdk-directory "j2sdk1.4.1_02">
  
  <!ENTITY ruby-version   "1.8.1">
  <!ENTITY ruby-package   "ruby-&ruby-version;.tar.gz">
  <!ENTITY ruby-directory "ruby-&ruby-version;">
  
  <!ENTITY gnat-version   "3.15p">
  <!ENTITY gnat-package   "gnat-&gnat-version;-i686-pc-redhat71-gnu-bin.tar.gz">
  <!ENTITY gnat-directory "gnat-&gnat-version;-i686-pc-linux-gnu-bin">
  
  <!ENTITY gcc-full-version   "3.3.2">
  <!ENTITY gcc-full-package   "gcc-&gcc-full-version;.tar.bz2">
  <!ENTITY gcc-full-directory "gcc-&gcc-full-version;">
  
  <!ENTITY gcc-full-patch1    "gcc-&gcc-full-version;-no_fixincludes-1.patch">
  
  <!ENTITY tcl-version   "8.4.5">
  <!ENTITY tcl-package   "tcl&tcl-version;-src.tar.gz">
  <!ENTITY tcl-directory "tcl&tcl-version;">
  
  <!ENTITY tk-version   "8.4.5">
  <!ENTITY tk-package   "tk&tk-version;-src.tar.gz">
  <!ENTITY tk-directory "tk&tk-version;">
  
  <!ENTITY gcc295-version   "2.95.3">
  <!ENTITY gcc295-package   "gcc-&gcc295-version;.tar.gz">
  <!ENTITY gcc295-directory "gcc-&gcc295-version;">
  
  <!ENTITY gcc295-patch1     "gcc-&gcc295-version;-2.patch">
  <!ENTITY gcc295-patch2     "gcc-&gcc295-version;-no-fixinc.patch">
  <!ENTITY gcc295-patch3     "gcc-&gcc295-version;-returntype-fix.patch">
  
  <!ENTITY nasm-version   "0.98.38">
  <!ENTITY nasm-package   "nasm-&nasm-version;.tar.bz2">
  <!ENTITY nasm-directory "nasm-&nasm-version;">
  
  <!--************* packages for chapter 13 *************-->
  
  <!ENTITY ppp-version   "2.4.2">
  <!ENTITY ppp-package   "ppp-&ppp-version;.tar.gz">
  <!ENTITY ppp-directory "ppp-&ppp-version;">
  
  <!ENTITY ppp-patch     "ppp-&ppp-version;-nobpf-3.patch">
  
  <!ENTITY wvdial-version   "1.53">
  <!ENTITY wvdial-package   "wvdial-&wvdial-version;.tar.gz">
  <!ENTITY wvdial-directory "wvdial-&wvdial-version;">
  
  <!--************* packages for chapter 14 *************-->
  
  <!ENTITY dhclient-version "3.0pl2">
  <!ENTITY dhclient-package "dhcp-&dhclient-version;.tar.gz">
  <!ENTITY dhclient-directory "dhcp-&dhclient-version;">
  
  <!ENTITY dhcpcd-version   "1.3.22-pl4">
  <!ENTITY dhcpcd-package   "dhcpcd-&dhcpcd-version;.tar.gz">
  <!ENTITY dhcpcd-directory "dhcpcd-&dhcpcd-version;">
  
  <!ENTITY dhcpcd-patch     "dhcpcd-&dhcpcd-version;-fhs.patch">
  
  <!--************* packages for chapter 15 *************-->
  <!ENTITY rp-pppoe-version "3.5">
  <!ENTITY rp-pppoe-package "rp-pppoe-&rp-pppoe-version;.tar.gz">
  <!ENTITY rp-pppoe-directory "rp-pppoe-&rp-pppoe-version;">
  
  <!--************* packages for chapter 16 *************-->
  
  <!ENTITY curl-version   "7.11.1">
  <!ENTITY curl-package   "curl-&curl-version;.tar.bz2">
  <!ENTITY curl-directory "curl-&curl-version;">
  
  <!ENTITY wvstreams-version   "3.70">
  <!ENTITY wvstreams-package   "wvstreams-&wvstreams-version;.tar.gz">
  <!ENTITY wvstreams-directory "wvstreams-&wvstreams-version;">
  
  <!ENTITY wvstreams-wvcrypto-patch     "wvstreams-3.70-wvcrypto.patch">
  <!ENTITY wvstreams-wvresolver-patch   "wvstreams-3.70-wvresolver.patch">
  
  <!ENTITY gnet-version   "2.0.5">
  <!ENTITY gnet-package   "gnet-&gnet-version;.tar.gz">
  <!ENTITY gnet-directory "gnet-&gnet-version;">
  
  <!ENTITY libsoup-version   "1.99.26">
  <!ENTITY libsoup-package   "libsoup-&libsoup-version;.tar.bz2">
  <!ENTITY libsoup-directory "libsoup-&libsoup-version;">
  
  
  <!--************* packages for chapter 17 *************-->
  
  <!ENTITY links-version   "2.1pre14">
  <!ENTITY links-package   "links-&links-version;.tar.bz2">
  <!ENTITY links-directory "links-&links-version;">
  
  <!ENTITY lynx-version   "2.8.5">
  <!ENTITY lynx-package   "lynx&lynx-version;.tar.bz2">
  <!ENTITY lynx-directory "lynx&lynx-version;">
  
  <!ENTITY w3m-version   "0.4.2">
  <!ENTITY w3m-package   "w3m-&w3m-version;.tar.gz">
  <!ENTITY w3m-directory "w3m-&w3m-version;">
  
  <!--************* packages for chapter 18 *************-->
  
  <!ENTITY ncftp-version   "3.1.7">
  <!ENTITY ncftp-package   "ncftp-&ncftp-version;-src.tar.bz2">
  <!ENTITY ncftp-directory "ncftp-&ncftp-version;">
  
  <!ENTITY cvs-version   "1.11.14">
  <!ENTITY cvs-package   "cvs-&cvs-version;.tar.bz2">
  <!ENTITY cvs-directory "cvs-&cvs-version;">
  
  <!ENTITY wget-version   "1.9.1">
  <!ENTITY wget-package   "wget-&wget-version;.tar.gz">
  <!ENTITY wget-directory "wget-&wget-version;">
  
  <!ENTITY tcpwrappers-version   "7.6">
  <!ENTITY tcpwrappers-package   "tcp_wrappers_&tcpwrappers-version;.tar.gz">
  <!ENTITY tcpwrappers-directory "tcp_wrappers_&tcpwrappers-version;">
  
  <!ENTITY tcpwrappers-shared-libs-plus-plus-patch     "tcp_wrappers-7.6-shared-lib-plus-plus.patch">
  
  <!ENTITY portmap-version   "5beta">
  <!ENTITY portmap-package   "portmap_&portmap-version;.tar.gz">
  <!ENTITY portmap-directory "portmap_&portmap-version;">
  
  <!ENTITY portmap-compilation-fixes-patch    "portmap-5beta-compilation-fixes-2.patch">
  <!ENTITY portmap-glibc-errno-fix-patch    "portmap-5beta-glibc-errno-fix.patch">
  
  <!ENTITY inetutils-version   "1.4.2">
  <!ENTITY inetutils-package   "inetutils-&inetutils-version;.tar.gz">
  <!ENTITY inetutils-directory "inetutils-&inetutils-version;">
  
  <!ENTITY nfs-utils-version   "1.0.6">
  <!ENTITY nfs-utils-package   "nfs-utils-&nfs-utils-version;.tar.gz">
  <!ENTITY nfs-utils-directory "nfs-utils-&nfs-utils-version;">
  
  <!ENTITY ncpfs-version   "2.2.4">
  <!ENTITY ncpfs-package   "ncpfs-&ncpfs-version;.tar.gz">
  <!ENTITY ncpfs-directory "ncpfs-&ncpfs-version;">
  
  <!ENTITY ntp-version   "4.2.0">
  <!ENTITY ntp-package   "ntp-&ntp-version;.tar.gz">
  <!ENTITY ntp-directory "ntp-&ntp-version;">
  
  <!--************* packages for chapter 19 *************-->
  
  <!ENTITY traceroute-version   "1.4a12">
  <!ENTITY traceroute-package   "traceroute-&traceroute-version;.tar.gz">
  <!ENTITY traceroute-directory "traceroute-&traceroute-version;">
  
  <!ENTITY nmap-version   "3.50">
  <!ENTITY nmap-package   "nmap-&nmap-version;.tar.bz2">
  <!ENTITY nmap-directory "nmap-&nmap-version;">
  
  <!ENTITY whois-version   "4.6.9">
  <!ENTITY whois-package   "whois_&whois-version;.tar.gz">
  <!ENTITY whois-directory "whois-&whois-version;">
  
  <!ENTITY bind-utils-version "9.2.3">
  <!ENTITY bind-utils-package "bind-&bind-version;.tar.gz">
  <!ENTITY bind-utils-directory "bind-&bind-utils-version;">
  
  
  <!--************* packages for chapter 20 *************-->
  
  <!ENTITY nail-version   "10.7">
  <!ENTITY nail-package   "nail-&nail-version;.tar.gz">
  <!ENTITY nail-directory "nail-&nail-version;">
  
  <!ENTITY procmail-version   "3.22">
  <!ENTITY procmail-package   "procmail-&procmail-version;.tar.gz">
  <!ENTITY procmail-directory "procmail-&procmail-version;">
  
  <!ENTITY fetchmail-version   "6.2.5">
  <!ENTITY fetchmail-package   "fetchmail-&fetchmail-version;.tar.gz">
  <!ENTITY fetchmail-directory "fetchmail-&fetchmail-version;">
  
  <!ENTITY mutt-version   "1.4.2.1i">
  <!ENTITY mutt-package   "mutt-&mutt-version;.tar.gz">
  <!ENTITY mutt-directory "mutt-1.4.2.1">
  
  <!ENTITY pine-version   "4.58">
  <!ENTITY pine-package   "pine&pine-version;.tar.bz2">
  <!ENTITY pine-directory "pine&pine-version;">
  
  <!ENTITY pine-patch     "pine-&pine-version;-fhs.patch">
  
  <!ENTITY slrn-version   "0.9.8.0">
  <!ENTITY slrn-package   "slrn-&slrn-version;.tar.bz2">
  <!ENTITY slrn-directory "slrn-&slrn-version;">
  
  <!--************* packages for chapter 21 *************-->
  
  <!ENTITY postfix-version   "2.0.19">
  <!ENTITY postfix-package   "postfix-&postfix-version;.tar.gz">
  <!ENTITY postfix-directory "postfix-&postfix-version;">
  
  <!ENTITY sendmail-version "8.12.10">
  <!ENTITY sendmail-package "sendmail.&sendmail-version;.tar.gz">
  <!ENTITY sendmail-directory "sendmail-&sendmail-version;">
  
  <!ENTITY exim-version "4.24">
  <!ENTITY exim-package "exim-&exim-version;.tar.bz2">
  <!ENTITY exim-directory "exim-&exim-version;">
  
  <!ENTITY qpopper-version   "4.0.5">
  <!ENTITY qpopper-package   "qpopper&qpopper-version;.tar.gz">
  <!ENTITY qpopper-directory "qpopper&qpopper-version;">
  
  <!ENTITY courier-version "0.45.4">
  <!ENTITY courier-package "courier-&courier-version;.tar.bz2">
  <!ENTITY courier-directory "courier-&courier-version;">
  
  
  <!--************* packages for chapter 22 *************-->
  
  <!ENTITY bind-version   "9.2.3">
  <!ENTITY bind-package   "bind-&bind-version;.tar.gz">
  <!ENTITY bind-directory "bind-&bind-version;">
  
  <!ENTITY dhcp-version "3.0pl2">
  <!ENTITY dhcp-package "dhcp-&dhcp-version;.tar.gz">
  <!ENTITY dhcp-directory "dhcp-&dhcp-version;">
  
  <!ENTITY leafnode-version   "1.9.43">
  <!ENTITY leafnode-package   "leafnode-&leafnode-version;.rel.tar.bz2">
  <!ENTITY leafnode-directory "leafnode-&leafnode-version;.rel">
  
  <!ENTITY openssh-version   "3.8.1p1">
  <!ENTITY openssh-package   "openssh-&openssh-version;.tar.gz">
  <!ENTITY openssh-directory "openssh-&openssh-version;">
  
  <!ENTITY rsync-version   "2.6.0">
  <!ENTITY rsync-package   "rsync-&rsync-version;.tar.gz">
  <!ENTITY rsync-directory "rsync-&rsync-version;">
  
  <!ENTITY openldap-version   "2.1.29">
  <!ENTITY openldap-package   "openldap-&openldap-version;.tgz">
  <!ENTITY openldap-directory "openldap-&openldap-version;">
  
  <!ENTITY samba-version "2.2.8a">
  <!ENTITY samba-package "samba-&samba-version;.tar.bz2">
  <!ENTITY samba-directory "samba-&samba-version;">
  
  <!ENTITY xinetd-version   "2.3.13">
  <!ENTITY xinetd-package   "xinetd-&xinetd-version;.tar.gz">
  <!ENTITY xinetd-directory "xinetd-&xinetd-version;">
  
  <!--************* packages for chapter 23 *************-->
  
  <!ENTITY db-version   "4.1.25">
  <!ENTITY db-package   "db-&db-version;.tar.gz">
  <!ENTITY db-directory "db-&db-version;">
  
  <!ENTITY db3-version   "3.3.11">
  <!ENTITY db3-package   "db-&db3-version;.tar.gz">
  <!ENTITY db3-directory "db-&db3-version;">
  
  <!ENTITY mysql-version   "4.0.18">
  <!ENTITY mysql-package   "mysql-&mysql-version;.tar.gz">
  <!ENTITY mysql-directory "mysql-&mysql-version;">
  
  <!ENTITY postgresql-version   "7.4.2">
  <!ENTITY postgresql-package   "postgresql-&postgresql-version;.tar.bz2">
  <!ENTITY postgresql-directory "postgresql-&postgresql-version;">
  
  <!--************* packages for chapter 24 **************-->
  
  <!ENTITY apache-version   "2.0.49">
  <!ENTITY apache-package   "httpd-&apache-version;.tar.gz">
  <!ENTITY apache-directory "httpd-&apache-version;">
  
  <!ENTITY apache-patch     "httpd-&apache-version;-config.patch">
  
  <!ENTITY php-version   "4.3.6">
  <!ENTITY php-package   "php-&php-version;.tar.bz2">
  <!ENTITY php-directory "php-&php-version;">
  
  <!ENTITY proftpd-version   "1.2.9">
  <!ENTITY proftpd-package   "proftpd-&proftpd-version;.tar.bz2">
  <!ENTITY proftpd-directory "proftpd-&proftpd-version;">
  
  <!--************* packages for chapter 25 *************-->
  
  <!ENTITY xorg-version "6.7.0">
  <!ENTITY xorg-package1 "X11R&xorg-version;-src1.tar.bz2">
  <!ENTITY xorg-package2 "X11R&xorg-version;-src2.tar.bz2">
  <!ENTITY xorg-package3 "X11R&xorg-version;-src3.tar.bz2">
  <!ENTITY xorg-package4 "X11R&xorg-version;-src4.tar.bz2">
  <!ENTITY xorg-package5 "X11R&xorg-version;-src5.tar.bz2">
  <!ENTITY xorg-package6 "X11R&xorg-version;-src6.tar.bz2">
  <!ENTITY xorg-package7 "X11R&xorg-version;-src7.tar.bz2">
  <!ENTITY xorg-directory "xc">
  
  <!ENTITY xfree86-version   "4.4.0">
  <!ENTITY xfree86-package1  "XFree86-&xfree86-version;-src-1.tgz">
  <!ENTITY xfree86-package2  "XFree86-&xfree86-version;-src-2.tgz">
  <!ENTITY xfree86-package3  "XFree86-&xfree86-version;-src-3.tgz">
  <!ENTITY xfree86-package4  "XFree86-&xfree86-version;-src-4.tgz">
  <!ENTITY xfree86-package5  "XFree86-&xfree86-version;-src-5.tgz">
  <!ENTITY xfree86-package6  "XFree86-&xfree86-version;-src-6.tgz">
  <!ENTITY xfree86-package7  "XFree86-&xfree86-version;-src-7.tgz">
  <!ENTITY xfree86-directory "xc">
  
  <!--************* packages for chapter 26 *************-->
  
  <!ENTITY qt-version   "3.3.1">
  <!ENTITY qt-package   "qt-x11-free-&qt-version;.tar.bz2">
  <!ENTITY qt-directory "qt-x11-free-&qt-version;">
  
  <!ENTITY gtkplus-version   "1.2.10">
  <!ENTITY gtkplus-package   "gtk+-&gtkplus-version;.tar.gz">
  <!ENTITY gtkplus-directory "gtk+-&gtkplus-version;">
  
  <!ENTITY gtkplus2-version   "2.4.0">
  <!ENTITY gtkplus2-package   "gtk+-&gtkplus2-version;.tar.bz2">
  <!ENTITY gtkplus2-directory "gtk+-&gtkplus2-version;">
  
  <!ENTITY atk-version   "1.6.0">
  <!ENTITY atk-package   "atk-&atk-version;tar.bz2">
  <!ENTITY atk-directory "atk-&atk-version;">
  
  <!ENTITY pango-version   "1.4.0">
  <!ENTITY pango-package   "pango-&pango-version;.tar.gz">
  <!ENTITY pango-directory "pango-&pango-version;">
  
  <!ENTITY lesstif-version   "0.93.94">
  <!ENTITY lesstif-package   "lesstif-&lesstif-version;.tar.bz2">
  <!ENTITY lesstif-directory "lesstif-&lesstif-version;">
  
  <!ENTITY startup-notification-version   "0.6">
  <!ENTITY startup-notification-package   "startup-notification-&startup-notification-version;.tar.gz">
  <!ENTITY startup-notification-directory "startup-notification-&startup-notification-version;">
  
  <!ENTITY shared-mime-info-version "0.14">
  <!ENTITY shared-mime-info-package "shared-mime-info-&shared-mime-info-version;.tar.gz">
  <!ENTITY shared-mime-info-directory "shared-mime-info-&shared-mime-info-version;">
  
  <!ENTITY hicolor-icon-theme-version "0.5">
  <!ENTITY hicolor-icon-theme-package "hicolor-icon-theme-&hicolor-icon-theme-version;.tar.gz">
  <!ENTITY hicolor-icon-theme-directory "hicolor-icon-theme-&hicolor-icon-theme-version;">
  
  <!ENTITY libxklavier-version "1.02">
  <!ENTITY libxklavier-package "libxklavier-&libxklavier-version;.tar.gz">
  <!ENTITY libxklavier-directory "libxklavier-&libxklavier-version;">
  
  <!--************* packages for chapter 28 *************-->
  
  <!ENTITY sawfish-version   "1.3">
  <!ENTITY sawfish-package   "sawfish-1.3.tar.gz">
  <!ENTITY sawfish-directory "sawfish-1.3">
  
  <!ENTITY fluxbox-version   "0.9.5">
  <!ENTITY fluxbox-package   "fluxbox-0.9.5.tar.bz2">
  <!ENTITY fluxbox-directory "fluxbox-0.9.5">
  
  <!ENTITY xfce-version   "3.8.18">
  <!ENTITY xfce-package   "xfce-3.8.18.tar.gz">
  <!ENTITY xfce-directory "xfce-3.8.18">
  
  <!ENTITY metacity-version   "2.4.55">
  <!ENTITY metacity-package   "metacity-2.4.55.tar.bz2">
  <!ENTITY metacity-directory "metacity-2.4.55">
  
  <!--************* packages for chapter 29 *************-->
  
  <!ENTITY arts-version      "1.1.4">
  <!ENTITY arts-package      "arts-1.1.4.tar.bz2">
  <!ENTITY arts-directory    "arts-1.1.4">
  
  <!ENTITY kde-version   "3.1.4">
  
  <!ENTITY kdelibs-version   "3.1.4">
  <!ENTITY kdelibs-package   "kdelibs-3.1.4.tar.bz2">
  <!ENTITY kdelibs-directory "kdelibs-3.1.4">
  
  <!ENTITY kdebase-version   "3.1.4">
  <!ENTITY kdebase-package   "kdebase-3.1.4.tar.bz2">
  <!ENTITY kdebase-directory "kdebase-3.1.4">
  
  <!--************* packages for chapter 30 *************-->
  
  <!ENTITY kdemultimedia-version   "3.1.4">
  <!ENTITY kdemultimedia-package   "kdemultimedia-3.1.4.tar.bz2">
  <!ENTITY kdemultimedia-directory "kdemultimedia-3.1.4">
  
  <!ENTITY kdenetwork-version   "3.1.4">
  <!ENTITY kdenetwork-package   "kdenetwork-3.1.4.tar.bz2">
  <!ENTITY kdenetwork-directory "kdenetwork-3.1.4">
  
  <!ENTITY kdegraphics-version   "3.1.4">
  <!ENTITY kdegraphics-package   "kdegraphics-3.1.4.tar.bz2">
  <!ENTITY kdegraphics-directory "kdegraphics-3.1.4">
  
  <!ENTITY kdepim-version   "3.1.4">
  <!ENTITY kdepim-package   "kdepim-3.1.4.tar.bz2">
  <!ENTITY kdepim-directory "kdepim-3.1.4">
  
  <!ENTITY kdeadmin-version   "3.1.4">
  <!ENTITY kdeadmin-package   "kdeadmin-3.1.4.tar.bz2">
  <!ENTITY kdeadmin-directory "kdeadmin-3.1.4">
  
  <!ENTITY kdegames-version   "3.1.4">
  <!ENTITY kdegames-package   "kdegames-3.1.4.tar.bz2">
  <!ENTITY kdegames-directory "kdegames-3.1.4">
  
  <!ENTITY kdeutils-version   "3.1.4">
  <!ENTITY kdeutils-package   "kdeutils-3.1.4.tar.bz2">
  <!ENTITY kdeutils-directory "kdeutils-3.1.4">
  
  <!ENTITY kdeedu-version   "3.1.4">
  <!ENTITY kdeedu-package   "kdeedu-3.1.4.tar.bz2">
  <!ENTITY kdeedu-directory "kdeedu-3.1.4">
  
  <!ENTITY kdeartwork-version   "3.1.4">
  <!ENTITY kdeartwork-package   "kdeartwork-3.1.4.tar.bz2">
  <!ENTITY kdeartwork-directory "kdeartwork-3.1.4">
  
  <!ENTITY kdetoys-version   "3.1.4">
  <!ENTITY kdetoys-package   "kdetoys-3.1.4.tar.bz2">
  <!ENTITY kdetoys-directory "kdetoys-3.1.4">
  
  <!ENTITY kdeaddons-version   "3.1.4">
  <!ENTITY kdeaddons-package   "kdeaddons-3.1.4.tar.bz2">
  <!ENTITY kdeaddons-directory "kdeaddons-3.1.4">
  
  <!--************* packages for chapter 31 *************-->
  
  <!ENTITY kdoc-version   "snapshot">
  <!ENTITY kdoc-package   "kdoc-snapshot.tar.gz">
  <!ENTITY kdoc-directory "kdoc">
  
  <!ENTITY kdebindings-version   "3.0.5a">
  <!ENTITY kdebindings-package   "kdebindings-3.0.5a.tar.bz2">
  <!ENTITY kdebindings-directory "kdebindings-3.0.5a">
  
  <!ENTITY kdesdk-version   "3.0.5a">
  <!ENTITY kdesdk-package   "kdesdk-3.0.5a.tar.bz2">
  <!ENTITY kdesdk-directory "kdesdk-3.0.5a">
  
  <!ENTITY kdevelop-version   "2.1.4">
  <!ENTITY kdevelop-package   "kdevelop-2.1.4_for_KDE_3.0.tar.bz2">
  <!ENTITY kdevelop-directory "kdevelop-2.1.4_for_KDE_3.0">
  
  <!--************* packages for chapter 32 *************-->
  
  <!ENTITY gtk-doc-version   "1.1">
  <!ENTITY gtk-doc-package   "gtk-doc-1.1.tar.bz2">
  <!ENTITY gtk-doc-directory "gtk-doc-1.1">
  
  <!ENTITY png-support-dtd   "png-support-3.1.dtd">
  
  <!ENTITY linc-version   "1.0.3">
  <!ENTITY linc-package   "linc-1.0.3.tar.bz2">
  <!ENTITY linc-directory "linc-1.0.3">
  
  <!ENTITY libidl-version   "0.8.2">
  <!ENTITY libidl-package   "libIDL-0.8.2.tar.bz2">
  <!ENTITY libidl-directory "libIDL-0.8.2">
  
  <!ENTITY orbit2-version   "2.8.2">
  <!ENTITY orbit2-package   "ORBit2-2.8.2.tar.bz2">
  <!ENTITY orbit2-directory "ORBit2-2.8.2">
  
  <!ENTITY intltool-version   "0.27.2">
  <!ENTITY intltool-package   "intltool-0.27.2.tar.bz2">
  <!ENTITY intltool-directory "intltool-0.27.2">
  
  <!ENTITY libbonobo-version   "2.4.2">
  <!ENTITY libbonobo-package   "libbonobo-2.4.2.tar.bz2">
  <!ENTITY libbonobo-directory "libbonobo-2.4.2">
  
  <!ENTITY gconf2-version   "2.4.0.1">
  <!ENTITY gconf2-package   "GConf-2.4.0.1.tar.bz2">
  <!ENTITY gconf2-directory "GConf-2.4.0.1">
  
  <!ENTITY gnome-mime-data-version   "2.4.0">
  <!ENTITY gnome-mime-data-package   "gnome-mime-data-2.4.0.tar.bz2">
  <!ENTITY gnome-mime-data-directory "gnome-mime-data-2.4.0">
  
  <!ENTITY gnome-vfs2-version   "2.4.1">
  <!ENTITY gnome-vfs2-package   "gnome-vfs-2.4.1.tar.bz2">
  <!ENTITY gnome-vfs2-directory "gnome-vfs-2.4.1">
  
  <!ENTITY libgnome-version   "2.4.0">
  <!ENTITY libgnome-package   "libgnome-2.4.0.tar.bz2">
  <!ENTITY libgnome-directory "libgnome-2.4.0">
  
  <!ENTITY libart-lgpl-version   "2.3.16">
  <!ENTITY libart-lgpl-package   "libart_lgpl-2.3.16.tar.bz2">
  <!ENTITY libart-lgpl-directory "libart_lgpl-2.3.16">
  
  <!ENTITY libglade-version   "2.0.1">
  <!ENTITY libglade-package   "libglade-2.0.1.tar.gz">
  <!ENTITY libglade-directory "libglade-2.0.1">
  
  <!ENTITY libgnomecanvas-version   "2.4.0">
  <!ENTITY libgnomecanvas-package   "libgnomecanvas-2.4.0.tar.bz2">
  <!ENTITY libgnomecanvas-directory "libgnomecanvas-2.4.0">
  
  <!ENTITY libbonoboui-version   "2.4.1">
  <!ENTITY libbonoboui-package   "libbonoboui-2.4.1.tar.bz2">
  <!ENTITY libbonoboui-directory "libbonoboui-2.4.1">
  
  <!ENTITY gnome-icon-themes-version   "1.0.9">
  <!ENTITY gnome-icon-themes-package   "gnome-icon-theme-1.0.9.tar.bz2">
  <!ENTITY gnome-icon-themes-directory "gnome-icon-theme-1.0.9">
  
  <!ENTITY libgnomeui-version   "2.4.0.1">
  <!ENTITY libgnomeui-package   "libgnomeui-2.4.0.1.tar.bz2">
  <!ENTITY libgnomeui-directory "libgnomeui-2.4.0.1">
  
  <!ENTITY libwnck-version   "2.4.0.1">
  <!ENTITY libwnck-package   "libwnck-2.4.0.1.tar.bz2">
  <!ENTITY libwnck-directory "libwnck-2.4.0.1">
  
  <!ENTITY gtk-engines-version   "2.2.0">
  <!ENTITY gtk-engines-package   "gtk-engines-2.2.0.tar.bz2">
  <!ENTITY gtk-engines-directory "gtk-engines-2.2.0">
  
  <!ENTITY gnome-themes-version   "2.4.1">
  <!ENTITY gnome-themes-package   "gnome-themes-2.4.1.tar.bz2">
  <!ENTITY gnome-themes-directory "gnome-themes-2.4.1">
  
  <!ENTITY scrollkeeper-version   "0.3.14">
  <!ENTITY scrollkeeper-package   "scrollkeeper-0.3.14.tar.bz2">
  <!ENTITY scrollkeeper-directory "scrollkeeper-0.3.14">
  
  <!ENTITY vte-version   "0.11.10">
  <!ENTITY vte-package   "vte-0.11.10.tar.bz2">
  <!ENTITY vte-directory "vte-0.11.10">
  
  <!ENTITY libgtop-version   "2.0.5">
  <!ENTITY libgtop-package   "libgtop-2.0.5.tar.bz2">
  <!ENTITY libgtop-directory "libgtop-2.0.5 ">
  
  <!ENTITY gail-version   "1.4.1">
  <!ENTITY gail-package   "gail-1.4.1.tar.bz2">
  <!ENTITY gail-directory "gail-1.4.1">
  
  <!ENTITY libcroco-version   "0.3.0">
  <!ENTITY libcroco-package   "libcroco-0.3.0.tar.bz2">
  <!ENTITY libcroco-directory "libcroco-0.3.0">
  
  <!ENTITY librsvg-version   "2.4.0">
  <!ENTITY librsvg-package   "librsvg-2.4.0.tar.bz2">
  <!ENTITY librsvg-directory "librsvg-2.4.0">
  
  <!ENTITY eel-version   "2.4.1">
  <!ENTITY eel-package   "eel-2.4.1.tar.bz2">
  <!ENTITY eel-directory "eel-2.4.1">
  
  <!ENTITY libgtkhtml-version   "2.4.1">
  <!ENTITY libgtkhtml-package   "libgtkhtml-2.4.1.tar.bz2">
  <!ENTITY libgtkhtml-directory "libgtkhtml-2.4.1">
  
  <!ENTITY libgsf-version    "1.8.2">
  <!ENTITY libgsf-package    "libgsf-1.8.2.tar.bz2">
  <!ENTITY libgsf-directory  "libgsf-1.8.2">
  
  <!ENTITY gal-version   "1.99.10">
  <!ENTITY gal-package   "gal-1.99.10.tar.bz2">
  <!ENTITY gal-directory "gal-1.99.10">
  
  <!ENTITY libgnomeprint-version   "2.4.0">
  <!ENTITY libgnomeprint-package   "libgnomeprint-2.4.0.tar.bz2">
  <!ENTITY libgnomeprint-directory "libgnomeprint-2.4.0">
  
  <!ENTITY libgnomeprintui-version   "2.4.0">
  <!ENTITY libgnomeprintui-package   "libgnomeprintui-2.4.0.tar.bz2">
  <!ENTITY libgnomeprintui-directory "libgnomeprintui-2.4.0">
  
  <!ENTITY gtksourceview-version   "0.7.0">
  <!ENTITY gtksourceview-package   "gtksourceview-0.7.0.tar.bz2">
  <!ENTITY gtksourceview-directory "gtksourceview-0.7.0">
  
  <!ENTITY gtkhtml-version   "3.0.9">
  <!ENTITY gtkhtml-package   "gtkhtml-3.0.9.tar.bz2">
  <!ENTITY gtkhtml-directory "gtkhtml-3.0.9">
  
  <!ENTITY at-spi-version   "1.1.9">
  <!ENTITY at-spi-package   "at-spi-1.1.9.tar.bz2">
  <!ENTITY at-spi-directory "at-spi-1.1.9">
  
  <!ENTITY at-spi-patch     "at-spi-1.1.9-lspi.patch">
  
  <!--************* packages for chapter 33 *************-->
  
  <!ENTITY gnome-desktop-version   "2.4.1.1">
  <!ENTITY gnome-desktop-package   "gnome-desktop-2.4.1.1.tar.bz2">
  <!ENTITY gnome-desktop-directory "gnome-desktop-2.4.1.1">
  
  <!ENTITY gnome-panel-version   "2.4.1">
  <!ENTITY gnome-panel-package   "gnome-panel-2.4.1.tar.bz2">
  <!ENTITY gnome-panel-directory "gnome-panel-2.4.1">
  
  <!ENTITY gnome-session-version   "2.4.1">
  <!ENTITY gnome-session-package   "gnome-session-2.4.1.tar.bz2">
  <!ENTITY gnome-session-directory "gnome-session-2.4.1">
  
  <!ENTITY nautilus-version   "2.4.1">
  <!ENTITY nautilus-package   "nautilus-2.4.1.tar.bz2">
  <!ENTITY nautilus-directory "nautilus-2.4.1">
  
  <!ENTITY control-center-version   "2.4.0">
  <!ENTITY control-center-package   "control-center-2.4.0.tar.bz2">
  <!ENTITY control-center-directory "control-center-2.4.0">
  
  <!--************* packages for chapter 34 *************-->
  
  <!ENTITY gnome-terminal-version   "2.4.1">
  <!ENTITY gnome-terminal-package   "gnome-terminal-2.4.1.tar.bz2">
  <!ENTITY gnome-terminal-directory "gnome-terminal-2.4.1">
  
  <!ENTITY gnome-applets-version   "2.4.1">
  <!ENTITY gnome-applets-package   "gnome-applets-2.4.1.tar.bz2">
  <!ENTITY gnome-applets-directory "gnome-applets-2.4.1">
  
  <!ENTITY yelp-version   "2.4.1">
  <!ENTITY yelp-package   "yelp-2.4.1.tar.bz2">
  <!ENTITY yelp-directory "yelp-2.4.1">
  
  <!ENTITY bug-buddy-version   "2.4.1">
  <!ENTITY bug-buddy-package   "bug-buddy-2.4.1.tar.bz2">
  <!ENTITY bug-buddy-directory "bug-buddy-2.4.1">
  
  <!ENTITY gedit-version   "2.4.1">
  <!ENTITY gedit-package   "gedit-2.4.1.tar.bz2">
  <!ENTITY gedit-directory "gedit-2.4.1">
  
  <!ENTITY eog-version   "2.4.1">
  <!ENTITY eog-package   "eog-2.4.1.tar.bz2">
  <!ENTITY eog-directory "eog-2.4.1">
  
  <!ENTITY acme-version   "2.4.1">
  <!ENTITY acme-package   "acme-2.4.1.tar.bz2">
  <!ENTITY acme-directory "acme-2.4.1">
  
  <!ENTITY ggv-version   "2.4.0.1">
  <!ENTITY ggv-package   "ggv-2.4.0.1.tar.bz2">
  <!ENTITY ggv-directory "ggv-2.4.0.1">
  
  <!ENTITY gnome-utils-version   "2.4.0">
  <!ENTITY gnome-utils-package   "gnome-utils-2.4.0.tar.bz2">
  <!ENTITY gnome-utils-directory "gnome-utils-2.4.0">
  
  <!ENTITY gnome-system-monitor-version   "2.4.0">
  <!ENTITY gnome-system-monitor-package   "gnome-system-monitor-2.4.0.tar.bz2">
  <!ENTITY gnome-system-monitor-directory "gnome-system-monitor-2.4.0">
  
  <!ENTITY gstreamer-version   "0.6.4">
  <!ENTITY gstreamer-package   "gstreamer-0.6.4.tar.bz2">
  <!ENTITY gstreamer-directory "gstreamer-0.6.4">
  
  <!ENTITY gst-plugins-version   "0.6.4">
  <!ENTITY gst-plugins-package   "gst-plugins-0.6.4.tar.bz2">
  <!ENTITY gst-plugins-directory "gst-plugins-0.6.4">
  
  <!ENTITY gnome-media-version   "2.4.1.1">
  <!ENTITY gnome-media-package   "gnome-media-2.4.1.1.tar.bz2">
  <!ENTITY gnome-media-directory "gnome-media-2.4.1.1">
  
  <!ENTITY nautilus-media-version   "0.2.2">
  <!ENTITY nautilus-media-package   "nautilus-media-0.2.2.tar.bz2">
  <!ENTITY nautilus-media-directory "nautilus-media-0.2.2">
  
  <!ENTITY gnome-games-version   "2.2.1">
  <!ENTITY gnome-games-package   "gnome-games-2.2.1.tar.bz2">
  <!ENTITY gnome-games-directory "gnome-games-2.2.1">
  
  <!ENTITY gnome2-user-docs-version   "2.0.6">
  <!ENTITY gnome2-user-docs-package   "gnome2-user-docs-2.0.6.tar.bz2">
  <!ENTITY gnome2-user-docs-directory "gnome2-user-docs-2.0.6">
  
  <!--************* packages for chapter 35 *************-->
  
  <!ENTITY gconf-editor-version   "2.4.0">
  <!ENTITY gconf-editor-package   "gconf-editor-2.4.0.tar.bz2">
  <!ENTITY gconf-editor-directory "gconf-editor-2.4.0">
  
  <!ENTITY gdm-version   "2.4.1.4">
  <!ENTITY gdm-package   "gdm-2.4.1.4.tar.bz2">
  <!ENTITY gdm-directory "gdm-2.4.1.4">
  
  <!--************* packages for chapter 37 *************-->
  
  <!ENTITY orbit-version   "0.5.17">
  <!ENTITY orbit-package   "ORBit-0.5.17.tar.gz">
  <!ENTITY orbit-directory "ORBit-0.5.17">
  
  <!ENTITY oaf-version   "0.6.10">
  <!ENTITY oaf-package   "oaf-0.6.10.tar.gz">
  <!ENTITY oaf-directory "oaf-0.6.10">
  
  <!ENTITY gnome-libs-version   "1.4.2">
  <!ENTITY gnome-libs-package   "gnome-libs-1.4.2.tar.gz">
  <!ENTITY gnome-libs-directory "gnome-libs-1.4.2">
  
  <!ENTITY gdk-pixbuf-version   "0.22.0">
  <!ENTITY gdk-pixbuf-package   "gdk-pixbuf-0.22.0.tar.bz2">
  <!ENTITY gdk-pixbuf-directory "gdk-pixbuf-0.22.0">
  
  <!ENTITY gconf-version   "1.0.9">
  <!ENTITY gconf-package   "GConf-1.0.9.tar.bz2">
  <!ENTITY gconf-directory "GConf-1.0.9">
  
  <!ENTITY gnome-vfs-version   "1.0.5">
  <!ENTITY gnome-vfs-package   "gnome-vfs-1.0.5.tar.bz2">
  <!ENTITY gnome-vfs-directory "gnome-vfs-1.0.5">
  
  <!ENTITY gnome-print-version   "0.37">
  <!ENTITY gnome-print-package   "gnome-print-0.37.tar.bz2">
  <!ENTITY gnome-print-directory "gnome-print-0.37">
  
  <!ENTITY libglade1-version   "0.17">
  <!ENTITY libglade1-package   "libglade-0.17.tar.gz">
  <!ENTITY libglade1-directory "libglade-0.17">
  
  <!ENTITY libcapplet-version   "1.5.11">
  <!ENTITY libcapplet-package   "libcapplet-1.5.11.tar.bz2">
  <!ENTITY libcapplet-directory "libcapplet-1.5.11">
  
  <!ENTITY libghttp-version   "1.0.9">
  <!ENTITY libghttp-package   "libghttp-1.0.9.tar.gz">
  <!ENTITY libghttp-directory "libghttp-1.0.9">
  
  <!ENTITY bonobo-version   "1.0.22">
  <!ENTITY bonobo-package   "bonobo-1.0.22.tar.bz2">
  <!ENTITY bonobo-directory "bonobo-1.0.22">
  
  <!ENTITY guppi-version   "0.40.3">
  <!ENTITY guppi-package   "Guppi-0.40.3.tar.bz2">
  <!ENTITY guppi-directory "Guppi-0.40.3">
  
  <!ENTITY bonobo-conf-version   "0.16">
  <!ENTITY bonobo-conf-package   "bonobo-conf-0.16.tar.gz">
  <!ENTITY bonobo-conf-directory "bonobo-conf-0.16">
  
  <!ENTITY soup-version   "0.7.11">
  <!ENTITY soup-package   "soup-0.7.11.tar.bz2">
  <!ENTITY soup-directory "soup-0.7.11">
  
  <!--************* packages for chapter 38 *************-->
  
  <!ENTITY abiword-version   "2.0.0">
  <!ENTITY abiword-package   "abiword-2.0.0.tar.bz2">
  <!ENTITY abiword-directory "abiword-2.0.0">
  
  <!ENTITY gnumeric-version   "1.2.0">
  <!ENTITY gnumeric-package   "gnumeric-1.2.0.tar.bz2">
  <!ENTITY gnumeric-directory "gnumeric-1.2.0">
  
  <!ENTITY gnucash-version   "1.8.2">
  <!ENTITY gnucash-package   "gnucash-1.8.2.tar.gz">
  <!ENTITY gnucash-directory "gnucash-1.8.2">
  
  <!ENTITY gimp-version   "1.2.3">
  <!ENTITY gimp-package   "gimp-1.2.3.tar.bz2">
  <!ENTITY gimp-directory "gimp-1.2.3">
  
  <!ENTITY evolution-version   "1.2.1">
  <!ENTITY evolution-package   "evolution-1.2.1.tar.bz2">
  <!ENTITY evolution-directory "evolution-1.2.1">
  
  <!ENTITY db3117-version   "3.1.17">
  <!ENTITY db3117-package   "db-3.1.17.tar.gz">
  <!ENTITY db3117-directory "db-3.1.17">
  
  <!--************* packages for chapter 39 *************-->
  
  <!ENTITY koffice-version   "1.2.93">
  <!ENTITY koffice-package   "koffice-1.2.93.tar.bz2">
  <!ENTITY koffice-directory "koffice-1.2.93">
  
  <!ENTITY openoffice-version   "1.0.2">
  <!ENTITY openoffice-package   "OOo_1.0.2_source.tar.bz2">
  <!ENTITY openoffice-directory "oo_1.0.2_src">
  
  <!ENTITY gpc-version   "231">
  <!ENTITY gpc-package   "gpc231.tar.Z">
  <!ENTITY gpc-directory "gpc231">
  
  <!ENTITY openoffice-01-patch   "openoffice-1.0.2-add-entry-for-kmail.patch">
  <!ENTITY openoffice-02-patch   "openoffice-1.0.2-linux-test-bin-location.patch">
  <!ENTITY openoffice-03-patch   "openoffice-1.0.2-add-pam-headers.patch">
  <!ENTITY openoffice-04-patch   "openoffice-1.0.2-main-retval.patch">
  <!ENTITY openoffice-05-patch   "openoffice-1.0.2-bison-fix.patch">
  <!ENTITY openoffice-06-patch   "openoffice-1.0.2-mdk-asm-fixes.patch">
  <!ENTITY openoffice-07-patch   "openoffice-1.0.2-cpputools-regcomp-makefile.patch">
  <!ENTITY openoffice-08-patch   "openoffice-1.0.2-new-mozilla-ab.patch">
  <!ENTITY openoffice-09-patch   "openoffice-1.0.2-debug-keepsetup.patch">
  <!ENTITY openoffice-10-patch   "openoffice-1.0.2-psprint-pdf-drivers.patch">
  <!ENTITY openoffice-11-patch   "openoffice-1.0.2-dmake-clean.patch">
  <!ENTITY openoffice-12-patch   "openoffice-1.0.2-sal-main-cmdline.patch">
  <!ENTITY openoffice-13-patch   "openoffice-1.0.2-dont-build-mozab.patch">
  <!ENTITY openoffice-14-patch   "openoffice-1.0.2-system-db-4.1.patch">
  <!ENTITY openoffice-15-patch   "openoffice-1.0.2-dont-catch-segv.patch">
  <!ENTITY openoffice-16-patch   "openoffice-1.0.2-system-freetype-2.1.patch">
  <!ENTITY openoffice-17-patch   "openoffice-1.0.2-dont-uglify-html.patch">
  <!ENTITY openoffice-18-patch   "openoffice-1.0.2-system-getopt.patch">
  <!ENTITY openoffice-19-patch   "openoffice-1.0.2-dont-unset-home.patch">
  <!ENTITY openoffice-20-patch   "openoffice-1.0.2-system-libXrender.patch">
  <!ENTITY openoffice-21-patch   "openoffice-1.0.2-honor-current-path.patch">
  <!ENTITY openoffice-22-patch   "openoffice-1.0.2-system-nas.patch">
  <!ENTITY openoffice-23-patch   "openoffice-1.0.2-jdk1.4-syntax-fix.patch">
  <!ENTITY openoffice-24-patch   "openoffice-1.0.2-user-fontpath.patch">
  
  <!--************* packages for chapter 40 *************-->
  
  <!ENTITY mozilla-version   "1.4">
  <!ENTITY mozilla-package   "mozilla-source-1.4.tar.bz2">
  <!ENTITY mozilla-directory "mozilla">
  
  <!ENTITY mozilla-patch1    "mozilla-1.4-already-running.patch">
  <!ENTITY mozilla-patch2    "mozilla-1.4-default-plugin-less-annoying.patch">
  <!ENTITY mozilla-patch3    "mozilla-1.4-over-the-spot.patch">
  <!ENTITY mozilla-patch4    "mozilla-1.4-wallet.patch">
  
  <!ENTITY mozilla-spellchecker-ppatch    "mozilla-1.3-spellchecker.tar.bz2">
  <!ENTITY mozilla-spellchecker-patch     "spellcheck">
  
  <!ENTITY galeon-version   "1.3.7">
  <!ENTITY galeon-package   "galeon-1.3.7.tar.gz">
  <!ENTITY galeon-directory "galeon-1.3.7">
  
  <!ENTITY dillo-version   "0.7.3">
  <!ENTITY dillo-package   "dillo-0.7.3.tar.bz2">
  <!ENTITY dillo-directory "dillo-0.7.3">
  
  <!--************* packages for chapter 41 *************-->
  
  <!ENTITY pan-version   "0.14.2">
  <!ENTITY pan-package   "pan-0.14.2.tar.bz2">
  <!ENTITY pan-directory "pan-0.14.2">
  
  <!ENTITY balsa-version   "2.0.14">
  <!ENTITY balsa-package   "balsa-2.0.14.tar.bz2">
  <!ENTITY balsa-directory "balsa-2.0.14">
  
  <!--************* packages for chapter 42 *************-->
  
  <!ENTITY alsa-driver-version   "0.9.8">
  <!ENTITY alsa-driver-package   "alsa-driver-0.9.8.tar.bz2">
  <!ENTITY alsa-driver-directory "alsa-driver-0.9.8">
  
  <!ENTITY alsa-lib-version      "0.9.8">
  <!ENTITY alsa-lib-package      "alsa-lib-0.9.8.tar.bz2">
  <!ENTITY alsa-lib-directory    "alsa-lib-0.9.8">
  
  <!ENTITY alsa-utils-version      "0.9.8">
  <!ENTITY alsa-utils-package      "alsa-utils-0.9.8.tar.bz2">
  <!ENTITY alsa-utils-directory    "alsa-utils-0.9.8">
  
  <!ENTITY alsa-tools-version      "0.9.8">
  <!ENTITY alsa-tools-package      "alsa-tools-0.9.8.tar.bz2">
  <!ENTITY alsa-tools-directory    "alsa-tools-0.9.8">
  
  <!ENTITY alsa-oss-version        "0.9.8">
  <!ENTITY alsa-oss-package        "alsa-oss-0.9.8.tar.bz2">
  <!ENTITY alsa-oss-directory      "alsa-oss-0.9.8">
  
  <!ENTITY audiofile-version      "0.2.4">
  <!ENTITY audiofile-package      "audiofile-0.2.4.tar.gz">
  <!ENTITY audiofile-directory    "audiofile-0.2.4">
  
  <!ENTITY esound-version      "0.2.32">
  <!ENTITY esound-package      "esound-0.2.32.tar.bz2">
  <!ENTITY esound-directory    "esound-0.2.32">
  
  <!ENTITY sdl-version      "1.2.6">
  <!ENTITY sdl-package      "SDL-1.2.6.tar.gz">
  <!ENTITY sdl-directory    "SDL-1.2.6">
  
  <!ENTITY libao-version      "0.8.4">
  <!ENTITY libao-package      "libao-0.8.4.tar.gz">
  <!ENTITY libao-directory    "libao-0.8.4">
  
  <!ENTITY libogg-version      "1.1">
  <!ENTITY libogg-package      "libogg-1.1.tar.gz">
  <!ENTITY libogg-directory    "libogg-1.1">
  
  <!ENTITY libvorbis-version      "1.0.1">
  <!ENTITY libvorbis-package      "libvorbis-1.0.1.tar.gz">
  <!ENTITY libvorbis-directory    "libvorbis-1.0.1">
  
  <!ENTITY nas-version      "1.6">
  <!ENTITY nas-package      "nas-1.6.src.tar.gz">
  <!ENTITY nas-directory    "nas-1.6">
  
  <!ENTITY nas-patch        "nas-1.6-bison-fix.patch">
  
  <!ENTITY libmpeg3-version      "1.5.2">
  <!ENTITY libmpeg3-package      "libmpeg3-1.5.2-src.tar.bz2">
  <!ENTITY libmpeg3-directory    "libmpeg3-1.5.2">
  
  <!ENTITY libmad-version      "0.15.0b">
  <!ENTITY libmad-package      "libmad-0.15.0b.tar.gz">
  <!ENTITY libmad-directory    "libmad-0.15.0b">
  
  <!ENTITY openquicktime-version      "1.0">
  <!ENTITY openquicktime-package      "openquicktime-1.0-src.tgz">
  <!ENTITY openquicktime-directory    "openquicktime-1.0-src">
  
  <!ENTITY libfame-version      "0.9.0">
  <!ENTITY libfame-package      "libfame-0.9.0.tar.gz">
  <!ENTITY libfame-directory    "libfame-0.9.0">
  
  <!ENTITY speex-version        "1.0.3">
  <!ENTITY speex-package        "speex-1.0.3.tar.gz">
  <!ENTITY speex-directory      "speex-1.0.3">
  
  <!ENTITY id3lib-version        "3.8.3">
  <!ENTITY id3lib-package        "id3lib-3.8.3.tar.gz">
  <!ENTITY id3lib-directory      "id3lib-3.8.3">
  
  <!ENTITY flac-version          "1.1.0">
  <!ENTITY flac-package          "flac-1.1.0.tar.gz">
  <!ENTITY flac-directory        "flac-1.1.0">
  
  <!ENTITY libdvdread-version          "0.9.4">
  <!ENTITY libdvdread-package          "libdvdread-0.9.4.tar.gz">
  <!ENTITY libdvdread-directory        "libdvdread-0.9.4">
  
  <!ENTITY libdvdcss-version           "1.2.8">
  <!ENTITY libdvdcss-package           "libdvdcss-1.2.8.tar.bz2">
  <!ENTITY libdvdcss-directory         "libdvdcss-1.2.8">
  
  <!ENTITY libdv-version               "0.99">
  <!ENTITY libdv-package               "libdv-0.99.tar.gz">
  <!ENTITY libdv-directory             "libdv-0.99">
  
  <!ENTITY liba52-version               "0.7.4">
  <!ENTITY liba52-package               "a52dec-0.7.4.tar.gz">
  <!ENTITY liba52-directory             "a52dec-0.7.4">
  
  <!ENTITY xvid-version      "0.9.2">
  <!ENTITY xvid-package      "xvidcore-0.9.2.tar.bz2">
  <!ENTITY xvid-directory    "xvidcore-0.9.2">
  
  <!ENTITY xine-lib-version      "1-rc0a">
  <!ENTITY xine-lib-package      "xine-lib-1-rc0a.tar.gz">
  <!ENTITY xine-lib-directory    "xine-lib-1-rc0a">
  
  <!ENTITY libmikmod-version      "3.1.10">
  <!ENTITY libmikmod-package      "libmikmod-3.1.10.tar.gz">
  <!ENTITY libmikmod-directory    "libmikmod-3.1.10">
  
  <!--************* packages for chapter 43 *************-->
  
  <!ENTITY mpg123-version      "0.59r">
  <!ENTITY mpg123-package      "mpg123-0.59r.tar.gz">
  <!ENTITY mpg123-directory    "mpg123-0.59r">
  
  <!ENTITY vorbis-tools-version      "1.0.1">
  <!ENTITY vorbis-tools-package      "vorbis-tools-1.0.1.tar.gz">
  <!ENTITY vorbis-tools-directory    "vorbis-tools-1.0.1">
  
  <!ENTITY xmms-version      "1.2.8">
  <!ENTITY xmms-package      "xmms-1.2.8.tar.bz2">
  <!ENTITY xmms-directory    "xmms-1.2.8">
  
  <!ENTITY lame-version      "3.93.1">
  <!ENTITY lame-package      "lame-3.93.1.tar.gz">
  <!ENTITY lame-directory    "lame-3.93.1">
  
  <!ENTITY cdparanoia-version      "III-alpha9.8">
  <!ENTITY cdparanoia-package      "cdparanoia-III-alpha9.8.src.tgz">
  <!ENTITY cdparanoia-directory    "cdparanoia-III-alpha9.8">
  
  <!--************* packages for chapter 44 *************-->
  
  <!ENTITY ffmpeg-version      "0.4.7">
  <!ENTITY ffmpeg-package      "ffmpeg-0.4.7.tar.gz">
  <!ENTITY ffmpeg-directory    "ffmpeg-0.4.7">
  
  <!ENTITY avifile-version      "0.7.38">
  <!ENTITY avifile-package      "avifile-0.7-0.7.38.tar.gz">
  <!ENTITY avifile-directory    "avifile-0.7-0.7.38">
  
  <!ENTITY avifile-binaries-package      "binaries-011002.tgz">
  
  <!ENTITY mplayer-version      "1.0pre1">
  <!ENTITY mplayer-package      "MPlayer-1.0pre1.tar.bz2">
  <!ENTITY mplayer-directory    "mplayer-1.0pre1">
  
  <!ENTITY mplayer-codecs-package            "extralite.tar.bz2">
  <!ENTITY mplayer-arial-iso-8859-1-package  "font-arial-iso-8859-1.tar.bz2">
  <!ENTITY mplayer-skin-package              "default-1.7.tar.bz2">
  
  <!ENTITY xine-ui-version      "0.9.21">
  <!ENTITY xine-ui-package      "xine-ui-0.9.21.tar.gz">
  <!ENTITY xine-ui-directory    "xine-ui-0.9.21">
  
  <!ENTITY transcode-version      "0.6.10">
  <!ENTITY transcode-package      "transcode-0.6.10.tar.gz">
  <!ENTITY transcode-directory    "transcode-0.6.10">
  
  <!--************* packages for chapter 45 *************-->
  
  <!ENTITY cdrtools-version   "2.00.3">
  <!ENTITY cdrtools-package   "cdrtools-2.00.3.tar.gz">
  <!ENTITY cdrtools-directory "cdrtools-2.00.3">
  
  <!ENTITY cdrdao-version     "1.1.7">
  <!ENTITY cdrdao-package     "cdrdao-1.1.7.src.tar.bz2">
  <!ENTITY cdrdao-directory   "cdrdao-1.1.7">
  
  <!--************* packages for chapter 46 *************-->
  
  <!ENTITY cups-version   "1.1.19">
  <!ENTITY cups-package   "cups-1.1.19-source.tar.bz2">
  <!ENTITY cups-directory "cups-1.1.19">
  
  <!ENTITY afplghostscript-version   "8.00">
  <!ENTITY afplghostscript-package   "ghostscript-8.00.tar.bz2">
  <!ENTITY afplghostscript-directory "ghostscript-8.00">
  
  <!ENTITY afplghostscript-fonts1 "ghostscript-fonts-std-8.11.tar.gz">
  <!ENTITY afplghostscript-fonts2 "gnu-gs-fonts-other-6.0.tar.gz">
  <!ENTITY afplghostscript-fonts3 "urw-fonts-1.0.7pre22.tar.bz2">
  
  <!ENTITY espghostscript-version   "7.07.1rc2">
  <!ENTITY espghostscript-package   "espgs-7.07.1rc2-source.tar.bz2">
  <!ENTITY espghostscript-directory "espgs-7.07.1rc2">
  
  <!ENTITY espghostscript-fonts1 "gnu-gs-fonts-std-6.0.tar.gz">
  <!ENTITY espghostscript-fonts2 "gnu-gs-fonts-other-6.0.tar.gz">
  <!ENTITY espghostscript-fonts3 "urw-fonts-1.0.7pre22.tar.bz2">
  
  <!ENTITY espghostscript-driver "Omni-0.9.0.tar.gz">
  
  <!ENTITY lprng-version   "3.8.20">
  <!ENTITY lprng-package   "LPRng-3.8.20.tgz">
  <!ENTITY lprng-directory "LPRng-3.8.20">
  
  <!--************* packages for chapter 46 *************-->
  
  <!ENTITY sane-version   "1.0.9">
  <!ENTITY sane-frontend-package   "sane-frontends-1.0.9.tar.gz">
  <!ENTITY sane-frontend-directory "sane-frontends-1.0.9">
  
  <!ENTITY sane-backend-package   "sane-backends-1.0.9.tar.gz">
  <!ENTITY sane-backend-directory "sane-backends-1.0.9">
  
  <!ENTITY xsane-version   "0.90">
  <!ENTITY xsane-package   "xsane-0.90.tar.gz">
  <!ENTITY xsane-directory "xsane-0.90">
  
  <!--************* packages for chapter 48 *************-->
  
  <!ENTITY sgml-common-version   "0.6.3">
  <!ENTITY sgml-common-package   "sgml-common-0.6.3.tgz">
  <!ENTITY sgml-common-directory "sgml-common-0.6.3">
  
  <!ENTITY sgml-dtd31-version   "3.1">
  <!ENTITY sgml-dtd31-package   "docbk31.zip">
  <!ENTITY sgml-dtd31-directory "docbk31">
  
  <!ENTITY sgml-dtd-version   "4.2">
  <!ENTITY sgml-dtd-package   "docbook-4.2.zip">
  <!ENTITY sgml-dtd-directory "docbook-4.2">
  
  <!ENTITY opensp-version   "1.5">
  <!ENTITY opensp-package   "OpenSP-1.5.tar.gz">
  <!ENTITY opensp-directory "OpenSP-1.5">
  	
  <!ENTITY opensp-patch     "OpenSP-1.5-LITLEN.patch">
  
  <!ENTITY openjade-version   "1.3.2">
  <!ENTITY openjade-package   "openjade-1.3.2.tar.gz">
  <!ENTITY openjade-directory "openjade-1.3.2">
  
  <!ENTITY docbook-dsssl-version   "1.78">
  <!ENTITY docbook-dsssl-package   "docbook-dsssl-1.78.tar.gz">
  <!ENTITY docbook-dsssl-directory "docbook-dsssl-1.78">
  
  <!--************* packages for chapter 49 *************-->
  
  <!ENTITY xml-dtd-version   "4.2">
  <!ENTITY xml-dtd-package   "docbook-xml-4.2.zip">
  <!ENTITY xml-dtd-directory "docbook-xml-4.2">
  
  <!ENTITY docbook-xsl-version   "1.61.3">
  <!ENTITY docbook-xsl-package   "docbook-xsl-1.61.3.tar.gz">
  <!ENTITY docbook-xsl-directory "docbook-xsl-1.61.3">
  
  <!--************* packages for chapter 50 *************-->
  
  <!ENTITY a2ps-version   "4.13b">
  <!ENTITY a2ps-package   "a2ps-4.13b.tar.gz">
  <!ENTITY a2ps-directory "a2ps-4.13">
  
  <!ENTITY enscript-version   "1.6.1">
  <!ENTITY enscript-package   "enscript-1.6.1.tar.gz">
  <!ENTITY enscript-directory "enscript-1.6.1">
  
  <!ENTITY gsview-version   "4.3">
  <!ENTITY gsview-package   "gsview-4.3.tar.gz">
  <!ENTITY gsview-directory "gsview-4.3">
  
  <!ENTITY psutils-version   "p17">
  <!ENTITY psutils-package   "psutils-p17.tar.gz">
  <!ENTITY psutils-directory "psutils">
  
  <!ENTITY xpdf-version   "2.02">
  <!ENTITY xpdf-package   "xpdf-2.02.tar.gz">
  <!ENTITY xpdf-directory "xpdf-2.02">
  
  <!--************* packages for chapter 50 *************-->
  
  <!ENTITY tex-version   "2.0.2">
  <!ENTITY tex-package   "tetex-src-2.0.2.tar.gz">
  <!ENTITY tex-directory "tetex-src-2.0.2">
  
  <!ENTITY tex-texmf-package     "tetex-texmf-2.0.2.tar.gz">
  <!ENTITY tex-texmfsrc-package  "tetex-texmfsrc-2.0.2.tar.gz">
  
  
  <!--************* packages for chapter 99 *************-->
  
  
  <!ENTITY t1lib-version   "1.3">
  <!ENTITY t1lib-package   "t1lib-1.3.tar.gz">
  <!ENTITY t1lib-directory "T1Lib-1.3">
  
  <!ENTITY bison175-version   "1.75">
  <!ENTITY bison175-package   "bison-1.75.tar.bz2">
  <!ENTITY bison175-directory "bison-1.75">
  
  <!ENTITY libole2-version   "0.2.4">
  <!ENTITY libole2-package   "libole2-0.2.4.tar.bz2">
  <!ENTITY libole2-directory "libole2-0.2.4">
  
  <!ENTITY mktemp-version   "1.5">
  <!ENTITY mktemp-package   "mktemp-1.5.tar.gz">
  <!ENTITY mktemp-directory "mktemp-1.5">
  
  <!ENTITY fribidi-version   "0.10.4">
  <!ENTITY fribidi-package   "fribidi-0.10.4.tar.gz">
  <!ENTITY fribidi-directory "fribidi-0.10.4">
   
  <!ENTITY stlport-version   "4.5.3">
  <!ENTITY stlport-package   "STLport-4.5.3.tar.gz">
  <!ENTITY stlport-directory "STLport-4.5.3">
  
  <!ENTITY stlport-patch     "STLport-4.5.3-gcc3.patch">
  
  
  
  
  1.2       +22 -29    ALFS/profiles/BLFS/misc/template.xml
  
  Index: template.xml
  ===================================================================
  RCS file: /home/cvsroot/ALFS/profiles/BLFS/misc/template.xml,v
  retrieving revision 1.1
  retrieving revision 1.2
  diff -u -r1.1 -r1.2
  --- template.xml	18 May 2004 20:45:20 -0000	1.1
  +++ template.xml	23 May 2004 01:26:24 -0000	1.2
  @@ -1,31 +1,24 @@
  +<?xml version="1.0" encoding="iso-8859-1"?>
   <package name="" version="">
  -
  -	<stage name="Unpacking.">
  -		<unpack>
  -			<archive>&packages_dir;/</archive>
  -			<destination>&build_dir;</destination>
  -		</unpack>
  -	</stage>
  -
  -
  -	<stage name="Installing.">
  -		<stageinfo>
  -			<base>&build_dir;/</base>
  -		</stageinfo>
  -
  -		<configure>
  -			<param>--prefix=/usr</param>
  -		</configure>
  -
  -		<make />
  -
  -		<make>
  -			<param>install</param>
  -		</make>
  -	</stage>
  -
  -	<stage name="Cleanup.">
  -		<remove>&build_dir;/</remove>
  -	</stage>
  +  <stage name="Unpacking.">
  +    <unpack>
  +      <archive>&packages_dir;/</archive>
  +      <destination>&build_dir;</destination>
  +    </unpack>
  +  </stage>
  +  <stage name="Installing.">
  +    <stageinfo>
  +      <base>&build_dir;/</base>
  +    </stageinfo>
  +    <configure>
  +      <param>--prefix=/usr</param>
  +    </configure>
  +    <make />
  +    <make>
  +      <param>install</param>
  +    </make>
  +  </stage>
  +  <stage name="Cleanup.">
  +    <remove>&build_dir;/</remove>
  +  </stage>
   </package>
  -
  
  
  
  1.1                  ALFS/profiles/BLFS/wget/chapter26.urls
  
  Index: chapter26.urls
  ===================================================================
  http://sunsite.rediris.es/mirror/Qt/source/qt-x11-free-3.3.1.tar.bz2
  
  ftp://ftp.gtk.org/pub/gtk/v1.2/gtk+-1.2.10.tar.gz
  
  ftp://ftp.gtk.org/pub/gtk/v2.4/pango-1.4.0.tar.gz
  
  ftp://ftp.gtk.org/pub/gtk/v2.4/atk-1.6.0.tar.bz2
  
  ftp://ftp.gtk.org/pub/gtk/v2.4/gtk+-2.4.0.tar.bz2
  
  http://telia.dl.sourceforge.net/sourceforge/lesstif/lesstif-0.93.94.tar.bz2
  
  http://www.freedesktop.org/software/startup-notification/releases/startup-notification-0.6.tar.gz
  
  http://freedesktop.org/Software/shared-mime-info/shared-mime-info-0.14.tar.gz
  
  http://freedesktop.org/Software/icon-theme/releases/hicolor-icon-theme-0.5.tar.gz
  
  http://heanet.dl.sourceforge.net/sourceforge/gswitchit/libxklavier-1.02.tar.gz
  
  
  



More information about the alfs-log mailing list