cvs commit: ALFS/nALFS bootstrap.configure

kpfleming at linuxfromscratch.org kpfleming at linuxfromscratch.org
Mon Mar 8 09:45:29 PST 2004


kpfleming    04/03/08 10:45:29

  Modified:    nALFS    bootstrap.configure
  Log:
  make configure script test curl version to be at least 7.10.0
  
  Revision  Changes    Path
  1.15      +13 -4     ALFS/nALFS/bootstrap.configure
  
  Index: bootstrap.configure
  ===================================================================
  RCS file: /home/cvsroot/ALFS/nALFS/bootstrap.configure,v
  retrieving revision 1.14
  retrieving revision 1.15
  diff -u -r1.14 -r1.15
  --- bootstrap.configure	7 Feb 2004 04:06:20 -0000	1.14
  +++ bootstrap.configure	8 Mar 2004 17:45:29 -0000	1.15
  @@ -165,10 +165,19 @@
   if test "${CURL_CONFIG}" != "no"; then
      AC_CHECK_LIB([curl], [curl_global_init], [AC_DEFINE([HAVE_LIBCURL], [], [Define to use libcurl instead of wget for downloading.])], [], [`${CURL_CONFIG} --libs`])
      if test "${ac_cv_lib_curl_curl_global_init}" = "yes"; then
  -      CURL_LIB=`${CURL_CONFIG} --libs | sed -e 's/^-L\(.*\) -lcurl.*$/\1/'`/libcurl.la
  -      CURL_INCLUDES=`${CURL_CONFIG} --cflags`
  -      AC_SUBST([CURL_LIB])
  -      AC_SUBST([CURL_INCLUDES])
  +      curl_version=0x`${CURL_CONFIG} --vernum`
  +      if test $(($curl_version > 0x070a00)) != 0; then
  +          CURL_LIB=`${CURL_CONFIG} --libs | sed -e 's/^-L\(.*\) -lcurl.*$/\1/'`/libcurl.la
  +          CURL_INCLUDES=`${CURL_CONFIG} --cflags`
  +	  AC_SUBST([CURL_LIB])
  +	  AC_SUBST([CURL_INCLUDES])
  +      else
  +          echo "***"
  +	  echo "*** The libcurl on this system is an older version than 7.10.0."
  +	  echo "*** Either install a newer version, or run configure without"
  +	  echo "*** including --with-curl."
  +	  exit 1
  +      fi
      else
         echo "***"
         echo "*** The libcurl installation on this system appears to be broken."
  
  
  



More information about the alfs-log mailing list