Failed to Load External Entity

Esben Stien b0ef at esben-stien.name
Thu Jul 11 17:08:34 PDT 2013


I built my LFS system in the end of 2008 and now I'm ready to update,
which will probably solve a lot of headache. 

I immediately run into problems, using jhalfs.

På revisjon 10304.
file:///usr/share/xml/docbook/xml-dtd-4.5/dbcentx.mod:308: warning:
failed to load external entity
"file:///usr/share/xml/docbook/xml-dtd-4.5/ent/isoamsa.ent"
%ISOamsa;
         ^
Entity: line 1: 
 %ISOamsa; 
          ^
file:///usr/share/xml/docbook/xml-dtd-4.5/dbcentx.mod:312: warning:
failed to load external entity
"file:///usr/share/xml/docbook/xml-dtd-4.5/ent/isoamsb.ent"
%ISOamsb;
         ^

Problem is that I don't have any directory called
/usr/share/xml/docbook/xml-dtd-4.5/ent/ containing all these .ent
files. 

I do however have this directory:
/usr/share/sgml/sgml-iso-entities-8879.1986/ which contains: 

/usr/share/sgml/sgml-iso-entities-8879.1986/ISOamsa.ent
/usr/share/sgml/sgml-iso-entities-8879.1986/ISOamsb.ent
/usr/share/sgml/sgml-iso-entities-8879.1986/ISOamsc.ent
/usr/share/sgml/sgml-iso-entities-8879.1986/ISOamsn.ent
/usr/share/sgml/sgml-iso-entities-8879.1986/ISOamso.ent
/usr/share/sgml/sgml-iso-entities-8879.1986/ISOamsr.ent
/usr/share/sgml/xml-iso-entities-8879.1986/ISOamsa.ent
/usr/share/sgml/xml-iso-entities-8879.1986/ISOamsb.ent
/usr/share/sgml/xml-iso-entities-8879.1986/ISOamsc.ent
/usr/share/sgml/xml-iso-entities-8879.1986/ISOamsn.ent
/usr/share/sgml/xml-iso-entities-8879.1986/ISOamso.ent
/usr/share/sgml/xml-iso-entities-8879.1986/ISOamsr.ent

These are uppercase files and the script requires lowercase files.

I did try to just rename all these file to lowercase and place them
inside the requested /usr/share/xml/docbook/xml-dtd-4.5/ent/ directory,
but that just gave me a new set of errors.

The script reports: 

KERNEL............ <2.6.38.2opteronize>  OK (Min version: 2.6.25)
BASH.............. <3.2.39(2)-release>   OK (Min version: 3.2)
GCC............... <4.3.2>               OK (Min version: 4.1.2)
G++............... <4.3.2>               OK (Min version: 4.1.2)
GLIBC............. <2.8>                 OK (Min version: 2.5.1)
BINUTILS.......... <2.18>                OK (Min version: 2.17)
TAR............... <1.26>                OK (Min version: 1.18)
BZIP2............. <1.0.5>               OK (Min version: 1.0.4)
BISON............. <2.3>                 OK (Min version: 2.3)
COREUTILS......... < 6.12>               OK (Min version: 6.9)
DIFF.............. <2.8.1>               OK (Min version: 2.8.1)
FIND.............. <4.4.0>               OK (Min version: 4.2.31)
GAWK.............. <3.1.6>               OK (Min version: 3.1.5)
GREP.............. <2.5.3>               OK (Min version: 2.5.1a)
GZIP.............. <1.3.12>              OK (Min version: 1.3.12)
M4................ <1.4.12>              OK (Min version: 1.4.10)
MAKE.............. <3.81>                OK (Min version: 3.81)
PATCH............. <2.5.4>               OK (Min version: 2.5.4)
PERL.............. <5.10.0>              OK (Min version: 5.8.8)
SED............... <4.1.5>               OK (Min version: 4.1.5)
TEXINFO........... <4.13>                OK (Min version: 4.9)
XZ................ <5.0.3>               OK (Min version: 5.0.0)
SUDO.............. <1.7.0>               OK (Min version: 1.7.0)
WGET.............. <1.11.4>              OK (Min version: 1.0.0)
LIBXML2........... <2.07.03>             OK (Min version: 2.06.20)
LIBXSLT........... <1.01.24>             OK (Min version: 1.01.14)

Any idea what I can try?. 

-- 
Esben Stien is b0ef at e     s      a             
         http://www. s     t    n m
          irc://irc.  b  -  i  .   e/%23contact
           sip:b0ef@   e     e 
           jid:b0ef@    n     n



More information about the alfs-discuss mailing list