Jhalfs with package management

Matt Burgess matthew at linuxfromscratch.org
Fri Jan 27 08:40:39 PST 2012


On Fri, 2012-01-27 at 17:20 +0100, Pierre Labastie wrote:
> Le 26/01/2012 23:02, Matt Burgess a ecrit :
> >
> > Thanks very much for the work here. One minor query. This hunk from
> > lines 1251-1254 of your patch:
> >
> > config  VIMLANG
> > -               bool "Install vim-lang package"
> > +#              bool "Install vim-lang package"
> > +               bool
> >
> > Was this for debugging purposes, or is there a problem in jhalfs'
> > handling of this config option that this fixes?
> Thanks for your interest.
> 
> Well, I believed that there were no vim lang package anymore with
> vim 7.3 (checked on vim site. the last version of vim-lang is 7.2). This
> means that if you tick this option, jhalfs (I mean without the patch)
> stops when trying to unpack it, (versions 6.8, 7.0 and current SVN of the
> book). That is the reason why I disabled it. If you apply the patch, it
> modifies also lfs.xsl, which then does not unpack vim-lang anyway. So I
> suppressed the option.

Ah, thanks for that.  That makes perfect sense now.

> 
> If you want me to re-enable it, let me know, I think it is not a big
> change. But it is not just reverting the hunk above.
> 
> I take the opportunity to list the other changes I have made:
> - Change the minimum versions in func_check_version to reflect
> what is in the current book (and correct a bug with libxml
> version check, where a minor version of '08'  was taken as octal
> and could not be parsed). Also use the 'ldd' trick to check
> glibc version. On a todo list: extract those versions automatically
> from the book.

Yeah, I noticed that the list was not parsed from the book ages ago, but
never looked at what was required to extract it.  That would indeed be
very useful!

> - Change the way tests are handled in the generation of the
> scriptlets, which allows to simplify slightly the generation,
> and to correct a bug, which for example transformed the 'ulimit'
> line of gcc tests into 'make -k >> $TEST_LOG 2>&1 || true'...

Hmm, that change may have caused a regression in chapter06 Glibc, but
I'll wait for my latest build to get to that point before confirming.
The last build I tried, with your patch applied,jhalfs bailed out after
hitting an 'Error 2' output from Glibc's tests.  The config I run with
is 'Run all chapter 6 testsuites' with 'Abort the build at the first
test suite failure'; that has usually continued on past the packages
with known failures such as GCC and Glibc.

Regards,

Matt.




More information about the alfs-discuss mailing list