Patch to extract minimal host tool versions from the book

Thomas Pegg tom.pegg at gmail.com
Mon Dec 31 15:48:30 PST 2012


On 12/31/2012 3:19 AM, Pierre Labastie wrote:
> Le 28/12/2012 23:36, Pierre Labastie a écrit :
>> Hi,
>> 
>> This is a long overdue patch for trying to automate the retrieval
>> of minimal tool versions from the "host requirements" section, to
>> use them in jhalfs' check_version. I have not tested all
>> configurations. It works well with a local book.
>> 
>> It is not really an automation: if a new requirement is added, it
>> has to be manually added to jhalfs. But if a version updating
>> occurs, it will be automatically ported to jhalfs.
>> 
>> Regards Pierre
>> 
>> 
> The patch I sent worked only with a local copy of the book. Here is
> another one, which works with SVN and tagged versions (I tried SVN,
> 6.3, 7.2), too. I had to change the order of operations: if you
> want to extract host requirements from the book, and you require
> the book to be downloaded, you have to download the book first. So
> this patch runs the check_prerequisite function just before running
> the build. In some way, I would say it is how it should be: 
> checking prerequisites is (should be) the first step in building
> LFS...

Pierre, I applaud your effort, but as the patch stands currently it
would break CLFS support in jhalfs. That being said though this might
be a good time to evaluate whether support for that should be
maintained. I'll address that in another email to the list.

Thomas





More information about the alfs-discuss mailing list