Warning: not found a working DocBook XML DTD 4.5 installation

linux fan linuxscratch at gmail.com
Fri Oct 1 20:58:00 PDT 2010


On 10/1/10, cliffhanger at gardener.com <cliffhanger at gardener.com> wrote:
> Hi
>
> Just installed LFS6.7 using JHalfs, brilliant no probs
>
> Moved onto BLFS, running 'make' etc. I get this error: Warning: not
> found a working DocBook XML DTD 4.5 installation
>
> I have just installed this ver. to the new LFS. So what goes? Any
> advice please?
>

See something like this in blfs-tool in jhalfs release directory (tarball/svn):
=============================================
XML_FILE="<?xml version='1.0' encoding='ISO-8859-1'?>
<?xml-stylesheet type='text/xsl'
href='http://docbook.sourceforge.net/release/xsl/1.69.1/xhtml/docbook.xsl'?>
<!DOCTYPE article PUBLIC '-//OASIS//DTD DocBook XML V4.5//EN'
  'http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd'>
<article>
  <title>Test file</title>
  <sect1>
    <title>Some title</title>
    <para>Some text</para>
  </sect1>
</article>"

if `echo $XML_FILE | xmllint -noout -postvalid - 2>/dev/null` ; then
  check_version "4.5" "4.5" "DocBook XML DTD"
else
  echo "Warning: not found a working DocBook XML DTD 4.5 installation"
  exit 2
fi
===========================================

Note the xsl version (1.69.1 above) that you do not have.

Refer to the DocBook XSL Stylesheets instructions which propose that
it is possible to make rewrite rules so that it will be happy.



More information about the alfs-discuss mailing list