Fwd: Re: Document version not set with jhalfs-20081011

George Boudreau georgeb at linuxfromscratch.org
Tue Oct 28 09:40:01 PDT 2008


Bruce Dubbs wrote:
> George Boudreau wrote:
>> Matthew Burgess wrote:
>>> Forwarding to lfs-dev...I'm currently unable to commit to SVN (my own
>>> network setup here).  I'd guess we either need to revert back to the '-' or
>>> change it to '–' (note the additional ';').
>>>
>>> George, how does 'xmllint' puke?  It'd be nice if the LFS Book's validation
>>> Makefile target could catch this.
>>>
>> xmllint prologue bookinfo.xml produces the following.
>>
>> Entity: line 1: parser error : Entity 'ndash' not defined
>>
>> 1999–2008
> 
> This looks like a problem with xmllint or it's invocation.  Why doesn't it know 
> about entities?  This change was made in revision 4648 on 02/19/05.  Why is is 
> coming up now?

   This was brought to my attention today, it may have been around for
quite a while. The code does not spew out the above text in jhalfs, due
to trapping, it only fails to translate the doc version for display.

   It may be xmllint, I will see what I can dig up.

    George
> 
> I'd perver to keep the entity.
> 
>    -- Bruce





More information about the alfs-discuss mailing list